Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

3moons

404, URL not found, SSL errors - please help!

6 posts in this topic

I just recently installed OS Commerce (v 2.2 MS2). Added my shipping, tax, payment info, etc. Tried to do a test checkout to make sure payment and shipping options were working correctly before moving on. Put one of the items in the cart that came with the default setup. When I hit the checkout button I receive the following errors:

 

Not Found

The requested URL /shop/checkout_shipping.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.31 Server at quasar.hyperdrivedns.com Port 443

 

I went into file manager to check, and yes the checkout_shipping.php IS there so why isn't it being recognized? Permissions are: -rwxr-xr-x.

 

Also - I don't know what to do about the 404 error.

 

In addition, in the Admin panel it says: You are not protected by a secure SSL connection. Although I selected to enable SSL and have a shared SSL through my hosting provider.

 

Any help would be appreciated!!!

 

Thanks!

 

Angela :blink: :blink:

Share this post


Link to post
Share on other sites

Did you use the correct url for the shared ssl?

 

I'd bet not. It won't just be your url with https in front of it.

Share this post


Link to post
Share on other sites

post the url so we can see it and see what the prob is..

 

if you dont want the search engines to find you tet type www dot domainname dot com

Share this post


Link to post
Share on other sites

Unless you access that admin home page with the SSL notice via your secure URL, it will tell you you are not protected... (i.e. https://yoursecuredomain/admin/index.php vs. http://yourdomain/admin/index.php)

 

You can set the HTTP_SERVER in the admin/includes/configure.php to whatever your *secure* server is and then the whole of the admin will run in SSL - though you still have to access the admin home via the SSL web address, or you'll get that message (although the links there would now go to SSL pages)... (It's a bit of a quirk with MS 2.2 and comes up a lot)

 

If you only want the order/customer info in secure mode, as is often the case, try my new contrib...

 

http://www.oscommerce.com/community/contributions,2274

Share this post


Link to post
Share on other sites
I just recently installed OS Commerce (v 2.2 MS2). Added my shipping, tax, payment info, etc. Tried to do a test checkout to make sure payment and shipping options were working correctly before moving on. Put one of the items in the cart that came with the default setup. When I hit the checkout button I receive the following errors:

 

Not Found

The requested URL /shop/checkout_shipping.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/1.3.31 Server at quasar.hyperdrivedns.com Port 443

 

I went into file manager to check, and yes the checkout_shipping.php IS there so why isn't it being recognized? Permissions are: -rwxr-xr-x.

 

Also - I don't know what to do about the 404 error.

 

In addition, in the Admin panel it says: You are not protected by a secure SSL connection. Although I selected to enable SSL and have a shared SSL through my hosting provider.

 

Any help would be appreciated!!!

 

Thanks!

 

Angela :blink:  :blink:

This exact thing started happening to me too.

 

www.mtoliveco.com

 

The site was working great until I started getting complaints that people couldn't enter the shipping page.

 

At first I thought it was the server but I copied the pages to another server and I still get the Page cannot be displayed error. I also checked it on 3 different computers.

 

What's going on? anyone have an idea?

Share this post


Link to post
Share on other sites

yjr reason you are having these erors is bec you dont have an ssl certificate or you dont have an ssl certificate installed properly .

so until you ge t a certificate change ssl in the configuration file to falce (includes/configure.php)

 

it should look something like this.

 

please note when it says http and when it says https

also note define('ENABLE_SSL', false)

 

  define('HTTP_SERVER', 'http://domain.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'domain.com');
 define('HTTPS_COOKIE_DOMAIN', 'domain.com');
 define('HTTP_COOKIE_PATH', '/');
 define('HTTPS_COOKIE_PATH', '/');
 define('DIR_WS_HTTP_CATALOG', '/');
 define('DIR_WS_HTTPS_CATALOG', '/');

Share this post


Link to post
Share on other sites