Jump to content
Sign in to follow this  
tototobo

Innovative Gateway access problem

Recommended Posts

This error sounds like you need to enter your server's IP address into the list of acceptable IP addresses in your Innovative control panel.

 

- Paul

Share this post


Link to post
Share on other sites
This error sounds like you need to enter your server's IP address into the list of acceptable IP addresses in your Innovative control panel.

 

- Paul

 

I'm actually happy I'm getting that error message. It means I'm able to connect to the Gateway.

 

Now if only someone can help me solve the problem with the headers ;)

Share this post


Link to post
Share on other sites

Have you tried eliminating all null characters from your php file? I've received those messages when there are extra spaces at the end of my file.

Share this post


Link to post
Share on other sites
Have you tried eliminating all null characters from your php file? I've received those messages when there are extra spaces at the end of my file.

 

I have done that, but I dont think that's the problem because when I comment out the additional codes the page goes back to normal.

 

Bit of an update: I dont know what it is I did but I got the Error Accessing Gateway message back BUT the failed transactions are now being posted on the Innovative merchant's section, under "failed transactions". It seems the Gateway sees the transaction as coming from an unauthorized IP address, yet I've already registered any and all related IPs I can think of.

Share this post


Link to post
Share on other sites
Do you use a shared SSL certificate? If so, have you registered that IP address?

 

Update: contacted innovative and for some reason the IP address that's being shown on their system is NOT the same one that's being shown on godaddy.com's control panel. Innovative's tech support fixed it and transactions are now going through.

 

HOWEVER

 

I'm still getting the Error Accessing Gateway message.

 

This is so frustrating...so near yet so far! :'(

Share this post


Link to post
Share on other sites

Have you turned off PHP safe mode and set the open_basedir directory properly for https? This is the same exact error I was getting. Like you, I was driving myself nuts. As soon as I did this, everything worked.

Share this post


Link to post
Share on other sites
Have you turned off PHP safe mode and set the open_basedir directory properly for https? This is the same exact error I was getting. Like you, I was driving myself nuts. As soon as I did this, everything worked.

 

I'll give it a shot, but the last time I asked godaddy they didnt answer directly, only that "they dont provide support for 3rd party applications". <_<

Share this post


Link to post
Share on other sites
Have you turned off PHP safe mode and set the open_basedir directory properly for https? This is the same exact error I was getting. Like you, I was driving myself nuts. As soon as I did this, everything worked.

 

I'll give it a shot, but the last time I asked godaddy they didnt answer directly, only that "they dont provide support for 3rd party applications". <_<

Share this post


Link to post
Share on other sites

I asked godaddy about making those changes and here is their response.

As for disabling safe mode for under https and also setting the open_basedir value to your home https/secure directory, currently at this time you are unable to make these types of modifications when using a shared hosting account.

Kevin

 

 

I'll give it a shot, but the last time I asked godaddy they didnt answer directly, only that "they dont provide support for 3rd party applications". <_<

Share this post


Link to post
Share on other sites

Honestly, I think your $%*#ed. Without signifant changes to the code, I'm not sure how you'd do it. (If you need a new hosting account, contact me. I'd set the gateway right up for you :thumbsup: )

Edited by pdecrett

Share this post


Link to post
Share on other sites
I asked godaddy about making those changes and here is their response.

 

Kevin

 

Are you under the Premium hosting plan? We signed up for that plan and they tell us that " The hosting account you are using is a Premium PHP/Perl, which means that the safe mode of the PHP is turned off and the program is running at full functionality; the https is also fully functional at this time. "

Share this post


Link to post
Share on other sites
Are you under the Premium hosting plan? We signed up for that plan and they tell us that " The hosting account you are using is a Premium PHP/Perl, which means that the safe mode of the PHP is turned off and the program is running at full functionality; the https is also fully functional at this time. "

 

My Hosting is "Deluxe Hosting with CGI"

Share this post


Link to post
Share on other sites

I am also getting the "Gateway Error" message when I try to get the Innovative gateway to work with GoDaddy.

 

Safe mode is off. I don't have access to change open_basedir. I have added the proxy code. I have tried using both exec and curl_exec.

 

I am getting desperate, almost to the point of changing hosting services.

 

Has anyone been able to get Innovative to work with GoDaddy? If not, can you suggest another hosting service.

 

Thanks

Share this post


Link to post
Share on other sites

POSSIBLE SOLUTION:

 

I use zencart (an osCommerce derivative which uses the Innovative Gateway module from osCommerce) on a Virtual Dedicated Server on GoDaddy. The openbase_dir and safe_mode were all correct. It worked fine until this past week, when Innovative Gateway closed port 80 (http) and would only allow transactions through port 443 (https).

 

I began receiving: "There has been an error processing your credit card. Please try again.<br>Error accessing gateway"

 

I spent the past week trying to get a site working using the secure certificate under https:.

 

For the life of me I couldn't figure out why it wouldn't accept my transactions. Even though I checked and double checked everyone's recommendations about how to set-up the code.

 

Tech support for Innovative Gateway wouldn't comment on third party software. GoDaddy actually tried to be helpful, but they could do little more that make sure that the secure certificate was properly installed, and say that it *should* be working, and that they didn't know why it wasn't.

 

Finally I tried something radical. Using the original code supplied in the payment module (without the extra code supplied earlier in this thread that used cURL) - within the admin section of the cart, under Payment:

 

http://transactions.innovativegateway.com/...gateway.aai.Aai

 

must be:

 

https://transactions.innovativegateway.com/...gateway.aai.Aai

 

After I did that it finally allowed my transaction to go through. I'll report back if I have any further problems with it, as long as anyone else who tries it reports that this helped them fix their problems as well.

 

If this is *infact* the cause, then the module should be rewritten so that https: is the standard set-up (especially since Innovative Gateway no longer accepts transactions through http).

Share this post


Link to post
Share on other sites

I am another poor Godaddy.com customer having the same problem. Any further suggestions would be greatly appreciated.

Share this post


Link to post
Share on other sites
"Warning: Cannot modify header information - headers already sent by (output started at /home/content/j/p/s/jpskin2/html/catalog/includes/modules/payment/innovative.php:202) in /home/content/j/p/s/jpskin2/html/catalog/includes/functions/general.php on line 29"

 

Can anyone help me fine tune the code so we can get this thing to work? Thanks!

 

This is the same error I'm getting, only it says line 33. The transaction is going through just fine.

 

I'm so close! Can someone help?

Share this post


Link to post
Share on other sites

Here's the code I added to make the darned thing to work:

 

// post the data

$cmd = MODULE_PAYMENT_INNOVATIVE_CURL . " -d \"$data\" " . MODULE_PAYMENT_INNOVATIVE_URL;

// echo "curl command<br>" . $cmd . "<br>";

 

$ch = curl_init();

curl_setopt($ch, CURLOPT_URL, MODULE_PAYMENT_INNOVATIVE_URL);

curl_setopt($ch, CURLOPT_HEADER, 1);

curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, 1);

curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);

curl_setopt($ch, CURLOPT_POST, 1);

curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

curl_setopt($ch, CURLOPT_PROXY, "http://64.202.165.130:3128");

curl_setopt($ch, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);

$return_string = curl_exec($ch);

curl_close($ch);

 

exec($cmd, $return_string);

 

// Set up default error condition

$card_status[0] = "error";

$card_status[1] = "Error accessing gateway";

 

 

Unfortunately, someone somewhere made some changes and now I'm back to getting the "There has been an error processing..." error message.

 

:(

Share this post


Link to post
Share on other sites
^ Please stick with it, sturmdogg. We're cheering you on! :thumbsup:

 

Mentat, can you try the code I put up and see if it works for you?

Share this post


Link to post
Share on other sites
POSSIBLE SOLUTION:

 

I use zencart (an osCommerce derivative which uses the Innovative Gateway module from osCommerce) on a Virtual Dedicated Server on GoDaddy. The openbase_dir and safe_mode were all correct. It worked fine until this past week, when Innovative Gateway closed port 80 (http) and would only allow transactions through port 443 (https).

 

I began receiving: "There has been an error processing your credit card. Please try again.<br>Error accessing gateway"

 

I spent the past week trying to get a site working using the secure certificate under https:.

 

For the life of me I couldn't figure out why it wouldn't accept my transactions. Even though I checked and double checked everyone's recommendations about how to set-up the code.

 

Tech support for Innovative Gateway wouldn't comment on third party software. GoDaddy actually tried to be helpful, but they could do little more that make sure that the secure certificate was properly installed, and say that it *should* be working, and that they didn't know why it wasn't.

 

Finally I tried something radical. Using the original code supplied in the payment module (without the extra code supplied earlier in this thread that used cURL) - within the admin section of the cart, under Payment:

 

http://transactions.innovativegateway.com/...gateway.aai.Aai

 

must be:

 

https://transactions.innovativegateway.com/...gateway.aai.Aai

 

After I did that it finally allowed my transaction to go through. I'll report back if I have any further problems with it, as long as anyone else who tries it reports that this helped them fix their problems as well.

 

If this is *infact* the cause, then the module should be rewritten so that https: is the standard set-up (especially since Innovative Gateway no longer accepts transactions through http).

 

So you used the original code as-is, without any additional curl settings?

 

What did you put in for the path to curl field?

Share this post


Link to post
Share on other sites

Problem Solved!

 

How'd I do it? It's simple really....I switched to authorize.net and now shopping cart works fine! :lol:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×