Jump to content
Sign in to follow this  
tototobo

Innovative Gateway access problem

Recommended Posts

i have the gateway account setup with innovative, already got my username and password and entered in the admin page of the payments module, every thing as far as the looks go is working fine the store is up and running and the products show up.

the problem starts when i start to buy something, as soon as i purchase anything i get the following error.

 

"There has been an error processing your credit card. Please try again.<br>Error accessing gateway"

 

what can i do to fix this . anything helps . i am totally new to this

 

Thankyou and God bless.

Share this post


Link to post
Share on other sites

I am having this same problem when using the test login.

 

On the confirmation click it comes back with the

 

Error accessing gateway

 

error.

 

anyone using this gateway that can perhaps help me?

Share this post


Link to post
Share on other sites

I found the error!

 

The latest contribution of this has the following code on line 137

 

$data  = "target_app=WebCharge_v6.00&";

 

 

you'll need to change that to:

 

$data  = "target_app=WebCharge_v5.06&";

Share this post


Link to post
Share on other sites

I'm having the same problem with the same error. However, I already have the webcharge variable set to 5.06. My username and password are all correct, as well as the gateway URL. I've been in touch with Innovative and they are at a loss as well.

 

My shopping cart was working and had processed 9 transactions. I didn't change anything that I'm aware of.

 

I made sure that my site's IP address is registered.

 

I downloaded the Innovative module from their web site. It didn't include the PostGateway.php file, and I don't remember where I got that. Is there anything that has to be edited in these modules to get them to work, or in the OSCommerce PHP files? From what I'm reading around the web, you should be able to plug these things in with no modifications and have them work.

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

I found the problem. Our web host decided to change the security settings on cURL and didn't bother to tell me, nor did they bother to tell their level one tech support, who swore up and down that they had changed nothing over the prior couple of months.

 

ARGH!

Share this post


Link to post
Share on other sites

I'm having the same problem, changed the line of code to v5.06 and everything. IMS told me to check my hosting for curl support. It was on and working fine, but made me suspect that maybe the path was wrong. It is currently set to /usr/local/bin/curl and I had asked my hosting company to send me the url path to verify.

 

In regards to your solution below, could you clarify what it was that was exactly wrong? Or does anyone else have any ideas?

 

Michael

 

 

I found the problem.  Our web host decided to change the security settings on cURL and didn't bother to tell me, nor did they bother to tell their level one tech support, who swore up and down that they had changed nothing over the prior couple of months.

 

ARGH!

Share this post


Link to post
Share on other sites

The hosting company said the correct path is /usr/bin/curl. When I changed it to that it still didn't work.

 

Anybody have any ideas? I'm in a real crunch to get this shopping cart functional.

 

Michael :o

 

I'm having the same problem, changed the line of code to v5.06 and everything.  IMS told me to check my hosting for curl support.  It was on and working fine, but made me suspect that maybe the path was wrong.  It is currently set to /usr/local/bin/curl and I had asked my hosting company to send me the url path to verify.

 

In regards to your solution below, could you clarify what it was that was exactly wrong?  Or does anyone else have any ideas?

 

Michael

Share this post


Link to post
Share on other sites
The hosting company said the correct path is /usr/bin/curl.  When I changed it to that it still didn't work.

 

Anybody have any ideas?  I'm in a real crunch to get this shopping cart functional.

 

Michael :o

 

 

I am having the same problem as all of you with Innovative. I have tested on my server on another domain and it works fine. The only differences between the domains are that the one that works is not secured. The one that is secured is the one that is not working.

 

Any ideas would be great. I'm in a time crunch with the site going live tomorrow!

 

thanks,

Angel

Share this post


Link to post
Share on other sites

No word yet, but it may have something to do with the cURL configuration.

 

Michael

 

I am having the same problem as all of you with Innovative.  I have tested on my server on another domain and it works fine.  The only differences between the domains are that the one that works is not secured.  The one that is secured is the one that is not working.

 

Any ideas would be great.  I'm in a time crunch with the site going live tomorrow!

 

thanks,

Angel

Share this post


Link to post
Share on other sites

Hello,

 

I was having this same problems and discovered that it worked fine when https was disabled. My host informed me that outgoing HTTP and HTTPS connections take place via a proxy server and that applications that need to make HTTPS connections will need to be made ?proxy aware?. Scripts using cURL with PHP will need to include the following lines on each script that utilizes cURL functions.

 

curl_setopt (, CURLOPT_HTTPPROXYTUNNEL, TRUE);

curl_setopt (, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt (, CURLOPT_PROXY, http://192.168.0.1:xxxx);

curl_setopt (, CURLOPT_SSL_VERIFYPEER, FALSE);

 

I am unsure of how to impliment this and am hoping someone can offer some guidence on how too.

 

Thanks, Kevin

Share this post


Link to post
Share on other sites
Hello,

 

I was having this same problems and discovered that it worked fine when https was disabled. My host informed me that outgoing HTTP and HTTPS connections take place via a proxy server and that applications that need to make HTTPS connections will need to be made ?proxy aware?. Scripts using cURL with PHP will need to include the following lines on each script that utilizes cURL functions.

 

curl_setopt (, CURLOPT_HTTPPROXYTUNNEL, TRUE);

curl_setopt (, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt (, CURLOPT_PROXY, http://192.168.0.1:xxxx);

curl_setopt (, CURLOPT_SSL_VERIFYPEER, FALSE);

 

I am unsure of how to impliment this and am hoping someone can offer some guidence on how too.

 

Thanks, Kevin

Share this post


Link to post
Share on other sites

What is the latest word on the innovative gateway problem-

 

There has been an error processing your credit card. Please try again.<br>Error accessing gateway

 

I have contacted innovative and they are somewhat less than helpful.

Their solution was that they did not write the module so to check with this forum.

Share this post


Link to post
Share on other sites

I have gotten no feedback from anyone on how to impliment the proxy aware code my host suggested. I got stuck in Cancun because of hurricane Whilma and have be scrambling to catch up ever since. Consequently my own site is on the back burner at the moment.

 

I have emailed Innovative Gateway several times and have not gotten a response. I am left with the impression that they are only interested in the initial sale, not the ongoing business. Their lack of response has led me to conclude that I will not be renewing their services and will pursue other alternatives.

Share this post


Link to post
Share on other sites
Hello,

 

I was having this same problems and discovered that it worked fine when https was disabled. My host informed me that outgoing HTTP and HTTPS connections take place via a proxy server and that applications that need to make HTTPS connections will need to be made “proxy aware”. Scripts using cURL with PHP will need to include the following lines on each script that utilizes cURL functions.

 

curl_setopt (, CURLOPT_HTTPPROXYTUNNEL, TRUE);

curl_setopt (, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt (, CURLOPT_PROXY, http://192.168.0.1:xxxx);

curl_setopt (, CURLOPT_SSL_VERIFYPEER, FALSE);

 

I am unsure of how to impliment this and am hoping someone can offer some guidence on how too.

 

Thanks, Kevin

 

I was having problems with godaddy.com and the UPS XML module, and this additional code fixed it. Unfortunately, I dont know how to integrate the code into the Innovative Gateway module, which is a pity as I believe this will fix the problem we're having. :(

Edited by sturmdogg

Share this post


Link to post
Share on other sites

I was having this same problem. Changing two PHP configuration values fixed it.

 

1. You need to disable safe mode under https.

 

php_admin_flag safe_mode Off

 

2. You need to set the open_basedir value to your home https/secure directory.

 

php_admin_value open_basedir "/home/httpd/vhosts/domain.com/httpsdocs:/"

 

If you do not have the access to make these changes yourself, and you probably don't, you need to contact your host and ask them to do it. This will allow the connection to the payment gateway using curl under the https protocol. Make sure they make the changes for https, not http.

 

Hope this helps; it worked for me.

 

- Paul

Edited by pdecrett

Share this post


Link to post
Share on other sites

Hello,

 

Thanks for the feedback. Did you change these two items in addition to adding the ?proxy aware? code?

 

I was having this same problem. Changing two PHP configuration values fixed it.

 

1. You need to disable safe mode under https.

 

php_admin_flag safe_mode Off

 

2. You need to set the open_basedir value to your home https/secure directory.

 

php_admin_value open_basedir "/home/httpd/vhosts/domain.com/httpsdocs:/"

 

If you do not have the access to make these changes yourself, and you probably don't, you need to contact your host and ask them to do it. This will allow the connection to the payment gateway using curl under the https protocol. Make sure they make the changes for https, not http.

 

Hope this helps; it worked for me.

 

- Paul

Share this post


Link to post
Share on other sites
Hello,

 

Thanks for the feedback. Did you change these two items in addition to adding the ?proxy aware? code?

 

I'm not sure what you mean by "proxy-aware" code....

 

- Paul

Share this post


Link to post
Share on other sites

Sorry Paul,

 

Earlier in the thread, when I first encountered this issue I posted code that my Web Hosting Company provided and referred to as "proxy aware". I tried to incorporate the code but have not had any success. I was wondering if you added this proxy aware code and the 2 php config changes or only the 2 php changes you outlined. I believe since you were not aware of the proxy aware code, you only made the two changes you posted.

 

Thanks, Kevin

 

I'm not sure what you mean by "proxy-aware" code....

 

- Paul

Share this post


Link to post
Share on other sites

Kevin,

 

No, I did not need your code. I just needed to override the default php settings. If you have root access to your server, this is easy. If not, you will need to request that your host do this for you (if they will). Let me know if it works for you or if you needmore clarification.

 

Best,

Paul

Share this post


Link to post
Share on other sites

Got the script working...sort of...

 

Find this line (line 175 or thereabouts):

 

$cmd = MODULE_PAYMENT_INNOVATIVE_CURL . " -d \"$data\" " . MODULE_PAYMENT_INNOVATIVE_URL;

 

Then add the following code right below that one (lifted and modified from the UPS XML module conribution):

 

exec($cmd, $return_string);

if ( empty($return_string) && $this->logfile) { // using exec no curl errors can be retrieved

error_log("Error from cURL using exec() since there is no \$return_string\n", 3, $this->logfile);

}

if ($this->logfile) {

error_log("IGS RESPONSE using exec(): " . $return_string[0] . "\n", 3, $this->logfile);

}

elseif ($this->use_exec == '1') { // if NOT (function_exists('exec') && $this->use_exec == '1'

if ($this->logfile) {

error_log("Sorry, exec() cannot be called\n", 3, $this->logfile);

}

} else{ // default behavior: cURL is assumed to be compiled in PHP

// echo "curl command<br>" . $cmd . "<br>";

$ch = curl_init();

curl_setopt ($ch, CURLOPT_URL, MODULE_PAYMENT_INNOVATIVE_URL);

curl_setopt ($ch, CURLOPT_HTTPPROXYTUNNEL, 1);

curl_setopt ($ch, CURLOPT_POST, 1);

curl_setopt ($ch, CURLOPT_POSTFIELDS, $data);

curl_setopt ($ch, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

curl_setopt ($ch, CURLOPT_PROXY, "64.202.165.130:3128");

curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, 0);

 

if ($this->logfile) {

error_log("IGS REQUEST: " . $return_string . "\n", 3, $this->logfile);

}

$return_string = curl_exec ($ch);

if (curl_errno($ch) && $this->logfile) {

$error_from_curl = sprintf('Error [%d]: %s', curl_errno($ch), curl_error($ch));

error_log("Error from cURL: " . $error_from_curl . "\n", 3, $this->logfile);

}

if ($this->logfile) {

error_log("RESPONSE: " . $return_string . "\n", 3, $this->logfile);

}

curl_close ($ch);

}

 

I dont get the "Error accessing gateway" error anymore. However, now i get the raw data, an error saying that "The server connection IP is invalid. Please try again. If you feel this message is in error please contact the security team at Innovative Gateway Solutions. (Error Code 1080)", as well as this error:

 

"Warning: Cannot modify header information - headers already sent by (output started at /home/content/j/p/s/jpskin2/html/catalog/includes/modules/payment/innovative.php:202) in /home/content/j/p/s/jpskin2/html/catalog/includes/functions/general.php on line 29"

 

Can anyone help me fine tune the code so we can get this thing to work? Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×