Jump to content
Sign in to follow this  
markchiu

Need some help after using Easy populate

Recommended Posts

Hello, guys, sorry to ask this stupid question, but after i use easy populate and upload it back, i found that all of my product pictures are gone!!! Did i miss any configurations for easypopulate.php???? Any help is always appreciated ;)


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

is this true? I just searched the base and found out that if you use easy populate and download it then edit then upload it to your database.....except that your image name IS the same as the model name of that particular item....................otherwise when you upload the edited file...all images of products will be gone..and you would have to re do it one by one in admin categories...

 

 

 

:o ...YOU MUST BE KIDDING ME! :( ...i SHOULD HAVE SEARCHED THIS BEFORE I INSTALLED EASY POPULATE... :unsure:

Edited by markchiu

OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

also why after i upload the edited file, then each of my products is double....sya, i have one called 123...then after upload the edited file, my 123 items is become 2-123s in my shop....why or did i set some configurations wrong?????


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

Can you show some example of image name in original easypopulate file downloaded from and the one edited by you?

 

Where are you uploading the products image file in your shop (directory name)?

 

It is not necessary that image names must be after products_model names while using easypopulate.

 

What product model numbers are you using? (example of products that gets doubled in your shop)?

 

It happens if the product model number of already existing product in shop is 2, when you upload easypopulate file, a new product is added with model number as 20.

 

You can try replacing $v_products_model in admin/easypopulate.php with trim($v_products_model).

Share this post


Link to post
Share on other sites

Hello, phpgold, to answer your quesiton

 

I upload my images by admin while i add new products, however, I believe all uploads to images (folder) directory

 

 

oh, ;) i think so, because after i upload the edited file, some image names aren't the same as some products, but they somehow still show up with their products...

 

 

all my products are using "YC" after with some numbers

 

It happens if the product model number of already existing product in shop is 2, when you upload easypopulate file, a new product is added with model number as 20.

 

You can try replacing $v_products_model in admin/easypopulate.php with trim($v_products_model).

 

Is this the final answer can solve my problem??? ;) ......sorry just kidding, but is it really?? Thank you very much :rolleyes:


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

bump :unsure:


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

btw, is that all of $v_products_model needed to change to

 

trim($v_products_model)

 

;)


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

Image file names are case sensitive, so they must match in your easypopulate file and on server. (*.JPG and *.jpg are different)

 

 

I have changed the following instance of $v_products_model in my file:

 

if ($v_products_model != "") {

                $v_products_model = trim($v_products_model);

Share this post


Link to post
Share on other sites

hello, phpgold, thanks, now after i edit it like what you say,...and how do i check if it works fine....say won't double my each of my itmes.......i am really worried about if it would mess up my products again... :unsure:


OS-commerce is great, but with other magical contributions, that is just so "COOL"!

Share this post


Link to post
Share on other sites

Right, Mibble!

 

Backup of database before using EP is neccessary as a slight mistake in file may harm the entire database.

 

I have also added the code in my easypopulate to delete the products from database, will be contributing the code shortly. However the code deletes all the products with same product id in the database, means if you have same product in different categories, it will deletes all the entries for that product from the database. It will also delete product image from the image directory, but won't delete it if the same image is attached with another product.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×