Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

You need to add the defines to admin/includes/database_tables.php:
   //MVS start
 define('TABLE_VENDORS', 'vendors');
 define('TABLE_VENDORS_INFO', 'vendors_info');
 define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');
 define('TABLE_ORDERS_SHIPPING', 'orders_shipping');
 define('TABLE_PACKAGING', 'packaging');
  //MVS end

 

Regards

Jim

Hi Jim,

Thats the same error I am getting, so I added the defines and im still getting the error. Just a couple questions.

1) With regards to the ... //MVS Start & //MVS End ... comments, am I supposed to remove these?

2) I put the defines at the bottom after VENDORS_ORDER_SENT, is that ok or does it need to be somewhere else on the page?

 

Thanks, never imagined id be doing something like this. =)

 

Don

Share this post


Link to post
Share on other sites

I am having a problem modifying the catalog/checkout shipping.php file.

 

I have a heavily modified store and am using Paypal WWP. There is one block of code to replace in this file that is causing me quite a bit of problems. Lines 58-135 need to be replaced with another block of code, however I have three Paypal mods in this section and it is not clear to me where to put them back in...I am not a php programmer.

 

Here is my unedited code segment with the Paypal mods added in:

 

$total_weight = $cart->show_weight();
 $total_count = $cart->count_contents();

// load all enabled shipping modules
 require(DIR_WS_CLASSES . 'shipping.php');
 $shipping_modules = new shipping;

 if ( defined('MODULE_ORDER_TOTAL_SHIPPING_FREE_SHIPPING') && (MODULE_ORDER_TOTAL_SHIPPING_FREE_SHIPPING == 'true') ) {
$pass = false;

switch (MODULE_ORDER_TOTAL_SHIPPING_DESTINATION) {
  case 'national':
	if ($order->delivery['country_id'] == STORE_COUNTRY) {
	  $pass = true;
	}
	break;
  case 'international':
	if ($order->delivery['country_id'] != STORE_COUNTRY) {
	  $pass = true;
	}
	break;
  case 'both':
	$pass = true;
	break;
}

$free_shipping = false;
if ( ($pass == true) && ($order->info['total'] >= MODULE_ORDER_TOTAL_SHIPPING_FREE_SHIPPING_OVER) ) {
  $free_shipping = true;

  include(DIR_WS_LANGUAGES . $language . '/modules/order_total/ot_shipping.php');
}
 } else {
$free_shipping = false;
 }

//---PayPal WPP Modification START ---//
 if (tep_paypal_wpp_enabled()) {
$ec_enabled = true;
 } else {
$ec_enabled = false;
 }

 if ($ec_enabled) {
if (isset($_GET['ec_cancel']) || (tep_session_is_registered('paypal_ec_token') && !tep_session_is_registered('paypal_ec_payer_id') && !tep_session_is_registered('paypal_ec_payer_info'))) {
  if (tep_session_is_registered('paypal_ec_temp')) tep_session_unregister('paypal_ec_temp');
  if (tep_session_is_registered('paypal_ec_token')) tep_session_unregister('paypal_ec_token');
  if (tep_session_is_registered('paypal_ec_payer_id')) tep_session_unregister('paypal_ec_payer_id');
  if (tep_session_is_registered('paypal_ec_payer_info')) tep_session_unregister('paypal_ec_payer_info');
}

$show_payment_page = false;

$config_query = tep_db_query("SELECT configuration_value FROM " . TABLE_CONFIGURATION . " WHERE configuration_key = 'MODULE_PAYMENT_PAYPAL_DP_DISPLAY_PAYMENT_PAGE' LIMIT 1");
if (tep_db_num_rows($config_query) > 0) {
  $config_result = tep_db_fetch_array($config_query);
  if ($config_result['configuration_value'] == 'Yes') {
	$show_payment_page = true;
  }
}

$ec_checkout = true;
if (!tep_session_is_registered('paypal_ec_token') && !tep_session_is_registered('paypal_ec_payer_id') && !tep_session_is_registered('paypal_ec_payer_info')) { 
  $ec_checkout = false;
  $show_payment_page = true;
} else {
  if (!tep_session_is_registered('payment')) tep_session_register('payment');
  $payment = 'paypal_wpp';
}
 }
//---PayPal WPP Modification END ---//

// process the selected shipping method
 if ( isset($HTTP_POST_VARS['action']) && ($HTTP_POST_VARS['action'] == 'process') ) {
if (!tep_session_is_registered('comments')) tep_session_register('comments');
if (tep_not_null($HTTP_POST_VARS['comments'])) {
  $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']);
}

if (!tep_session_is_registered('shipping')) tep_session_register('shipping');

if ( (tep_count_shipping_modules() > 0) || ($free_shipping == true) ) {
  if ( (isset($HTTP_POST_VARS['shipping'])) && (strpos($HTTP_POST_VARS['shipping'], '_')) ) {
	$shipping = $HTTP_POST_VARS['shipping'];

	list($module, $method) = explode('_', $shipping);
	if ( is_object($$module) || ($shipping == 'free_free') ) {
	  if ($shipping == 'free_free') {
		$quote[0]['methods'][0]['title'] = FREE_SHIPPING_TITLE;
		$quote[0]['methods'][0]['cost'] = '0';
	  } else {
		$quote = $shipping_modules->quote($method, $module);
	  }
	  if (isset($quote['error'])) {
		tep_session_unregister('shipping');
	  } else {
		if ( (isset($quote[0]['methods'][0]['title'])) && (isset($quote[0]['methods'][0]['cost'])) ) {
		  $shipping = array('id' => $shipping,
							'title' => (($free_shipping == true) ?  $quote[0]['methods'][0]['title'] : $quote[0]['module'] . ' (' . $quote[0]['methods'][0]['title'] . ')'),
							'cost' => $quote[0]['methods'][0]['cost']);

//---PayPal WPP Modification START ---//
						if ($show_payment_page || !$ec_enabled) {
							tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'));
						} else {
							tep_redirect(tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL'));
						}
//---PayPal WPP Modification END ---//
		}
	  }
	} else {
	  tep_session_unregister('shipping');
	}
  }
} else {
  $shipping = false;

//---PayPal WPP Modification START ---//
		if ($show_payment_page || !$ec_enabled) {
			tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'));
		} else {
			tep_redirect(tep_href_link(FILENAME_CHECKOUT_CONFIRMATION, '', 'SSL'));
		}
//---PayPal WPP Modification END ---//
}	
 }

 

Anyone using this same mod and able to figure out the crossover?? I tried using winmerge, but am not fluent with it yet and see too many differences. Files are backed up, so guess I can experiment if no one has any ideas. Thanks,

Rod

Share this post


Link to post
Share on other sites

One more thing...sorry for so many posts...I am still getting this error on the admin side. My pages are loading and some are partially functional or some have no errors, but the error is always the same:

 

Fatal error: Cannot redeclare tep_get_country_list() (previously declared in /hsphere/local/home/rodrico/eratoys.com/catalog/admin/includes/functions/html_output.php:299) in /hsphere/local/home/rodrico/eratoys.com/catalog/admin/includes/functions/html_output.php on line 299

 

I looked through the code and could not find my error.

 

Thanks,

Rod

Share this post


Link to post
Share on other sites

I am very glad to see this dialogue going on. We have implemented a number of new web stores which are very heavily modified and tailored under the skin (one is for the only American F1 driver!). We have incorporated MVS into all of them with a host of mods to get it to do what we wanted and fit with the heavy mods already done. It is working very well indeed (thanks guys!). It was a hell of an edit to shoehorn it all in (so many mods in our systems that things like WinMerge were no use).

 

One of the mods we have made, for example, is to the vendor email elements as many of our products drop ship. Our systems send fully loaded electronic POs to our vendors when a customer orders complete with custom info such as embroidery and screen printing requirements even with associated thumbnails of the designs in question. So here is one of our inputs: we support the multi shipment options for each product for each vendor described above. We do, for example, use UPS for shipments in the US and FedEx for overseas shipments. We do not presently have anything as easy as a "Domestic = UPS and International = FedEx" configuration option in Admin for the same drop ship vendor for the same products.

 

We have also attempted to implement product bundles. This has been fun in the context of MVS as the products in the bundle each have attributes (i.e. size and color and logo) and can each come from a different drop ship vendor and this in itself doesn't have a clean answer yet. Each product has to flow through the shopping cart and checkout process as a bundle and also be split out to calculate the individual and combined shipping costs, split out to send the individual POs to the vendors (a bundle can have more than one vendor in it) and split out for database update for stock and sales, etc. - all the while making sure that you know which products are in a bundle and which are not so that invoice pricing and totals are not hosed on the way through and you preserve the product attributes for each of the products in the bundle so they are correctly shown on the email POs. Products in a bundle also show, for example, 'Product in Bundle" where you would normally see a price in the shopping cart and have the delete option removed to prevent people deleting products that are in a bundle from the shopping cart. We have the same issue with shipments for products in bundles on the shipping page when they come from different drop ship places and you need to allow their individual selections and then aggregate the cost for the entire bundle.

 

I have no idea whether your scope goes to these lengths but we have found MVS fundamental to what we are trying to achieve and we are very happy to see more work done in that direction. More power to you.

 

If you know anyone who would like to tackle the product bundle/MVS combination issues we have (and no I do necessarily mean for free!) then let me know!

 

Cheers

 

Peter

Share this post


Link to post
Share on other sites
Hi Jim,

Thats the same error I am getting, so I added the defines and im still getting the error. Just a couple questions.

1) With regards to the ... //MVS Start & //MVS End ... comments, am I supposed to remove these?

2) I put the defines at the bottom after VENDORS_ORDER_SENT, is that ok or does it need to be somewhere else on the page?

 

Thanks, never imagined id be doing something like this. =)

 

Don

The comments are optional. I leave them in so I know where the changes are, but it's up to you.

 

Anything that defines VENDORS_ORDER_SENT should not be in this file. Check that you are actually in admin/includes/database_tables.php. If you are, then you have pasted some defines in the wrong place. As for these changes, they can go anywhere in the PHP section of the page (between <?php and ?>).

 

If you are still having problems with this, please copy and paste the exact error message you are getting here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
One more thing...sorry for so many posts...I am still getting this error on the admin side. My pages are loading and some are partially functional or some have no errors, but the error is always the same:

I looked through the code and could not find my error.

 

Thanks,

Rod

The most common error that causes this is loading a code file in the place of a language file. That is, putting the file that is supposed to be in admin/index.php in admin/includes/languages/english/index.php. Check the appropriate language file and replace if necessary. If that's not it, check that you have not added a second definition for tep_get_country_list(). We added that to admin/includes/functions/html_output.php, but some other contributions add the same function. It may have been added in a different file, so I would do a search of all of the function files to be certain.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
The comments are optional. I leave them in so I know where the changes are, but it's up to you.

 

Anything that defines VENDORS_ORDER_SENT should not be in this file. Check that you are actually in admin/includes/database_tables.php. If you are, then you have pasted some defines in the wrong place. As for these changes, they can go anywhere in the PHP section of the page (between <?php and ?>).

 

If you are still having problems with this, please copy and paste the exact error message you are getting here.

 

Regards

Jim

This is the error message :

1146 - Table 'allfoode_osc00.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

-----------------------------

 

I am in --- my site.com/admin/includes/database.php and i took out the following vendor related stuff from the database_tables.php page.

 

1.

//MVS Start

define('TABLE_HEADING_PRODUCTS_VENDOR', 'Vendor');

define('TABLE_HEADING_QUANTITY', 'Qty');

define('TABLE_HEADING_VENDORS_SHIP', 'Shipper');

define('TABLE_HEADING_SHIPPING_METHOD', 'Method');

define('TABLE_HEADING_SHIPPING_COST', 'Ship Cost');

define('VENDOR_ORDER_SENT', 'Order Sent to ');

//MVS End

 

2.

//MVS Start

define('TABLE_VENDORS', 'vendors');

define('TABLE_VENDORS', 'vendors_info');

define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');

define('TABLE_ORDERS_SHIPPING', 'orders_shipping');

define('TABLE_PACKAGING', 'packaging');

//MVS End

 

and this may be of some help, im confused about this line:

 

###### admin/includes/classes/vendor_order_data.php(added directly to classes/order.php for PHP compatibility)######

 

Has it been added already or do I need to do this?

 

Sorry, it gets confusing when your trying hard not to screw up.

 

Thanks, Don

Share this post


Link to post
Share on other sites
This is the error message :

1146 - Table 'allfoode_osc00.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

-----------------------------

 

I am in --- my site.com/admin/includes/database.php and i took out the following vendor related stuff from the database_tables.php page.

 

1.

//MVS Start

define('TABLE_HEADING_PRODUCTS_VENDOR', 'Vendor');

define('TABLE_HEADING_QUANTITY', 'Qty');

define('TABLE_HEADING_VENDORS_SHIP', 'Shipper');

define('TABLE_HEADING_SHIPPING_METHOD', 'Method');

define('TABLE_HEADING_SHIPPING_COST', 'Ship Cost');

define('VENDOR_ORDER_SENT', 'Order Sent to ');

//MVS End

 

2.

//MVS Start

define('TABLE_VENDORS', 'vendors');

define('TABLE_VENDORS', 'vendors_info');

define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');

define('TABLE_ORDERS_SHIPPING', 'orders_shipping');

define('TABLE_PACKAGING', 'packaging');

//MVS End

 

and this may be of some help, im confused about this line:

 

###### admin/includes/classes/vendor_order_data.php(added directly to classes/order.php for PHP compatibility)######

 

Has it been added already or do I need to do this?

 

Sorry, it gets confusing when your trying hard not to screw up.

 

Thanks, Don

BTW: I do NOT have --- my site.com catalog/admin/*

I have --- mysite.com/admin/*

Share this post


Link to post
Share on other sites
BTW: I do NOT have --- my site.com catalog/admin/*

I have --- mysite.com/admin/*

The location of your Admin section is not the problem, although you should rename it before you take the site live. The defines that you have listed under #2 in your post need to be in admin/includes/database.php. The lack of those defines will cause the error message that you describe. The defines in your #1 belong in admin/includes/languages/english/orders.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
The location of your Admin section is not the problem, although you should rename it before you take the site live. The defines that you have listed under #2 in your post need to be in admin/includes/database.php. The lack of those defines will cause the error message that you describe. The defines in your #1 belong in admin/includes/languages/english/orders.php.

 

Regards

Jim

 

Hi Jim,

 

Ok , i changed defines in database_tables & orders.php as you suggested but to no avail. And I've checked and double checked against the admin install txt., im at a loss. Also, you may have misunderstood me about the catalog folder, I do not have this folder on the server. Do I need it?

 

And I put the "vendor_order_data.php" in... /admin/includes/classes... i have a feeling that's wrong too.

 

Off to bed, 11 hrs of this is enough.

 

Thank you very much,

Don

Share this post


Link to post
Share on other sites

First, thanks for developing such a nice contribution... if only I could get it to work :blush:

 

I keep getting this :

 

 

Warning: main(includes/languages/english/index.php): failed to open stream: No such file or directory in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

 

Warning: main(includes/languages/english/index.php): failed to open stream: No such file or directory in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

 

Fatal error: main(): Failed opening required 'includes/languages/english/index.php' (include_path='.:/usr/local/lib/php') in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

 

 

after the installation..

 

Does anybody have any ideas?

 

Thanks

Share this post


Link to post
Share on other sites
Hi Jim,

 

Ok , i changed defines in database_tables & orders.php as you suggested but to no avail. And I've checked and double checked against the admin install txt., im at a loss. Also, you may have misunderstood me about the catalog folder, I do not have this folder on the server. Do I need it?

 

And I put the "vendor_order_data.php" in... /admin/includes/classes... i have a feeling that's wrong too.

 

Off to bed, 11 hrs of this is enough.

 

Thank you very much,

Don

The "catalog" folder is referring to the main folder containg the osC installation, you should have noticed when unpacking osCommerce, that the site files are in the "catalog" folder, it is standard practice to use it as a proper reference point for the file structure.

 

So, in your case, "public_html" or "htdocs" is the same as "catalog". If you are still getting the error about the "table does not exist", the problem does lie in the includes/database_tables.php on either the admin side or the "catalog" side or both. I would suggest you go back to the original file and compare it to the one included in the MVS package. You can use a compare program for this as well if you want, I use WinMerge, a free one available at Source Forge.

 

Good luck, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
First, thanks for developing such a nice contribution... if only I could get it to work :blush:

 

I keep getting this :

Warning: main(includes/languages/english/index.php): failed to open stream: No such file or directory in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

 

Warning: main(includes/languages/english/index.php): failed to open stream: No such file or directory in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

 

Fatal error: main(): Failed opening required 'includes/languages/english/index.php' (include_path='.:/usr/local/lib/php') in /home/terramag/domains/terramaga.com/public_html/shop/index.php on line 33

after the installation..

 

Does anybody have any ideas?

 

Thanks

This is from the server not finding your language files. Double check(look for the files through FTP or your file manager in your hosts CP) and go to 'includes/languages/english/' and see if the files are there. If they are not, you need to upload them again.

 

There should not have been anything during MVS installation to effect the particular file being referenced in the error message you posted, so the question needs to be, what happened to it? When you installed MVS you should have modified the files in the language directory as needed, did you modify or replace?

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
Thx,

 

solved it, but I don't get to see the vendors module...

 

back to the drawing board.. pff

Check that you added the link to the Vendors box in admin/includes/column_left.php.

 

That is where you will see the links to get to all of the setup.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
The "catalog" folder is referring to the main folder containg the osC installation, you should have noticed when unpacking osCommerce, that the site files are in the "catalog" folder, it is standard practice to use it as a proper reference point for the file structure.

 

So, in your case, "public_html" or "htdocs" is the same as "catalog". If you are still getting the error about the "table does not exist", the problem does lie in the includes/database_tables.php on either the admin side or the "catalog" side or both. I would suggest you go back to the original file and compare it to the one included in the MVS package. You can use a compare program for this as well if you want, I use WinMerge, a free one available at Source Forge.

 

Good luck, Craig :)

 

Thanks Craig, but herein lies the problem i think. The hosting company offered OSC it as a package ($$) and it was already loaded for me. So i just added the files from the MVS folders to the current admin & includes folders and edited it as per the admin install txt file. I dunno, maybe thats the problem.

 

Thanks, Don

Share this post


Link to post
Share on other sites
Thanks Craig, but herein lies the problem i think. The hosting company offered OSC it as a package ($$) and it was already loaded for me. So i just added the files from the MVS folders to the current admin & includes folders and edited it as per the admin install txt file. I dunno, maybe thats the problem.

 

Thanks, Don

HMMMMMM....

 

Well, take a good look at the database.php files from both sides and see just how much is different from yours and the ones included with MVS. Perhaps you have a package that has been modified with some other mods that we don't realise we are working with.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
HMMMMMM....

 

Well, take a good look at the database.php files from both sides and see just how much is different from yours and the ones included with MVS. Perhaps you have a package that has been modified with some other mods that we don't realise we are working with.

 

Craig :)

 

I modified the files on the original, i have nothing to compare to.

Share this post


Link to post
Share on other sites

Jim or Craig,

 

at /admin/index.php I have an x in a box shot that I don't have an image "admin/images/categories/vendors.ico" what image do I need?


Wade Morris

Amarillo, Texas

 

Before you do any changes on your site you need to do BACKUP! BACKUP!

Share this post


Link to post
Share on other sites
I modified the files on the original, i have nothing to compare to.

At the top of this page, click Solutions, then Downloads, then download the latest version of the software. You can use that for comparison purposes. I have found that most providers do not keep their osCommerce installs up to date. For security reasons I suggest that you delete your existing copy and start over with a clean install of the latest version. If you have too many modifications to make that practical, at least put in the security updates in the o51113 update.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hi. I just installed MVS into an osCMax version of oscommerce.

I'm having a little trouble getting things to work properly with the "Admin w/access levels" contribution.

Initially, when I went to the admin page, and clicked on any of the vendor links (Vendor management, Vendors, Product Reports, or Vendors Orders List), I got an error-- something like "No Right Permission Access". It basically said that I didn't have permission to access that link.

I looked around in the code, and found the admin_files database table, and it looked like I needed to have entries in that table for the files: vendors.php, prods_by_vendor.php, orders_by_vendor.php, move_vendor_prods.php.

 

I couldn't find any documentation on this table (is there anything I could look at???), but I guessed as follows:

I inserted 4 records into the table:

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('124', 'vendors.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('125', 'prods_by_vendor.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('126', 'orders_by_vendor.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('127', 'move_vendor_prods.php', '0', '124', '1');

 

I was then able to click on the vendor links.

But then when I went to the links, I noticed that the vendor links didn't show up in the box on the left, so I went to the "File Access" link (admin_files.php), and for "Vendors", I clicked on the green button to install the vendors box.

The Vendors links now show up in the box on the left, but I now have 2 records in the admin_files table for "vendors.php".

What should I do to fix this? Should I not have done the original inserts into the table? Should I have just gone to the admin_files.php and clicked on the green button?

Should I now remove the 4 entries that I added?

 

Thanks very much for any help with this.

I'm hoping I didn't totally mess things up. I looked all over the forums to try to find any kind of description of the admin_files table.

Share this post


Link to post
Share on other sites
Hi. I just installed MVS into an osCMax version of oscommerce.

I'm having a little trouble getting things to work properly with the "Admin w/access levels" contribution.

Initially, when I went to the admin page, and clicked on any of the vendor links (Vendor management, Vendors, Product Reports, or Vendors Orders List), I got an error-- something like "No Right Permission Access". It basically said that I didn't have permission to access that link.

I looked around in the code, and found the admin_files database table, and it looked like I needed to have entries in that table for the files: vendors.php, prods_by_vendor.php, orders_by_vendor.php, move_vendor_prods.php.

 

I couldn't find any documentation on this table (is there anything I could look at???), but I guessed as follows:

I inserted 4 records into the table:

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('124', 'vendors.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('125', 'prods_by_vendor.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('126', 'orders_by_vendor.php', '0', '124', '1');

insert into admin_files (admin_files_id, admin_files_name, admin_files_is_boxes, admin_files_to_boxes, admin_groups_id) values ('127', 'move_vendor_prods.php', '0', '124', '1');

 

I was then able to click on the vendor links.

But then when I went to the links, I noticed that the vendor links didn't show up in the box on the left, so I went to the "File Access" link (admin_files.php), and for "Vendors", I clicked on the green button to install the vendors box.

The Vendors links now show up in the box on the left, but I now have 2 records in the admin_files table for "vendors.php".

What should I do to fix this? Should I not have done the original inserts into the table? Should I have just gone to the admin_files.php and clicked on the green button?

Should I now remove the 4 entries that I added?

 

Thanks very much for any help with this.

I'm hoping I didn't totally mess things up. I looked all over the forums to try to find any kind of description of the admin_files table.

No other than the original osCommerce are allow on this website. So osCMax is not allow on this forum


Wade Morris

Amarillo, Texas

 

Before you do any changes on your site you need to do BACKUP! BACKUP!

Share this post


Link to post
Share on other sites
No other than the original osCommerce are allow on this website. So osCMax is not allow on this forum

 

I apologize if I wasn't supposed to post this question to this forum.

But I thought that it was an appropriate place. I'm just trying to get the MVS contribution to work with the Admin w/access levels contribution. If this is not the appropriate place for this type of question, could you please let me know where I can ask such a question.

Thanks very much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×