Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

However, I have found the "Welcome to" does not appear. What can I do to make good?

If I insert EMAIL_TEXT_GREETING after $email_order = STORE_NAME . "\n" . It will appear, so it needs something before it to appear.

 

The url used to be displayed as a blue underline hyperlink, its now just plain text. Any ideas what I may have done to cause the loss of the hyperlink?

I've now sorted parts of my original question :) (snipped from above)

 

I'm still stuck with getting some text to appear before

$email_order = STORE_NAME . "\n" .

It still won't appear in the email.

 

Can any one give me a hand please?

Here is the issue:

 

you have:

EMAIL_TEXT_GREETING . $email_order = STORE_NAME . "\n" .

and it should be:

$email_order = EMAIL_TEXT_GREETING . STORE_NAME . "\n" .

 

In order for your defined greeting to show before the store name.

 

You may want to add a line break between them, but that will be your preference.

 

Good luck, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
Here is the issue:

 

you have:

EMAIL_TEXT_GREETING . $email_order = STORE_NAME . "\n" .

and it should be:

$email_order = EMAIL_TEXT_GREETING . STORE_NAME . "\n" .

 

In order for your defined greeting to show before the store name.

 

You may want to add a line break between them, but that will be your preference.

 

Good luck, Craig :)

Another success, thank you again Craig :)


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

I have installed MVS on what will be my live shopping cart.

 

I have set up 3 venders :

 

1) using per item Shipping

2) using table rate

3) using free shipping

 

When I create orders I don't even get $0.00 amount printed out for the per item shipping and I show $0.00 for the table rate.

 

In other words the cart is not charging anything for shipping.

 

Can anyone help me with this?

 

Thanks,

 

Lisa

Edited by lisa65

Share this post


Link to post
Share on other sites

I'm also getting this error when I try to proceed through checkout.

 

ERROR_NO_SHIPPING_SELECTED_SELECTED

 

Thanks,

 

Lisa

Share this post


Link to post
Share on other sites

Okay, I fixed the per Item rate and I am not receiving the error any more. Now the only problem I am having is the table rate adding $0 for shipping.

 

Lisa

Share this post


Link to post
Share on other sites

Hello again,

when I put the shipping modules attacched in my previous post, the error is:

 

Warning: main(/membri/spicyshop/catalog/includes/languages/italian/modules/vendors_shipping/postepostaraccomandata.php) [function.main]: failed to open stream: Permission denied in /membri/spicyshop/catalog/admin/vendor_modules.php on line 129

 

Warning: main() [function.include]: Failed opening '/membri/spicyshop/catalog/includes/languages/italian/modules/vendors_shipping/postepostaraccomandata.php' for inclusion (include_path='.:') in /membri/spicyshop/catalog/admin/vendor_modules.php on line 129

 

Warning: main(/membri/spicyshop/catalog/includes/modules/vendors_shipping/postepostaraccomandata.php) [function.main]: failed to open stream: Permission denied in /membri/spicyshop/catalog/admin/vendor_modules.php on line 130

 

Warning: main() [function.include]: Failed opening '/membri/spicyshop/catalog/includes/modules/vendors_shipping/postepostaraccomandata.php' for inclusion (include_path='.:') in /membri/spicyshop/catalog/admin/vendor_modules.php on line 130

 

HELP PLEASE....

Share this post


Link to post
Share on other sites
Hello again,

when I put the shipping modules attacched in my previous post, the error is:

 

Warning: main(/membri/spicyshop/catalog/includes/languages/italian/modules/vendors_shipping/postepostaraccomandata.php) [function.main]: failed to open stream: Permission denied in /membri/spicyshop/catalog/admin/vendor_modules.php on line 129

 

Warning: main() [function.include]: Failed opening '/membri/spicyshop/catalog/includes/languages/italian/modules/vendors_shipping/postepostaraccomandata.php' for inclusion (include_path='.:') in /membri/spicyshop/catalog/admin/vendor_modules.php on line 129

 

Warning: main(/membri/spicyshop/catalog/includes/modules/vendors_shipping/postepostaraccomandata.php) [function.main]: failed to open stream: Permission denied in /membri/spicyshop/catalog/admin/vendor_modules.php on line 130

 

Warning: main() [function.include]: Failed opening '/membri/spicyshop/catalog/includes/modules/vendors_shipping/postepostaraccomandata.php' for inclusion (include_path='.:') in /membri/spicyshop/catalog/admin/vendor_modules.php on line 130

 

HELP PLEASE....

 

 

Sorry... I don't have setting the right permission!

 

but now the error is:

 

Fatal error: Call to undefined function: sort_order() in /membri/spicyshop/catalog/admin/vendor_modules.php on line 136

 

and I add in the top of the file this:

 

  class postepostaraccomandata {
var $code, $title, $description, $enabled, $num_zones, $vendors_id;

 

but the error remain the same...

Share this post


Link to post
Share on other sites

sorry...

 

another stupid question:

 

Can I set for some articles one vendors and for other none vendors (with default shipping and payment modules)?

 

thanks

Share this post


Link to post
Share on other sites

So I've searched everywhere and couldn't find an answer. The closest thing I read was from blucollarguy saying that they didn't need the vendor email to show all of the products order totals the way the customer email does. I need my vendor's to see shipping cost as well as the total tax, if there is any. I have coded it to display the toal shipping cost and it's working great, but I have no idea how to get it to show the total tax amount. Has anybody solved this?

 

TIA

Share this post


Link to post
Share on other sites

Here are some of the errors I found with the install:

 

*****ADMIN INSTALL********CATEGORIES.PHP INSTRUCTIONS

========================

Find Lines 370 thru 384

========================

 

if ($action == 'new_product') {

$parameters = array('products_name' => '',

'products_description' => '',

'products_url' => '',

'products_id' => '',

'products_quantity' => '',

'products_model' => '',

'products_image' => '',

'products_price' => '',

'products_weight' => '',

'products_date_added' => '',

'products_last_modified' => '',

'products_date_available' => '',

'products_status' => '',

'products_tax_class_id' => '',

******* the following should be replaced too but is not mentioned: *********

'manufacturers_id' => '');

 

 

=============

Replace With

=============

 

//MVS Many additions here, the order they are listed is very important, all new fields have vendor or vendors in the name, (ie, "vendors_product_price,")

if ($action == 'new_product') {

$parameters = array('products_name' => '',

'products_description' => '',

'products_url' => '',

'products_id' => '',

'products_quantity' => '',

'products_model' => '',

'products_image' => '',

'products_price' => '',

'products_weight' => '',

'products_date_added' => '',

'products_last_modified' => '',

'products_date_available' => '',

'products_status' => '',

'products_tax_class_id' => '',

// MVS start

'vendors_product_price' => '',

'vendors_prod_comments' => '',

'vendors_prod_id' => '',

'vendors_id' => '',

//MVS end

'manufacturers_id' => '');

 

 

 

 

 

 

==============

Find Line 701

==============

 

<td class="pageHeading" align="right"><?php echo $currencies->format($pInfo->products_price); ?></td>

 

 

===================

Add After Line 701

===================

 

<?php //MVS start

?>

<td class="pageHeading" align="right"><?php echo "Vendor Price: <br>" . $currencies->format($pInfo->vendors_product_price); ?></td>

</tr> ************I THINK THIS TR IS NOT NEEDED*****************

<?php //MVS end

?>

 

 

 

 

 

 

 

 

 

 

 

the following needs to go into database tables

 

 

//MVS Start

define('TABLE_HEADING_PRODUCTS_VENDOR', 'Vendor');

define('TABLE_HEADING_QUANTITY', 'Qty');

define('TABLE_HEADING_VENDORS_SHIP', 'Shipper');

define('TABLE_HEADING_SHIPPING_METHOD', 'Method');

define('TABLE_HEADING_SHIPPING_COST', 'Ship Cost');

define('VENDOR_ORDER_SENT', 'Order Sent to ');

 

 

// mlti vendor

define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');

 

//vendors email

define('TABLE_VENDORS', 'vendors');

define('TABLE_VENDORS_INFO', 'vendors_info');

define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');

define('TABLE_ORDERS_SHIPPING', 'orders_shipping');

define('TABLE_PACKAGING', 'packaging');

 

//MVS End

 

 

 

 

Checkout shipping in catalog has an extra <? around line 63

 

 

also around the first entry for MVS the first part is messed up. comapre to original file included with the package,

you should be able to figure it out pretty easy using the search command

Share this post


Link to post
Share on other sites
So I've searched everywhere and couldn't find an answer. The closest thing I read was from blucollarguy saying that they didn't need the vendor email to show all of the products order totals the way the customer email does. I need my vendor's to see shipping cost as well as the total tax, if there is any. I have coded it to display the toal shipping cost and it's working great, but I have no idea how to get it to show the total tax amount. Has anybody solved this?

 

TIA

Do you need the total tax for the entire order or just for that vendor? You can get the total tax from

$cart->info['tax']

but I can't imagine why you would need to show a vendor that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

Just installed MVS 1.1 today. I also have installed order editor and Admin Access version 2.2. Order Editor and MVS appear to work, but when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107. I did not see this error before I installed MVS today.

 

Does anyone know of any reason why this could be happening. Line 107 in my databse.php file is

 

Line 106 function tep_db_num_rows($db_query) {

Line 107 return mysql_num_rows($db_query);

Line 108 }

 

I read the previous post on how the installation instructions need to be modified and didn't know what these two lines were about or if I needed to modify them at this point. I am not sure if this would help me though.

Thank you.

 

Checkout shipping in catalog has an extra <? around line 63

 

 

also around the first entry for MVS the first part is messed up. comapre to original file included with the package,

you should be able to figure it out pretty easy using the search command

 

Any insight provided would be greatly appreciated.

Thank you.

Share this post


Link to post
Share on other sites
Hello,

 

Just installed MVS 1.1 today. I also have installed order editor and Admin Access version 2.2. Order Editor and MVS appear to work, but when I double click in my administrative system with admin access on my admin name, I recieve this error Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in */includes/functions/database.php on line 107. I did not see this error before I installed MVS today.

<snip>

I haven't used Admin Access so I can only give you some general ideas. I would start by searching for $db_query in your Admin files. This should be used in database.php and nowhere else. If it was redeclared elsewhere then you would see this error. There may also be some obscure possible causes, but try that one first.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Thank you for the quick reply. I haven't been able to find $db_query in any other admin files(although I didn't search everyone). I found tep_db_query in my admin section, but I don't think this should be an issue.

 

The weird thing about this is when I try to edit another user(not the 1st one) I have no problems. It is just when I try to access this file admin/admin_members.php?page=1&mID=1&action=edit_member I recieve the error message. Is this making my site any less secure?

 

Any other suggestions?

 

Best,

Steve

Share this post


Link to post
Share on other sites

I have the latest mvs, indiship, osc ms2.2

I have every thing working vas advertised except the handling charge does not show and is not added. This is my last issue before adding the CC/paypal code. I have sucessfully moded and tested my shop but I can't quite seem to find the issue.

Cold someone point me in the right direction? Have searched and searched the forums no success!

Share this post


Link to post
Share on other sites
I have the latest mvs, indiship, osc ms2.2

I have every thing working vas advertised except the handling charge does not show and is not added. This is my last issue before adding the CC/paypal code. I have sucessfully moded and tested my shop but I can't quite seem to find the issue.

Cold someone point me in the right direction? Have searched and searched the forums no success!

Forgot to mention- I am using stock ot and testing using cod and usps.

Share this post


Link to post
Share on other sites

I'm currently merging in MVS into my newly downloaded version of oscmax.

This is a challenge--I've got 33 files to merge!

 

I'm looking at the changes in catalog/checkout_confirmation.php.

It contains the following snippet of code:

 

//MVS start

// load the selected shipping module

if (($total_weight > 0 ) || (SELECT_VENDOR_SHIPPING == 'true')){

include(DIR_WS_CLASSES . 'vendor_shipping.php');

} elseif (($total_weight > 0 ) || (SELECT_VENDOR_SHIPPING == 'false')){

include(DIR_WS_CLASSES . 'shipping.php');

}

$shipping_modules = new shipping($shipping);

//MVS End

 

It looks to me like if $total_weight is greater than 0, it will always execute the first clause, whether SELECT_VENDOR_SHIPPING is true or false, and it will never execute the second clause.

Shouldn't these be && instead of || (AND instead of OR)??

 

Thanks,

-Lori-

Share this post


Link to post
Share on other sites
Forgot to mention- I am using stock ot and testing using cod and usps.

This was not a MVS problem but a dumb programmer problem. Forgot to change sort order in OT mods so handling would work. sorry for wasting your bits.

Share this post


Link to post
Share on other sites

Thanks for the reply Jim. I am looking for somewhere in the checkout_process page and $cart info isn't there. I set up shipping by adding the following:

 

'Vshipcost' => $vendor_order['shipping_cost']

 

and then in the body of the email:

 

'<br> Shipping Cost: ' . $vendor_products[$l]['Vshipcost'] .

 

Can I do something similar in that file to display the tax for that order?

 

Thanks again ofr the help.

 

Do you need the total tax for the entire order or just for that vendor? You can get the total tax from
$cart->info['tax']

but I can't imagine why you would need to show a vendor that.

 

Regards

Jim

Share this post


Link to post
Share on other sites
Thanks for the reply Jim. I am looking for somewhere in the checkout_process page and $cart info isn't there. I set up shipping by adding the following:

 

'Vshipcost' => $vendor_order['shipping_cost']

 

and then in the body of the email:

 

'<br> Shipping Cost: ' . $vendor_products[$l]['Vshipcost'] .

 

Can I do something similar in that file to display the tax for that order?

 

Thanks again ofr the help.

Yes, the Cart class is instantiated in application_top.php, so it is available on any page. You could define something like

'Vshiptax' => $cart->info['tax'];

and then add the tax into the email. Again, remember that this is the total tax for the order, not just the tax for one vendor.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
I read the previous post on how the installation instructions need to be modified and didn't know what these two lines were about or if I needed to modify them at this point. I am not sure if this would help me though.

Thank you.

 

Checkout shipping in catalog has an extra <? around line 63

also around the first entry for MVS the first part is messed up. comapre to original file included with the package,

you should be able to figure it out pretty easy using the search command

 

Any insight provided would be greatly appreciated.

Thank you.

 

Both of those notes refer to checkout_shipping.php. If you look at the version they include that is already modified and compare it to the instructions you can see the errors in the instructions pretty easily.

 

Also, another error I think I found in this package that I didn't document was that there was a duplicate function they had declared in their install code on the admin side. It was in one of the main function files.. It may be that some other mod I had done already had it declared but I don't recall whether or not that was the case. Sorry.

Share this post


Link to post
Share on other sites
Also, another error I think I found in this package that I didn't document was that there was a duplicate function they had declared in their install code on the admin side. It was in one of the main function files.. It may be that some other mod I had done already had it declared but I don't recall whether or not that was the case. Sorry.

The tep_cfg_select_multioption() function is used by other contributions, so you may have it already installed. Somebody might have used tep_get_country_list() since it's just copied from the Catalog side. I can't imagine anybody else finding a use for tep_set_vendor_email(), tep_get_vendors_info() or tep_get_vendors_prod_comments(). That's all we added to the Admin side.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I have just installed the MVS contribution and get the following error on the admin side:

 

1146 - Table 'rodrico_shopping.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

I checked my sql database and that table exists with all the data from the sql file.

 

Can someone steer me in the right direction??

 

Thanks,

Rod

Share this post


Link to post
Share on other sites
I have just installed the MVS contribution and get the following error on the admin side:

 

1146 - Table 'rodrico_shopping.TABLE_VENDOR_CONFIGURATION' doesn't exist

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

[TEP STOP]

You need to add the defines to admin/includes/database_tables.php:

   //MVS start
 define('TABLE_VENDORS', 'vendors');
 define('TABLE_VENDORS_INFO', 'vendors_info');
 define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');
 define('TABLE_ORDERS_SHIPPING', 'orders_shipping');
 define('TABLE_PACKAGING', 'packaging');
  //MVS end

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×