Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

Thanks for the link. This is the problem I am having. The instructions say to add some new files to the catalog folder. I don't have a catalog folder anywhere in my osCommerce installation, test or live versions.

 

I keep running into these inconsistancies with instructions pertaining to file names and paths.

 

I have version 2.2 MS2 so I am not sure what the problem is. I am not a programmer but I usually have no problems editing and implementing scripts like this.

 

Any ideas?

 

Thanks,

 

Lisa

 

These are not inconsistencies, as a matter of fact, they are just the opposite. Catalog refers to the directory where you installed your shop. Since it would be highly improbable that everyone installing osC would name the directory file exactly the same or install it on the same branch of the tree; we use the generic term "Catalog".

 

What the hell am I talking about? It's like this; where you can see the list of all directories (admin, includes, images, etc.) and all of the shop files needed to run your store; that is your "Catalog". If you installed osCommerce in a sub-directory i.e www DOT mywebsite DOT com/mycoolstore/ then mycool store would be your "Catalog"

 

I hope this helps.

Edited by HallMarc

Share this post


Link to post
Share on other sites
These are not inconsistencies, as a matter of fact, they are just the opposite. Catalog refers to the directory where you installed your shop. Since it would be highly improbable that everyone installing osC would name the directory file exactly the same or install it on the same branch of the tree; we use the generic term "Catalog".

 

What the hell am I talking about? It's like this; where you can see the list of all directories (admin, includes, images, etc.) and all of the shop files needed to run your store; that is your "Catalog". If you installed osCommerce in a sub-directory i.e www DOT mywebsite DOT com/mycoolstore/ then mycool store would be your "Catalog"

 

I hope this helps.

 

 

Well, that explains everything!

 

I have been looking for the catalog file all morning. hahaha

 

Thanks,

 

Lisa

Share this post


Link to post
Share on other sites

Email notifications

 

I want to include the full customer address in the emails sent out to the venders.

 

At present only the emails that go out to the customer has the full address, which consists of

Street Address:

Suburb:

Post Code:

City:

State:

Country:

 

In the emails that go out to the vendor/supplier, I have a line missing (Suburb:) so left with

Street Address:

Post Code:

City:

State:

Country:

 

Can any one help me to add the missing line to the vendor emails please?

 

Thanks for looking

 

Steve


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Email notifications

 

I want to include the full customer address in the emails sent out to the venders.

 

At present only the emails that go out to the customer has the full address, which consists of

Street Address:

Suburb:

Post Code:

City:

State:

Country:

 

In the emails that go out to the vendor/supplier, I have a line missing (Suburb:) so left with

Street Address:

Post Code:

City:

State:

Country:

 

Can any one help me to add the missing line to the vendor emails please?

 

Thanks for looking

 

Steve

You can reference this page in the forum for the Vendors Auto Email thread, VAE Add Address field to email

 

There are a couple of posts on that page that address exactly what you are trying to do, just check that you use the correct table name(customer_suburb... or what ever it is) in the database.

 

Good luck, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites

Thanks for your reply Craig

 

:D

 

Steve


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

Well, I installed MVS 1.1 and I can access my store just fine. When I try and access the admin area I get this error message...

 

1146 - Table 'mysite_osc2.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

 

I ran the sql queries with php my admin.

 

VENDOR_CONFIGURATION does exist in the database so I am a little confused about the error.

 

Anyone familiar with this one?

 

Thanks,

 

Lisa

Share this post


Link to post
Share on other sites
Well, I installed MVS 1.1 and I can access my store just fine. When I try and access the admin area I get this error message...

 

1146 - Table 'mysite_osc2.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

 

I ran the sql queries with php my admin.

 

VENDOR_CONFIGURATION does exist in the database so I am a little confused about the error.

 

Anyone familiar with this one?

 

Thanks,

 

Lisa

 

 

Never mind guys, I found the missing code in another post. I can now access my admin screen. I sure hope all goes well with this thing. :)

 

Lisa

Share this post


Link to post
Share on other sites
Well, I installed MVS 1.1 and I can access my store just fine. When I try and access the admin area I get this error message...

 

1146 - Table 'mysite_osc2.TABLE_VENDOR_CONFIGURATION' doesn't exist

 

select configuration_key as cfgKey, configuration_value as cfgValue from TABLE_VENDOR_CONFIGURATION

 

[TEP STOP]

 

I ran the sql queries with php my admin.

 

VENDOR_CONFIGURATION does exist in the database so I am a little confused about the error.

 

Anyone familiar with this one?

 

Thanks,

 

Lisa

Add the following to admin/includes/database_tables.php:

// mlti vendor
 define('TABLE_VENDOR_CONFIGURATION', 'vendor_configuration');

//vendors email
 define('TABLE_VENDORS', 'vendors');
 define('TABLE_VENDORS_INFO', 'vendors_info');

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

It looks like the installation of Multi_Vendor_Shipping is working fine except for the link on the main Admin screen the link to Vendor Management under catalog doesn't work.

 

I'm not sure which file might be causing the problem.

 

How can I fix this?

 

Thanks again,

 

Lisa

Share this post


Link to post
Share on other sites

Hello, I installed MVS and everything seems to work up to checkout. I have one vendor who uses Fedex. When I hit continue from the initial checkout The following error comes up

 

Warning: Missing argument 2 for _setservice() in /var/www/html/store/includes/modules/vendors_shipping/fedex1.php on line 309

 

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/store/includes/modules/vendors_shipping/fedex1.php:309) in /var/www/html/store/includes/functions/general.php on line 32

 

The code from those lines are as follows, fedex1.php: 309 first:

 

function _setService($service, $vendors_id) {

$this->service = $service;

}

 

the function line is 309

 

// Redirect to another page or site

function tep_redirect($url) {

if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page

if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url

$url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL

}

}

 

header('Location: ' . $url);

 

tep_exit();

}

 

The header line is line 32

 

Has anyone encountered this or know what's going on? I'm sooo close....hehe

Share this post


Link to post
Share on other sites
It looks like the installation of Multi_Vendor_Shipping is working fine except for the link on the main Admin screen the link to Vendor Management under catalog doesn't work.

 

I'm not sure which file might be causing the problem.

 

How can I fix this?

 

Thanks again,

 

Lisa

If you are getting a 404 error, the file admin/vendors.php is missing, or the file definition is missing from admin/includes/filenames.php. If that doesn't do it, please copy and paste the error message here so we can figure it out.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Hello, I installed MVS and everything seems to work up to checkout. I have one vendor who uses Fedex. When I hit continue from the initial checkout The following error comes up

<snip>

Change the code from fedex1.php to read:

function _setService($service) {
$this->service = $service;
}

I thought that we had fixed that one. Sigh. Another bug....

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I actually changed $vendors_id to $vendors_id = '1'. It seems to have fixed it unless setting that to 1 does something I don't understand. That is completely possible BTW, hehe.

 

Sorry if I caught a bug. Thanks again for all your work on this. It saved my store.

Share this post


Link to post
Share on other sites
If you are getting a 404 error, the file admin/vendors.php is missing, or the file definition is missing from admin/includes/filenames.php. If that doesn't do it, please copy and paste the error message here so we can figure it out.

 

Regards

Jim

 

I don't get a 404 error and I don't get an error message. It just reloads the main admin screen.

 

When I mouse over the link, http://mystore.com/test/admin/ is the link shown at the bottom left of my browser window.

 

Lisa

Share this post


Link to post
Share on other sites
I don't get a 404 error and I don't get an error message. It just reloads the main admin screen.

 

When I mouse over the link, http://mystore.com/test/admin/ is the link shown at the bottom left of my browser window.

 

Lisa

That link is incomplete, so I suspect an error in admin/includes/boxes/vendors.php. If that file has not been modified, then the definition in admin/includes/filenames.php is incorrect. It should be

  define('FILENAME_VENDORS', 'vendors.php');

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
That link is incomplete, so I suspect an error in admin/includes/boxes/vendors.php. If that file has not been modified, then the definition in admin/includes/filenames.php is incorrect. It should be

  define('FILENAME_VENDORS', 'vendors.php');

Regards

Jim

 

I can't seem to find an error, maybe you can.

 

This is the code I pasted into admin/includes/filenames.php...

 

//MVS and vendors email Start

define('FILENAME_VENDORS', 'vendors.php');

define('FILENAME_VENDOR_MODULES', 'vendor_modules.php');

define('FILENAME_PRODS_VENDORS', 'prods_by_vendor.php');

define('FILENAME_ORDERS_VENDORS', 'orders_by_vendor.php');

define('FILENAME_VENDORS_EMAIL_SEND', 'vendor_email_send.php');

define('FILENAME_MOVE_VENDORS', 'move_vendor_prods.php');

//MVS and vendors email End

 

This is the code I copied from admin/index.php regarding venders...

 

//MVS start

array('title' => BOX_HEADING_VENDOR_MODULES,

'image' => 'vendors.ico',

'href' => tep_href_link(FILENAME_VENDORS, 'selected_box=vendors'),

'children' => array(array('title' => BOX_HEADING_VENDORS, 'link' => tep_href_link(FILENAME_VENDORS, 'selected_box=vendors')),

array('title' => BOX_VENDORS_REPORTS_PROD, 'link' => tep_href_link(FILENAME_PRODS_VENDORS, 'selected_box=vendors')),

array('title' => BOX_VENDORS_ORDERS, 'link' => tep_href_link(FILENAME_ORDERS_VENDORS, 'selected_box=vendors'))

)), //MVS end

 

I'm sure it's some silly mistake I've made but I sure can't figure it out. Let me know if you need me to post anything else.

 

Thanks again for your help.

 

Lisa

Share this post


Link to post
Share on other sites
I can't seem to find an error, maybe you can.

 

<snip>

That all looks right to me. Try this: Click on any of the other headings in admin/index.php, then click on the Vendors heading in the left column. Can you get to the file that way?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
That all looks right to me. Try this: Click on any of the other headings in admin/index.php, then click on the Vendors heading in the left column. Can you get to the file that way?

 

Regards

Jim

 

That's what was strange, I could get to the vender management area from the left column but not from the main admin screen.

 

I finally fixed it by copying the admin/index file from the unzipped files and now it seems to work just fine. I have no idea what I did wrong but it seems to be fixed now.

 

Everything else seems to be working.

 

Thanks again for your help.

 

Lisa

Share this post


Link to post
Share on other sites

hi everyone.

i am sorry to post this question before even reading the forum, but,, you have 113pages here, a bit too much!!

 

i am looking to build a multivendor portal, where the user can browse products from different vendors at same time, or enter the vendor subsite and move only inside it.

first question: is there any collaboaration for this yet?

 

now, everything will be collected in the same cart, but on checkout, user should choose different time and cost of shipping for each vendor (i didnt figure out yet the interface/process.. risk to get ugly ah!)

 

i just delevloped a module to let the user select the time of delivery (I will post it soon), which will be integrated with this system too.

 

do we have something to do this? thanks

jacopo from shanghai


Expresionario.com | Pura Sub-cultura!

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for your great work for making this contribution.

 

I have managed to successfully install this, however it is not doing what I was expecting it to do, and I was wondering if it was because I am not using it properly, or if the module was not intended to do it.

 

We have a warehouse on the west coast which is where we stock most of our products. However, we do have some products to Drop Ship from on the east coast.

 

I added a new Vendor on the east coast, and then added a new product with the new vendor. I installed the standard base UPS module with the new vendor. I filled in most of the sections for the vendor information (City, State, Zip etc) However, when I test this purchase with a test account, the shipping is still calculated as shipping from the West Coast instead of the new vendor on the east coast. That means all of our west coast buyers are getting much cheaper shipping than they are meant to pay.

 

Is there something I am not setting correctly so that the shipping for this new item will be calculated as being shipped from the east coast?

 

Thanks in advance :)

 

Mark

Share this post


Link to post
Share on other sites

I'm not coder, so treat my question as a complete beginner :)

 

I've been changing catalog/checkout_process.php to a style I'm happy with, however I need to forward the customers telephone number to the vendor (they won't ship to customers without a contact telephone number)

 

Below is the bit of code detailing the customers address in the email to the vendor. The bit I'm totally lost on, is what code should I enter to display the telephone number?

 

 '<br>Please deliver to:<br>' .
$vendor_delivery_address_list['delivery_company'] .'<br>' .
$vendor_delivery_address_list['delivery_name'] .'<br>' .
$vendor_delivery_address_list['delivery_street_address'] .'<br>' .
$vendor_delivery_address_list['delivery_suburb'] .'<br>' .
$vendor_delivery_address_list['delivery_city'] .'<br>' .
$vendor_delivery_address_list['delivery_state'] .'<br>' .
$vendor_delivery_address_list['delivery_postcode'] . '<br><br>' .
>>> Telephone number here <<<

 

I've tried this line, but I get nothing :(

 

 $order->customer['telephone'] .

It would be nice to have the telephone number displayed as

 

>>> Tel No.: 01234567890 <<<

 

Can anyone guide me without getting too technical and shooting way over my head please?


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Hi,

 

Thank you for your great work for making this contribution.

...

Mark

 

:-" nevermind, I should have read the first line in the HOW TO USE section " Open your Admin panel, click on Configuration->Shipping/Packaging, then click on Use Vendor Shipping." before posting. Sorry.

Share this post


Link to post
Share on other sites
I'm not coder, so treat my question as a complete beginner :)

 

I've been changing catalog/checkout_process.php to a style I'm happy with, however I need to forward the customers telephone number to the vendor (they won't ship to customers without a contact telephone number)

 

Below is the bit of code detailing the customers address in the email to the vendor. The bit I'm totally lost on, is what code should I enter to display the telephone number?

 

 '<br>Please deliver to:<br>' .
$vendor_delivery_address_list['delivery_company'] .'<br>' .
$vendor_delivery_address_list['delivery_name'] .'<br>' .
$vendor_delivery_address_list['delivery_street_address'] .'<br>' .
$vendor_delivery_address_list['delivery_suburb'] .'<br>' .
$vendor_delivery_address_list['delivery_city'] .'<br>' .
$vendor_delivery_address_list['delivery_state'] .'<br>' .
$vendor_delivery_address_list['delivery_postcode'] . '<br><br>' .
>>> Telephone number here <<<

 

I've tried this line, but I get nothing :(

 

 $order->customer['telephone'] .

It would be nice to have the telephone number displayed as

 

>>> Tel No.: 01234567890 <<<

 

Can anyone guide me without getting too technical and shooting way over my head please?

 

You need to add the "CUSTOMERS_TELEPHONE" to the query first:

$delivery_address_query = tep_db_query("select distinct delivery_company, delivery_name, delivery_street_address, delivery_city, delivery_state, delivery_postcode, customers_email_address, customers_telephone from " . TABLE_ORDERS . " where orders_id='" . $oID ."'");

 

The add the call you are looking for:

 '<br>Please deliver to:<br>' .
$vendor_delivery_address_list['delivery_company'] .'<br>' .
$vendor_delivery_address_list['delivery_name'] .'<br>' .
$vendor_delivery_address_list['delivery_street_address'] .'<br>' .
$vendor_delivery_address_list['delivery_suburb'] .'<br>' .
$vendor_delivery_address_list['delivery_city'] .'<br>' .
$vendor_delivery_address_list['delivery_state'] .'<br>' .
$vendor_delivery_address_list['delivery_postcode'] . '<br><br>' .
'>>>' .  $vendor_delivery_address_list['customers_telephone'] . '<<<'

 

That should do it just fine, good luck, Craig :)

Edited by blucollarguy

Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites

Hello,

 

Been meaning to ask this for a while.

 

In the UPS shipping module, where, how can I find out what all the abbreviations for the shipping methods represent?

 

1DM, 1DML, 1DA, 1DAL, 1DAPI, 1DP, 1DPL, 2DM, 2DML, 2DA, 2DAL, 3DS, GND, STD, XPR, XPRL, XDM, XDML, XPD

 

Some are obvious but many, I have no clue.

 

TIA

Share this post


Link to post
Share on other sites
Hello,

 

Been meaning to ask this for a while.

 

In the UPS shipping module, where, how can I find out what all the abbreviations for the shipping methods represent?

 

1DM, 1DML, 1DA, 1DAL, 1DAPI, 1DP, 1DPL, 2DM, 2DML, 2DA, 2DAL, 3DS, GND, STD, XPR, XPRL, XDM, XDML, XPD

 

Some are obvious but many, I have no clue.

 

TIA

Look in the module (catalog/includes/modules/vendors_shipping/ups.php) starting at line 38.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×