Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

I dont ship items myself I use drop shipping can I still use UPS XML or should i Use reg UPS?

 

Also the handling fee isnt working on the UPS XML Module, Some of my vendors use signature Delivery confirmation added so how can I add that?

Share this post


Link to post
Share on other sites
Do you have at least one shipping module installed for each vendor?

 

Regards

Jim

I've now done that, which has stopped the page error :) Thanks :D

 

However the page now loads, but in a red background at the top I get this message "ERROR_NO_SHIPPING_SELECTED_SELECTED"

This is the page url -

http // mystore.net /store/checkout_shipping.php?error_message=ERROR_NO_SHIPPING_SELECTED_SELECTED

 

Lower down the page I have;

 

Shipping Method

Products

Geo Pump

This is currently the only shipping method available to use on this order.

 

Zone Rates

No shipping available to the selected country

Going through the purchasing as a customer (registered) there isn't any options for what shipping I'd like or what the products options are.

 

I've set everything that I have found via admin to united kingdom. So very stumped as to why I get the above.

 

On adding/editing a product, there dosn't seem to be any options to set up a shipping method or cost, or am I looking in the wrong place?

 

Any ideas where I may be going wrong please?


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
I dont ship items myself I use drop shipping can I still use UPS XML or should i Use reg UPS?

 

Also the handling fee isnt working on the UPS XML Module, Some of my vendors use signature Delivery confirmation added so how can I add that?

The regular UPS module might be better for you. It would save the bother of getting a UPS account that you don't plan on shipping from. It's up to you; use whatever works best for you.

 

I thought that the handling fee was working on this module; I'll take a look at it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
I've now done that, which has stopped the page error :) Thanks :D

 

However the page now loads, but in a red background at the top I get this message "ERROR_NO_SHIPPING_SELECTED_SELECTED"

This is the page url -

http // mystore.net /store/checkout_shipping.php?error_message=ERROR_NO_SHIPPING_SELECTED_SELECTED

 

Lower down the page I have;

 

Going through the purchasing as a customer (registered) there isn't any options for what shipping I'd like or what the products options are.

 

I've set everything that I have found via admin to united kingdom. So very stumped as to why I get the above.

 

On adding/editing a product, there dosn't seem to be any options to set up a shipping method or cost, or am I looking in the wrong place?

 

Any ideas where I may be going wrong please?

You have your zones set improperly. The result is that no shipping module is currently valid, so shipping cannot be selected. The error message is caused by an attempt to proceed with checkout without a valid shipping method being selected.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
You have your zones set improperly. The result is that no shipping module is currently valid, so shipping cannot be selected. The error message is caused by an attempt to proceed with checkout without a valid shipping method being selected.

 

Regards

Jim

Thanks for the reply Jim,

 

Can you indicate wher I should be looking please.

 

Is there a demo site anywhere, that I can access the admin panel to see what a store is supposed to have as I get the feeling I have bits missing.


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites

What about tax lets sat my vendor is in California and If customer is from california then he needs to get taxed, Is this possible?\\

 

I tried it but it gets taxed all the time..

Share this post


Link to post
Share on other sites
Thanks for the reply Jim,

 

Can you indicate wher I should be looking please.

 

Is there a demo site anywhere, that I can access the admin panel to see what a store is supposed to have as I get the feeling I have bits missing.

Craig has a demo site for MVS -- see the readme.txt in the MVS distribution for the location. I also have a test site for mvs. Craig's site seems to be down right now. Mine is used for testing, so parts of it may be acting a bit weird. You can at least get an idea of what to expect.

 

You might want to start with something simple just to test your installation. Try disabling all of your modules except Flat. Set the flat fee differently for each vendor so you can see what is happening. After you have it figured out, then try setting each vendor, one at a time, to the modules and settings you want to use. Test each vendor thoroughly before making more changes. This will make it a lot easier to figure out what is going wrong (or right.)

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
What about tax lets sat my vendor is in California and If customer is from california then he needs to get taxed, Is this possible?\\

 

I tried it but it gets taxed all the time..

You need to set up a tax zone for California in Admin > Locations / Taxes > Tax Zones, then set up a tax rate for California in Admin > Locations / Taxes > Tax Rates and assign it to the tax zone that you previously created. I have a client who taxes in Michigan and California and this works just fine. I had to add county taxes for two California counties, though, and that was a royal pain. Hope that you don't need to do that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Craig has a demo site for MVS -- see the readme.txt in the MVS distribution for the location. I also have a test site for mvs. Craig's site seems to be down right now. Mine is used for testing, so parts of it may be acting a bit weird. You can at least get an idea of what to expect.

 

You might want to start with something simple just to test your installation. Try disabling all of your modules except Flat. Set the flat fee differently for each vendor so you can see what is happening. After you have it figured out, then try setting each vendor, one at a time, to the modules and settings you want to use. Test each vendor thoroughly before making more changes. This will make it a lot easier to figure out what is going wrong (or right.)

 

Regards

Jim

I had to setup a new demo, I got hacked on the other site(sometimes I just don't get people), any way, links are in my signature now and I will update the readme.txt with the next release.

 

It sounds like your tax zones are not set up properly, try clicking "details" from the "tax zones" link, and see if there is a zone set for your tax zone.

 

Good luck, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
You might want to start with something simple just to test your installation. Try disabling all of your modules except Flat. Set the flat fee differently for each vendor so you can see what is happening. After you have it figured out, then try setting each vendor, one at a time, to the modules and settings you want to use. Test each vendor thoroughly before making more changes. This will make it a lot easier to figure out what is going wrong (or right.)

 

Regards

Jim

Hey great, got that working now :) Just needed pointing in the right direction :D

 

Is there some way I can set specific delivery prices for individual stock/catalogue items please?

 

Thanks

 

Steve


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Hey great, got that working now :) Just needed pointing in the right direction :D

 

Is there some way I can set specific delivery prices for individual stock/catalogue items please?

 

Thanks

 

Steve

Try the Individual Shipping contribution. There's a version already modified for MVS.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Try the Individual Shipping contribution. There's a version already modified for MVS.

 

Regards

Jim

Thanks for that Jim, I'll go and have a look :)

 

Been testing and would like to change a few words. On the VSM I'd like to rename 'Flat Rate' to something else, so which file should I look for please.

vendershipping.jpg

 

On the following screen shot from the checkout, which file do I need to change 'Best Way' please?

shippingmethod.jpg

 

Thanks again :D

 

Steve


____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Thanks for that Jim, I'll go and have a look :)

 

Been testing and would like to change a few words. <snip>

Language files are in catalog/includes/languages/english/modules/vendors_shipping/<module name>.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
The regular UPS module might be better for you. It would save the bother of getting a UPS account that you don't plan on shipping from. It's up to you; use whatever works best for you.

 

I thought that the handling fee was working on this module; I'll take a look at it.

 

Regards

Jim

 

 

Jim,

 

The handling fee doesn't work for my UPS XML either. All looks OK in the code from what I can see. I also tried to set the fee at the vendor level and that didn't work either.


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites
Jim,

 

The handling fee doesn't work for my UPS XML either. All looks OK in the code from what I can see. I also tried to set the fee at the vendor level and that didn't work either.

 

 

 

As a follow up. The fees work when I use the Table rate, but not with UPS XML.

I switched to the Table rate for now, I was tired of just breaking even on some of my smaller sales.


Life Is Too Short,

Enjoy Your Coffee!

Pete

Share this post


Link to post
Share on other sites

Please forgive me. I know I have asked this a few times already and people have graciously answered me in several ways, but for some reason I just can't wrap my head around this - and I know everyone has worked with it so I know it's easy. But something just isn't clicking with me.

 

Vendors are drop shippers.

 

Vendor A ships via UPS, except when provided a P.O. Box, then they ship via USPS.

 

Ok, from what I understand, I set up the Vendor as:

 

Vendor A - UPS and then Vendor A - USPS

 

But when I go to their products, I can only assign one or the orther, not both.

 

So, how does this work? If I assign all of Vendor A's products as Vendor A - UPS, what happens when a customer only provides a P.O. Box? How are the right shipping charges then shown?

 

OR -

 

Are UPS charges typically higher than USPS, and just charge UPS and if the Vendor ship via USPS, then just refund the customer the difference in shipping charges?

 

Thanks for putting up with me on this.


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites

EMAIL PROBLEM -

 

OK, on the intermitent = signs, this is showing up at the actual mailing, when I look at the preliminary email, before sending to the vendor, they aren't there. They are showing up on all of the emails, the onese to the customer, the ones to the store owner and the ones to the remote vendor. This does not happen with MVS turned off.

 

Thanks for any assistance anyone can provide

Share this post


Link to post
Share on other sites
catalog/includes/modules/vendors_shipping/upsxml.php has been in the regular distribution since 0.9RC3. You can find a copy in the latest distribution.

 

Regards

Jim

 

Then I obviously don't understand how it works. I have now installed the latest version and I can't see how dimension works without recording the dimensions of individual products. I don't see where these fields are added to the product table. Was I supposed to install something else as well?

 

Does UPS XML only work if the site has an account with UPS? If so how does that work with MVS when the account is the Vendor not the store? Is there a test user that can be used?

Share this post


Link to post
Share on other sites

From what I understand, in order to use UPS XML, you (store owner) needs to open an account with UPS. If you don't want to open an UPS account, then you use the "plain" UPS module - both of which are in the MVS vendor shipping modules (among other choices).

 

If so how does that work with MVS when the account is the Vendor not the store?

 

Sorry, I can't answer the above sentence, since I couldn't understand what it said.


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites

Hello,

 

I have been using easy populate 2.78 to add products. I now use MVS. Does MVS support easypopulate or vice versa? I found the MVS_Options package but it appears its for vendor email.

 

I need to add a new category of products from a new vendor and it will be too many to let them go in under my default vendor.

 

How can I use easy populate to do this?

 

TIA

Share this post


Link to post
Share on other sites
Are UPS charges typically higher than USPS, and just charge UPS and if the Vendor ship via USPS, then just refund the customer the difference in shipping charges?

 

Thanks for putting up with me on this.

I think this is the way you are going to have to go. There is no way (that I know of) to check for a PO Box and select the shipping based on that. You will not get perfectly accurate shipping in any case; there will always be small errors that occur some of the time. If you are at least close to the correct cost then these minor errors will even out in the long run. We sometimes spend too much time trying to get every little detail perfect when it's not really necessary. My opinion anyway.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim,

 

I honestly thought this was the way I would have to go. I did do UPS.

 

Ok, I have one vendor that is $6.95 for orders under $50.00 and then 15% of the order total for orders over $50.00. Shipped via UPS ground. And it's a vendor that has a good amount of products that with be picked (more so than others).

 

If I use the Table Rate module for this vendor - how does one figure out this puppy? Geez, why can't shipping be relatively consistant? UGH!


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites
Jim,

 

I honestly thought this was the way I would have to go. I did do UPS.

 

Ok, I have one vendor that is $6.95 for orders under $50.00 and then 15% of the order total for orders over $50.00. Shipped via UPS ground. And it's a vendor that has a good amount of products that with be picked (more so than others).

 

If I use the Table Rate module for this vendor - how does one figure out this puppy? Geez, why can't shipping be relatively consistant? UGH!

You'll need the Percent modification for the Table module. Find this code at line 95 in includes/modules/vendor_shipping/table.php:

	function quote($method = '', $module = '', $vendors_id = '1') {
  global $HTTP_POST_VARS, $shipping_weight, $order, $cart, $shipping_num_boxes;

  if (@constant('MODULE_SHIPPING_TABLE_MODE_' . $vendors_id) == 'price') {
	$order_total = $shipping_cost;
  } else {
	$order_total = $shipping_weight;
  }

  $table_cost = split("[:,]" , @constant('MODULE_SHIPPING_TABLE_COST_' . $vendors_id));
  $size = sizeof($table_cost);
  for ($i=0, $n=$size; $i<$n; $i+=2) {
	if ($order_total <= $table_cost[$i]) {
	  $shipping = $table_cost[$i+1];
	  break;
	}
  }

and replace it with this code:

function quote($method = '', $module = '', $vendors_id = '1') {
 global $HTTP_POST_VARS, $shipping_weight, $order, $cart, $shipping_num_boxes;

 if (@constant('MODULE_SHIPPING_TABLE_MODE_' . $vendors_id) == 'price') {
$order_total = $cart->vendor_shipping[$vendors_id]['cost'];
 } else {
$order_total = $cart->vendor_shipping[$vendors_id]['weight'];
 }

 $table_cost = split("[:,]" , @constant('MODULE_SHIPPING_TABLE_COST_' . $vendors_id));
 $size = sizeof($table_cost);
 for ($i=0, $n=$size; $i<$n; $i+=2) {
if ($order_total <= $table_cost[$i]) {
  $pos = strpos($table_cost[$i+1], '%');
  if ($pos === false) {
	$shipping = $table_cost[$i+1];
  } else {
	$shipping_cost_temp = split("%", $table_cost[$i+1]);
	print $shipping_cost_temp[0] . '<br>';
	$shipping = $order_total * $shipping_cost_temp[0] / 100;
  }
  break;
}
 }

Then install the module and set the table to:

50:6.95,10000:15%

That should do it. We really need to get this mod into the Table module, since so many of you are using it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim,

 

Thank you for such a quick response! Great - one more vendor down!


26 contributions installed - - And counting ....

 

Just want to take this time to extend my appreciation to everyone who have patiently answered my questions over the months of working on my site. I hope to be able to "pass it forward" and help new folks.

Share this post


Link to post
Share on other sites

I don't seem to be able to get a clear answer on MVS and UPS XML.

 

I clearly do not have dimensions recorded against my products. There are no fields for hold them. So while UPS XML is installed as a shipping module, the product fields it relies on are absent.

 

As far as I can see and so you have to install UPS XML first then this one. Is that correct?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×