Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

I ended up doing a fresh install..i wanted to get this package working first and be sure it was solid befor i moved on. i'm now getting this error on confirming an order

 

1054 - Unknown column 'vendor_order_sent' in 'field list'

 

insert into orders_shipping (orders_id, vendors_id, shipping_module, shipping_method, shipping_cost, shipping_tax, vendors_name, vendor_order_sent) values ('1', '1', 'firstitemplus', '($6.00 for first item, $1.00 for each additional)', '6.00', '0', 'My Store', 'no')

 

looks like a missing field in the database but where? I've bought a stack of books unfortunatly i can only absorb the info so fast hehe and I just cant figure this one out.

 

is there a fresh package anywhere to download?

 

i'm also getting

1054 - Unknown column 'vendor_order_sent' in 'field list'

 

select distinct orders_id, vendor_order_sent from orders_shipping where vendors_id='1' group by orders_id desc

when i hit orders by vendors in the config.

Share this post


Link to post
Share on other sites
I ended up doing a fresh install..i wanted to get this package working first and be sure it was solid befor i moved on. i'm now getting this error on confirming an order

 

1054 - Unknown column 'vendor_order_sent' in 'field list'

 

insert into orders_shipping (orders_id, vendors_id, shipping_module, shipping_method, shipping_cost, shipping_tax, vendors_name, vendor_order_sent) values ('1', '1', 'firstitemplus', '($6.00 for first item, $1.00 for each additional)', '6.00', '0', 'My Store', 'no')

 

looks like a missing field in the database but where? I've bought a stack of books unfortunatly i can only absorb the info so fast hehe and I just cant figure this one out.

 

is there a fresh package anywhere to download?

Sorry, I'm tired and I tried to answer this post and then realized my answer was incorrect. I wil try again tomorrow.

Edited by HallMarc

Share this post


Link to post
Share on other sites

i'm also getting 2 of the following lines

 

When to send the Vendor Email

 

under shipping/packaging in the admin

 

this is a clean install with only this package added u d/led the package updated sql is this the latest ?

Share this post


Link to post
Share on other sites
i'm also getting

1054 - Unknown column 'vendor_order_sent' in 'field list'

 

select distinct orders_id, vendor_order_sent from orders_shipping where vendors_id='1' group by orders_id desc

when i hit orders by vendors in the config.

'vendor_order_sent' is in all of the install SQL files that I have looked at. It's part of the creation of the new orders_shipping table that MVS uses. Since this is a new installation, I would just drop that table and reinstall it with the orders_shipping table from the SQL file. The one in the RC4 or RC5 release should work for you.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I added that line manually but you are correct it is definatly in the sql files i used...on 3 seperate occasions..i am at a loss as to why it wouldnt take

 

aside from gremlins any ideas why i would still have

 

2 configs for

When to send the Vendor Email

 

i'll tell you what its hard to drink tea with 4 freakin books open :P anyway i apprieciatte all the help its sort of baffling

Share this post


Link to post
Share on other sites
I added that line manually but you are correct it is definatly in the sql files i used...on 3 seperate occasions..i am at a loss as to why it wouldnt take

 

aside from gremlins any ideas why i would still have

 

2 configs for

When to send the Vendor Email

 

i'll tell you what its hard to drink tea with 4 freakin books open :P anyway i apprieciatte all the help its sort of baffling

 

hmm had a nights sleep.. now i am curious i have been reuseing a database i've been clearing all the fiels and just running the sql's on it I wonder if that has gotten corrupt think i will try deleteing that..not gonna be happy till I get this installed clean i absolutly hate little problems cropping up a month later..

Share this post


Link to post
Share on other sites

well damn i redid the database and ran the sql's ones that i had peeked at and made sure that line was in them.... it still didnt add the line looks identical to all the others <well in form not content> this is wierd

Edited by dkalasz

Share this post


Link to post
Share on other sites

alright now trying to use the usps module i am getting this error

 

Fatal error: Cannot instantiate non-existent class: domdocument in /mnt/web_l/d49/s31/b0277664//catalog/includes/modules/vendors_shipping/usps.php on line 506

 

This seems to be the chunk of code its choking on but I am only able to vaguely understand what it is doing <which is better than yesterday!>

 

// EOF: UPS USPS

 

$http->Disconnect();

} else {

return false;

}

 

$responsedoc = new DomDocument($body);

$root = $responsedoc->document_element();

if ($root->first_child->tagname == "Error") {

$errordetails=$this->_dom2array($responseroot->first_child);

return array('error' => $errordetails['Number'] . ' - ' . $errordetails['Description']);

}

 

$rates = array();

if ($order->delivery['country']['id'] == SHIPPING_ORIGIN_COUNTRY) {

$postages = $root->get_elements_by_tagname("Postage");

foreach ($postages as $postage) {

$postagedetails=$this->_dom2array($postage);

Share this post


Link to post
Share on other sites

I am having issues with the upsxml module as well it would seem that i am having "issues " heh anyway i've looked and maybe i am just to damn dense but i can seem to find the documentation for each module . if someone would be kind enough to give me a boot in the ass toward them i would be eternaly grateful

Share this post


Link to post
Share on other sites
alright now trying to use the usps module i am getting this error

 

Fatal error: Cannot instantiate non-existent class: domdocument in /mnt/web_l/d49/s31/b0277664//catalog/includes/modules/vendors_shipping/usps.php on line 506

The DOM functions are a part of PHP 5.X, and an available (although experimental) extension for PHP 4.3.x. In order to use them with PHP 4.3.x you need to compile the extensions in with PHP.

 

If you are getting this error, your copy of PHP is not supporting the extensions. If you are using a hosting service, you could try asking to have this turned on, but your chances are not good. We probably should not be coding with this to retain support for PHP 4.

 

As far as documentation goes, I'm sorry that there is so little available. Since MVS uses modified versions of available modules, the documentation will be (mostly) the same as the original module. For the standard osCommerce modules (Flat, Item, Table, UPS, USPS, and Zones) see the osCommerce support documentation. For other modules (FedEx, UPS XML, etc.) see the documentation for the original contribution. You can also ask specific questions in this thread.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
The DOM functions are a part of PHP 5.X, and an available (although experimental) extension for PHP 4.3.x. In order to use them with PHP 4.3.x you need to compile the extensions in with PHP.

 

If you are getting this error, your copy of PHP is not supporting the extensions. If you are using a hosting service, you could try asking to have this turned on, but your chances are not good. We probably should not be coding with this to retain support for PHP 4.

 

 

Regards

Jim

 

fortunatly i was able to update to php 5 my host had the option in the config and it seems that the dom commands are turned on but i still get the same error here is a link to a script to pull up the info sheet for the php thats running on my server php info maybe i missed something while I cant personally change any of that information i may beable to get them to trn something on if i need to

Share this post


Link to post
Share on other sites
fortunatly i was able to update to php 5 my host had the option in the config and it seems that the dom commands are turned on but i still get the same error here is a link to a script to pull up the info sheet for the php thats running on my server php info maybe i missed something while I cant personally change any of that information i may beable to get them to trn something on if i need to

I see that DOM/XML is turned on, so this should now work. I am now officially out of ideas. Perhaps somebody here who is more familiar with the USPS module can help. You might also search the forums for that error name; maybe somebody else has had a similar problem.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

i'm also getting this error when i try to look at a previously placed order any ideas?

 

Fatal error: Using $this when not in object context in /mnt/web_l/d49/s31/b0277664/www/gewgawonline.com/catalog/includes/vendor_order_data.php on line 86

Share this post


Link to post
Share on other sites
i'm also getting this error when i try to look at a previously placed order any ideas?

 

Fatal error: Using $this when not in object context in /mnt/web_l/d49/s31/b0277664/www/gewgawonline.com/catalog/includes/vendor_order_data.php on line 86

That's an error that was fixed in the Febr. 6 rollup version. If you are using an older version of MVS you may be missing a lot of bugfixes. You can fix this one by replacing every instance of $this->products with $these_products, or you can replace the file with the one from the Rollup version.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
am i looking for these rollups in the wrong place? this is where i've beens going http://www.oscommerce.com/community/contributions,2906

and i've tried the ones uploaded on fed 17 and the one from feb 20 i dont see a feb 6 version though.

 

sigh i'm starting to annoy myself with all these posts :P bear with me

Sorry, I meant Febr. 17. I think. I have a copy labeled Febr. 6, but that's probably my error, or maybe the file date. The huge size of the MVS updates means that they show up on the Contributions page a week or more after they are posted. We're working on that.

 

If you can hold off a bit, Craig just sent me a copy of the new release. It should be up soon.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

$this->products doesnt appear in my code for vendor_order_data but

$this->info does appear 8 times i have multiple instances of $these_products already i am assumeing this means they have already been changed

Share this post


Link to post
Share on other sites

could you email me a copy at dkalasz@gewgawonline.com?

 

man they really need to allow editing of msg's

Share this post


Link to post
Share on other sites
$this->products doesnt appear in my code for vendor_order_data but

$this->info does appear 8 times i have multiple instances of $these_products already i am assumeing this means they have already been changed

Yikes. My mistake, I thought that the whole thing was fixed. I'll take a look.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
$this->products doesnt appear in my code for vendor_order_data but

$this->info does appear 8 times i have multiple instances of $these_products already i am assumeing this means they have already been changed

OK, try this. Add the following to the top of the file, just below the comment block:

  $order_query = tep_db_query("select currency, currency_value from " . TABLE_ORDERS . " where orders_id = '" . (int)$order_id . "'");
 $order = tep_db_fetch_array($order_query);

Now change every instance of $this->info to $order. That should work, but may be buggy. I haven't tested it thoroughly.

 

I'm going to wait on sending out the next release until Craig says that he has everything in that he wants. This bugfix should probably be included as well.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

need to make the change in vendor_order_data as well but works like a charm so far.. now if only the gremlins would remove themselves from any of the shipping options that require to update via a server.. i'm sure theres a conection and a clue i just need to figure it out.. and no columbo am I

Share this post


Link to post
Share on other sites

in reference to this error

Fatal error: Call to undefined method DOMDocument::document_element() in /mnt/web_l/d49/s31/b0277664/www/gewgawonline.com/store/catalog/includes/modules/vendors_shipping/usps.php on line 507

 

i have found the following and since i am so new at this I really am uncertain of what i am thinking is right or not

 

$responsedoc = new DomDocument($body);

 

that is line 506 what i believe it is doing and please correct me if i am wrong is assigning $responsedoc to be a new domdocument...now $body should according to the manual be passing a version,encoding value and I cant find anywhere in this document where $body gets that value.

 

i'm sure i am missing something and I hope you dont mind but honestly untill i figure out the logic i'm not gonna sleep much heh

 

thanks again for all future and former help you guys are great most people woulda shoved me in the closet by now

Share this post


Link to post
Share on other sites
in reference to this error

i have found the following and since i am so new at this I really am uncertain of what i am thinking is right or not

 

$responsedoc = new DomDocument($body);

 

that is line 506 what i believe it is doing and please correct me if i am wrong is assigning $responsedoc to be a new domdocument...now $body should according to the manual be passing a version,encoding value and I cant find anywhere in this document where $body gets that value.

 

i'm sure i am missing something and I hope you dont mind but honestly untill i figure out the logic i'm not gonna sleep much heh

 

thanks again for all future and former help you guys are great most people woulda shoved me in the closet by now

 

I found out where its suppose to be assigning the value now i just have to figure out if i am actually getting that value

Share this post


Link to post
Share on other sites

I have uploaded MVS V1.0 to: MVS V1.0 new download page. This is new because we felt it was time to get out from under the "developers only" code that page was started with. I will be updating the MVS_OPTIONS and MVS_ADDONS packages as well. I have not had time to write instructions for updating from earlier versions yet, if anyone can do it, please send them to me or Jim, so we can go over it before posting to the contrib page.

 

Virtually every file in the package has been updated. In some instances the changes are simply to clean up code or re-organize code changes. The instructions have also been updated. From here on out we will be posting a bit more regularly to keep up with the minor bugs that I am sure will crop up.

 

Thanks to all who have supported MVS, we have a great bit of work here.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×