Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

Hey Jim,

I got it to work :D I changed:

//Get a quote, added $shiptotal for IndvShip
function quote($method = '', $module = '', $vendors_id = '1') {
  global $order, $total_count, $shipping_weight, $shipping_num_boxes;
  $shiptotal = $cart->vendor_shipping[$vendors_id]['ship_cost'];

to:

//Get a quote, added $shiptotal for IndvShip
function quote($method = '', $module = '', $vendors_id = '1') {
  global $order, $total_count, $shipping_weight, $shipping_num_boxes, $shiptotal;

in indvship.php.

 

And I added to the vendor_shipping.php like so:

// Get a quote for one or many shipping methods, for a specific vendor 
//added $shiptotal for indvship
function quote($method = '', $module = '', $vendors_id='1') {
  global $shipping_quoted, $order, $cart, $shipping_num_boxes, $shipping_weight, $shiptotal;

  $quotes_array = array();
  if (is_array($this->modules[$vendors_id])) {
	$shipping_quoted = '';
	$shipping_num_boxes = 1;

	$shipping_weight = $cart->vendor_shipping[$vendors_id]['weight'];
	//mod indvship
	$shiptotal = $cart->vendor_shipping[$vendors_id]['ship_cost'];
	//mod indvship
	$shipping_cost = $cart->vendor_shipping[$vendors_id]['cost'];
	$total_count = $cart->vendor_shipping[$vendors_id]['qty'];

 

I guess I answered my own question. I knew it should work similar to weight but needed to find where the $shipping_weight was coming from.

 

Yea I am soooo Happy :rolleyes:

That will probably work. I just hate using global variables, so I avoid them wherever possible. Too many ways to get in trouble. Well, I've caused enough trouble with using the wrong keys, so I'll shut up now. Glad to hear that it's working now.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
That will probably work. I just hate using global variables, so I avoid them wherever possible. Too many ways to get in trouble. Well, I've caused enough trouble with using the wrong keys, so I'll shut up now. Glad to hear that it's working now.

 

Regards

Jim

 

If you know a better way we can do it, I can change it. Or I can give you the files and you can change it.

I was trying to only change the shopping_cart.php because I wanted to change as few files as possible. The other indvship changes a lot more files and that isn't good when your trying to add a lot of contributions for a nice customized store.

 

Thanks for your help!

Steph

Share this post


Link to post
Share on other sites

HallMarc, gr8sale, kymation

 

Can one of you guys email me the latest and greatest upsxml.php. I just got it to work with all your suggestions from 2/18 - 2/21. However, I'm sure there are some lurking bugs that you guys have probably already flattened.

 

Thanx in advance.

 

ps. When are you guys planning another rollup?

Share this post


Link to post
Share on other sites
HallMarc, gr8sale, kymation

 

Can one of you guys email me the latest and greatest upsxml.php. I just got it to work with all your suggestions from 2/18 - 2/21. However, I'm sure there are some lurking bugs that you guys have probably already flattened.

 

Thanx in advance.

 

ps. When are you guys planning another rollup?

I'm leaving releases up to Jim and Craig from now on. I think I caused enough confusion this last time! :-"

 

Speaking of Jim and Craig; have you figured out to fix the Free shipping part of osCommerce so that it will work with MVS?

Share this post


Link to post
Share on other sites
I'm leaving releases up to Jim and Craig from now on. I think I caused enough confusion this last time! :-"

 

Speaking of Jim and Craig; have you figured out to fix the Free shipping part of osCommerce so that it will work with MVS?

I have created a "free shipping" module for MVS. I plan on cleaning it up a bit and posting it to the contrib section. I found it easier to use a module for now, still looking through the code for the standard osC free shipping function issue. It works part time for me on my own test server(Admin->Modules->Order Total->Shipping), but something is strange about it sometimes.

 

I will post when I get it.

 

I will be getting back to the new release this week. Hopefully, I will be able to stay focused on it long enough to finish it up. I am creating a "bug" and "feature" list to post here for review before I release the next version. If anyone sees anything missing from it, be sure to post and let me know.

 

Again, I personally appreciate everyone's support, as you all know, both Jim and I get very busy at times and are not able to offer the attention here we would like. Your help has been fantastic :thumbsup: , thanks.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
How do I get the regular UPS going? either UPS will work for me I think. Do I need to install a db or something?

right now I get (4lbsX!box) but no charges at checkout?

 

Thanks,

Steph

The standard UPS module(not the UPSXML) included with MVS is a modified version of the UPS Choice module. There should be nothing you need to do other than install it via the Vendor Mangaer. There is a database adjustment needed in order to use the "method selection" from the module itself. In the MVS Options download, you will find the instructions for this.

 

Good luck, and great work with the Indiv Ship module, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
The standard UPS module(not the UPSXML) included with MVS is a modified version of the UPS Choice module. There should be nothing you need to do other than install it via the Vendor Mangaer. There is a database adjustment needed in order to use the "method selection" from the module itself. In the MVS Options download, you will find the instructions for this.

 

Good luck, and great work with the Indiv Ship module, Craig :)

 

Hi Guys,

Now that I have the individual shipping working how would you like it posted? Do you want me to post it as an add on for MVS or would you like the files to add to the rollup so that people don't have to install it separately? And is it even OK with all of you if I post it on the MVS contribution page?

Share this post


Link to post
Share on other sites
I have created a "free shipping" module for MVS. I plan on cleaning it up a bit and posting it to the contrib section. I found it easier to use a module for now, still looking through the code for the standard osC free shipping function issue. It works part time for me on my own test server(Admin->Modules->Order Total->Shipping), but something is strange about it sometimes.

 

I will post when I get it.

 

I will be getting back to the new release this week. Hopefully, I will be able to stay focused on it long enough to finish it up. I am creating a "bug" and "feature" list to post here for review before I release the next version. If anyone sees anything missing from it, be sure to post and let me know.

 

Again, I personally appreciate everyone's support, as you all know, both Jim and I get very busy at times and are not able to offer the attention here we would like. Your help has been fantastic :thumbsup: , thanks.

 

Craig :)

 

Craig that is great!

Because I am going to have free shipping on some highend stuff and was going to try to write something myself because I didn't want to just use a flat rate of $0.00, I wanted it to say FREE. Nice :)

Thank you,

Steph

Share this post


Link to post
Share on other sites

I have uploaded a package to the contributions section.

 

This package contains 3 additional shipping modules for MVS. They should work with any after RC3, and perhaps earlier, I have not tested any earlier versions.

 

These are simple copy and paste modules with no file modifications needed. Simply copy them into the appropraite directories, and install them via the Vendor Manager just like every other module.

 

All 3 are being used on live stores, so I am confident there will be no problems, but as usual, I offer no guarantees.

 

These are all modified from other modules: Store Pickup, Free Amount and First Item Plus.

 

I am not including the instructions for those here, but can be found in the contributions section.

 

Most of the credit for goes to their original authors, and again, thanks to the osCommerce community for this wonderful piece of work.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
I have uploaded a package to the contributions section.

 

This package contains 3 additional shipping modules for MVS. They should work with any after RC3, and perhaps earlier, I have not tested any earlier versions.

 

These are simple copy and paste modules with no file modifications needed. Simply copy them into the appropraite directories, and install them via the Vendor Manager just like every other module.

 

All 3 are being used on live stores, so I am confident there will be no problems, but as usual, I offer no guarantees.

 

These are all modified from other modules: Store Pickup, Free Amount and First Item Plus.

 

I am not including the instructions for those here, but can be found in the contributions section.

 

Most of the credit for goes to their original authors, and again, thanks to the osCommerce community for this wonderful piece of work.

 

Craig :)

Thanks for trying. That isn't what I was asking about. All of the mods for MVS shipping are on a per vendor basis. Truthfully, I had already written a mod for virtual products like GC, vouchers and downloadable items. I know that it will work for free shipping on amounts over with a little rewrite, however, when it comes down to it I want something that works globally with the Free Shipping option of the ot module that comes with osCommerce.

 

I have made a little progress with this one. I can get it to show up with a radio button and it will pass the security checks at checkout_payment.php, but I also want the other shipping options to be available to the client in case ground too long of a wait. I have that working now too. I just removed the if else part of that. The only problems I am running into are this. No matter what shipping method I select the shipping cahrge still comes up $0.00 and two radio buttons can be selected (the Free shipping option and other shipping option.)

Share this post


Link to post
Share on other sites

Hello

 

Have MVS 0.9.5 up and running.. well almost..

 

Everything works like a charm except for vendor_id is being set to 0 in orders_products, but ok in the restie. its show under orders that products is ordred from that vendor weight, shipping ect. but no products but order total is ok.

 

If i go into orders_products and set the vendor_id to fx 1 then the product show up correctly.

 

Have looked trough the code but cant find anywhere the vendor_id should be missing.

 

Any hints or solutions is welcome...

 

quickly please its a kind of anoying that costumers gets a mail with no product shown but order total ok, so i have to write each and everyone that we have recieved an order on that and that... and i have to go into vendor_email_send to see the products ordered...

 

HEEELP PLZ

Share this post


Link to post
Share on other sites
OK,

 

I missed something in IndvShip. Items in the shopping cart are displaying a total of $0.00, the subtotal is calculating correctly though. :blink: Does anyone know where I might find it in the code?

Thanks,

Steph

 

MMM...

It happens on all of the shipping methods except UPS. So maybe it's not IndvShip...

Share this post


Link to post
Share on other sites
MMM...

It happens on all of the shipping methods except UPS. So maybe it's not IndvShip...

I have a feeling we are dealing with a problem in the same section of code. I'll be damn if I can find where some things like this are in osCommerce. Craig if you can point us in the right direction maybe we can fix these issues.

Of course for me my issues only come up when I activate (Install)Order Shipping Cost (found in Order Total Modules) AND MVS.

Edited by HallMarc

Share this post


Link to post
Share on other sites
I have a feeling we are dealing with a problem in the same section of code. I'll be damn if I can find where some things like this are in osCommerce. Craig if you can point us in the right direction maybe we can fix these issues.

Of course for me my issues only come up when I activate (Install)Order Shipping Cost (found in Order Total Modules) AND MVS.

OK so apparently I may be related to Homer Simpson. DOH! Looking for the code that runs the order total free shipping mod? Why not look in catalog/includes/modules/order_total/ot_shipping.php? :blink:

Some days your the teacher other days your the kid in the back of the room with the dunce hat on!

 

And yes I am talking about myself!

 

If anyone else needs this to work let me know by posting here and I will post my changes. They were many to be sure because this part of osCommerce needed changes in both the standard version and MVS.

 

gr8sale, I'm thinking that somewhere in your modifications you left out a variable or two so they aren't being passed to the order total. I would check your pages (checkout_shipping.php, checkout_payment.php, ot_shipping.php, etc.) + any other pages you modified against the original files

Edited by HallMarc

Share this post


Link to post
Share on other sites

Trying to get a "Low Order Fee" working with MVS, and can't seem to get it to add in. I am setting it via the Order Total Module, but it does not add it at checkout. Does this need to be done differntly in MVS, or do I need to look at something else going on?

 

Thanks for any help you might be able to give!

 

John

Share this post


Link to post
Share on other sites
OK so apparently I may be related to Homer Simpson. DOH! Looking for the code that runs the order total free shipping mod? Why not look in catalog/includes/modules/order_total/ot_shipping.php? :blink:

Some days your the teacher other days your the kid in the back of the room with the dunce hat on!

 

And yes I am talking about myself!

 

If anyone else needs this to work let me know by posting here and I will post my changes. They were many to be sure because this part of osCommerce needed changes in both the standard version and MVS.

 

gr8sale, I'm thinking that somewhere in your modifications you left out a variable or two so they aren't being passed to the order total. I would check your pages (checkout_shipping.php, checkout_payment.php, ot_shipping.php, etc.) + any other pages you modified against the original files

 

Hey Marc,

The order is totalling correctly the customer is being charged the correct amount. But the shoppoing cart subtotal page is like so:

T-shirt 9.99

Auto Parts 0.00

Sub Total 29.99

 

All items not using UPS aren't showing up in the per item charges. Not for flat or per item either not just indvship?

 

I will chect the files but I only added to shopping_cart.php, I didn't remove anything. And I only added 2 lines to the vendors_shipping.php. I will go back through them.

 

Thanks,

Steph :(

Share this post


Link to post
Share on other sites
Hey Marc,

The order is totalling correctly the customer is being charged the correct amount. But the shoppoing cart subtotal page is like so:

T-shirt 9.99

Auto Parts 0.00

Sub Total 29.99

 

All items not using UPS aren't showing up in the per item charges. Not for flat or per item either not just indvship?

 

I will chect the files but I only added to shopping_cart.php, I didn't remove anything. And I only added 2 lines to the vendors_shipping.php. I will go back through them.

 

Thanks,

Steph :(

 

You were right Marc,

I'm not sure what it was but I took a fresh copy of shopping_cart,php and edited it carefully :rolleyes: and now everything is working correctly.

Thanks for the help :thumbsup:

Steph

Share this post


Link to post
Share on other sites
You were right Marc,

I'm not sure what it was but I took a fresh copy of shopping_cart,php and edited it carefully :rolleyes: and now everything is working correctly.

Thanks for the help :thumbsup:

Steph

I'm glad you were able to get it working. I have had a few times when I have added a modification either from the contributions section or that have written and had things not work. It can be hard to find it especially if it is a typo!

Share this post


Link to post
Share on other sites

Wow... just getting started, but this is exactly what I need!

 

Can someone bring me up to speed on the stability of this contrib and recommended rollup/patch/upgrade order? I saw many different RC revs, but... :blink:

Share this post


Link to post
Share on other sites

Greetings Forum and thanks to the authors and contributors for all their hard work.

 

Currentl grinding through this Mod into a store and have a Q:

 

I have installed RC4 and run all the RC5 SQL updates etc. Everything is 'starting' to look ok but when i go into my admin/orders i am seeing:

 

1054 - Unknown column 'ov.vendor_order_sent' in 'field list'

 

select distinct ov.orders_id, ov.vendors_id, ov.vendor_order_sent, v.vendors_name from orders_shipping ov, vendors v where v.vendors_id=ov.vendors_id and orders_id='0' group by vendors_id

 

Now im assuming the table is missing a column obviously but the SQL has been run and it seems to be present. Have fixed other minor glitches but this one is slowing me down.

 

Im hoping one of the authors (or anybody) can slap me in the right direction.

 

Cheers and thanks for all the hard work!


And with a 9 in 10 search rate success the no.1 returned Oscommerce forum hit:

"The administrator has enabled flood control - please try again in 30 seconds."

 

Never fails.

 

Every time.

Share this post


Link to post
Share on other sites

Dave

 

If you haven't made any other changes to osCommerce yet, I would grab the 17 Feb 2006 rollup file from the distribution and just drop all of the files in. If you have already made other changes, you'll need to use a file comparison program to apply the changes. MVS makes a lot of changes in a lot of files, so it's a bit of a pain to apply to a heavily modified store.

 

Brian

 

It looks like you missed some SQL. My copy of the MVS SQL file has this:

#
# Table structure for table `orders_shipping`
#

CREATE TABLE `orders_shipping` (
 `orders_shipping_id` int(11) NOT NULL auto_increment,
 `orders_id` int(11) NOT NULL default '0',
 `vendors_id` int(11) NOT NULL default '1',
 `shipping_module` varchar(16) NOT NULL default '',
 `shipping_method` varchar(128) NOT NULL default '',
 `shipping_cost` decimal(15,3) NOT NULL default '0.00',
 `shipping_tax` decimal(15,3) NOT NULL default '0.00',
 `vendors_name` varchar(64) NOT NULL default '',
 `vendor_order_sent` varchar(3) NOT NULL default 'no',
 PRIMARY KEY  (`orders_shipping_id`)
) TYPE=MyISAM AUTO_INCREMENT=0;

The last line of that appears to be missing from your code. You should be able to add it in without much trouble, or just drop the table and run the above to put it back properly.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Greetings Forum and thanks to the authors and contributors for all their hard work.

 

Currentl grinding through this Mod into a store and have a Q:

 

I have installed RC4 and run all the RC5 SQL updates etc. Everything is 'starting' to look ok but when i go into my admin/orders i am seeing:

 

1054 - Unknown column 'ov.vendor_order_sent' in 'field list'

 

select distinct ov.orders_id, ov.vendors_id, ov.vendor_order_sent, v.vendors_name from orders_shipping ov, vendors v where v.vendors_id=ov.vendors_id and orders_id='0' group by vendors_id

 

Now im assuming the table is missing a column obviously but the SQL has been run and it seems to be present. Have fixed other minor glitches but this one is slowing me down.

 

Im hoping one of the authors (or anybody) can slap me in the right direction.

 

Cheers and thanks for all the hard work!

 

Ok - somehow my column got lost so i have re run the SQL and viola this error disappears - onto the next one! Disregard this post - but im sure ill be back!


And with a 9 in 10 search rate success the no.1 returned Oscommerce forum hit:

"The administrator has enabled flood control - please try again in 30 seconds."

 

Never fails.

 

Every time.

Share this post


Link to post
Share on other sites

Adding this again ass it is so far up now..

 

Hello

 

Have MVS 0.9.5 up and running.. well almost..

 

Everything works like a charm except for vendor_id is being set to 0 in orders_products, but ok in the restie. its show under orders that products is ordred from that vendor weight, shipping ect. but no products but order total is ok.

 

If i go into orders_products and set the vendor_id to fx 1 then the product show up correctly.

 

Have looked trough the code but cant find anywhere the vendor_id should be missing.

 

Any hints or solutions is welcome...

 

quickly please its a kind of anoying that costumers gets a mail with no product shown but order total ok, so i have to write each and everyone that we have recieved an order on that and that... and i have to go into vendor_email_send to see the products ordered...

 

HEEELP PLZ

 

kymation?? maybe you can tell where it grabs vendor_id to put into orders_products table

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×