Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

The ugly return of Checkout Without Paying For Shipping (aka "Just when you thought it was safe to go back in the water")

 

Case 1- I was just testing my site for completely unrelated reasons and ran into a strange snag. On checkout_shipping.php everything looked fine: two different shipping rates were displayed, the cheapest was pre-selected, everyone was Fat, Dumb, and Happy. Then I hit Continue. The page hung. And hung. And hung some more, and then finally went to checkout_payment.php. When I then went on to checkout_confirmation.php, there was no shipping charge in the total. Que hora es, ladies and gentleman. I have no explanation for this one, and right now am assuming it's a fluke, but if anyone else has seen this please raise your hand.

 

Case 2- A customer enters in a shipping address in which the state and zip code don't match. I don't know what happens with other modules, but with FedEx you get the error "No Rates Returned, F01C : Recipient postal code and state/province do not match." This is fine- most people will go up to "Change Address" and fix the problem. Unfortunately there's a button at the bottom of the page that says "Continue" and there are some people out there who will click on that instead. If they do, they can then check out without paying for shipping. The same thing can happen if the FedEx site is down and no data is reurned.

 

Now, both of these cases are rare. Case 1 might be impossible to recreate. But Case 2, I think, should be possible to fix, just in case. And fixing Case 2 might fix Case 1 too, so hey, why not?

 

There is a section of code in checkout_payment.php that is intended to deal with this problem, however something about MVS must bypass it somehow. Here is the code in question:

 

// if no shipping method has been selected, redirect the customer to the shipping method selection page
 if (!tep_session_is_registered('shipping')) {
tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'));
 }

 

I got the bright idea to change 'shipping' to 'vendor_shipping' - that does kick people back to checkout_shipping.php if they haven't selected a shipping method, however it also kicks them back even when they have. So, what should it be changed to in order to operate as it was originally intended? Or is there something else I'm missing?

 

Thank you very much for the help. I checked the files you suggested and you are right. There was some problem in the FTP to the admin folder. It is working now.

 

But I have another small problem.

 

I am now installing Page Cache v1.5 for osCommerce-ms2 and I have already installed Ultimate SEO URLs by Chemo so when I come to modifying the includes/functions/html_output.php file I can no longer find the lines I am supposed to replace to install the Page Cache module in this file as they seem to have been replaced by the SEO module. What to do?

 

Thanks for your help and patience...

 

 

Welcome to the Wonderful World of Overlapping Contributions! Unfortunately, I have no idea what to tell you, and odds are no one else who posts here will either. If there is a support thread for either, or both, of those contributions, you should post your problem there.

 

Good luck,

Stew

Edited by djmonkey1

Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

I'm having some unfortunate success in recreating Case 1. For whatever reason my site is horribly, painfully slow right now, and in this state it has taken to skipping forward to checkout_payment.php without properly processing all the data from checkout_shipping.php (or some such thing, that's the best way that I can understand it).


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Case 1: It's entirely possible that some data is being lost between pages. There is no really good solution for this, since there are a large number of variables passed by nearly every means possible at some point in the process. The code that you posted only works if the shipping session has not been set or has been lost. It is still quite possible that session has been set but one or more values have been lost, so this is of limited use. And the session name is still 'shipping', MVS doesn't change that.

 

You could test for the value of the shipping cost being non-zero, although that would preclude ever giving free shipping. Not useful in the general case, but it might work for those who intend to always charge for shipping. It should also be possible to generate some sort of hash across all of the variables and redirect to an error page if it doesn't match at both ends of the transfer. This would be messy to implement, but it would fix the problem in every case. It's probably a good idea for every page in the cart/checkout process.

 

You could also try some social engineering: Put up a notice that failure to select a shipping method means that products will not be shipped. Some sellers do this deliberately so that local customers can pick up their products in person if they wish. Not a perfect solution, but it might help.

 

Case 2: Any module that relies on an external server (FedEx, UPS, USPS, and others) can return an error if the remote server has a problem or does not respond. It should be possible for the checkout script to recognize this and refuse to continue. I believe that this is a problem with osCommerce in general, and not one that MVS has introduced. If there is an existing fix I'm not aware of, please let me know so it can be incorporated. Otherwise this goes on the wishlist for future upgrades.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Case 1: It's entirely possible that some data is being lost between pages. There is no really good solution for this, since there are a large number of variables passed by nearly every means possible at some point in the process. The code that you posted only works if the shipping session has not been set or has been lost. It is still quite possible that session has been set but one or more values have been lost, so this is of limited use. And the session name is still 'shipping', MVS doesn't change that.

....

 

Case 2: Any module that relies on an external server (FedEx, UPS, USPS, and others) can return an error if the remote server has a problem or does not respond. It should be possible for the checkout script to recognize this and refuse to continue. I believe that this is a problem with osCommerce in general, and not one that MVS has introduced. If there is an existing fix I'm not aware of, please let me know so it can be incorporated. Otherwise this goes on the wishlist for future upgrades.

 

Regards

Jim

 

Hmmmmm.... thanks, Jim. I may put up a warning as you suggest. At this point I'm convinced that there's something simple that can be added to checkout_payment.php to loop back to checkout_shipping.php if a shipping method wasn't chosen. Not that I have any idea what that would be, but I'm convinced nonetheless. I'll keep looking.

 

Moving on- has anyone worked MVS in with Fast Easy Checkout? I'm considering giving it a go but haven't really looked at it. Part of me says there shouldn't be a problem, the other part is concerned it could be a nightmare.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Firstly I would like to thank everyone who has contributed to this contribution. If I can get it working well, it is going to save me a tonne of time :)

 

I am receiving a few small errors at the moment. When I add a number of products from different vendors and then checkout, everything works fine until the confirmation page. On the confirmation page The combined shipping price does not add up to the correct figure. Intead of adding upto $15 for example is adds upto $20. In the admin section it also shows the $20 instead of the $15. Does anyone know what could be causing this error.

 

I am also have a problem with the sending of order to vendors, it does not do this unless I manually do in the admin section, and even then, it does not record that it has been sent. Is still says: vendor email sent: no instead of yes.

 

Any help is much appreciated.

Share this post


Link to post
Share on other sites
Firstly I would like to thank everyone who has contributed to this contribution. If I can get it working well, it is going to save me a tonne of time :)

 

I am receiving a few small errors at the moment. When I add a number of products from different vendors and then checkout, everything works fine until the confirmation page. On the confirmation page The combined shipping price does not add up to the correct figure. Intead of adding upto $15 for example is adds upto $20. In the admin section it also shows the $20 instead of the $15. Does anyone know what could be causing this error.

 

I am also have a problem with the sending of order to vendors, it does not do this unless I manually do in the admin section, and even then, it does not record that it has been sent. Is still says: vendor email sent: no instead of yes.

 

Any help is much appreciated.

 

 

Hello

is there a update for this to work with Cre Loaded oscommerce 615 version ?

cause I was looking for some thing like this for vendors so you can have the correct shipping prices for each vendor or warehouse supplier.

please if there is one that works with the NEW version of cre loaded oscommerce 615 let me know ?

and where I can download it from too ?

cause I downloaded mine from cre loaded oscommerce website and it does not work with cre loaded 615 version at all.

cause the coding in cre loaded oscommerce is different.

I like using cre loaded oscommerce cause it has alot of pre-loaded mods made in to it plus a realy good template system as well.

thanks

Share this post


Link to post
Share on other sites
Hello

is there a update for this to work with Cre Loaded oscommerce 615 version ?

cause I was looking for some thing like this for vendors so you can have the correct shipping prices for each vendor or warehouse supplier.

please if there is one that works with the NEW version of cre loaded oscommerce 615 let me know ?

and where I can download it from too ?

cause I downloaded mine from cre loaded oscommerce website and it does not work with cre loaded 615 version at all.

cause the coding in cre loaded oscommerce is different.

I like using cre loaded oscommerce cause it has alot of pre-loaded mods made in to it plus a realy good template system as well.

thanks

 

 

p.s.

I am also looking for a export or import shipping mod for cre loaded oscommerce.

were export aka import shipping addon shipping fees and tax and storage fee can be displayed for countries out side the usa area.

for using a export aka import shipping service.

cause most warehouse suppliers do not ship out side the usa area.

and some customers not within the usa area like to order from my shop.

but theres nothing to calculate for export, import fees and tax and storage fee with addon extra shipping from the export aka import shipping service.

cause I have 3 major warehouse suppliers that do not ship out side the usa area.

the close country they ship to is cannada area.

so in order to do business with customers from other countries and ship the goods to the customers I have to use a export aka import shipping service which we ship the items to from the warehouse and theres a export handling fee and storage fee and duty tax fee and then theres the extra shipping fee the export office charges to ship to countries out side the usa area.

even bigger businesses like Tigerdirect.com has to use a export shipping service for shipping out side the usa area.

so I was wondering if some one could make up a modification for oscommerce and cre loaded oscommerce for shop owners who need this type of addon for their shops ?

it would make life alot easier for the customers and for the shop owners to have such a mod for their shops.

so the customers thats not shipping in the usa area can display export aka import service extra charges and fees and shipping and the customer can choose what type of air mail shipping they want or shipping by sea.

and so the customers will know about the extra charges added on to their order.

and can agree to the terms of the addon fees and shipping.

thanks

Share this post


Link to post
Share on other sites
I still cannot get it to work, in the catalog install.txt for shopping_cart.php it does not show the code for add_weight....Add_weight and UPSXML work fine if I disable MVS... here is my code starting from line 230 to the end of UPSXML fix...can someone compare it to theirs or tell me what is wrong...I am out of ideas...

 

Can someone please post their code from /includes/classes/shopping_cart.php? The install instructions for MVS say you need to have Add_Weight_to_Attributes contribution installed....and I do. But if you look at the /includes/classes/shopping_cart.php included with MVS install, I do not see the code...that is odd to me.

 

Anyway I really need to compare mine to a working one....

Share this post


Link to post
Share on other sites
Can someone please post their code from /includes/classes/shopping_cart.php? that has Add_Weight contribution installed...

 

I really need to compare mine to a working one....

Share this post


Link to post
Share on other sites
Firstly I would like to thank everyone who has contributed to this contribution. If I can get it working well, it is going to save me a tonne of time :)

 

I am receiving a few small errors at the moment. When I add a number of products from different vendors and then checkout, everything works fine until the confirmation page. On the confirmation page The combined shipping price does not add up to the correct figure. Intead of adding upto $15 for example is adds upto $20. In the admin section it also shows the $20 instead of the $15. Does anyone know what could be causing this error.

 

I am also have a problem with the sending of order to vendors, it does not do this unless I manually do in the admin section, and even then, it does not record that it has been sent. Is still says: vendor email sent: no instead of yes.

 

Any help is much appreciated.

 

Your problem is that one shipping charge is shown on checkout_shipping.php but a different charge is assessed on checkout_confirmation?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Can someone please post their code from /includes/classes/shopping_cart.php? The install instructions for MVS say you need to have Add_Weight_to_Attributes contribution installed....and I do. But if you look at the /includes/classes/shopping_cart.php included with MVS install, I do not see the code...that is odd to me.

 

Anyway I really need to compare mine to a working one....

It is not installed in MVS. It must be added if you intend to use that feature of the UPSXML module. I will double check the instructions on this issue for the next release.

 

Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
Hello

is there a update for this to work with Cre Loaded oscommerce 615 version ?

cause I was looking for some thing like this for vendors so you can have the correct shipping prices for each vendor or warehouse supplier.

please if there is one that works with the NEW version of cre loaded oscommerce 615 let me know ?

and where I can download it from too ?

cause I downloaded mine from cre loaded oscommerce website and it does not work with cre loaded 615 version at all.

cause the coding in cre loaded oscommerce is different.

I like using cre loaded oscommerce cause it has alot of pre-loaded mods made in to it plus a realy good template system as well.

thanks

As far as I know noone has installed MVS on any CRE version yet. It can be done, no different than a heavily modified store. Go for it and see what you get, just make sure you back up first.

 

Did you say you downloaded a copy of MVS from the CRE site? I didn't know they had approved MVS in it's current state for use with any of their releases.

 

Good luck, Craig :)

 

Does anyone have MVS working with "Add Weight To Product Attributes"? MVS is only adding the weight of the main product, not the weight of additional products using product attributes....

 

any ideas?

Did you get this done? I have added it to several client sites and intend to include it as an optional add-on in the next release. If you need to I may be able to send you a copy of the changes I made.

Contact me via PM if you want some help. Craig


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites
It is not installed in MVS. It must be added if you intend to use that feature of the UPSXML module. I will double check the instructions on this issue for the next release.

 

Craig :)

 

My bad, it is not in the instructions...I was looking at another install when I wrote that....I tried to edit the post...but no luck.

 

Thanks, Keith

 

 

Good luck, Craig :)

Did you get this done? I have added it to several client sites and intend to include it as an optional add-on in the next release. If you need to I may be able to send you a copy of the changes I made.

Contact me via PM if you want some help. Craig

 

Man that would be great! I have tried everything I can think of to make this work, but with no luck....I will PM you...

Thanks a million...Keith

Share this post


Link to post
Share on other sites
Your problem is that one shipping charge is shown on checkout_shipping.php but a different charge is assessed on checkout_confirmation?

 

Yes that is the problem I am having. Any ideas on where the error is coming from?

 

Cheers

Share this post


Link to post
Share on other sites
Yes that is the problem I am having. Any ideas on where the error is coming from?

 

Cheers

 

No, but that is really weird. I'd go over the changes you made in the catalog files, starting with checkout_process.php and checkout_shipping.php.

 

Also, for the problem you're having with vendors emails, it sounds like you missed something in admin.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
No, but that is really weird. I'd go over the changes you made in the catalog files, starting with checkout_process.php and checkout_shipping.php.

 

Also, for the problem you're having with vendors emails, it sounds like you missed something in admin.

 

Thanks, I will go over all installation files.

Share this post


Link to post
Share on other sites

I have been working on modifying the Quick Price Update contribution http://www.oscommerce.com/community/contributions,122 to work with the Multi-Vendor Shipping contribution. I have finally gotten it to where I have it working well on my Admin, and I am thinking maybe it should be a contribution to the community (it's nice to give back when you can! :) ).

 

Before I make it a contribution, if anyone has any interest and would like to preview and test this first (same disclaimer as MVS - Beta code, use at your own risk, BACK EVERYTHING UP, etc.) I can send you a copy or post it for download.

 

This contribution makes it much easier to update and modify all fields of a product in a table format, and has the ability to apply a price increase/decrease (either percentage or fixed value) to all products.

 

The only part that I am not sure about, and is not really changed from the original contribution, is the "Commercial Margin" markup/markdown function mentioned above. There is a enable/disable in the Admin-->Configuration-->Quick Updates for this function, but the only thing that I see that it does it turn a little check box off next to the preview button for the price increase. However, I can increase/decrease prices whether this is enabled or disabled, so I'm not sure what it was meant to do. If anyone has an idea what the intent was, I will be glad to try and fix it (if it is truly 'broken'). I really may not just understand what it is supposed to do.

 

Feedback on functionality or bugs is appreciated!

 

John

Share this post


Link to post
Share on other sites
No, but that is really weird. I'd go over the changes you made in the catalog files, starting with checkout_process.php and checkout_shipping.php.

 

Also, for the problem you're having with vendors emails, it sounds like you missed something in admin.

 

I have re-installed all the files and gone through all the code and I am still having the same problem. Whenever I have more than one vendor shipping products, I either get $10 or $20 as the combined shipping amount on the checkout confirmation and order page in admin. It does not seem to be adding up the total shipping costs from each vendor correctly.

 

Weird....

 

Any more ideas?

 

Cheers

Share this post


Link to post
Share on other sites
I have re-installed all the files and gone through all the code and I am still having the same problem. Whenever I have more than one vendor shipping products, I either get $10 or $20 as the combined shipping amount on the checkout confirmation and order page in admin. It does not seem to be adding up the total shipping costs from each vendor correctly.

 

Weird....

 

Any more ideas?

 

Cheers

 

Just adding to the above... It seems that the combined amount is always a round number ie:10, 20, 100. It seems to be rounding up or down??

Share this post


Link to post
Share on other sites

For every problem I think I fix, another pops up....

 

I am getting

Parse error: parse error, unexpected $ in /httpdocs/catalog/checkout_process.php on line 544

 

I cannot seem to get rid of it....nothing before or after the <?php ........ ?>

 

Never mind, I was missing a } a few lines up....

Share this post


Link to post
Share on other sites
I have been working on modifying the Quick Price Update contribution http://www.oscommerce.com/community/contributions,122 to work with the Multi-Vendor Shipping contribution. I have finally gotten it to where I have it working well on my Admin, and I am thinking maybe it should be a contribution to the community (it's nice to give back when you can! :) ).

 

Before I make it a contribution, if anyone has any interest and would like to preview and test this first (same disclaimer as MVS - Beta code, use at your own risk, BACK EVERYTHING UP, etc.) I can send you a copy or post it for download.

 

This contribution makes it much easier to update and modify all fields of a product in a table format, and has the ability to apply a price increase/decrease (either percentage or fixed value) to all products.

 

The only part that I am not sure about, and is not really changed from the original contribution, is the "Commercial Margin" markup/markdown function mentioned above. There is a enable/disable in the Admin-->Configuration-->Quick Updates for this function, but the only thing that I see that it does it turn a little check box off next to the preview button for the price increase. However, I can increase/decrease prices whether this is enabled or disabled, so I'm not sure what it was meant to do. If anyone has an idea what the intent was, I will be glad to try and fix it (if it is truly 'broken'). I really may not just understand what it is supposed to do.

 

Feedback on functionality or bugs is appreciated!

 

John

 

Go ahead and post this as an add-on to MVS with the note that is beta or something, it needs to be tested. I'm sure a lot of folks will want to work with it. And thanks for sharing, Craig :)


Happy Coding!

Craig Garrison Sr

Anything worth having, is worth working for.

Multi Vendor Shipping V1.1 Demo Catalog

3 Vendors, each category, "buy" a product from each category to see how MVS works during checkout.

Multi Vendor Shipping V1.1 Demo Admin

login: webmaster@blucollarsales.com

pass: mvs_demo

MVS Thread:

Multi-Vendor Shipping

My contribs:

Download Multi Vendor Shipping V1.1

Vendor Email

Vendor Info in easypopulate

EZ Price Updater

And more to come!

Share this post


Link to post
Share on other sites

Ok now a new problem...going through checkout and make it to confirmation page...all the products being purchase are listed....with qty, name, description, etc...

 

Go to admin/orders to view the order, and only the first product has a qty and description...each product after that is listed...But no quantity or product title description....the email sent does not have this info either

 

any clues on this one....?

Share this post


Link to post
Share on other sites
Go ahead and post this as an add-on to MVS with the note that is beta or something, it needs to be tested. I'm sure a lot of folks will want to work with it. And thanks for sharing, Craig :)

 

 

Posted the Quick Updates 2.8 for Multi-Vendor Shipping in the contributions. As Craig mentions, this should be thoroughly tested on your install. Seems to be working OK for me on MS2.2 with MVS RC5.

 

John

Share this post


Link to post
Share on other sites
Go to admin/orders to view the order, and only the first product has a qty and description...each product after that is listed...But no quantity or product title description....the email sent does not have this info either

 

Look in the orders_products table in your database. If the data is there, you have a problem in the Orders page of the admin. If it isn't there, look in checkout_process.php where the data is stored. This is also where the email is sent, so it's most likely in this page or in the data being sent to this page.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites
Just adding to the above... It seems that the combined amount is always a round number ie:10, 20, 100. It seems to be rounding up or down??

 

 

Are the prices for the items in your shop all round numbers? Ie product number 1 is $10, product number 2 is $20, etc?


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×