Jump to content
Latest News: (loading..)
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

That's a known bug. It's not that critical, since it rarely happens and customers can still chose their preferred shipping. In fact, I've had customers complain that the preselected shipping allowed them to check out without forcing them to select the shipping that they wanted. That's why I haven't taken the time to figure it out yet.

So to answer your question, I'm certain that there is a way to fix this, but i don't know what it is.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

Actually, it’s not rare at all, but rather consistent. As in, when you get to the confirmation page and click on the Edit button to edit the shipping options, you can be sure of one thing, ..none of the shipping methods you selected or where auto-selected for you (as the cheapest option) ..will be selected.

I think the shipping method selections need to be somehow added to the session. I’m not exactly sure how to structure that.

 

Share this post


Link to post
Share on other sites

@kymation

I'm having an issue with Free Shipping and was wondering if you have come across this issue before.  When proceeding to the checkout_payment page from checkout_shipping after reaching the Free shipping minimum, I am redirected back to the checkout_shipping page via this line:

if (!is_array($shipping['vendor']) || count($shipping['vendor']) != count($cart->vendor_shipping)) {

After doing a var_dump I found that count($shipping['vendor']) is coming back with 0 for free shipping, while count($cart->vendor_shipping) is coming back with 2,.. as in the two vendors I am testing. Also,.. var_dump(($shipping['vendor'])); is coming back as NULL.

So, when the minimum amount for Free shipping is reached, the shipping vendors are not counted. I think this is on the checkout_shipping.php page for the MVS code or perhaps in the freeamount.php module.

Could you help on this?

Edited by Demitry

Share this post


Link to post
Share on other sites

If you're using the built-in osCommerce Free Shipping option, that will not work. The free shipping module should work though. I haven't seen any problems with that.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I was trying to say that that one works for me. Could this be a problem with the version of PHP that you are using? I can't think of anything else right now.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

I think I found a way to fix this ...just comment out that if statement on checkout_payment.php and on checkout_confirmation.php pages. It's there as a test to make sure that a shipping method for each vendor is selected. However, in BS Edge it is not needed because a customer cannot proceed to the payment page without having those shipping method radio buttons selected.

Edited by Demitry

Share this post


Link to post
Share on other sites

That is the test that prevents a customer from proceeding if they have not selected a shipping method for each vendor. Removing that is very dangerous.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

yeah, and I tested it, Even if you select one of the shipping methods for one of the vendors, but not the other, the checkout_shipping.php page will not let you move on to the checkout_payment.php page and all the radio buttons light up like Christmas lights. Try it yourself, ..you'll see.

That test may have been of use in an older osC version, but BS Edge has it built into the checkout_shipping.php page. And realistically this would never be needed at all if that issue I mentioned above regarding the radio buttons being un-selected when returning to the checkout_shipping.php page,.. was resolved.

unselected-radio-buttons.png.d56dddf0ca5a106028f23b2e154126bd.png

Share this post


Link to post
Share on other sites

That's interesting. I have no idea how stock osCommerce is detecting multiple vendors. I need to look into this.

In any case, remove that old code if it works for you. I'll make the change in the Addon when I get a chance to confirm it.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

I am working on finishing a new MVS BS Edge release with several new features and it fixes a problem with Free Shipping, ..including allowing a customer to have the option for expedited shipping after they have reached the minimum amount required for free shipping.

After I finish this update, you should set it up on BS EDGE and PHP7.1 ..It's niiiiiiiice!

 

Share this post


Link to post
Share on other sites

Hi all, 

I'm trying to modify the freeamount module to charge a flat rate (regardless of how many vendors its applied to or are represented in the shopping cart at the time), and then to default to free above the set threshold.

This is using mvs 1.3 on 2.3.4.

Anybody know of a way of doing that - has it been done etc?

I'm wondering about:

declare a global variable to count the number of times the module is loaded per basket then to divide the shipping cost by the number of times its loaded.  Although actually that wouldn't work either as its run sequentially, the first time would charge the whole fee, the rest would have to be set to zero.

Other vendors in the basket could have a separate shipping cost - so overriding the global shipping total I don't think would work.

Is there already a count of the number of times a particular module as loaded?

Getting a bit bogged down in it!

Thanks in advance.

Rob

 

Share this post


Link to post
Share on other sites

I think it would be easier to do this as an Order Total module. That module could get the subtotal of the product(s) cost, then decide whether to charge the flat fee or zero.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

hi Jim,

I'm working on installing the MVS Shipping Cost Estimator and keep getting the same error in the error log:

[30-May-2018 21:31:35 America/New_York] PHP Warning:  Creating default object from empty value in /home/ ... /public_html/dev2/ship_estimator.php on line 98

and the code block for that line 98 is this:

        $order->delivery = array('postcode' => $shippostcode,
                                 'country' => array('id' => $shipcountry, 'title' => $country_info['countries_name'], 'iso_code_2' => $country_info['countries_iso_code_2'], 'iso_code_3' => $country_info['countries_iso_code_3']),
                                 'country_id' => $shipcountry,
                                 'format_id' => tep_get_address_format_id($shipcountry));

Any idea on how to fix that error? Thanks.

 

Share this post


Link to post
Share on other sites

Which version of the Shipping Estimator are you using? That line doesn't match the code I have.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@kymation

It's actually this in the latest version. So, I changed it to the $_POST['country_id'] and re-ran it, but am still getting the same error message for this line.

        $order->delivery = array('postcode' => $shippostcode,
                                 'country' => array('id' => $shipcountry, 'title' => $country_info['countries_name'], 'iso_code_2' => $country_info['countries_iso_code_2'], 'iso_code_3' => $country_info['countries_iso_code_3']),
                                 'country_id' => $_POST['country_id'],
                                 'format_id' => tep_get_address_format_id($_POST['country_id']));

 

Share this post


Link to post
Share on other sites

Never mind; I found it.

There's some pretty horrible old code in there. It may be that it just won't run under a modern version of PHP. What version is your store running on?

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim, I'm actually still working with it, so this may be a bit premature. Let me get this file completed and I'll revisit the topic if that error still persists. At which point I could give you the full source code. I just thought I'd ask to see if this was an issue you've encountered before.

Edited by Demitry

Share this post


Link to post
Share on other sites

I have a newer version of this code that may fix some of these issues. Apparently I never finished it so I didn't release it. I can put a copy up for you if it would help.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

well, what I'm doing is using a modified version from my MS2.2 site. Then, using a comparison tool I updated it to the latest version of the addon and updated all the code structures to work with osCv2.3.4 BS. And now, I've made it as a modal box pop-up from the shopping cart page. I still have some issues to resolve, including that php warning.

I wanted to create this as a BS Edge module, but ran into technical issues that are beyond my scope of know-how. Perhaps after I get it completed, we could share the files and see if the combined changes can become a new updated version of this addon?

 

Edited by Demitry

Share this post


Link to post
Share on other sites

However you want to handle it. I don't have a lot of free time right now, but I'll help as much as I can.

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

that's fine, then let me get those from you. Do you want to pm those to me?

I'll follow up with you when I get as far as I can with it.

Share this post


Link to post
Share on other sites

Hi,

I would like to know if the verion of MVS 1.4 is stable version?

I downloaded it and installed it. But I found some files are missing.

catalog/includes/modules/boxes/bm_estimate_shipping.php

I only found bm_estimate_shipping.php in catalog/includes/languages/english/modules/boxes/.

I noticed that the shipping modules files are located in the folder of vendors_shipping.

Does it mean I have to create a new module management of Vendors Shipping to install these modules or I just put it to the folder of catalog/includes/modules/shipping/ ?

I have created Vendors Shipping with cfg_vendors_shipping.php under modules menu to manage these shipping modules, and it did work. Even I put them to the modules of shipping folder and install the shipping module, they are same problems. The options and texts of the module did show after the shipping module is install.

I noticed that the value in the shipping module is MODULE_SHIPPING_ will them be conficted with the shipping modules? I found there is flat shipping module in shipping module folder, I replaced all MODULE_SHIPPING_ with MODULE_VENDORS_SHIPPING_ .

Please advise me.

chuntse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×