Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

The SQL query failed because you've already done this. You can only run the query once.

 

Starting over would be an extreme move, and is certainly not necessary. You do need to figure out what you've done wrong and fix it. MVS 1.2.3 was designed for osCommerce 2.2x, so you can't simply overwrite files. You need to add the MVS changes into your existing files. If you overwrote files, go back to your backup and start over.

 

I have a version for osC 2.3x but it hasn't been properly tested. You can get a copy here if you want it.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim, thank you so much. We have installed the new MVS for version osC 2.3x, and so far it has functioned perfectly on the install. Now all we have to do is to plug in the dimension size, weight, ect., and we should have a fully functioning MVS, I am about to go see if there is a "Usage.txt" file for me to read, so I'm sure I'll be back with lots of questions, and if there are any bugs or problems, I'll be sure to let you know and ask plenty of questions. I know we're adding FedEX, and probably later, USPS, UPS, and maybe another. Also, I will have some items "drop shipped" to customers, Distributor or Manufacturer ------> Customer. We'll never even see the product. So I'll have to use the Vendor location function for certain items that will be "drop shipped." Other items, we will act as the "middle-man." On some items, we will manufacture them, and ship them directly to customers. This program is amazing, I have to say. I'm in awe of this and many other programs created here on this website. Simple amazing. Exactly what we needed. I promise you I'm not dense, I'm just a complete newb when it comes to php , code, and website design, and I've learned more about code and computer programs in the past two or three days reading here than I have in my first 30 years. I'll probably be back very soon with questions. Again, thank you so much for all the really great help.

Edited by EJR914

Share this post


Link to post
Share on other sites

Check the updates in the MVS Addon section before adding any shipping modules. UPS and USPS have both been updated since the last release. I think I got those in the new release, but I'm not certain.

 

Please let me know if you find any bugs in the MVS pre-release copy you got. It should work, and is working on one store right now, but that store's code has been modified so heavily that I'm not sure I got everything into the MVS package.

 

Oh, and read the User's Manual PDF in the distribution for operating instructions. Those could probably use improvement as well.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The Alpha new MVS that we used had quite a few bugs on it. I tried my best to work on it, and I will continue to tinker with it, until we perfect it, because we really need it. Right now, I just need to get a FedEx, UPS, and maybe even USPS shipping module just to work for right now, so the many people waiting, can go ahead and start to purchase my products from the website. I've now installed FedEx_1_4-webservices_v9_4_2, because I have the Web Services Key, Web Services Password, Account Number, and Meter Number for FedEx, so as soon as the Fed Ex Module runs well enough, I'll be taking the site live and people can begin to buy products. I'm still working on getting those from UPS and USPS as well.

 

I still have to go into the "Install.txt" file and change all that coding around, because after the install, I still have some bugs and error type codes popping up on the website, but that should be an easy fix if I can follow directions well enough. You'll see me posting new questions over at the FedEx1..4 webservices v9.4.2 thread here shortly, if I have any trouble with fixing the code. Also, I noticed in the Install.txt file it says that there is no guarantee that those changes will work with osC2.3, so we'll have to hope and pray they do.

 

I haven't given up on MVS yet, and I will continue to try my hardest to make it work. I'm also going to buying a PHP book for dummies, so that maybe I can help you with fixing all the bugs on the new Alpha MVS. I'd like to keep osC 2.3 if I can, and not have to drop down to using 2.2, if I can help it. Wish me luck, I know I'll need it.

 

Thank you for all of your guidance and help, Jim.

Edited by EJR914

Share this post


Link to post
Share on other sites

Hello,

 

Does anyone have easy populate working with MVS installed?

 

My hosting provider upgraded to PHP 5.3. I have a 2rc2a shop and was using EP 2.74 for MVS. After I went through and corrected all the depricated function, I can't get EP to work, 2.74 or 2.77a w/attributes.

 

2.74 doesn't split the files. 2.77a splits the files but won't strip carrige returns/line feeds from the products_description which causes the file to be mangled

 

Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

i have installed this module in oscommerce 2.3.1 and it works great after some adjustments... thanks you for this mod i just like it !

Share this post


Link to post
Share on other sites

ok, after a good nights sleep I tackled the free shipping issue head on. What I ended up doing is changing whereever it says "MODULE_SHIPPING_FREEAMOUNT..." I changed it to "MODULE_VENDORS_SHIPPING_FREEAMOUNT...".

The ... is the rest of the line which didn't change.

This was a very labor intensive issue as there are multiple files that require the changes. If I have some free time I will put together a mod for it.

 

Can someone please let me know which files I need to edit to make the above changes.

Share this post


Link to post
Share on other sites

Use the search function in your operating system or in your editor, or download a copy of Grep for your OS.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Use the search function in your operating system or in your editor, or download a copy of Grep for your OS.

 

Regards

Jim

Thank you Grep worked great.

Share this post


Link to post
Share on other sites

Just installed the 1.3 version on a 2.3.3 test store. Everything went OK. Had some missing files I had to take from the 1.2.3 package, includes/languages/english/modules/vendors_shipping and a ups file that I can't remember the name.

 

Any way, I click on the default vendor, My Store, Manage and it gives me the error:

 

Warning: require(includes/classes/xmldocument.php) [function.require]: failed to open stream: No such file or directory in /....../includes/modules/vendors_shipping/upsxml.php on line 29

 

Warning: require(includes/classes/xmldocument.php) [function.require]: failed to open stream: No such file or directory in /....../includes/modules/vendors_shipping/upsxml.php on line 29

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/xmldocument.php' (include_path='.:/usr/local/php5_3/lib/php') in /....../includes/modules/vendors_shipping/upsxml.php on line 29

 

Both these are present. Not sure what's going on.

 

The offending line of code in upsxml.php is: require ('includes/classes/xmldocument.php');

 

TIA

Edited by edukes

Share this post


Link to post
Share on other sites

That's odd. It seems to be looking for the file in catalog/includes/classes/xmldocument.php, which is where it should be. Try putting a copy in admin/includes/classes/xmldocument.php and see if that works. Or you could just delete the /includes/modules/vendors_shipping/upsxml.php, or replace it with the new version from the MVS download page if you want to use UPS.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's odd. It seems to be looking for the file in catalog/includes/classes/xmldocument.php, which is where it should be. Try putting a copy in admin/includes/classes/xmldocument.php and see if that works. Or you could just delete the /includes/modules/vendors_shipping/upsxml.php, or replace it with the new version from the MVS download page if you want to use UPS.

 

Regards

Jim

 

Moving xmldocument,php to the admin side worked. I have two errors on the catlog side during checkout but I think that has to do with not having a shipping method specified/setup.

 

Thanks!!

Share this post


Link to post
Share on other sites

Ooops, I thought I would run into this again.

 

Deprecated: Function ereg() is deprecated in /....../admin/vendor_modules.php on line 229

 

In my live store I made this change:

 

// if (ereg('->', $use_function)) {

if (preg_match('/->/', $use_function)) {

 

Not sure its right but I don't get any errors

Share this post


Link to post
Share on other sites

Have a new problem.

 

Going through the checkout process and I get to checkout_confirmation, then

 

?>

Warning: Cannot modify header information - headers already sent by (output started at /....../includes/languages/english/checkout_payment.php:36) in /....../includes/functions/general.php on line 50

 

Not sure what's causing the ?>

 

I am using the checkout_confirmation file from the 1.3 package. The only addition to the general.php is the Ultimate SEO URLs 5 Pro

 

TIA

Share this post


Link to post
Share on other sites

@@edukes

Your use of preg_match() looks correct to me.

 

When I see a ?> followed by the headers already sent error message, it's always been due to a space or other special character after the ?> in a language file, or a duplicated ?>. Yours indicates that the problem is in /includes/languages/english/checkout_payment.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@edukes

Your use of preg_match() looks correct to me.

 

When I see a ?> followed by the headers already sent error message, it's always been due to a space or other special character after the ?> in a language file, or a duplicated ?>. Yours indicates that the problem is in /includes/languages/english/checkout_payment.php.

 

Regards

Jim

 

Thanks, I found the error in the includes/languages/english/checkout_payment.php file. I had an extra ?> at the end of the file I didn't see the first time.

 

I'm getting there. Going through the check out, I get to checkout_confirmation and get

 

Warning: strpos() expects parameter 1 to be string, array given in /......includes/classes/vendor_shipping.php on line 46

 

Warning: substr() expects parameter 1 to be string, array given in /....../includes/classes/vendor_shipping.php on line 46

 

Warning: strpos() expects parameter 1 to be string, array given in /....../includes/modules/order_total/ot_shipping.php on line 48

 

Warning: substr() expects parameter 1 to be string, array given in /....../includes/modules/order_total/ot_shipping.php on line 48

 

We're getting close!! :)

 

Thanks!!

Share this post


Link to post
Share on other sites

What shipping method(s) do you have set for the product(s) in your cart?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

What shipping method(s) do you have set for the product(s) in your cart?

 

Regards

Jim

 

Hey Jim,

 

I have flat rate and USPS. I installed the updated USPS package. (Using it on my live, rc2a) site with no problems.)

 

Thanks,

 

Eddie

Share this post


Link to post
Share on other sites

On which vendors? Are you certain you have the vendor specified for the product(s) in your cart?

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello,

 

Does anyone have easy populate working with MVS installed?

 

My hosting provider upgraded to PHP 5.3. I have a 2rc2a shop and was using EP 2.74 for MVS. After I went through and corrected all the depricated function, I can't get EP to work, 2.74 or 2.77a w/attributes.

 

2.74 doesn't split the files. 2.77a splits the files but won't strip carrige returns/line feeds from the products_description which causes the file to be mangled

 

Any help would be greatly appreciated.

 

I must have gotten the memo, but the new easy populate uses the vendor name, not the vendor id. :blush:

Share this post


Link to post
Share on other sites

On which vendors? Are you certain you have the vendor specified for the product(s) in your cart?

 

Regards

Jim

 

I have only one, My Store.

 

When I go into a products description, it shows no vendor. I tried changing it to My Store but it won't save. I can do an easy populate download and it shows all products with the vendor name as My Store.

 

Also, I found to tables that were not added by the mvs.sql

 

products_sort_order

products_qty_blocks

 

I added them to the products table as VARCHAR. That may not be right.

Share this post


Link to post
Share on other sites

I may need to do an easy populate download, add the vendor then re-upload?

Edited by edukes

Share this post


Link to post
Share on other sites

@@edukes

You have an error somewhere in your Admin setup. The vendor should save as Vendor #1 (My Store or whatever you renamed that as.) For USPS, you need the store address including Zip code in the Vendor settings. The flat rate should work without any additional data. You may have additional installation errors/bugs. Check your database to see if data is being saved correctly.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

@@edukes

You have an error somewhere in your Admin setup. The vendor should save as Vendor #1 (My Store or whatever you renamed that as.) For USPS, you need the store address including Zip code in the Vendor settings. The flat rate should work without any additional data. You may have additional installation errors/bugs. Check your database to see if data is being saved correctly.

 

Regards

Jim

 

I checked the products table in the database. Then vendor id is set to 1, My Store.

 

I guessing that the 1 in "Warning: strpos() expects parameter 1 to be string" is the vendor id of My Store.

Share this post


Link to post
Share on other sites

No, that's the first parameter that is being fed to strpos(). You'll have to look at that variable and follow it back to where it is being set.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×