Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

Tax on shipping is calculated in the shipping module using the data from the vendor settings.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Tax on shipping is calculated in the shipping module using the data from the vendor settings.

 

Regards

Jim

 

Hi jim

 

If i set Vendor Shipping set to false and use the stock shipping modules it all works fine.

 

I have double checked all my settings and i dont know what i am doing wrong..I can see the shippping charge being passed to checkout_confirmation.php but it not being added to the total or to vat(tax)

 

Vendor Shipping: true

Array Vendor Shipping:

 

Array

(

[id] => Array

(

)

 

[title] => Best Way

[cost] => 10

[shipping_tax_total] => 2

[vendor] => Array

(

[8] => Array

(

[id] => flat_flat

[title] => Best Way

[ship_tax] => 2

[products] => Array

(

[0] => 375

)

 

[cost] => 10

)

 

)

 

)

 

 

Vendor Count: 1

Cart Vendor Count: 1

Share this post


Link to post
Share on other sites

It appears that MVS is setting the shipping charge correctly. Check your edits to checkout_confirmation.php.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

It appears that MVS is setting the shipping charge correctly. Check your edits to checkout_confirmation.php.

 

Regards

Jim

i checked checkout shipping, checkout confirmation,checkout_process ,checkout shipping, checkout payment .. can find anything wrong i even replaced the file with one from the contrib...

 

 

Still no joy...

 

dont know whats is wrong here...

Share this post


Link to post
Share on other sites

That's all I can think of. There's only so much I can do from here.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's all I can think of. There's only so much I can do from here.

 

Regards

Jim

thanks for you help...will keep trying to nail it..:)

Share this post


Link to post
Share on other sites

I just installed MVS (1.2.3) on a new osCommerce (2.3.1) install. I installed osCommerce using Fantastico. I believe I followed the instructions correctly but I started getting error messages. The first error I received was on the admin panel. When I went to the admin panel it was a blank screen with the following message

 

Fatal error: Call to undefined function tep_get_version() in /home/XXXXXXXX/public_html/XXXXXXXXXX.com/admin/includes/header.php on line 20

 

I was able to fix that (I think) by adding the following code in /admin/includes/functions/general.php

 

//// 
// Get the installed version number 
 function tep_get_version() { 
   static $v; 

   if (!isset($v)) { 
     $v = trim(implode('', file(DIR_FS_CATALOG . 'includes/version.php'))); 
   } 

   return $v; 
 }

 

Now when I go the the admin panel, the osCommerce logo is there, but where the login should be, I have the following error:

 

Fatal error: Call to undefined function tep_draw_button() in /home/XXXXXXXX/public_html/XXXXXXXXXX.com/admin/login.php on line 163

 

Here is the code from line 163

 

    $contents[] = array('align' => 'center', 'text' => '<br />' . tep_draw_button(BUTTON_LOGIN, 'key'));

 

I have searched and I am not sure how to fix this. Does it have something to do with the html_output.php file? What do I need to add or remove? Any help is greatly appreciated.

Share this post


Link to post
Share on other sites

Those functions are a part of stock osCommerce 2.3.1. The MVS version you installed is designed for osC 2.2x. You cannot replace files with the MVS versions -- you have to modify your existing 2.3.1 files. Use a comparison program to find the changes in MVS.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Jim, Thank you for replying. I will reinstall osCommerce and just modify the files. Now I just have to find a comparison program.

Share this post


Link to post
Share on other sites

There's a list here. I use Meld and have used WinMerge. Both work well enough for me to recommend.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

There's a list here. I use Meld and have used WinMerge. Both work well enough for me to recommend.

 

Regards

Jim

 

I started comparing using notepad ++, do I just replace everything that is different? I mean if something is completely different between osCommerce and MVS do I overwrite the different part in the osCommerce file? And if something has been deleted in MVS, should I also delete that part or just leave it in the osCommerce file. Sorry still very new to this.

Share this post


Link to post
Share on other sites

Replace everything that is marked MVS. Delete only if there is an MVS section marked there. I don't recall any deletes that are not replaced with MVS code, but there might be. Leave everything else alone.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Replace everything that is marked MVS. Delete only if there is an MVS section marked there. I don't recall any deletes that are not replaced with MVS code, but there might be. Leave everything else alone.

 

Regards

Jim

 

 

Thank you so much for all of your help. I opted to just install osCommerce 2.2 (hopefully this version is still usable) and then MVS instead of merging the files. I know I would have created more problems for myself if I tried to merge the files. I got further this method than I did the first time. I now have both installed and I am able to login to the admin panel. When I click on vendors I get this:

 

 

1054 - Unknown column 'vendors_id' in 'where clause'

 

select count(*) as total from products where vendors_id = '1'

 

[TEP STOP]

 

I did use the same database that I had created for the newer version of osCommece. I don't know if that is an issue or not.

Share this post


Link to post
Share on other sites

I hope you used 2.2RC2a. Any older version is unusable. Don't forget to apply all of the changes in the Security forum for 2.2. This will be nearly as much work as installing MVS on 2.3.1. Possibly more.

 

The databases in 2.2x and 2.3.1 are incompatible. You need to install the 2.2 database, then run the changes for MVS.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Replace everything that is marked MVS. Delete only if there is an MVS section marked there. I don't recall any deletes that are not replaced with MVS code, but there might be. Leave everything else alone.

 

Regards

Jim

 

Ok, So I went ahead and attempted to modify the files in order to install MVS on osCommerce 2.3.1, since installing the security updates would probably be more difficult for me. I started with a fresh install, uploaded the new MVS files and used notepad++ to compare the modify files and replace everything starting with //MVS. Now I am getting the following error when going to the admin panel:

 

Fatal error: Call to undefined function tep_redirect() in /home/XXXXXXXX/public_html/XXXXXXXXXX.com/admin/includes/application_top.php on line 161

 

Not sure what I did wrong or where to look to fix this.

Share this post


Link to post
Share on other sites

tep_redirect() is a stock osCommerce function in both the 2.2 and 2.3 series. It's defined in includes/functions/general.php. You may have deleted this line in includes/application_top.php:

  require(DIR_WS_FUNCTIONS . 'general.php');

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

tep_redirect() is a stock osCommerce function in both the 2.2 and 2.3 series. It's defined in includes/functions/general.php. You may have deleted this line in includes/application_top.php:

  require(DIR_WS_FUNCTIONS . 'general.php');

Regards

Jim

 

I checked /includes/application_top.php and /admin/includes/application_top.php and that line is present in both files. Line 161 in admin/includes/application_top.php referred to in the error reads as follow:

 

      tep_redirect(tep_href_link(FILENAME_LOGIN, (isset($redirect_origin['auth_user']) ? 'action=process' : '')));

Share this post


Link to post
Share on other sites

Then you somehow deleted the definition of tep_redirect() in includes/functions/general.php. MVS doesn't make any changes to that file, so I have no idea how you managed to do that. Perhaps you uploaded the admin file to the catalog side.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

What file places the "install" and "edit" buttons on admin/vendor_modules.php? I had everything working and setup but I went to add a new shipping method only to find that the buttons are now gone. I have no idea what I did or how I did it. I compared the vendor_modules file to the one in the contribution and they are identical. All of the shipping methods show but I cannot edit them or install new ones. Also I will add that mvs functions just fine on the store side

Edited by crashexpert

Share this post


Link to post
Share on other sites

You have some sort of error, probably in the shipping module that you just added. Try deleting the module file and see if the Vendor Manager starts working again. If it doesn't, your database is corrupted and will need to be cleaned by hand.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I couldnt install a new one because the install button is gone... I wrote over all of the moduals anyway and it didnt help so now you say it has to be in the DB. I dont know what needs to be "cleaned" so would I be better off dropping vendors, vendors_info, and vendors_configuration tables and starting over. If I do that I will loose what products belong to each vendor wont I?

Share this post


Link to post
Share on other sites

No, you need to delete the module file. Remove it completely from your server. Nothing that you do in the Admin is going to help.

 

If that doesn't work, you can then truncate (empty) the vendors_configuration table. This will remove all of your shipping module configuration, so you'll have to reinstall any modules that you need.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Yes thanks a bunch emptied the DB and all is well Thanks again for ALL of your help!!

Edited by crashexpert

Share this post


Link to post
Share on other sites

Can anyone who has added this to a customised osc v2.3.1 tell me how long it took? I am pretty proficient with adding modules and adapting code, but this MVS module would replace some home brew code that currently works, but is not quite so functional..

 

Is there a 2.3.1 version install in the works Jim?

 

Thanks!

Share this post


Link to post
Share on other sites

I can't tell you exactly how long it takes, but it wasn't very long. The conversion mostly involves changing the buttons and adding the references to template_top.php and template_bottom.php. Oh, and converting one box. It's not that hard.

 

Yes, I do intend to make a 2.3.1 release whenever I have the time. I've done the install on 2.3.1, but that is a very heavily modified store, so it's not that simple to extract the files. I'll probably have to do it over on a stock copy of 2.3.1 to get it right.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×