Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

From the Addons.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The 3 Mar 2010 release is 1.2.4. Sorry, I forget that the numbering isn't clear. Anyway, use that version with osCommerce 2.2RC2a. I'm working on a release for osC 2.3.1.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

The 3 Mar 2010 release is 1.2.4. Sorry, I forget that the numbering isn't clear. Anyway, use that version with osCommerce 2.2RC2a. I'm working on a release for osC 2.3.1.

 

Regards

Jim

 

 

I was hoping that 1.2.4 was the release for OsCommerce 2.3.1

We have to upgrade our shop for multiple reasons, so we are starting over from scratch with OSCv2.3.1. One of the 'must haves' is multi-vendor support. osCommerce 2.2RC2a with MVS 1.2.3 worked really nice for us.

How long will it take, you think, for you to release this new version?

 

Regards, Marja

Share this post


Link to post
Share on other sites

It'll probably be a while. I have to install it on a 2.3.1 store that has a bunch of other mods, so I can't just post that. I'll have to port it to a clean copy of 2.3.1 and test that. And update the instructions. MVS is big, so it's a lot of work to put out a release.

 

If you want to do this sooner, use 1.2.4 and patch the files using a comparison program. The changes are all marked. The only tricky part is going to be checkout_shipping.php. I haven't done that part yet, but I will soon, so I can help with that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

It'll probably be a while. I have to install it on a 2.3.1 store that has a bunch of other mods, so I can't just post that. I'll have to port it to a clean copy of 2.3.1 and test that. And update the instructions. MVS is big, so it's a lot of work to put out a release.

 

If you want to do this sooner, use 1.2.4 and patch the files using a comparison program. The changes are all marked. The only tricky part is going to be checkout_shipping.php. I haven't done that part yet, but I will soon, so I can help with that.

 

Regards

Jim

 

That's why I start with MVS ;)

I'll see how far I can get with version 1.2.4. Thanks for that suggestion! And yeah I'll probably need some help with checkout_shipping.php. That one has given me headaches in the past... :rolleyes:

 

Marja

Share this post


Link to post
Share on other sites

hi

 

i am new to mvs, and i have a question:

 

does mvs support importing a product.csv file, via easy populate, with the vendors id per product also imported?

 

thanks

Share this post


Link to post
Share on other sites

hi

 

i am new to mvs, and i have a question:

 

does mvs support easy populate?

 

also, how could easy populate be made to support mvs?

 

thanks

Share this post


Link to post
Share on other sites

Your question is backwards: it is Easy Populate that needs to support MVS. And yes, it does. See the instructions for EP to turn on MVS support.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello again,

 

Always appreciate the quick responses and help here. I have a question regarding MVS and its capabilities: Is there a way to calculate customs duties & additional taxes with MVS so the customer can pay for these fees before purchase? We are attempting to become an international store and looking at ways to do this easily and conveniently and aren't sure what to do.

 

If not MVS, does anyone have any insight on the matter? Thanks again.

 

Matt

Share this post


Link to post
Share on other sites

That's not really anything to do with MVS. You need a shipping module that will calculate the charges for you, or let you enter them as a table. I'm not aware of any module that does that. I believe that FedEx adds in the customs brokerage fees automatically, but not the customs fees themselves. I'm not even certain that you can legally collect customs fees in advance.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Hello again,

 

Has anyone had any luck getting MVS to work with a Single Page / One Page checkout contribution?

 

Thanks,

 

Matt

Share this post


Link to post
Share on other sites

Hi Jim,

Any chance of getting updates for the USPS and UPS modules? My pricing is usually off by a dollar or so on both.

Thanks,

Matt


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

Hi again,

I installed the free shipping with minimum amount, using the modded files from the MVS contribution. The free shipping choice appears in checkout_shipping but there is no way to select it. If you click continue it brings you back to the same shipping page with the error"please select a shipping option".

I ran winmerge on all the files and don't see an error. Any thoughts?


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

ok, after a good nights sleep I tackled the free shipping issue head on. What I ended up doing is changing whereever it says "MODULE_SHIPPING_FREEAMOUNT..." I changed it to "MODULE_VENDORS_SHIPPING_FREEAMOUNT...".

The ... is the rest of the line which didn't change.

This was a very labor intensive issue as there are multiple files that require the changes. If I have some free time I will put together a mod for it.


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

First off, wow what a great tool!! Just what I needed thanks alot to all that was involved!!

I just installed this contribution and all is working fine but I just noticed that the cvv2 is no longer showing in the order page of the admin. I looked through the files that where changed and and everything cvv2 related still seams to be there. Cvv2 feild is still on the website and in the admin panel but it the cvv2 number itself is not showing up anymore. Any idea of what file may have changed this? or where to look closer?

Edited by crashexpert

Share this post


Link to post
Share on other sites

MVS provides an alternate shipping section that is used when MVS is enabled. Any changes that you make to the stock shipping section, such as for a CVV field, will also need to be made to the MVS code or they won't show up when MVS is turned on.

 

I've never used the CVV Addon so I can't give you any more detailed instructions than that.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

understandable but even if MVS is turned off the CVV does not show.

 

Upon further testing I now realize that when I select a vendor and click manage there are no shipping modules that show for me to install. I am working on this now but no luck. Any input is welcome

Share this post


Link to post
Share on other sites

MVS should not affect the operation of the site when it is turned off. You may have errors in your installation.

 

Check that the vendor modules are in catalog/includes/modules/vendors_shipping/ and that the language files are in catalog/includes/languages/english/modules/vendors_shipping/.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

the shipping modules are uploaded in both locations. When MVS is turned off the site acts normal as before but when MVS is turned on no shipping is displayed due to the fact that no shipping modules are installed to the vendor? (correct me if Im wrong) I can not install shipping modules to each vendor because none are displayed in the admin to install. When I click manage instead of a list of shipping modules to install I just get the following

 

Vendor Module Directory: /home/users/web/b2874/"myaddress_here"/public_html/includes/modules/vendors_shipping/

 

Am I missing something here????

Share this post


Link to post
Share on other sites

Yes, you're missing something. Apparently you made some sort of error in the installation, probably in the Admin side. Sorry I can't be more specific. Check your edits to each of the files. Also check your error logs to see if the problem is generating an error message.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

after going through every file 3 times I finally thought to check the name of the new folder I had to create...sure enough I had "vendor_shipping" not "vendors_shipping".. Figured I would post incase someone else does the same thing

Edited by crashexpert

Share this post


Link to post
Share on other sites

hi

 

i cant get tax on shipping to work .It work properly if i use the stock osc shipping module.

 

..It wont work w if i am using vendor shipping.It only shows shipping price without tax.

 

regards

 

sales

Share this post


Link to post
Share on other sites

hi

 

i cant get tax on shipping to work .It work properly if i use the stock osc shipping module.

 

..It wont work w if i am using vendor shipping.It only shows shipping price without tax.

 

regards

 

sales

 

okay.. after days of messing and trying to figure out.... i have found out if the display price with tax is set to true then i dont get the tax on shiping , but it is set to false then it works..

 

dont know why this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×