Jump to content
blucollarguy

Multi_Vendor_Shipping new thread

Recommended Posts

Hi,

first of all, thank you for your good support.

I'm Italian and I need an help.

It's three days I'm searching the solution.

I have MVS in my shop and I'd like to have the possibility to have 2 or 3 zone rates. That because I will use one for registred mail (4 Zones: Italy, Europe, Africa and rest of world), one for Priority Mail (4 zones) and the last one for the pack (4 zones).

Now I have only one zone rates and I can propose only registred mail.

THANK YOU very much to all community.

I hope you have a solution.

Best regards.

 

P.S.: I'm sorry for my english.

Share this post


Link to post
Share on other sites

There are two ways to do this:

1. Get a copy of the MZMT module from the Addons section. This will need to be modified for MVS. Search this thread for the modifications, or read the modules.txt file in the MVS download for instructions and modify it yourself.

2. Make two new copies of whatever MVS module you want to use. Rename both of the copies, and change all of the constants in the copies to new names. Adding a number to the filename and the constants is the easiest way to do this. You now have 3 modules that you can use with one zone each.

 

Regards

Jim

Edited by kymation

See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Help with Zones setup.

 

I'm looking to use the Zones module for MVS 1.2.3 which appears to have been modified to allow states as shipping zones as well as countries, however I'm having difficulty in figuring out exactly how to set up my zones in the admin side. There's no documentation as to how exactly I need to format my entries so it will allow states. If I just put in a state abbreviation (NY for example) I get the result that there's no shipping to that zone.

 

Do I need to set up Tax Zones differently and how exactly should I format the names when entering them in the shipping module settings. I spent a fair amount of time searching this thread for the answers, but couldn't find any complete answer.

Share this post


Link to post
Share on other sites

That's not an MVS mod; the module can do that out of the box. You need to check that your zone exists in your Admin > Locations/Taxes > Zones. Remember that zone names are Case Sensitive.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

That's not an MVS mod; the module can do that out of the box. You need to check that your zone exists in your Admin > Locations/Taxes > Zones. Remember that zone names are Case Sensitive.

 

Regards

Jim

I know the module can do it, what I asked was how do I fill it out so it will work for states instead of countries.

zones.jpg

 

I understand if I want to create Zone 1 for US and Zone 2 for the UK, I would just put US in the first zone box, and UK in the 2nd zone box. But what if I want to have Zone 1 be California, Oregon and Washington states, and Zone 2 be New York, Connecticut and Pennsylvania?

 

Do I need to enter some sort of array? Just entering CA,OR,WA or using the full state name (California,Oregon,Washington) gives me the result "No shipping available to the selected country"

I apologize if I'm missing something simple, but under Taxes>Zones I've got United States listed with all of the states, so I do not understand what isn't working.

Share this post


Link to post
Share on other sites

I know the module can do it, what I asked was how do I fill it out so it will work for states instead of countries.

zones.jpg

 

I understand if I want to create Zone 1 for US and Zone 2 for the UK, I would just put US in the first zone box, and UK in the 2nd zone box. But what if I want to have Zone 1 be California, Oregon and Washington states, and Zone 2 be New York, Connecticut and Pennsylvania?

 

Do I need to enter some sort of array? Just entering CA,OR,WA or using the full state name (California,Oregon,Washington) gives me the result "No shipping available to the selected country"

I apologize if I'm missing something simple, but under Taxes>Zones I've got United States listed with all of the states, so I do not understand what isn't working.

 

Can no one clarify how to properly configure this for me? The module text itself doesn't indicate how to enter states, just countries (by their ISO2 code)

My Locations > Zones are set up as the default, like this:

Country Zones Code

United States Alabama AL

United States Alaska AK

United States Arizona AZ

United States Arkansas AR

 

Do I need to create zones differently?

Share this post


Link to post
Share on other sites

Hi Jim,

I'm getting an error when using the ship estimator in the cart. It reads Fatal error: Cannot use string offset as an array in /home/lyons/public_html/includes/modules/vendors_shipping/upsxml.php on line 381

 

I noticed the upsxml.php file is rather old. Can I combine the new file with this one?


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

That should not be happening. I'm using this on a couple of sites right now and it works fine. It's probably something wrong in your setup, although I can't think what might do that. I suggest that you turn on logging in upsxml.php and see what UPS is sending back.

 

The code is an old version. Since it still works, I have little incentive to modify the latest version. You're welcome to do that if you want. Please share the result with the rest of us.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Did anyone fix the MVS to work with the new Oscommerce version?

 

I tried it but some of the code im having problems with converting to the new oscommerce

 

Thanks

Share this post


Link to post
Share on other sites

Yes, that's a problem with the Javascript submit. There's no way to pass the other variables, so they all get reset. A standard form should fix this.

 

Regards

Jim

 

I like to use a form instead of javascript but not sure how this is done, can anyone show me?

Share this post


Link to post
Share on other sites

I'm new to OsCommerce (and php) and currently trying to set up a multilanguage store with OCS 2.3.1 and MVS.

I've got it working so far, even with PDF invoice and several other contribs.

 

But now I have a problem:

As I would like to have two zone based shipping methods (one for standard and one for express shipping), I copied the zones.php to expresszones.php and renamed all _ZONES_ constants, the class zones and $this->code = 'zones' to expresszones.

 

I can install and setup the new shipping method, the shipping estimator is working with the new method, too.

But when I select the radio button for this new second zone based method in checkout_shipping and click on checkout, it comes up with "Error: You have not selected a shipping method for all groups of products. Please select one shipping method for each group of products below."

As I see, the radio button should contain the shipping method as it's value. In examüple "zones_zones_2.625" for the standard zones method, "spu_spu_2.625" for store pickup and so on. But for my new expresszones it just contains "__2.625", so the name of the shipping method is missing the radiobutton. I think, that's the problem.

 

Could anyone please give me a hint how this radiobuttons are filled with values and where I have to look to find my fault?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

It should be the code variable:

      $this->code = 'foo';

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Then you have an error somewhere else. It's hard to guess where that might be. I would do a compare between the original module file and your modified file and see if anything looks wrong.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

I found the fault - it was just to simple...

I didn't rename the function, so it was still "function zones()" :blush:

 

Thank you, Jim.

Share this post


Link to post
Share on other sites

Of course that was too simple for my devious mind to think of. Glad you found the problem.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Drillsar, I still have problems with the shipping estimator, to.

 

I couldn't get the combination of tep_draw_button and the javascript popup working (it didn't open a new window or the shipping estimator poped up twice), so I just placed a link in textformat in the product_info, shopping_cart and bm_shopping_cart. That's not so fine, but at least the popup is working.

 

Now the estimator window pops up and is useable in Mozilla Firefox, but not in Internet Explorer. In MSIE the buttons just don't do anything.

The next problem is with the product shipping estimator, it drops the product id when the customer is not logged in and doesn't enter all the required data.

 

I hope to fix this things in the next days, but it's not on the top of my list.

Share this post


Link to post
Share on other sites

hi all there has been talk for a long time on mvs and paypal ipn merger as it were

 

in modules-payment-paypal_ipn.php

find

function confirmation() {

 

and add $shipping after $order_total_modules

 

find

 tep_db_perform(TABLE_ORDERS_PRODUCTS_DOWNLOAD, $sql_data_array);

               }

             }

           }

         }

after add

//MVS 
if (($total_weight > 0 ) || (SELECT_VENDOR_SHIPPING == 'true')){
          $shipping_array = $shipping['vendor'];
 foreach ($shipping_array as $vendors_id => $shipping_data) {

   $vendors_query = tep_db_query("select vendors_name
                                  from " . TABLE_VENDORS . "
                                  where vendors_id = '" . (int)$vendors_id . "'"
                                );
   $vendors_name = 'Unknown';
   if ($vendors = tep_db_fetch_array($vendors_query)) {
     $vendors_name = $vendors['vendors_name'];
   }

               $shipping_method_array = explode ('_', $shipping_data['id']);
               if ($shipping_method_array[0] == 'fedex1') {
                       $shipping_method = 'Federal Express';
                       } elseif ($shipping_method_array[0] == 'upsxml') {
                       $shipping_method = 'UPS';
                       } elseif ($shipping_method_array[0] == 'usps') {
                       $shipping_method = 'USPS';
                       } else {
                   $shipping_method = $shipping_method_array[0];
                   }
   $sql_data_array = array('orders_id' => $insert_id,
                           'vendors_id' => $vendors_id,
                           'shipping_module' => $shipping_method,
                           'shipping_method' => $shipping_data['title'],
                           'shipping_cost' => $shipping_data['cost'],
                           'shipping_tax' =>  $shipping_data['ship_tax'],
                           'vendors_name' => $vendors_name,
                           'vendor_order_sent' => 'no'
                          );
   tep_db_perform(TABLE_ORDERS_SHIPPING, $sql_data_array);
 }
 }
//MVS End

 

thats it

hope this helps

Al

Share this post


Link to post
Share on other sites

Where is the paypal Ipn module? or is this already included with oscommerce? Im confused. I see that paypal has a plugin for oscommerce anyone adapt this to MVS?

Share this post


Link to post
Share on other sites

Where is the paypal Ipn module? or is this already included with oscommerce? Im confused. I see that paypal has a plugin for oscommerce anyone adapt this to MVS?

 

I added it to mvs addons for convenience, compare it to the IPN you have if you have already made changes

 

 

Alman

Edited by alman

Share this post


Link to post
Share on other sites

i'm getting this error in checkout_process when I use paypal express button"

 

Warning: Invalid argument supplied for foreach() in /home/giftboundgifts/public_html/checkout_process.php on line 155

 

Any Ideas why this is hapening?

 

 

//MVS start

// Insert data into new orders_shipping table

$shipping_array = $shipping['vendor'];

foreach ($shipping_array as $vendors_id => $shipping_data) {

$vendors_query = tep_db_query ("select vendors_name

from " . TABLE_VENDORS . "

where vendors_id = '" . (int)$vendors_id . "'"

);

$vendors_name = 'Unknown';

if ($vendors = tep_db_fetch_array($vendors_query)) {

$vendors_name = $vendors['vendors_name'];

}

$shipping_method_array = explode ('_', $shipping_data['id']);

// Fix the shipper name where needed

switch ($shipping_method_array[0]) {

case 'fedex1':

$shipping_method = 'Federal Express';

case 'upsxml':

$shipping_method = 'UPS';

case 'usps':

$shipping_method = 'USPS';

default:

$shipping_method = $shipping_method_array[0];

} //switch

Share this post


Link to post
Share on other sites

Paypal Express bypasses part of the osCommerce checkout process. The osCommerce checkout process is modified by MVS to make MVS work. You'll need to modify Paypal's code as well. The only version that has been modified for MVS so far is Paypal IPN. See the comments above.

 

Regards

Jim


See my profile for a list of my addons and ways to get support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×