Jump to content
Sign in to follow this  
spoot

Automated FedEx Labels

Recommended Posts

Thanks for this great contribution! It has made my life exponentially easier!

 

In my cart when the order status is manually set to deliver i still have a ship button.

How do I correct this?

 

Thanks for your help!

Share this post


Link to post
Share on other sites

I've recently been receiving this error when shipping:

 

1062 - Duplicate entry '' for key 2 insert into shipping_manifest

 

It doesn't happen all the time, usually only when there is no weight associated. However, this has me stumped because I have an order where all the correct information is filled in, but I'm still unable to ship since I receive this error.

 

Anyone know what might be happening?

 

Thanks!

Chris B.

Share this post


Link to post
Share on other sites

Hi guys,

 

Quick question about this contribution: After creating a label, will it automatically be added to my Fedex Label Log? Usually I can see labels I created in my Fedex, but my test labels weren't in there. Does this contribution not have this option or is the install bad...? Everything else appears to work perfectly.

 

Thanks!

Share this post


Link to post
Share on other sites

tilteffect,

 

Are you still on the test server, or the production server?

 

The label is created and saved on your site as a .png image file. (The .png file is saved in your Admin>images>fedex folder on your site.) You are able to then print the label once you have gone through the Fedex shipping process (in the Admin area of your site). To view the label at any time after it is created, you go to your "Orders" area of your site (in Admin). On orders that have been marked as "Delivered", on the right of the orders screen, you should see a few buttons. ("Fedex Label", "Track", "Cancel Shipment") If you want to view the label again to print or just view it, then click on the button "Fedex Label" for that particular order.

 

Now, I'm not quite sure what you mean by "Fedex Label Log". If you mean being able to view a list of all your shipments in one area, then no one has written an add-on to this contribution for that. It does create a shipping manifest for all your ground orders, though. The program will continue to make new manifests which are viewable by day. But like I said, it's only for ground shipping. This should be located under the "Reports" section of the Admin area.

 

HTH,

Chris

 

Hi guys,

 

Quick question about this contribution: After creating a label, will it automatically be added to my Fedex Label Log? Usually I can see labels I created in my Fedex, but my test labels weren't in there. Does this contribution not have this option or is the install bad...? Everything else appears to work perfectly.

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks in advanced for your help!

I just shipped a package where the shipping address was:

Customer One

200 Main St

Ste 3

Miami, Florida 33129

The label can out as below missing the Ste 3

Customer One

200 Main St

Miami, Florida 33129

 

Why did this happen and how do I fix this?

Share this post


Link to post
Share on other sites

I would really like to use this contributions. I sometimes do 15-20 fedex labels a day and it takes me hours.

 

I have two questions I couldn't find in the readme.

 

1st. We ship through a 3rd party, when I use fedex website I select a 3rd party fedex account number and it uses their account. Does the contribution support this?

 

2nd. I have a flat rate shipping of 30 dollars, I don't actually do the fedex calculation while the user checks out (Fedex real time quotes). Can I still use this contribution to print out my labels?

 

Thanks

 

Ian

Share this post


Link to post
Share on other sites
I would really like to use this contributions. I sometimes do 15-20 fedex labels a day and it takes me hours.

 

I have two questions I couldn't find in the readme.

 

1st. We ship through a 3rd party, when I use fedex website I select a 3rd party fedex account number and it uses their account. Does the contribution support this?

 

2nd. I have a flat rate shipping of 30 dollars, I don't actually do the fedex calculation while the user checks out (Fedex real time quotes). Can I still use this contribution to print out my labels?

 

Thanks

 

Ian

 

 

 

1. The contribution does not include this, but with some basic php programming, you can easily incorporate this. Make sure you find the right API code in the Fedex API guides. I have this added into my site.

 

2. The contribution, once again, does not include this -- but I'm sure you can change the appropriate php function to force it to $30 at all times.

Edited by arkane8

Share this post


Link to post
Share on other sites
1st. We ship through a 3rd party, when I use fedex website I select a 3rd party fedex account number and it uses their account. Does the contribution support this?

 

Just put the 3rd party account number into FedEx Account Number field in Admin, Module, Fedex Zones during setup.

 

2nd. I have a flat rate shipping of 30 dollars, I don't actually do the fedex calculation while the user checks out (Fedex real time quotes). Can I still use this contribution to print out my labels?

 

Charging and shipping are 2 separate operations. I don't see why you can't use this contribution to print labels. It doesn't affect how you currently charge shipping.


- The Jackal

Share this post


Link to post
Share on other sites
Just put the 3rd party account number into FedEx Account Number field in Admin, Module, Fedex Zones during setup.

Charging and shipping are 2 separate operations. I don't see why you can't use this contribution to print labels. It doesn't affect how you currently charge shipping.

 

 

In regards to putting the 3rd party account # in setup, that's only assuming if the account will always be the same. If you want to use a different fedex account each time, that becomes a hassle. It's a rather easy piece of code to add/change to make it so you can enter third party #s per shipment (under Billing Recipient).

Share this post


Link to post
Share on other sites

Thanks for this great contribution. I've used it for quite long and it really saved me lots of time. :thumbsup:

 

I just upgraded to the most recently version that includes thermal printing capability. Everything works fine except for one little problem -- my Zebra thermal printer always print 2 pages for each label, one blank and one with the real label. I can see it under Print Preview as well. I've set Page Setup to 4x6 label size and with 0 margins on the borders.

 

Has anyone experienced similar problem? Is there a solution to this?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

--need labels to not list our store name--

 

this contrib is great. we do tons of business with fedex and it saves a lot of time. lately a number of customers have requested that we ship our packages without our company name on the label.

 

i've tried to do some quick hacking in admin/ship_fedex.php by replacing the STORE_NAME variable with our desired shipping company 'Shipping Department'. we have cleared this name with our fedex billing contact but it throws an error when we try this. here is the code:

starts at line ~51
// get sender's fedex info from configuration table
// (requires installation & configuration of FedEx RealTime Quotes)

			$fedex_vars = array (
					10=>'MODULE_SHIPPING_FEDEX1_ACCOUNT', // 0
					498=>'MODULE_SHIPPING_FEDEX1_METER',	// 1
					75=>'MODULE_SHIPPING_FEDEX1_WEIGHT',	// 2
					4=>'STORE_NAME',																						// 3
					5=>'MODULE_SHIPPING_FEDEX1_ADDRESS_1',// 4
					6=>'MODULE_SHIPPING_FEDEX1_ADDRESS_2',// 5
					7=>'MODULE_SHIPPING_FEDEX1_CITY',					   // 6
					8=>'MODULE_SHIPPING_FEDEX1_STATE',			  // 7
					9=>'MODULE_SHIPPING_FEDEX1_POSTAL',			 // 8
					183=>'MODULE_SHIPPING_FEDEX1_PHONE',	// 9
					68=>'DEFAULT_CURRENCY',														 // 10
					);

advice about how to go about doing this would be much appreciated. have searched the site but not found anything illuminating... the search function on here seems mentally challenged.

 

cheers,

jake

Share this post


Link to post
Share on other sites
my Zebra thermal printer always print 2 pages for each label, one blank and one with the real label.

I could think of a few possibilities causing the problem. Maybe you should test them and narrow the problem:

 

1. Browser: Try changing to another browser (e.g. IE or Firefox)

2. Screen Size: Try using another computer (e.g. Notebook with another screen size)

3. Driver: Get the latest Zebra driver from FedEx

 

The first 2 tests are easiest to perform. But my suspicion is actually with the 3rd. I have lots of printing problems with the older driver.


- The Jackal

Share this post


Link to post
Share on other sites

fixed this by forcing shipData array to hold the values i wanted at line ~256 in admin/ship_fedex.php:

// force shipData[4] = 'Shipping Department' and index 4003 as well
			$shipData[4] = 'Shipping Department';
			$shipData[4003] = 'Shipping Department';

 

hacking on PHP is fun =).

 

cheers,

jake

 

--need labels to not list our store name--

 

this contrib is great. we do tons of business with fedex and it saves a lot of time. lately a number of customers have requested that we ship our packages without our company name on the label.

 

i've tried to do some quick hacking in admin/ship_fedex.php by replacing the STORE_NAME variable with our desired shipping company 'Shipping Department'. we have cleared this name with our fedex billing contact but it throws an error when we try this. here is the code:

starts at line ~51
// get sender's fedex info from configuration table
// (requires installation & configuration of FedEx RealTime Quotes)

			$fedex_vars = array (
					10=>'MODULE_SHIPPING_FEDEX1_ACCOUNT', // 0
					498=>'MODULE_SHIPPING_FEDEX1_METER',	// 1
					75=>'MODULE_SHIPPING_FEDEX1_WEIGHT',	// 2
					4=>'STORE_NAME',																						// 3
					5=>'MODULE_SHIPPING_FEDEX1_ADDRESS_1',// 4
					6=>'MODULE_SHIPPING_FEDEX1_ADDRESS_2',// 5
					7=>'MODULE_SHIPPING_FEDEX1_CITY',					   // 6
					8=>'MODULE_SHIPPING_FEDEX1_STATE',			  // 7
					9=>'MODULE_SHIPPING_FEDEX1_POSTAL',			 // 8
					183=>'MODULE_SHIPPING_FEDEX1_PHONE',	// 9
					68=>'DEFAULT_CURRENCY',														 // 10
					);

advice about how to go about doing this would be much appreciated. have searched the site but not found anything illuminating... the search function on here seems mentally challenged.

 

cheers,

jake

Share this post


Link to post
Share on other sites

Thanks for your suggestions.

 

1. Browser. I tried both IE 6 and IE7. Same problem.

2. I tried on different computers. Same problem.

3. I downloaded the latest USB driver from Fedex website. Still the same problem.

 

I'm wondering what kind of label you're using, 4x6 or 4x6.75? I'm using 4x6 thermal labels and I set the page size to be 4x6. I read somewhere that Fedex sets the label to be 6.75 for customers to add notes/comments on the label. Did I remember it correct? Is that the cause then?

 

Wendy

I could think of a few possibilities causing the problem. Maybe you should test them and narrow the problem:

 

1. Browser: Try changing to another browser (e.g. IE or Firefox)

2. Screen Size: Try using another computer (e.g. Notebook with another screen size)

3. Driver: Get the latest Zebra driver from FedEx

 

The first 2 tests are easiest to perform. But my suspicion is actually with the 3rd. I have lots of printing problems with the older driver.

Share this post


Link to post
Share on other sites

Hello All. Here is the problem. I cant slove it...

 

I recive error : "ERROR: FedEx Return Error F834 : Shipper company name cannot exceed 35 characters"

 

I would appreciate if someone could help me.

 

Thank you in advance.

Share this post


Link to post
Share on other sites

I can't seem to get the Labels approved by FedEx. Here's their message:

Please contact customer and inform label format is Not Approved.

Problem:

* Astra barcode is 13.5 mil should be 15

* 2d barcode is 8.9 mil should be 10 mil

 

any suggestions?

Share this post


Link to post
Share on other sites

Hi all,

I'm still getting this error:

 

1062 - Duplicate entry '' for key 2 insert into shipping_manifest

 

There was one person here who did some db changes which corrected the error. I've pm'd him/her, but no reply. Does anyone have a solution for this?

 

I've deleted every shipping manifest from the "Tools" tab in the admin area, yet still get this error.

 

TIA,

Chris B.

Share this post


Link to post
Share on other sites

Hmmm, well, seems I found the answer from a while ago. Just didn't think it was relevant to my problem. Ah well. To resolve:

 

1) Open "admin/includes/fedexdc.php"

2) Find "function _sendCurl() {"

3) After "curl_setopt( $ch, CURLOPT_POSTFIELDS, $this->sBuf );" - insert "curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);" (without quotes)

 

This resolved my problem - for now.

 

Hi all,

I'm still getting this error:

There was one person here who did some db changes which corrected the error. I've pm'd him/her, but no reply. Does anyone have a solution for this?

 

I've deleted every shipping manifest from the "Tools" tab in the admin area, yet still get this error.

 

TIA,

Chris B.

Share this post


Link to post
Share on other sites

Open label in new page. Please post some code that will allow the label to be opened in a new page when the "Submit" button is pushed on the "/admin/ship_fedex.php" page.

 

Many thanks,

stickypod


Anyone can buy a camera... it's what you do with it that counts!

Sticky Pod

www.stickypod.com

Share this post


Link to post
Share on other sites

The second address line is not appearing on the fedex labels.

The shipping address is:

 

Customer One

200 Main St

Ste 3

Miami, Florida 33129

 

 

The label can out as below missing the second part of the address - Ste 3

 

Customer One

200 Main St

Miami, Florida 33129

 

How do I fix this?

Thanks for your help

Share this post


Link to post
Share on other sites
The second address line is not appearing on the fedex labels.

The shipping address is:

 

Customer One

200 Main St

Ste 3

Miami, Florida 33129

The label can out as below missing the second part of the address - Ste 3

 

Customer One

200 Main St

Miami, Florida 33129

 

How do I fix this?

Thanks for your help

Hey Chriweb,

 

Just follow these instructions in this post: http://forums.oscommerce.com/index.php?sho...mp;#entry621469

 

If you have not changed the core of your OSC store with the ADDRESS_2 field (not necessary), just substitute address_2 with suburb and your 2nd address line will show up.

 

Good luck,

stickypod


Anyone can buy a camera... it's what you do with it that counts!

Sticky Pod

www.stickypod.com

Share this post


Link to post
Share on other sites

How to change the email that updates the customer?

 

I see that in catalog/admin/ship_fedex.php that this block of code constructs the email that gets sent to a customer:

 

				$email_txt = STORE_NAME . '<br>' . EMAIL_SEPARATOR . '<br>' . EMAIL_TEXT_ORDER_NUMBER . ' ' . $order . '<br><br>' . EMAIL_TEXT_INVOICE_URL . ' ' . tep_catalog_href_link(FILENAME_CATALOG_ACCOUNT_HISTORY_INFO, 'order_id=' . $order, 'SSL') . '<br>' . EMAIL_TEXT_DATE_ORDERED . ' ' . tep_date_long($check_status['date_purchased']) . '<br><br>' . '<br>' . $email_notify_tracking . '<br><br>' . sprintf(EMAIL_TEXT_STATUS_UPDATE, 'Shipped');

 

Unfortunately, when the email is sent, it simply runs all the lines together and does not provide the spacing it needs to make it readable. Please help me change this so it works appropriately.

 

Many thanks,

stickypod


Anyone can buy a camera... it's what you do with it that counts!

Sticky Pod

www.stickypod.com

Share this post


Link to post
Share on other sites

Multiple FedEx errors, please help. The first error is in the admin section and has been posted before, but there was no reply. When the track button is pushed after an order has shipped, the following error shows up at the bottom of the admin section on all pages:

 

1062 - Duplicate entry '4e8c19bf29495b57871fadf54fa7e68e' for key 1

insert into sessions values ('4e8c19bf29495b57871fadf54fa7e68eoID=4509', '1193437119', 'language|s:7:\"english\";languages_id|s:1:\"1\";selected_box|s:13:\"configuration\";')

[TEP STOP]


Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

 

The next error has to do with the customer tracking button. When a customer wants to track their package from the account history, they get the following:

 

Warning: fopen(/admin/images/fedex/post.txt): failed to open stream: No such file or directory in /xxxxxx/xxxxxxx/public_html/osc/includes/fedexdc.php on line 310

Warning: fwrite(): supplied argument is not a valid stream resource in /xxxxxx/xxxxxx/public_html/osc/includes/fedexdc.php on line 312

 

Now I know this error has been brought up before, but none of the fixes in here are working. Not only that, but the error does not make sense. The error states the directory and file do not exist, but in fact they do and the permissions are set to 777. When I view the post.txt file, it is blank. Maybe that's a clue.

 

Any help would be great. Thank you, stickypod

Edited by stickypod

Anyone can buy a camera... it's what you do with it that counts!

Sticky Pod

www.stickypod.com

Share this post


Link to post
Share on other sites
Multiple FedEx errors, please help. The first error is in the admin section and has been posted before, but there was no reply. When the track button is pushed after an order has shipped, the following error shows up at the bottom of the admin section on all pages:

 

1062 - Duplicate entry '4e8c19bf29495b57871fadf54fa7e68e' for key 1

insert into sessions values ('4e8c19bf29495b57871fadf54fa7e68eoID=4509', '1193437119', 'language|s:7:\"english\";languages_id|s:1:\"1\";selected_box|s:13:\"configuration\";')

[TEP STOP]
Warning: Unknown(): A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

 

The next error has to do with the customer tracking button. When a customer wants to track their package from the account history, they get the following:

 

Warning: fopen(/admin/images/fedex/post.txt): failed to open stream: No such file or directory in /xxxxxx/xxxxxxx/public_html/osc/includes/fedexdc.php on line 310

Warning: fwrite(): supplied argument is not a valid stream resource in /xxxxxx/xxxxxx/public_html/osc/includes/fedexdc.php on line 312

 

Now I know this error has been brought up before, but none of the fixes in here are working. Not only that, but the error does not make sense. The error states the directory and file do not exist, but in fact they do and the permissions are set to 777. When I view the post.txt file, it is blank. Maybe that's a clue.

 

Any help would be great. Thank you, stickypod

 

Hi,

 

I believe it's either a path or permissions problem.

 

1. if .htaccess is present, temporarily rename your .htaccess to .htaccess1

2. make sure both the permissions on the folder and file is 777

3. if above still fails, you can test your permission or path setting using the following simple 'test writing' script: (paste it to anywhere appropriate)

$myfile = "admin/images/fedex/post.txt";
$myfile = DIR_FS_CATALOG . $myfile;
$fp = fopen($myfile,"a");
$line="Testing 123";
fputs($fp,$line);
fclose($fp);

4. You should see "Testing 123" in post.txt. If not, you know for sure its a path or permissions problem.


- The Jackal

Share this post


Link to post
Share on other sites

Thanks for the info Jackal, but that did not work either and all permissions, ownership and the path are definitely correct. Is it possible it's a SSL issue. This is a secured area.

 

Also, any ideas about the first problem?

 

PS since I have posted this, others have come forward with the same problem. This is a problem that's not going away and it's not just me.

 

Thanks for the help.

Tom


Anyone can buy a camera... it's what you do with it that counts!

Sticky Pod

www.stickypod.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×