Jump to content
Sign in to follow this  
spoot

Automated FedEx Labels

Recommended Posts

Helloo i Installed the module and I got this error :

 

when i click on ship on one order i get this message :

Access Denied

No Right permission access

Please contact your Webmaster to request

more access or if you found any problem.

Does anyone knows where this comes from? i did setup the permissions on the fedex folder!

 

You need to set up the file permissions for "shipping_manifest.php", "fedex_popup.php", "ship_fedex.php", "track_fedex.php" under your admin area. (Should be under "Administrator" > "File Access")

 

HTH,

Chris B.

Share this post


Link to post
Share on other sites
Wow you really did not take the time to read ANY of this forum and the instructions in the contribution have you? If you'd take the time to even look at the contrib after you install it you'll realize this is all there already and this function you are looking for explains itself.

 

Actually I did read some on this forum before being able to successfully install this module. It did not install correctly at one go. No complains though. It works fine now after prodding through this great forum which in itself was a lot of fun. Now I can brag to people that I know PHP. But I guess I'm missing some kind of a point here somewhere.

Below the Required Fields section, I have the following options to choose from:

 

Number of Packages:

Oversized? 123

Packaging Type ("other" for ground shipments): Your PackagingFedEx PakFedEx BoxFedEx TubeFedEx Envelope

Type of Service: FedEx Ground ServiceFedEx PriorityFedEx 2dayFedEx Standard OvernightFedEx First OvernightFedEx Express Saver

Payment Type: Bill sender (Prepaid)Bill recipientBill third partyBill credit cardBill recipient for FedEx Ground

Dropoff Type: Regular pickupRequest courierDrop boxDrop at BSCDrop at station

Pickup date (yyyymmdd):

Declared Value ($):

Package Weight

 

Nowhere above can I find Home Deliveries listed but it shows on the real time quotes on the delivery information page under "Shipping Methods" on the catalog. I apolozige for not giving this info in my previous post. Is that the way this is supposed to work?

Since we deliver mostly to businesses, is there a way to change that Home Delivery option below the Shipping Methods to Ground and somehow still find a way to print out labels for all Ground, Home, and Express to send to FedEx?

Please help.

Share this post


Link to post
Share on other sites
Actually I did read some on this forum before being able to successfully install this module. It did not install correctly at one go. No complains though. It works fine now after prodding through this great forum which in itself was a lot of fun. Now I can brag to people that I know PHP. But I guess I'm missing some kind of a point here somewhere.

Below the Required Fields section, I have the following options to choose from:

 

Number of Packages:

Oversized? 123

Packaging Type ("other" for ground shipments): Your PackagingFedEx PakFedEx BoxFedEx TubeFedEx Envelope

Type of Service: FedEx Ground ServiceFedEx PriorityFedEx 2dayFedEx Standard OvernightFedEx First OvernightFedEx Express Saver

Payment Type: Bill sender (Prepaid)Bill recipientBill third partyBill credit cardBill recipient for FedEx Ground

Dropoff Type: Regular pickupRequest courierDrop boxDrop at BSCDrop at station

Pickup date (yyyymmdd):

Declared Value ($):

Package Weight

 

Nowhere above can I find Home Deliveries listed but it shows on the real time quotes on the delivery information page under "Shipping Methods" on the catalog. I apolozige for not giving this info in my previous post. Is that the way this is supposed to work?

Since we deliver mostly to businesses, is there a way to change that Home Delivery option below the Shipping Methods to Ground and somehow still find a way to print out labels for all Ground, Home, and Express to send to FedEx?

Please help.

The Real Time Quotes and the Fedex Shipping only share the fedexdc.php file. They are not otherwise related. The "Home Delivery" option has not been coded into the Fedex Shipping Module. If you only ship to businesses then just go through your test scenarios and print out your labels for whichever Ground and Express scenarios you need. I believe a couple of the scenarios are not coded within the shipping module, so you will not be able to print and send those.

 

When I did my scenarios, I created the orders in admin, not in my store area. I think that is where you are confused.

 

HTH,

Chris B.

Share this post


Link to post
Share on other sites
The Real Time Quotes and the Fedex Shipping only share the fedexdc.php file. They are not otherwise related. The "Home Delivery" option has not been coded into the Fedex Shipping Module. If you only ship to businesses then just go through your test scenarios and print out your labels for whichever Ground and Express scenarios you need. I believe a couple of the scenarios are not coded within the shipping module, so you will not be able to print and send those.

 

When I did my scenarios, I created the orders in admin, not in my store area. I think that is where you are confused.

 

HTH,

Chris B.

 

Chris is correct home delivery is an option on the backend not on the catalog side (different module not covered by this thread) so the customer chooses ground. Then on the backend the module (this thread) will automatically default to ground if there is a biz name or home if there is not. You can also manually choose this as well. They are different modules as Chris said but the work together for a couple of unrelated functions.

Edited by homewetbar

Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites
Chris is correct home delivery is an option on the backend not on the catalog side (different module not covered by this thread) so the customer chooses ground. Then on the backend the module (this thread) will automatically default to ground if there is a biz name or home if there is not. You can also manually choose this as well. They are different modules as Chris said but the work together for a couple of unrelated functions.

 

Thank you all for clearing out my confusion. This is a great forum with obviously a lot of helpful folks. I'm about to send the test scripts to FedEx for approval and again, I have you all to thank for that.

Share this post


Link to post
Share on other sites

I had this same problem and at the urging of Fed EX, I removed the words "NONE" from my Meter ID field and then tried again and the system worked perfectly. It generated a correct Meter ID and also returned a label.

 

Hi all. I have this message when I submit the form to make a ship:

 

This transaction could not be completed. Please note the error message below.

 

ERROR: FedEx Return Error 110A : The login failed

What can I do, to Fix it?

 

thanks a lot!

 

Matias Paterlini

Share this post


Link to post
Share on other sites

Hi all,

 

I have made a new small tweak for fedex labels.

 

v1.3

Allows you to see the

'Ship Fedex', 'Cancel Shipment', 'FedEx Label' button on the admin 'Edit Orders' screen.

 

Just replace 1 line in catalog/admin/orders.php.

 

Depending on your way of operation, this simple tweak can save you lots of time and hassle.

 

Requirements:

Intended for v1.2b and below.

 

NOT a full package. Only install instruction for the tweak is attached.

 

I don't foresee any problems, but if there is any, please report them here. Enjoy!


- The Jackal

Share this post


Link to post
Share on other sites

Well I have been approved for production, flipped my code to production, and ran a test. Did the subscribe and got a new meter id, but the label will not come up.

I get the page, but all I get is "Astra Barcode and the outline of where the label should be.

Everything else works fine. I get a tracking number and the customer gets notified.

I created several new orders and they all fail to show the actual label.

Looks like Fedex should be returning the actual label picture and it is not coming into my system.

Anyone else run into this?

Share this post


Link to post
Share on other sites
Well I have been approved for production, flipped my code to production, and ran a test. Did the subscribe and got a new meter id, but the label will not come up.

I get the page, but all I get is "Astra Barcode and the outline of where the label should be.

Everything else works fine. I get a tracking number and the customer gets notified.

I created several new orders and they all fail to show the actual label.

Looks like Fedex should be returning the actual label picture and it is not coming into my system.

Anyone else run into this?

 

 

Found it.... did a search on "png" and discovered commenting out a line in the fedexdc solves it. I am alive.....

Share this post


Link to post
Share on other sites

Great contribution, as i can tell from the positive results and the screenshots! I installed everything, but i get:

 

Access Denied

 

No Right Permission Access

Please contact your Webmaster to request

more access or if you found any problem.

 

I think this is because it is trying to acces files/dirs that have different file permissions on them. Could anyone please tell me which functions are called so I can talk to my host to make sure that the proper files get the proper file permissions?

 

Thanks in advance!

Share this post


Link to post
Share on other sites
Great contribution, as i can tell from the positive results and the screenshots! I installed everything, but i get:

 

 

 

I think this is because it is trying to acces files/dirs that have different file permissions on them. Could anyone please tell me which functions are called so I can talk to my host to make sure that the proper files get the proper file permissions?

 

Thanks in advance!

 

Sorry, i just read another post that addresses the same problem. I'll try that first.

Share this post


Link to post
Share on other sites
Sorry, i just read another post that addresses the same problem. I'll try that first.

 

 

Thanks to Chris B. for pointing out the file access menu, it works, let's now test it with fedex!

 

Thanks for this great contribution!!

Share this post


Link to post
Share on other sites
Thanks to Chris B. for pointing out the file access menu, it works, let's now test it with fedex!

 

Thanks for this great contribution!!

 

You're welcome! :D

 

Chris B.

Share this post


Link to post
Share on other sites

Hello everyone ...

 

Is there anyone capable of writing a contribution like this for UPS?

 

I will pay this. If you can do it please email me.

 

Craig

Share this post


Link to post
Share on other sites

Hello, I had successfully installed this contribution like a month back. After doing so, I went ahead and installed the following contributions and edited the required files for those contributions to work; not to mention, make any changes in the DB, if so required for any of those contributions to work. Following are the contributions that I installed after installing the FedEx Automated Labels contribution:

 

-------------------------------------------------------------------------------

1. Related Products (http://www.oscommerce.com/community/contributions,2293/category,all/search,related+products)

 

Files edited:

 

catalog/admin/categories.php

catalog/admin/includes/database_tables.php

catalog/admin/includes/boxes/catalog.php

catalog/admin/includes/languages/"YOUR LANGUAGE.PHP"

includes/boxes/catalog.php

catalog/admin/includes/filenames.php

catalog/includes/database_tables.php

catalog/includes/"YOUR LANGUAGE"/product_info.php

catalog/product_info.php

 

Aside from changes to these files, this contrib. also required the following SQL script to be run:

 

DROP TABLE IF EXISTS `products_options_products`;

CREATE TABLE `products_options_products` (

`pop_id` int(11) NOT NULL auto_increment,

`pop_products_id_master` int(11) NOT NULL default '0',

`pop_products_id_slave` int(11) NOT NULL default '0',

`pop_order_id` smallint(6) NOT NULL default '0',

PRIMARY KEY (`pop_id`)

) TYPE=MyISAM AUTO_INCREMENT=18 ;

 

INSERT INTO `configuration_group` ( `configuration_group_id` , `configuration_group_title` , `configuration_group_description` , `sort_order` , `visible` )

VALUES (

'', 'Related Products', 'Optional Related Products module', '999', '1'

);

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )

VALUES ('', 'Show Thumbnails', 'MODULE_RELATED_PRODUCTS_SHOW_THUMBS', 'False', 'Show Related Products Thumbnails', last_insert_id(), '1', NULL, '2005-03-29 23:20:20', NULL , 'tep_cfg_select_option(array(\'True\', \'False\'),');

 

Finally, it required two "new" files, both called products_options.php , to be added into these directories:

\catalog\admin\includes\languages\english

\catalog\admin

--------------------------------------------------------------------------

2. Unique Category Descriptions - (Made Simple) 1.3

(http://www.oscommerce.com/community/contributions,4053/category,all/search,Unique+Category+Descriptions+-+%28Made)

 

Files edited:

 

/catalog/index.php

and

Created a directory in /catalog/includes called /descriptions/. and created a bunch of files with a .php extension bearing the name of all of my categories and sub-categories.

---------------------------------------------------------------------------

3. PWA_0.910_1_2

(http://www.oscommerce.com/community/contributions,355/category,all/search,PWA)

 

Files edited:

 

/catalog/account.php

/catalog/checkout_process.php

/catalog/checkout_success.php

/catalog/login.php

/catalog/create_account.php

/catalog/includes/header.php

/catalog/includes/filenames.php

/catalog/includes/languages/english.php

/catalog/includes/languages/english/login.php

/catalog/includes/languages/english/create_account.php

/catalog/admin/orders.php

 

Files added:

 

/catalog/order_info.php

/catalog/includes/languages/english/images/buttons/button_create_account.gif

 

SQL Script run:

 

ALTER TABLE customers ADD purchased_without_account TINYINT(1) UNSIGNED DEFAULT '0' NOT NULL AFTER customers_id;

ALTER TABLE customers ADD INDEX (purchased_without_account);

INSERT INTO configuration_group VALUES (40, 'Accounts', 'Configuration of Account settings', 40, 1);

INSERT INTO configuration VALUES ('', 'Purchase Without Account', 'PWA_ON','true','Allow Customers to purchase without an account', 40, 1, '2003-04-08 13:07:44', '2003-04-08 12:10:51', NULL, 'tep_cfg_select_option(array(\'true\', \'false\'),');

ALTER TABLE orders ADD purchased_without_account TINYINT (1) UNSIGNED DEFAULT '0' NOT NULL;

--------------------------------------------------------------------------------

 

All of the aforementioned contributions work perfectly fine with my OSCommerce installation. But after some point in between installing those contributions (I guess), I'm not sure when, the FedEx Automated Label contribution just disappeared. Literally. And I have absolutley no clue as to whether or not any of the files I edited while installing those contributions have anything, if at all, to do with Automated Labels not working anymore. There are no buttons pertaining to this contrib like Track, Ship, FedEx Label, Cancel Shipment etc anymore on the admin page although they still reside as graphic files under the /admin/includes/languages/english/images/buttons folder. There are no more png files at /admin/images/fedex/ as well. I also do not see post.txt anywhere anymore. It's as if I never installed Automated Label contrib. since there are no errors on the admin page.

I'm completely lost and do not know where to begin to find out what went wrong.

Thankfully, I have a backup of all the files including the DB before I installed those 3 contributions but I really am not looking forward to going through the whole process again that includes reentering products and other form of content.

Somebody, please help.

Share this post


Link to post
Share on other sites

Great contrib, I really enjoy using it. I had an issue arise today where I wasn't able to print the second label in a multiple package shipment. Shouldn't there be a "next" button or something? I had to ftp into the directory and manually edit the url to get the label to display. Any help please. Thank you again.

Share this post


Link to post
Share on other sites
The automated fedex labels contribution is an addition to the administrative pages that retrieves label data from FedEx.

 

To use this contribution, you must have a FedEx account number.

 

In order to get on FedEx's production server, you must contact FedEx directly. They will have you, uh, FedEx your printed labels to them. When they give you their OK, you can go live. These labels come directly from FedEx, so they should pass the test.

 

//============================================================//

 

Hi,

 

I installed fxfreight_0.6 contrbution for integrating shipping with osCommerce, i also want to integrate the lebel printing facilty for the shipping orders.

With fedex I am able to process the orders as well, where can I get the patch for lebel printing with fedex.

 

Also following error is popped in the checkout_shipping.php for usps shipping methods

//

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

//

 

the shipping details such as the postal code, country and zone are entered correctly though this is the error why usps is not active giving the above error.

pls suggest if you know the soln.

 

thanks in advance.

 

Dadasaheb H.

//============================================================//

Share this post


Link to post
Share on other sites

I'm going out of my mind with this one - I just can't find a clue. I have FedEx Shipping Labels installed with the Free Shipping w/minium amount contrib. It works just fine except that all shipments over the free ship limit are marked as "Ground" deliveries no matter if the customer's Company field is empty or not. This costs my client an extra $2 on each of those deliveries (since most are not to businesses) and he isn't happy. I can't find anything that would account for this and I'm out of ideas. Does anyone else have this combination installed? Are you having the same problem? Any ideas at all? I will check out any leads. Thanks!

 

I believe I am using version 1.10 of the FedEx label contrib.

 

David

Share this post


Link to post
Share on other sites
I'm going out of my mind with this one - I just can't find a clue. I have FedEx Shipping Labels installed with the Free Shipping w/minium amount contrib. It works just fine except that all shipments over the free ship limit are marked as "Ground" deliveries no matter if the customer's Company field is empty or not. This costs my client an extra $2 on each of those deliveries (since most are not to businesses) and he isn't happy. I can't find anything that would account for this and I'm out of ideas. Does anyone else have this combination installed? Are you having the same problem? Any ideas at all? I will check out any leads. Thanks!

 

I believe I am using version 1.10 of the FedEx label contrib.

 

David

 

The only thing that would cause this is characters entered into the company field when they create an account or you have changed something in the fedex labels contrib. Look into your db mysql or your db program and see if there are characters in the company field, possibly even extra spaces in the company field of the db could cause this. So if you find the company field has nothing in it then you know you must have changed something when you added the free ship contrib (which should not affect this contrib) so you need to redownload and reinstall the fedex labels...and so on.... basically just debug it from there.

Edited by homewetbar

Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Hi,

I've been using the Automated FedEx Labels and recently got a Zebra Thermal printer from FedEx and was wondering if anyone would be willing to code a contribution which allows me to print the labels through my oscommerce admin area like the "Automated FedEx Labels" system.

 

Please send me your bids by either replying, sending me a PM or e-mailing me at sigel@sigeltek.com, I also have aim: sigeltekinn

 

Hope to hear from somene soon!

Thank You,

 

- Sigel

Share this post


Link to post
Share on other sites
Found it.... did a search on "png" and discovered commenting out a line in the fedexdc solves it. I am alive.....

Can you please tell me what you did to get it working after you got approved? I too got approved now I do not know what file to tweak to do the following.

 

1. Modify the URL contained within your HTTPS post operation from "gatewaybeta.fedex.com:443/GatewayDC" to "gateway.fedex.com:443/GatewayDC"

 

2. Use the "Subscribe" transaction to obtain a production meter number.

 

Can you help?

Share this post


Link to post
Share on other sites

Has anybody done a successful Subscribe() transaction to receive a meter number for production? If so, could you please share how you did it or at least point me to the right direction? I've searched through this forum looking for answers but to no avail.

Thanks in advance.

Share this post


Link to post
Share on other sites
Has anybody done a successful Subscribe() transaction to receive a meter number for production? If so, could you please share how you did it or at least point me to the right direction? I've searched through this forum looking for answers but to no avail.

Thanks in advance.

 

Read the forum, its explained at least 3 times already in this forum.


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites
Read the forum, its explained at least 3 times already in this forum.

 

 

Ok, people have stated that they used it, only without explaining how. And that is all I'm trying to find out as to how to go about doing it. Not even installing this contribution took so long than to figure out the next steps after FedEx approved me. Thanks for your help.

Share this post


Link to post
Share on other sites
Ok, people have stated that they used it, only without explaining how. And that is all I'm trying to find out as to how to go about doing it. Not even installing this contribution took so long than to figure out the next steps after FedEx approved me. Thanks for your help.

The first interaction with the server is suposed to subscribe the account and get the meter number. Of course you have to be signed up with the FedEx and have an your account linked to the test server (takes 24 to 48 hours after request). I actually got it from the API service rep when I was trying to get FedExDC working in a Joomla! ValueMart install for the same client. Had to abandon when I realized the FexEx Plugin was only set up to get rates and not ship or track.

 

Once I had the Meter number it was easy to get it working, well after gettting over the fact that with GoDaddy/Wild West Reseller accounts need a Proxy Server entry added in the Curl Code. Not sure if other ISP's would have this issue too. Without the Proxy it could not talk to the FedEX Server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×