Jump to content
Sign in to follow this  
spoot

Automated FedEx Labels

Recommended Posts

I'm sorry I can't help you do what it is you're trying to achieve. I've attempted to do some ridiculously complicated things with shipping modules only to find that there is a much simpler way to achieve, or at least to simulate, the same thing, and end up with the same result. In my experience the best and easiest thing for you to do would be to add in a handling fee, because no matter how many checks you put in, not every customer is going to use them properly.

 

Good luck!


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

Wait a second....

 

Find the following code in your fedex1.php file:

 

if ($order->delivery['company'] == '' && MODULE_SHIPPING_FEDEX1_RESIDENTIAL == 0) {

$data .= '440,"Y"'; // Residential address

}else {

$data .= '440,"N"'; // Business address, use if adding a residential surcharge

}

 

and change it to this:

 

$data .= '440,"Y"'; // Residential address

 

and then see what happens, although I make no guarantees.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites

FYI Installation Nits.

 

I've just installed this contribution for the first time and ran into the following problems. The problems were minor, but it would be nice if they could be incorporated into a subsequent release.

 

1. Ran into cURL errors that some others have run into, and I had to add:

 

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);

 

in function _sendCurl(). My suggestion is to add this code preceded by a comment delimiter (//)

and make a note in the install.txt

 

2. The fedexdc.php class is duplicated, but not quite, between catalog & catalog/admin. My suggestion

is to make a note in install.txt to copy the catalog/admin/fedexdc.php to catalog/fedexdc.php and

perhaps not include a copy in catalog/.

 

3. There is debug code in fedexdc.php that writes to a post.txt file but doesn't close the handle. My

suggestion is to remove this code.

 

4. EMAIL_TEXT_CONTENT is not defined (bug introduced by recent saturday shipping release)

 

5. Cancel results in order status of 6. This was again a recent change. Older code returned

the order into processing (2). My suggestion is that authors or modifiers of the cancel function

decide on what is appropriate. If 6 is the answer, then the install.txt must be updated.

 

6. The fedex readme.txt should be modified to state that the change to configure.php is necessary

on a virgin ms2 install; i.e., just copying the included files on a full distribution will not install

the feature without making the configure.php change.

Share this post


Link to post
Share on other sites
FYI Installation Nits.

 

I've just installed this contribution for the first time and ran into the following problems. The problems were minor, but it would be nice if they could be incorporated into a subsequent release.

 

1. Ran into cURL errors that some others have run into, and I had to add:

 

curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);

 

in function _sendCurl(). My suggestion is to add this code preceded by a comment delimiter (//)

and make a note in the install.txt

 

2. The fedexdc.php class is duplicated, but not quite, between catalog & catalog/admin. My suggestion

is to make a note in install.txt to copy the catalog/admin/fedexdc.php to catalog/fedexdc.php and

perhaps not include a copy in catalog/.

 

3. There is debug code in fedexdc.php that writes to a post.txt file but doesn't close the handle. My

suggestion is to remove this code.

 

4. EMAIL_TEXT_CONTENT is not defined (bug introduced by recent saturday shipping release)

 

5. Cancel results in order status of 6. This was again a recent change. Older code returned

the order into processing (2). My suggestion is that authors or modifiers of the cancel function

decide on what is appropriate. If 6 is the answer, then the install.txt must be updated.

 

6. The fedex readme.txt should be modified to state that the change to configure.php is necessary

on a virgin ms2 install; i.e., just copying the included files on a full distribution will not install

the feature without making the configure.php change.

 

3. Could you please be more specific about the location of this code?

 

4. Where do you find EMAIL_TEXT_CONTENT?

 

5. I noticed the same thing. IMO the status should be changed to 2, as 6 is not a stock osC option. Also the recent release was set to delete the order if the shipment was cancelled. I find this to be bit draconian and it could've caused me trouble if I hadn't caught it during testing. Perhaps set it to return to status 2 by default but include the code that deletes the order for those who want to do it that way?

 

6. Could you please be more specific about this?

 

Great comments, thanks for helping out.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
3. Could you please be more specific about the location of this code?

 

4. Where do you find EMAIL_TEXT_CONTENT?

 

5. I noticed the same thing. IMO the status should be changed to 2, as 6 is not a stock osC option. Also the recent release was set to delete the order if the shipment was cancelled. I find this to be bit draconian and it could've caused me trouble if I hadn't caught it during testing. Perhaps set it to return to status 2 by default but include the code that deletes the order for those who want to do it that way?

 

6. Could you please be more specific about this?

 

Great comments, thanks for helping out.

Share this post


Link to post
Share on other sites
3. Could you please be more specific about the location of this code?

 

4. Where do you find EMAIL_TEXT_CONTENT?

 

5. I noticed the same thing. IMO the status should be changed to 2, as 6 is not a stock osC option. Also the recent release was set to delete the order if the shipment was cancelled. I find this to be bit draconian and it could've caused me trouble if I hadn't caught it during testing. Perhaps set it to return to status 2 by default but include the code that deletes the order for those who want to do it that way?

 

6. Could you please be more specific about this?

 

Great comments, thanks for helping out.

 

3. in function _sendCurl. Is in 1.07 and later (maybe earlier).

 

4. line 420 of ship_fedex.php in saturday shipping release.

 

5. the code really doesn't delete the order, but it appears to be deleted because after a cancel, the final

orders screen doesn't show the order, because the sql query fails because there is no status 6 in

the orders status file. There are two ways of addressing the problem. Add an orders_status 6 to

to the orders_status file (ostensibly named Cancelled Shipping???), or simply return the code to

an earlier version and use status code 2. My preference is the later, but I do not claim to understand

why the coding change was made.

 

6. the readme.txt states:

 

"Read install.txt for detailed installation information. The file includes all ne

cessary

code updates; you can also just drop the included files into a new oscommerce in

stallation."

 

However this is not true, because the file package does not (nor should it) contain configure.php.

 

For a custom installation, the install.txt states.

##
## add to admin/includes/configure.php:
##

// fedex
	define('DIR_WS_FEDEX_LABELS', DIR_WS_IMAGES . 'fedex/');
// fedex eof

##

 

Hence, the correct instruction in readme.txt is that you can drop the included files into a new oscommerce

installation AND make the change to configure.php.

 

If you drop in the included files without making the change to configure.php, you will never see a printed

label (because the directory logic will fail).

 

 

-- These were all minor nits and my many thanks to those who worked on this contribution.

Share this post


Link to post
Share on other sites
3. in function _sendCurl. Is in 1.07 and later (maybe earlier).

 

4. line 420 of ship_fedex.php in saturday shipping release.

 

5. the code really doesn't delete the order, but it appears to be deleted because after a cancel, the final

orders screen doesn't show the order, because the sql query fails because there is no status 6 in

the orders status file. There are two ways of addressing the problem. Add an orders_status 6 to

to the orders_status file (ostensibly named Cancelled Shipping???), or simply return the code to

an earlier version and use status code 2. My preference is the later, but I do not claim to understand

why the coding change was made.

 

6. the readme.txt states:

 

"Read install.txt for detailed installation information. The file includes all ne

cessary

code updates; you can also just drop the included files into a new oscommerce in

stallation."

 

However this is not true, because the file package does not (nor should it) contain configure.php.

 

For a custom installation, the install.txt states.

##
## add to admin/includes/configure.php:
##

// fedex
	define('DIR_WS_FEDEX_LABELS', DIR_WS_IMAGES . 'fedex/');
// fedex eof

##

 

Hence, the correct instruction in readme.txt is that you can drop the included files into a new oscommerce

installation AND make the change to configure.php.

 

If you drop in the included files without making the change to configure.php, you will never see a printed

label (because the directory logic will fail).

-- These were all minor nits and my many thanks to those who worked on this contribution.

 

Sorry about the EMAIL_TEXT_CONTENT problem, it was something I had done previously to updating the ship_fedex.php to include the Saturday Delivery. My client needed to add text to the email sent when updating to status "delivered".

 

Chris B.

Share this post


Link to post
Share on other sites

Hi guys, I am loving this contrib but cannot seem to ship to Canada .. for this latest shipment I am getting this error:

 

This transaction could not be completed. Please note the error message below.

 

ERROR: FedEx Return Error F84A : Invalid recipient province code for Canada

 

Can anyone help?

 

Thanks!

 

Craig

Share this post


Link to post
Share on other sites

Hello everybody,

 

I'm getting the following message when submitting my package to Fedex Ground Service:

This transaction could not be completed. Please note the error message below.

 

ERROR: FedEx Return Error F820 : Ground Packaging type must be 01 only

What is this 'o1 only' means? What settings I suppose to change?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
Hello everybody,

 

I'm getting the following message when submitting my package to Fedex Ground Service:

 

What is this 'o1 only' means? What settings I suppose to change?

 

Thanks a lot.

 

01 is customer packaging- you must select "Your packaging" as the packaging type in order to ship by Ground.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
01 is customer packaging- you must select "Your packaging" as the packaging type in order to ship by Ground.

This is what I selected, "Your packaging". What else can cause this error message to appear?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
This is what I selected, "Your packaging". What else can cause this error message to appear?

 

Thanks a lot.

 

Run through all the packaging options and see if any of them work.

 

Check the code array for the packaging typies in the ship_fedex.php file and make sure "01" is associated with "Your Packaging".


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Run through all the packaging options and see if any of them work.

 

Check the code array for the packaging typies in the ship_fedex.php file and make sure "01" is associated with "Your Packaging".

I tried every one from the packaging options but neither one of them works. And I checked my code in admin/ship_fedex.php and here is what I have for "your package":

// if "your package" type is selected, add the dimensions flag

if ($HTTP_POST_VARS['packaging_type'] == 01) {

$shipData[57] = $HTTP_POST_VARS['dim_height'];

$shipData[58] = $HTTP_POST_VARS['dim_width'];

$shipData[59] = $HTTP_POST_VARS['dim_length'];

}

I'll appreciate any ideas. Thanks.

Share this post


Link to post
Share on other sites
I tried every one from the packaging options but neither one of them works. And I checked my code in admin/ship_fedex.php and here is what I have for "your package":

 

I'll appreciate any ideas. Thanks.

 

Irin,

 

If you select "Your Packaging", you must input the dimension height, width and length. Have you done that?

 

Chris B.

Share this post


Link to post
Share on other sites
Irin,

 

If you select "Your Packaging", you must input the dimension height, width and length. Have you done that?

 

Chris B.

You're right, I didn't input dimensions. :blush: They're under Optional Fields, so I didn't really paid attention to it. Now, when I specified dimensions and chose Dropoff Type: Drop at Station, I'm getting the following message:

You cannot schedule a pickup on a weekend or holiday! Please go back and change the pickup date.

It says "change the pickup date" although Drop at Station is chosen. There is still something wrong. How can I make Drop at Station as a default for a Dropoff Type?

 

Thanks.

Share this post


Link to post
Share on other sites

djmonkey1,

 

Thanks so much for your help.

 

I finally took the plunge and bravely took a look of the fedex1.php file (I'm not a programmer).

switch (substr($type,0,2)) {

case 90:

if ($order->delivery['company'] != '') {

$skip = TRUE;

}

break;

 

 

I commented

$skip = TRUE;

to ignore the company check and it worked. Now Fedex shipping can quote residential address even with company information filled.

 

Wendy

 

Wait a second....

 

Find the following code in your fedex1.php file:

 

 

 

and change it to this:

 

$data .= '440,"Y"'; // Residential address

 

and then see what happens, although I make no guarantees.

:P :lol: :lol: :lol: :P :P

Share this post


Link to post
Share on other sites
You're right, I didn't input dimensions. :blush: They're under Optional Fields, so I didn't really paid attention to it. Now, when I specified dimensions and chose Dropoff Type: Drop at Station, I'm getting the following message:

 

It says "change the pickup date" although Drop at Station is chosen. There is still something wrong. How can I make Drop at Station as a default for a Dropoff Type?

 

Thanks.

 

The system considers Pickup Date and Ship date to be the same thing...so you have to change the date for when you'll actually drop it off so it puts the correct date on the label.

Share this post


Link to post
Share on other sites

I've been using this contribution for months, and have been very happy with it.

 

However, the last few weeks, it just doesn't seem to want to work right. I have checked the files, and they are identical to what they have been. When I get to the point where I am shipping, and have completed the data that it needs, I click the button. Usually I get the label and can print it. However, recently about 90% of the time, I get "Page cannot be found". If I hit refresh, it goes to the normal print page, but instead of the label, I get the red X indicating a bad image.

 

Has anyone else had this problem? or is is just me? I'm thinking that maybe the FEDEX system might be overwhelmed by holiday stuff, but I just don't get it.

 

Any ideas?

Share this post


Link to post
Share on other sites

I just installed a fresh copy of OSCMax 2.0 that has this contrib. I went through the entire 24 pages of posts, and found the exact error I'm getting, with no solution posted. Problem is:

 

(1) Once the form is complete, and the image of the label is supposed to appear on screen, I get sent back to the Admin login screen.

 

(2) The .png file is getting created with the tracking number, but it is 0 bytes.

 

(3) When I cancel the order, it's marked as such, but I get sent back to the Admin login screen once again.

 

I beleive this is using v1.11 of the contrib, however, I'm not exactly certain.

 

Any ideas?


John Skurka

Share this post


Link to post
Share on other sites
I just installed a fresh copy of OSCMax 2.0 that has this contrib. I went through the entire 24 pages of posts, and found the exact error I'm getting, with no solution posted. Problem is:

 

(1) Once the form is complete, and the image of the label is supposed to appear on screen, I get sent back to the Admin login screen.

 

(2) The .png file is getting created with the tracking number, but it is 0 bytes.

 

(3) When I cancel the order, it's marked as such, but I get sent back to the Admin login screen once again.

 

I beleive this is using v1.11 of the contrib, however, I'm not exactly certain.

 

Any ideas?

 

in admin/includes/fedexdc.php, look for this around line 223:

 

if (empty($match[1])) continue;

 

and it doesn't already, make it look like this:

 

// if (empty($match[1])) continue;


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
in admin/includes/fedexdc.php, look for this around line 223:

 

if (empty($match[1])) continue;

 

and it doesn't already, make it look like this:

 

// if (empty($match[1])) continue;

 

 

Yeah, I tried that. Makes no difference in the results. Still get sent back to the login screen rather than the label being displayed on the screen.


John Skurka

Share this post


Link to post
Share on other sites
Yeah, I tried that. Makes no difference in the results. Still get sent back to the login screen rather than the label being displayed on the screen.

 

Do you know what Admin Access contribution you are using? An admin login screen is not a stock MS2 feature. Maybe it's a problem with that contribution.


Do, or do not. There is no try.

 

Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Share this post


Link to post
Share on other sites
Do you know what Admin Access contribution you are using? An admin login screen is not a stock MS2 feature. Maybe it's a problem with that contribution.

 

He said he was using OSCMax.

 

So, do you know if OSCMax uses the Ultimate SEO contrib? That contrib seems to be giving a lot of problems since the OSCId isn't in the url...

 

Chris B.

Share this post


Link to post
Share on other sites
He said he was using OSCMax.

 

So, do you know if OSCMax uses the Ultimate SEO contrib? That contrib seems to be giving a lot of problems since the OSCId isn't in the url...

 

Chris B.

 

Just looked it up and it does. I would be looking for some support there for that contrib.

 

Chris B.

Share this post


Link to post
Share on other sites
Just looked it up and it does. I would be looking for some support there for that contrib.

 

Chris B.

 

Hmm. So you think that all my problems (including the 0kb .png file) is related to this SEO contrib? I know that I have the SE Safe URL's turned off, and don't believe that I've done anything with the SEO contrib in question, even though it is included in OSCMax.


John Skurka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×