Jump to content
Latest News: (loading..)

Search the Community

Showing results for tags 'session'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Announcements
    • News and Announcements
    • Partner Announcements
    • Ambassadors
  • Commercial Support
    • Developer Feedback
  • osCommerce Online Merchant v2.x
    • General Support
    • Installation and Configuration
    • Upgrading from Earlier Versions (v2.x to v2.x)
    • Add-Ons
    • Tips and Tricks
    • Security
  • Development
    • osCommerce Online Merchant v2.4
    • osCommerce Online Merchant Community Bootstrap Edition
    • osCommerce Online Merchant v3.x
    • Development Proposals
  • General
    • OSCOMMERCE.TV
    • Next Steps / Optimizations / Marketing
    • Live Shop Reviews
    • E-Commerce Laws
    • General Discussions
    • PHP / SQL / Web Design
  • Club osC's Announcements
  • PayPal's Announcements
  • Sage Pay's Announcements
  • Solomono - new level osCommerce templates's Announcements
  • German Community's OSCOM v2.x
  • German Community's Allgemein
  • German Community's OSCOM v3.x

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Location


Interests


Website


Skype

Found 3 results

  1. Please please.. Who can help me? I have OsC2.3.4BS Edge on PHP5.6. Existing clients with >1 address get this error: (see attached image) Warning: session_start(): Failed to decode session object. Session has been destroyed. The effect is that the checkout procedure is redirected to the login page again This line: ...\sessions.php:122 contains this: return session_start(); This code previously used to be at line 95 (I did only add some comment). Please help, I have been researching for days already, without results.. Much obliged if.. Eveline Bernard
  2. playing around with the application_top i find that can be nice to move the session logic from application_top to a dedicated class Here the changed that i made, seems that something works but on the account creation process there are some problems (cannot record a new user)- https://github.com/acidvertigo/oscommerce2/pull/121/files Let me know if this can be useful. I think that also cart actions can be moved from application_top to a dedicated class. The purpose of this is to have a more modular application_top.php file.
  3. I'm running v2.3.3. I downloaded this contribution: http://addons.oscommerce.com/info/8727 I've followed all of the instructions properly. Okay, so here is where it all falls apart. I'm browsing the admin section, and decide to visit the "Sliders" admin area under "Configuration"... When I click on "Sliders", I am logged out, and a new session ID is generated (login.php?osCAdminID=<new session id here>) When I log back in, I land on the "Sliders" admin panel (with same session ID shown on login page). If I then try to upload a slider, I'm logged out, and a new session ID is generated (shown on the login page). So there you have it - when I try to navigate to the slider settings page, I'm logged out, and when I try to upload an image, I'm logged out. I have no other issues with this happening anywhere else on the store or any other session issues. My store is running perfectly fine. I installed this addon, and this issue only arises when accessing or using the particular admin panel for the addon. Any help would be appreciated! Cordially, Robert Whitis
×