Jump to content

Search the Community

Showing results for tags 'checkout'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Announcements
    • News and Announcements
  • osCommerce Online Merchant v2.x
    • General Support
    • osCommerce Online Merchant Community Bootstrap Edition
    • Add-Ons
  • Development
  • General
    • General Discussions
    • Live Shop Reviews
    • Security
    • Developer Feedback
  • PayPal's Announcements
  • Sage Pay's Announcements
  • Solomono - new level osCommerce templates's Announcements
  • German Community's OSCOM v2.x
  • German Community's Allgemein

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Location


Interests


Website

Found 22 results

  1. SolidAmerica

    Error With Checkout Paypal

    Hello, I appreciate if someone can assist me on how to fix this payment issue. have the store with an installation version of CE Phoenix v1.0.7.7 When i test the shopping payment, i get this error. : Notice: Undefined index: in /home/www/mysite.com/stores/includes/system/versioned/1.0.7.3/payment.php on line 65 Notice: Undefined variable: in /home/www/mysite.com/stores/checkout_confirmation.php on line 59 Notice: Trying to get property 'enabled' of non-object in /home/www/mysite.com/stores/checkout_confirmation.php on line 59 Warning: Cannot modify header information - headers already sent by (output started at /home/www/mysite.com/stores/includes/system/versioned/1.0.7.3/payment.php:65) in /home/www/mysite.com/stores/includes/functions/general.php on line 36 " https://bookoflikes.com/stores/
  2. Hi - hoping someone can help with this one. what looks like overnight, the paypal payment option on our shops have stopped working (we have two shops, each on their own domain) the customer could select paypal on the checkout_payment page, but when clicking continue it sends them back to the shopping cart. After a little investigation, it appears the issue is happening during the verifying of the SSL certificate that the issue is happening, as when we change this check to false, the checkout process completes without an issue. When testing the SSL connection we get the following message: cURL Version: 7.62.0 cURL SSL Version: OpenSSL/1.0.2k Default Setting: Failed TLS v1.2: Failed A connection to PayPal could not be made using TLS v1.2. Please consult with your hosting provider to upgrade the cURL version that is installed with your PHP web server to support TLS v1.2 connections. This must be performed by June 30, 2017 otherwise connections will continue to fail. We have spoken to our hosting company, requesting confirmation what versions of TLS, cURL and PHP but as yet have found nothing that would explain the sudden change. Has anyone experienced a similar issue? Or have a little more knowledge on the paypal module that could suggest something that could cause this issue? PHP version 7.1 TLS capable of TLSv1.2 or higher connections Osc Version v2.3.4 PayPal App v5.018 Thanks in advance
  3. As stated in the title. When a customer goes through the checkout process it doesn't add the shipping cost to the total and then the order total is "order - shipping". Example: Customer A adds a 10SEK item to his/her basket. Then goes through checkout (after signing in and all of that), on checkout.php it states "This is the only shipping option available" and the cost of that shipping option. But the shipping cost is set to 0 in the "Products" box above "confirm purchase". The shipping cost continues to be 0 on all following steps. Any ideas? Been googling and looking through code for a couple of hours now.
  4. gjpinzino

    PayPal Checkout Process not completing

    I am running the PayPal app v.5.010 on osC 2.3.4 in Sandbox mode using PayPal Payments Standard. The payment process proceeds smoothly, and when PayPal returns to osC it shows checkout success. The problem is no confirming emails are sent. I have planted “die” commands at various points in the checkout_process.php code and it appears that that the processing leaves checkout_process when it instantiates the payment class, never to return (about line 47). I have set the PayPal Auto Return parameter to both checkout_process and checkout_success and get the same result – no confirmations. It looks lie there are over 100 lines of code that never see the light of day. How do I fix this?
  5. Bei Aktivierung des SSL Zertifikats (Let´s encrypt it) werden die SSL Seiten korrekt aufgerufen. Sobald es um den Kundenbereich geht (Login, Checkout, etc.) kann ich mich nicht einloggen. Die configure.php scheint ok: define('HTTP_SERVER', 'http://www.domain.de'); define('HTTPS_SERVER', 'https://domain.de'); define('ENABLE_SSL', false); define('HTTP_COOKIE_DOMAIN', 'www.domain.de'); define('HTTPS_COOKIE_DOMAIN', 'domain.de'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/');
  6. Hi OSCOMMERCE/PHP experts! I am searching for this error for two days now and I still cannot locate this strange behaviour. I installed the following plugin "Consolidated Login Page with Guest Checkout" and it works like a charm (at least that is what I thought). I found an error now that I just cannot track down. If someone checks out using a German Umlaut (äöüß) in one of the fields of the form he is redirected from the checkout_shipping.php to the login.php due to the customer_id is no longer registered or valid. This is the part of the code in the checkout_shipping.php that redirects him // if the customer is not logged on, redirect them to the login page if (!tep_session_is_registered('customer_id')) { $navigation->set_snapshot(); tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL')); } Without any Umlaut it is no problem at all, he is forwarded to the checkout. Apparently the whole session is destroyed, because the cart is empty afterwards, too. I just cannot find any difference between the handling of the (apparently) same form in the login.php compared to a "regular" registered user where using an Umlaut is no problem at all. It seems that some function is called that has problems with these special characters, but is only used when the guest flag is set and the guest checkout is used therefore destroying the whole session. At least that is the only thing I could imagine.... Has anyone any hint where I could search or point me in the right direction what could cause this error / or anyone installed this plugin, too and can try, if the same error happens - I'm searcing for days now, it's driving me crazy... :) Thanky you!!! Robert PHP 5.3.29 / OsCommerce 2.3.3.4
  7. tgely

    Upsell

    Hi all, Incrase product selling in the checkout approx. by 10% When the checkout shipping page upload a fancybox popup give a product upsell. Give a product id in the module settings and product will displayed in upsell. Download package: http://addons.oscommerce.com/info/8723 Upsell language constant could be edited in standard oscommerce language editor. http://your-domain/admin/define_language.php?lngdir=english&filename=english/popup_upsell.php Note: this Upsell module use iframe or Modal type If you would like prefer modal popup you have to do button and page styles. KNOWN PROBLEM or CONFLICTS: ****************************************************************************** The upsell header tags scripts need loading after fancybox scripts! The scripts sort orders very important. If newer jQuery function library used change to the requested codes in popup_upsell.php header by iFrame type. The popup use default or browser language. Not cleared the issue. http://forums.oscommerce.com/topic/391674-localization/ Regards, Gergely
  8. igor1991-06@mail.ru

    Checkout

    I need to in the basket there was nothing superfluous: no payment. no registration Only email, phone number and name and that on the e-mail I went shopping list there are add-ons?
  9. Hello, I tried using the Paypal Express Checkout 1.0 add on you can see here: http://addons.oscommerce.com/info/7333 On step 2 of the instructions I don't understand what I need to do. See below text in red: 2) remove "checkout with paypal" button from shopping cart page : comment below code found in paypal_express.php in includes/modules/payment: function checkout_initialization_method() { global $language; if (file_exists(DIR_FS_CATALOG . 'ext/modules/payment/paypal/images/btn_express_' . basename($language) . '.gif')) { $image = 'ext/modules/payment/paypal/images/btn_express_' . basename($language) . '.gif'; } else { $image = 'ext/modules/payment/paypal/images/btn_express.gif'; } $string = '<a href="' . tep_href_link('ext/modules/payment/paypal/express.php', '', 'SSL') . '"><img src="' . $image . '" border="0" alt="" title="' . tep_output_string_protected(MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_BUTTON) . '" /></a>'; return $string; } Where exactly do I go to remove "checkout with paypal" button from shopping cart page? And what do they mean by "comment" below code? I am a bit of a novice at this so if someone could give me simple step by step instructions on what to do, I'd really appreciate it. Thanks
  10. I posted this in another part of the forum but thought i would be better here. Here is an updated addon to make the product descriptions show up instead of your shop name on the paypal checkout page using Paypal Standard...This is specifically for PayPal Standard...not PayPal Express..... http://addons.oscommerce.com/info/8981 Thanks...Steven
  11. jQuery/Ajax Dynamic Checkout for osCommerce 2.3.3 - Support thread - Download Add-On here: http://addons.oscommerce.com/info/8898
  12. We have found a bug that is causing us serious problems. It happens at random times but when you add an item to the cart then click on the checkout button it takes you to the checkout page but sometimes for whatever reason the page will redirect to the sharperjacks.com/login.php page forcing the customer to create an account. Sometimes even worse when the customer clicks on the checkout button it will redirect them to the sharperjacks.com/checkout_shipping.php page. We have looked at the code but cannot understand why this bug occurs and why it happens so randomly. You can sometimes make this redirect problem occur by clicking the refresh page button on your browser over and over until it just redirects you to either page. We are using the browser FireFox. This is a problem we must get solved. Any help would be very much appreciated.
  13. Hi all! I'm looking for a really simple upsell module/contribution - all I need it to do is recommend a product (as defined by me in some way) to the customer before they finish checking out, and give them the ability to add it to the order/total. So for example, if they had got to the payment options page, a pop up or info box would show saying "hey would you like to buy this other product?" I hope that makes sense... I don't really need any other types of cross-selling stuff you see, just this simple upsell bit at checkout. If anyone has any ideas or can suggest a simple contribution that would be awesome! Thanks! Kitty :)
  14. H1,I have recently installed the addon for two kinds of Chinese. I have a language box with the flags of the countries inside, so the visitor can switch between Chinese and Engish as they go from pages to pages. Everything is fine but when a visitor tries to add an item to the cart or when he/she tries to check out in the Chinese interface the screen would freeze and just leave a white screen there. The checkout in my English interface if completely fine, it is only in Chinese that I am encountering this problem. Please help me as my shop is live and I have been trying to fix this for the last few days with no improvement. I have tried to compare the files one by one and so far they all seems to be identical. Thank you.
  15. I'm having a problem, and not sure if it's the shopping cart, or another file. I hope someone can help. I can add 10 items into my cart, and at checkout, both usps, and ups modules, reflect the correct weight, but only 1 package. I really appreciate any time and effort. version 2.3
  16. milauskas

    Error with virtual merchant transaction

    Hi, I have an osc site built for a client and now customers can't complete any orders. It's been up and running for 6+ years (it's version 2.2). There was some hacking (a bunch of spam emails were being sent from the site) so I don't know if that's related to this, but when I try to go through checkout I enter my credit card (real or fake) and I get this error from virtual merchant. An Error Occurred While Processing Your Request Error Code : 4000 Error Name : VID Not Supplied Error Message : The VirtualMerchant ID was not supplied in the authorization request. This is on a virtual merchant page, not on any page from the client's site/domain. I didn't install the module to be able to use elevon as a payment gateway. That was done by a third party. However, it's worked for years and now I'm getting this error. Any solutions? Does anyone know what this error refers to? Thanks!
  17. Hello everybody :) This is my first post and I'm very glad to be here :). On beggining I apologise for my english. I'm not good in foreing languages so forgive me my misteakes :). I write from Poland :) I have problem with points - rewards module. I can't enter amount of points I wish to redeem in second step of checkout (checkout_payment.php). There is any box to write number of points. I only have a checkbox to use all available points for an order. In FAQ of points - rewards module I've found: In checkout_payment.php there is only: <!-- Points/Rewards Module V2.1rc2a Redeemption box bof --> <?php if ((USE_POINTS_SYSTEM == 'true') && (USE_REDEEM_SYSTEM == 'true')) { //echo points_selection(); $cart_show_total= $cart->show_total(); echo points_selection($cart_show_total); if (tep_not_null(USE_REFERRAL_SYSTEM) && (tep_count_customer_orders() == 0)) { echo referral_input(); } } ?> <!-- Points/Rewards Module V2.1rc2a Redeemption box eof --> Could you tell me what I did wrong? I think I did everything good in instalation. OsCommerce: osCommerce 2.2-MS2 Points/Rewards Module: 2.1rc2a
  18. psgill

    First Data Gateway

    Hello Everyone, I'm currently using osCommerece 2.2. I have Paypal and Authorize.net. Recently, we got a new merchant account with firstdata.com and I was wondering if there's a plugin available to use first data's payment gateway. I have already searched the plugin database but didn't find anything related to first data. It is very likely that a plugin may not exist and in such case I am willing to pay someone to do the coding so that we can integrate first data into the oscommerce website. Thanks.
  19. I'm currently using the PayPal IPN payment module, although I'm not entirely sure if this issue is related to it or not. The problem seems to be centred around the checkout_confirmation page. If a customer reaches that page and then decides to go back and change their shipping address, billing address, or shipping method, the order that was written into the database does not reflect the changes they make, nor is a new order generated. What the customer sees on the screen changes, and the correct data is sent to Paypal when they pay (new order total, shipping method & rate, etc.), however the order I see in admin (and thus what they see in their order history and order confirmation email) shows the order as it was before they made any changes. In addition, even though payment is successfully completed, the order status displays as "Pending" "PayPal IPN Verified [payment status: Completed]" instead of "Completed" "PayPal IPN Verified [payment status: Completed]". Interestingly, when a customer makes any change to items in the shopping cart, a new order *is* generated in the database when they hit the checkout_confirmation page again. What can I do to allow these other changes to be "recorded" in oscommerce? (thanks in advance for any advice!) ~ Elaine
  20. iofast

    Google Checkout + MVS

    Hello, Has anyone been able to get Google Checkout working with MVS (Multi-Vendor Shipping) reliably? The 3 second timeout required by Google to provide shipping rates seems to make this quite challenging to work reliably when quoting from many vendors as it can take over 3 seconds to get that number of responses from UPS + FedEx + USPS. We setup some code to cache shipping rates from the rate providers so it will generally always work after the page is F5'd but Google defaults to the standard provided rates in almost all cases on the initial page load. Is anyone aware of a method to allow GoogleCheckout to work properly with MVS? Thanks
  21. infopack

    dc_autoinstaller issue

    Hello All, We're building a new store and I got a templated version of oscommerce from one of the template sites. It installed and runs well : http://www.info-pack.com I then thought about trying coupons on the site so I looked at the available modules and picked the latest dc_autoinstaller The installation says it ran well, then I thought I would check how it works, but when I go to the checkout it gives me this error: On the confirmation page (signed up, and press continue to confirm the shipping details) http://info-pack.com/catalog/checkout_confirmation.php Fatal error: Call to undefined method order_total::clear_posts() in /home/infopack/public_html/catalog/checkout_payment.php on line 88 Anyone got any ideas on how to fix this? Thanks
  22. Hi Everyone, I've installed the noChex checkout module in Oscommerce 2.2 RC2 version.Few weeks ago, It's working fine but now I'm facing few difficulties to use the checkout noChex module. User have to register/login in to the noChex after confirmed the checkout process.No one can purchase products without login/register in to the noChex as well as it asking 4 digit security code. I want to disable the Registration/Login For Customers Through Checkout in nochex.the pay by nochex icons are not displaying. Please refer the screenshot (noChex.png), it should be displayed like the sample one(sample.png). Any assistance would be appreciated. Thanks in advance.
×