Jump to content

Search the Community

Showing results for tags 'checkout'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Announcements
    • News and Announcements
  • osCommerce Online Merchant v2.x
    • General Support
    • osCommerce Online Merchant Community Bootstrap Edition
    • Add-Ons
  • Development
  • General
    • General Discussions
    • Live Shop Reviews
    • Security
    • Developer Feedback
  • PayPal's Announcements
  • Sage Pay's Announcements
  • Solomono - new level osCommerce templates's Announcements
  • German Community's OSCOM v2.x
  • German Community's Allgemein

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Location


Interests


Website

Found 24 results

  1. Hello, I installed a online payment module (MobilPay) and after process, the page "checkout_process.php?&orderId=" not redirect to checkout_success.php. Is only for this module. When i reload the page, the order is transmitted, but do not redirect to Thank You page (checkout_success.php). If i chose the option Cash On delivery, the process work successfully. How i can resolve this? Thank you!
  2. Hello, @Dan Cole, @kymation, @Tsimi, @altoid, @piernas, @burt Would you (and everybody else also very welcome) be interested in forming a team to develop the modularized versions of the checkout pages? It would allow to add for example discount code, matc, points and rewards or just a simple module with additional info text without any core change, hook or ht injections. Exposé: - - Leave the checks and security part between includes application_top.php and includes template_top.php in the main page files. - - Leave the forms in main page file - - Move only the content part between includes template_top.php and includes template_bottom.php into content modules - - Suggested modules: o Checkout shipping and payment: - page header - address (2 modules) - shipping/payment methods - comments - continue button - progress line o Checkout confirmation: - page header - products+ot - delivery address - payment address - shipping method - payment method - payment information - comments - confirm order button - progress line o Checkout shipping/payment address (optional) - page header - address (2 modules) - new shipping/billing address - continue button - progress line It could be projected as an add-on like the modular shopping cart or, if @burt is interested, pull request for core. I would create a github fork with maybe the easiest module “comments” as a starting point. Best regards Rainer
  3. Hi all, When I try to do check out in my shopping cart, whenever I get to the checkout_shipping.php page and click the [continue] button, the cart instantly logs out. I noticed that while on the shopping_cart.php, if I hover over the [continue] button, it gets darker and points to the checkout_shipping.php page. However, on the checkout_shipping.php page the [continue] button (while it gets darker on hovering) points to nowhere (ie nothing shows on the bottom of the page unlike the page before) and upon clicking it logs out. Can someone help debug this? I have installed Bootstrap Gold Edge (2.3.4.1 or master) under PHP 7.1 Thank you, Thadson
  4. gjpinzino

    PayPal Checkout Process not completing

    I am running the PayPal app v.5.010 on osC 2.3.4 in Sandbox mode using PayPal Payments Standard. The payment process proceeds smoothly, and when PayPal returns to osC it shows checkout success. The problem is no confirming emails are sent. I have planted “die” commands at various points in the checkout_process.php code and it appears that that the processing leaves checkout_process when it instantiates the payment class, never to return (about line 47). I have set the PayPal Auto Return parameter to both checkout_process and checkout_success and get the same result – no confirmations. It looks lie there are over 100 lines of code that never see the light of day. How do I fix this?
  5. Bei Aktivierung des SSL Zertifikats (Let´s encrypt it) werden die SSL Seiten korrekt aufgerufen. Sobald es um den Kundenbereich geht (Login, Checkout, etc.) kann ich mich nicht einloggen. Die configure.php scheint ok: define('HTTP_SERVER', 'http://www.domain.de'); define('HTTPS_SERVER', 'https://domain.de'); define('ENABLE_SSL', false); define('HTTP_COOKIE_DOMAIN', 'www.domain.de'); define('HTTPS_COOKIE_DOMAIN', 'domain.de'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/');
  6. Hi OSCOMMERCE/PHP experts! I am searching for this error for two days now and I still cannot locate this strange behaviour. I installed the following plugin "Consolidated Login Page with Guest Checkout" and it works like a charm (at least that is what I thought). I found an error now that I just cannot track down. If someone checks out using a German Umlaut (äöüß) in one of the fields of the form he is redirected from the checkout_shipping.php to the login.php due to the customer_id is no longer registered or valid. This is the part of the code in the checkout_shipping.php that redirects him // if the customer is not logged on, redirect them to the login page if (!tep_session_is_registered('customer_id')) { $navigation->set_snapshot(); tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL')); } Without any Umlaut it is no problem at all, he is forwarded to the checkout. Apparently the whole session is destroyed, because the cart is empty afterwards, too. I just cannot find any difference between the handling of the (apparently) same form in the login.php compared to a "regular" registered user where using an Umlaut is no problem at all. It seems that some function is called that has problems with these special characters, but is only used when the guest flag is set and the guest checkout is used therefore destroying the whole session. At least that is the only thing I could imagine.... Has anyone any hint where I could search or point me in the right direction what could cause this error / or anyone installed this plugin, too and can try, if the same error happens - I'm searcing for days now, it's driving me crazy... :) Thanky you!!! Robert PHP 5.3.29 / OsCommerce 2.3.3.4
  7. I want to prevent double clicks on the confirm order button so that impatient customers don't click twice and get their credit cards charged twice. I am wonderingif I have the right logic that will change the 'Confirm Order' button to a stateful button http://getbootstrap.com/javascript/#buttons-stateful Currently the button code is <div class="buttonSet"> <span class="buttonAction"> <?php if (is_array($payment_modules->modules)) { echo $payment_modules->process_button(); } ?> <?php echo tep_draw_button(IMAGE_BUTTON_CONFIRM_ORDER, 'glyphicon glyphicon-ok', null, 'primary'); ?> </span> </div> which gives html <div class="buttonSet"> <span class="buttonAction"> <button type="submit" class="btn btn-default"> <span class="glyphicon glyphicon-ok"></span> Confirm Order</button> </span> </div> adding an id to the div and parameters to the button <div id="confirmation" class="buttonSet"> <span class="buttonAction"> <?php if (is_array($payment_modules->modules)) { echo $payment_modules->process_button(); } ?> <?php //echo tep_draw_button(IMAGE_BUTTON_CONFIRM_ORDER, 'glyphicon glyphicon-ok', null, 'primary'); echo tep_draw_button(IMAGE_BUTTON_CONFIRM_ORDER, 'glyphicon glyphicon-ok', null, 'primary', array('params' => 'id="confirmation" data-loading-text="Loading..." autocomplete="off"')); ?> </span> ouputs <div id="confirmation" class="buttonSet"> <span class="buttonAction"> <button type="submit" id="confirmation" data-loading-text="Loading..." autocomplete="off" class="btn btn-default"> <span class="glyphicon glyphicon-ok"></span> Confirm Order</button> </span> </div> Next need to add the required javascript above the div with id="confirmation" <script type="text/javascript"> $(function() { $("#confirmation .btn").click(function(){ $(this).button('loading').delay(100000).queue(function() { }); }); }); </script> Not too sure if that is the correct Javascript - it certainly works and the button does as intended but may need to be changed?
  8. igor1991-06@mail.ru

    Checkout

    I need to in the basket there was nothing superfluous: no payment. no registration Only email, phone number and name and that on the e-mail I went shopping list there are add-ons?
  9. Hello, I tried using the Paypal Express Checkout 1.0 add on you can see here: http://addons.oscommerce.com/info/7333 On step 2 of the instructions I don't understand what I need to do. See below text in red: 2) remove "checkout with paypal" button from shopping cart page : comment below code found in paypal_express.php in includes/modules/payment: function checkout_initialization_method() { global $language; if (file_exists(DIR_FS_CATALOG . 'ext/modules/payment/paypal/images/btn_express_' . basename($language) . '.gif')) { $image = 'ext/modules/payment/paypal/images/btn_express_' . basename($language) . '.gif'; } else { $image = 'ext/modules/payment/paypal/images/btn_express.gif'; } $string = '<a href="' . tep_href_link('ext/modules/payment/paypal/express.php', '', 'SSL') . '"><img src="' . $image . '" border="0" alt="" title="' . tep_output_string_protected(MODULE_PAYMENT_PAYPAL_EXPRESS_TEXT_BUTTON) . '" /></a>'; return $string; } Where exactly do I go to remove "checkout with paypal" button from shopping cart page? And what do they mean by "comment" below code? I am a bit of a novice at this so if someone could give me simple step by step instructions on what to do, I'd really appreciate it. Thanks
  10. I posted this in another part of the forum but thought i would be better here. Here is an updated addon to make the product descriptions show up instead of your shop name on the paypal checkout page using Paypal Standard...This is specifically for PayPal Standard...not PayPal Express..... http://addons.oscommerce.com/info/8981 Thanks...Steven
  11. As stated in the title. When a customer goes through the checkout process it doesn't add the shipping cost to the total and then the order total is "order - shipping". Example: Customer A adds a 10SEK item to his/her basket. Then goes through checkout (after signing in and all of that), on checkout.php it states "This is the only shipping option available" and the cost of that shipping option. But the shipping cost is set to 0 in the "Products" box above "confirm purchase". The shipping cost continues to be 0 on all following steps. Any ideas? Been googling and looking through code for a couple of hours now.
  12. jQuery/Ajax Dynamic Checkout for osCommerce 2.3.3 - Support thread - Download Add-On here: http://addons.oscommerce.com/info/8898
  13. We have found a bug that is causing us serious problems. It happens at random times but when you add an item to the cart then click on the checkout button it takes you to the checkout page but sometimes for whatever reason the page will redirect to the sharperjacks.com/login.php page forcing the customer to create an account. Sometimes even worse when the customer clicks on the checkout button it will redirect them to the sharperjacks.com/checkout_shipping.php page. We have looked at the code but cannot understand why this bug occurs and why it happens so randomly. You can sometimes make this redirect problem occur by clicking the refresh page button on your browser over and over until it just redirects you to either page. We are using the browser FireFox. This is a problem we must get solved. Any help would be very much appreciated.
  14. Hi all! I'm looking for a really simple upsell module/contribution - all I need it to do is recommend a product (as defined by me in some way) to the customer before they finish checking out, and give them the ability to add it to the order/total. So for example, if they had got to the payment options page, a pop up or info box would show saying "hey would you like to buy this other product?" I hope that makes sense... I don't really need any other types of cross-selling stuff you see, just this simple upsell bit at checkout. If anyone has any ideas or can suggest a simple contribution that would be awesome! Thanks! Kitty :)
  15. H1,I have recently installed the addon for two kinds of Chinese. I have a language box with the flags of the countries inside, so the visitor can switch between Chinese and Engish as they go from pages to pages. Everything is fine but when a visitor tries to add an item to the cart or when he/she tries to check out in the Chinese interface the screen would freeze and just leave a white screen there. The checkout in my English interface if completely fine, it is only in Chinese that I am encountering this problem. Please help me as my shop is live and I have been trying to fix this for the last few days with no improvement. I have tried to compare the files one by one and so far they all seems to be identical. Thank you.
  16. tgely

    Upsell

    Hi all, Incrase product selling in the checkout approx. by 10% When the checkout shipping page upload a fancybox popup give a product upsell. Give a product id in the module settings and product will displayed in upsell. Download package: http://addons.oscommerce.com/info/8723 Upsell language constant could be edited in standard oscommerce language editor. http://your-domain/admin/define_language.php?lngdir=english&filename=english/popup_upsell.php Note: this Upsell module use iframe or Modal type If you would like prefer modal popup you have to do button and page styles. KNOWN PROBLEM or CONFLICTS: ****************************************************************************** The upsell header tags scripts need loading after fancybox scripts! The scripts sort orders very important. If newer jQuery function library used change to the requested codes in popup_upsell.php header by iFrame type. The popup use default or browser language. Not cleared the issue. http://forums.oscommerce.com/topic/391674-localization/ Regards, Gergely
  17. milauskas

    Error with virtual merchant transaction

    Hi, I have an osc site built for a client and now customers can't complete any orders. It's been up and running for 6+ years (it's version 2.2). There was some hacking (a bunch of spam emails were being sent from the site) so I don't know if that's related to this, but when I try to go through checkout I enter my credit card (real or fake) and I get this error from virtual merchant. An Error Occurred While Processing Your Request Error Code : 4000 Error Name : VID Not Supplied Error Message : The VirtualMerchant ID was not supplied in the authorization request. This is on a virtual merchant page, not on any page from the client's site/domain. I didn't install the module to be able to use elevon as a payment gateway. That was done by a third party. However, it's worked for years and now I'm getting this error. Any solutions? Does anyone know what this error refers to? Thanks!
  18. I'm having a problem, and not sure if it's the shopping cart, or another file. I hope someone can help. I can add 10 items into my cart, and at checkout, both usps, and ups modules, reflect the correct weight, but only 1 package. I really appreciate any time and effort. version 2.3
  19. Hello everybody :) This is my first post and I'm very glad to be here :). On beggining I apologise for my english. I'm not good in foreing languages so forgive me my misteakes :). I write from Poland :) I have problem with points - rewards module. I can't enter amount of points I wish to redeem in second step of checkout (checkout_payment.php). There is any box to write number of points. I only have a checkbox to use all available points for an order. In FAQ of points - rewards module I've found: In checkout_payment.php there is only: <!-- Points/Rewards Module V2.1rc2a Redeemption box bof --> <?php if ((USE_POINTS_SYSTEM == 'true') && (USE_REDEEM_SYSTEM == 'true')) { //echo points_selection(); $cart_show_total= $cart->show_total(); echo points_selection($cart_show_total); if (tep_not_null(USE_REFERRAL_SYSTEM) && (tep_count_customer_orders() == 0)) { echo referral_input(); } } ?> <!-- Points/Rewards Module V2.1rc2a Redeemption box eof --> Could you tell me what I did wrong? I think I did everything good in instalation. OsCommerce: osCommerce 2.2-MS2 Points/Rewards Module: 2.1rc2a
  20. psgill

    First Data Gateway

    Hello Everyone, I'm currently using osCommerece 2.2. I have Paypal and Authorize.net. Recently, we got a new merchant account with firstdata.com and I was wondering if there's a plugin available to use first data's payment gateway. I have already searched the plugin database but didn't find anything related to first data. It is very likely that a plugin may not exist and in such case I am willing to pay someone to do the coding so that we can integrate first data into the oscommerce website. Thanks.
  21. I'm currently using the PayPal IPN payment module, although I'm not entirely sure if this issue is related to it or not. The problem seems to be centred around the checkout_confirmation page. If a customer reaches that page and then decides to go back and change their shipping address, billing address, or shipping method, the order that was written into the database does not reflect the changes they make, nor is a new order generated. What the customer sees on the screen changes, and the correct data is sent to Paypal when they pay (new order total, shipping method & rate, etc.), however the order I see in admin (and thus what they see in their order history and order confirmation email) shows the order as it was before they made any changes. In addition, even though payment is successfully completed, the order status displays as "Pending" "PayPal IPN Verified [payment status: Completed]" instead of "Completed" "PayPal IPN Verified [payment status: Completed]". Interestingly, when a customer makes any change to items in the shopping cart, a new order *is* generated in the database when they hit the checkout_confirmation page again. What can I do to allow these other changes to be "recorded" in oscommerce? (thanks in advance for any advice!) ~ Elaine
  22. iofast

    Google Checkout + MVS

    Hello, Has anyone been able to get Google Checkout working with MVS (Multi-Vendor Shipping) reliably? The 3 second timeout required by Google to provide shipping rates seems to make this quite challenging to work reliably when quoting from many vendors as it can take over 3 seconds to get that number of responses from UPS + FedEx + USPS. We setup some code to cache shipping rates from the rate providers so it will generally always work after the page is F5'd but Google defaults to the standard provided rates in almost all cases on the initial page load. Is anyone aware of a method to allow GoogleCheckout to work properly with MVS? Thanks
  23. infopack

    dc_autoinstaller issue

    Hello All, We're building a new store and I got a templated version of oscommerce from one of the template sites. It installed and runs well : http://www.info-pack.com I then thought about trying coupons on the site so I looked at the available modules and picked the latest dc_autoinstaller The installation says it ran well, then I thought I would check how it works, but when I go to the checkout it gives me this error: On the confirmation page (signed up, and press continue to confirm the shipping details) http://info-pack.com/catalog/checkout_confirmation.php Fatal error: Call to undefined method order_total::clear_posts() in /home/infopack/public_html/catalog/checkout_payment.php on line 88 Anyone got any ideas on how to fix this? Thanks
  24. Hi Everyone, I've installed the noChex checkout module in Oscommerce 2.2 RC2 version.Few weeks ago, It's working fine but now I'm facing few difficulties to use the checkout noChex module. User have to register/login in to the noChex after confirmed the checkout process.No one can purchase products without login/register in to the noChex as well as it asking 4 digit security code. I want to disable the Registration/Login For Customers Through Checkout in nochex.the pay by nochex icons are not displaying. Please refer the screenshot (noChex.png), it should be displayed like the sample one(sample.png). Any assistance would be appreciated. Thanks in advance.
×