Jump to content

ttoomey

Members
  • Content count

    81
  • Joined

  • Last visited

1 Follower

About ttoomey

  • Birthday 07/07/1984

Profile Information

  1. ttoomey

    Header Tags SEO

    Disabling STS did not fix the problem. I understand the installation may be at fault but I went back through and re-did the installation on the index page and several other pages that I thought may cause the problem. Any idea where I can start? The administration install appears to be working 100% correctly, where else would be a good place to start? I believe the category_id at some point is not passed because it comes in as 0 which woudl explain the empty H1 and images being broken. Any starting points where I can go in and check first before pouring over this line by line?
  2. ttoomey

    Header Tags SEO

    http://plaksmacker.flixelstudios.com/sts.png That's what you mean right? I've added that to the index, default, and product-info pages.
  3. ttoomey

    Header Tags SEO

    I've completed the installation on a practically fresh RC2 oscommerce installation that has STS installed. For some reason my H1 title tags and images blank on index.php pages, and nested category pages. All is well on my product info pages, and my meta tags show up just fine, but for some reason my images and h1 tags for title tags of the page do not work. I've checked my index.php file and I have completed the changes as instructedhttp://plaksmacker.flixelstudios.com by the documentation EXACTLY. Has anyone else had this? It appears as though the variables are coming in blank and that the categories id is set to 0 (or nothing). Here's the store so you can see what I'm talking about: http://plaksmacker.flixelstudios.com I have filled in all blank tags as instructed and it's quite weird that they would show up in the <header> area of the site but not in the body section. Has anyone had this problem? Is there a fix for this?
  4. ttoomey

    [Contribution] SEO-G

    I'm having some trouble getting this to work with my categories. My regular product pages work great as does everything else. But for some reason only my one main category is working. The others are redirecting... the category t_shirts is the parent of mens-t-shirts the url /t_shirts_men-s-t-shirts.html works but the other subcategories do not ex. the subcategory women-s-t-shirts aka /t_shirts_women-s-t-shirts.html is not working There is an entry for it on this page SEO-G Zones » Categories and I it is marked green for included as are all the other categories, but there is no entry for it on the reports page, and in the mysql database, for the seo_urls table there is no entry for it. This is true for about 5 other subcategory pages. Is there a reason for this? How can I fix this?
  5. Tracy: thanks for your help. I have tracked down the lack of the "invalid coupon code" messages to a line of code on checkout_confirmation (as I guessed) The line is right before your shipping and order_total modules are loaded and this is the line that is correct if( tep_not_null( $HTTP_POST_VARS['coupon'] ) && is_object( $order->coupon ) ) { //if they have entered something in the coupon field This is what I had for that line of code: if( tep_not_null( $coupon ) && is_object( $order->coupon ) ) { //if they have entered something in the coupon field Don't know how it happened or why, but it works now and it also is compatible with the paypal direct payments module. Thanks for the source Tracy. You're a lifesaver.
  6. Tracy: Sent you my email I have re-installed the contribution and turned on the debugging to see if there was any information for when I entered an invalid code. As it turns out no debugging information shows up in the source code, but if I enter a correct coupon code, the debug code shows up. I am still not being re-redirected to the checkout_payment.php as I should when there is an invalid coupon code entered. I can enter just about anything and I am still redirected to the checkout_confirmation.php page. Why aren't errors showing up? Why am I not redirected when an indirect coupon code is entered?
  7. I am having trouble with getting error messages to return on any of the initial discount_coupon class errors as well as the ones that are supposed to be URL encoded. I do not receive errors when customers enter an invalid code, or when they enter a code that has a minimum amount when they haven't reached the minimum amount. I have installed the STS template system as well as the Paypal direct payments module. The module does work if you enter a valid code and it deducts items automatically, but any incorrect codes simply return you to the checkout_confirmation.php with no errors or code discount... As far as I can tell everything initializes properly, but no errors are echoing out. I've even added this line to my checkout_payment.php like the "common problems" of the readme tell you to: <?php if (isset($HTTP_GET_VARS['error_message']) && tep_not_null($HTTP_GET_VARS['error_message'])) { ?> <table border="0" width="100%" cellspacing="0" cellpadding="2"> <tr class="headerError"> <td class="headerError"><?php echo htmlspecialchars(urldecode($HTTP_GET_VARS['error_message'])); ?></td> </tr> </table> <?php } ?> And I still have no error messages returning. I can also not see any output from turning on the debugging. Are there any quick fixes or patches I should be applying to my site? Here's the checkout_confirmation.php relevant code: require('includes/application_top.php'); // if the customer is not logged on, redirect them to the login page if (!tep_session_is_registered('customer_id')) { $navigation->set_snapshot(array('mode' => 'SSL', 'page' => FILENAME_CHECKOUT_PAYMENT)); tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL')); } // if there is nothing in the customers cart, redirect them to the shopping cart page if ($cart->count_contents() < 1) { tep_redirect(tep_href_link(FILENAME_SHOPPING_CART)); } // avoid hack attempts during the checkout procedure by checking the internal cartID if (isset($cart->cartID) && tep_session_is_registered('cartID')) { if ($cart->cartID != $cartID) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL')); } } // if no shipping method has been selected, redirect the customer to the shipping method selection page if (!tep_session_is_registered('shipping')) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL')); } if (!tep_session_is_registered('payment')) tep_session_register('payment'); if (isset($HTTP_POST_VARS['payment'])) $payment = $HTTP_POST_VARS['payment']; if (!tep_session_is_registered('comments')) tep_session_register('comments'); if (tep_not_null($HTTP_POST_VARS['comments'])) { $comments = tep_db_prepare_input($HTTP_POST_VARS['comments']); } //---PayPal WPP Modification START ---// if (tep_paypal_wpp_enabled()) { $ec_enabled = true; } else { $ec_enabled = false; } if ($ec_enabled) { $show_payment_page = false; $config_query = tep_db_query("SELECT configuration_value FROM " . TABLE_CONFIGURATION . " WHERE configuration_key = 'MODULE_PAYMENT_PAYPAL_DP_DISPLAY_PAYMENT_PAGE' LIMIT 1"); if (tep_db_num_rows($config_query) > 0) { $config_result = tep_db_fetch_array($config_query); if ($config_result['configuration_value'] == 'Yes') { $show_payment_page = true; } } $ec_checkout = true; if (!tep_session_is_registered('paypal_ec_token') && !tep_session_is_registered('paypal_ec_payer_id') && !tep_session_is_registered('paypal_ec_payer_info')) { $ec_checkout = false; $show_payment_page = true; } } //---PayPal WPP Modification END ---// //kgt - discount coupons if (!tep_session_is_registered('coupon')) tep_session_register('coupon'); //this needs to be set before the order object is created, but we must process it after $coupon = tep_db_prepare_input($HTTP_POST_VARS['coupon']); //end kgt - discount coupons // load the selected payment module require(DIR_WS_CLASSES . 'payment.php'); $payment_modules = new payment($payment); require(DIR_WS_CLASSES . 'order.php'); $order = new order; $payment_modules->update_status(); if ( ( is_array($payment_modules->modules) && (sizeof($payment_modules->modules) > 1) && !is_object($$payment) ) || (is_object($$payment) && ($$payment->enabled == false)) ) { tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode(ERROR_NO_PAYMENT_MODULE_SELECTED), 'SSL')); } //kgt - discount coupons if( tep_not_null( $coupon ) && is_object( $order->coupon ) ) { //if they have entered something in the coupon field $order->coupon->verify_code(); if( MODULE_ORDER_TOTAL_DISCOUNT_COUPON_DEBUG != 'true' ) { if( !$order->coupon->is_errors() ) { //if we have passed all tests (no error message), make sure we still meet free shipping requirements, if any if( $order->coupon->is_recalc_shipping() ) tep_redirect( tep_href_link( FILENAME_CHECKOUT_SHIPPING, 'error_message=' . urlencode( ENTRY_DISCOUNT_COUPON_SHIPPING_CALC_ERROR ), 'SSL' ) ); //redirect to the shipping page to reselect the shipping method } else { if( tep_session_is_registered('coupon') ) tep_session_unregister('coupon'); //remove the coupon from the session tep_redirect( tep_href_link( FILENAME_CHECKOUT_PAYMENT, 'error_message=' . urlencode( implode( ' ', $order->coupon->get_messages() ) ), 'SSL' ) ); //redirect to the payment page } } } else { //if the coupon field is empty, unregister the coupon from the session if( tep_session_is_registered('coupon') ) { //we had a coupon entered before, so we need to unregister it tep_session_unregister('coupon'); //now check to see if we need to recalculate shipping: require_once( DIR_WS_CLASSES.'discount_coupon.php' ); if( discount_coupon::is_recalc_shipping() ) tep_redirect( tep_href_link( FILENAME_CHECKOUT_SHIPPING, 'error_message=' . urlencode( ENTRY_DISCOUNT_COUPON_SHIPPING_CALC_ERROR ), 'SSL' ) ); //redirect to the shipping page to reselect the shipping method } } //end kgt - discount coupons if (is_array($payment_modules->modules)) { $payment_modules->pre_confirmation_check(); } // load the selected shipping module require(DIR_WS_CLASSES . 'shipping.php'); $shipping_modules = new shipping($shipping); require(DIR_WS_CLASSES . 'order_total.php'); $order_total_modules = new order_total; // Stock Check $any_out_of_stock = false; if (STOCK_CHECK == 'true') { for ($i=0, $n=sizeof($order->products); $i<$n; $i++) { if (tep_check_stock($order->products[$i]['id'], $order->products[$i]['qty'])) { $any_out_of_stock = true; } } // Out of Stock if ( (STOCK_ALLOW_CHECKOUT != 'true') && ($any_out_of_stock == true) ) { tep_redirect(tep_href_link(FILENAME_SHOPPING_CART)); } } require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_CONFIRMATION); $breadcrumb->add(NAVBAR_TITLE_1, tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL')); $breadcrumb->add(NAVBAR_TITLE_2); I entered in echo statements in the verify() function to make sure that is initializing as well and it shows up fine. Has anyone else had similiar problems to this?
  8. ttoomey

    fast easy checkout

    Using the most recent version of fast easy checkout and everything looks great. My only issue is with the checkout is if someone chooses a shipping method and clicks on the ajax update total button the entire site is included in the page just below the button. I have included a screenshot. Any ideas on what's wrong? Or what I might need to fix?
  9. http://www.abercrombie.com/webapp/wcs/stor...1&langId=-1 On this site you have the capability to click on a small image swatch on the product page in order to see multiple styles of shirts etc. I was wondering if there is a contribution that does something similiar to this? More pics looked promising but it uses a multiple popup image approach to it and I just want to have a small image swatch that you can click on. I haven't tried ultrapics but I'm not sure if that is the way to go either. If you have any recommendations please let me know. thanks in advance!
  10. ttoomey

    [contribution] Simple Template System (sts)

    In response to my own problem above I upgraded to 4.2 and everything was fixed.
  11. ttoomey

    [contribution] Simple Template System (sts)

    I have had the STS system installed for quite awhile now and for some reason I can't seem to get rid of the line of whitespace above my template. It appears as though the information from the original PHP pages of OSCommerce are still being parsed, but they are empty. This causes the body and header to be displayed twice (Though there is nothing displayed in the first parsing of the page) Here is the top of the header code on my pages after viewing the source: <!-- header_eof //--> <!-- body //--> <table border="0" width="100%" cellspacing="3" cellpadding="3"> <tr> <td width="171" valign="top"><table border="0" width="171" cellspacing="0" cellpadding="2"> <!-- left_navigation //--> <!-- right_navigation_eof //--> </table></td> </tr> </table> <!-- body_eof //--> <!-- footer //--> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html dir="LTR" lang="en"> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <title>Salty Dog Cafe Online Store</title><base href="http://www.saltydog.com/store/"> <!-- start get_javascript(applicationtop2header) //--> <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') } //--></script> <!-- end get_javascript(applicationtop2header) //--> <link rel="stylesheet" type="text/css" href="stylesheet.css"> <body> As you can see the header and body are showing up twice. I have posted my template code as well so you can see that there should be nothing out of the ordinary going on. let me know if anyone has any ideas. A live version of this site is located here: http://www.saltydog.com/store/index.php <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html $htmlparams> <head> <!--$headcontent--> <link rel="stylesheet" type="text/css" href="stylesheet.css"> </head> <table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td>?</td> <td width="785"><table width="785" border="0" cellspacing="0" cellpadding="0"> <tr> <td width="16" background="includes/sts_templates/full/images/l_shadow.jpg"><img src="includes/sts_templates/full/images/l_shadow.jpg" width="16" height="11"></td> <td width="769"><table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td><img src="includes/sts_templates/full/images/t_nav.jpg" width="769" height="63" border="0" usemap="#Map"></td> </tr> <tr> <td><table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td valign="middle" bgcolor="#00449b"><img src="includes/sts_templates/full/images/r2_c1.jpg" width="94" height="26"></td> <td valign="middle" bgcolor="#00449b" class="topnav"><a href="http://www.saltydog.com/store/index.php?cPath=32">T-Shirts </a> <a href="http://www.saltydog.com/store/index.php?cPath=80">Sweatshirts </a> <a href="http://www.saltydog.com/store/index.php?cPath=28">Men </a> <a href="http://www.saltydog.com/store/index.php?cPath=26">Women </a> <a href="http://www.saltydog.com/store/index.php?cPath=27">Childrenswear </a> <a href="http://www.saltydog.com/store/index.php?cPath=22">Hats </a> <a href="http://www.saltydog.com/store/index.php?cPath=25">Pets </a> <a href="http://www.saltydog.com/store/index.php?cPath=40">Products </a> </td> <TD width="230" height="26" align="right" valign="middle" background="includes/sts_templates/full/images/r2_c3.jpg"> Search: <form name="quick_find" action="http://www.saltydog.com/store/advanced_search_result.php" method="get"> <input type="text" name="keywords" size="10" maxlength="30" style="width: 75px" class="loginButton"> ? <input name="submit" type="submit" title=" Quick Find " value="GO"> </form> ?? </tr> </table></td> </tr> <tr> <td><table width="100%" border="0" cellpadding="4" cellspacing="0"> <tr bgcolor="#1b7eab"> <td height="18" colspan="2" valign="top"><table width="75%" border="0" cellspacing="0" cellpadding="0"> <tr> <td width="17%" height="22" valign="middle" class="subnav">?</td> <td width="83%" height="22" valign="middle" class="subnav">?</td> </tr> </table></td> </tr> <tr> <td height="303" colspan="2" valign="top" background="includes/sts_templates/full/images/r3_c1.jpg">?</td> </tr> <tr> <td width="171" align="center" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="4"> <tr> <td><p>$cartbox</p> <p>$informationbox</p> <p>$bestsellersbox</p></td> </tr> </table> <table width="135" border="0" cellpadding="2" cellspacing="0"> <tr> <td width="135" align="center" valign="top"><script src=https://seal.verisign.com/getseal?host_name=www.saltydog.com&size=M&use_flash=YES&use_transparent=YES?=en></script> <br /> <a href="http://www.verisign.com/ssl/ssl-information-center/" target="_blank" style="color:#000000; text-decoration:none; font:bold 7px verdana,sans-serif; letter-spacing:.5px; text-align:center; margin:0px; padding:0px;">About SSL Certificates</a></td> </tr> </table></td> <td width="614" rowspan="2" valign="top"> $content <p>$specialfriendbox</p> <p>$footer_text</p> </td> </tr> </table></td> </tr> </table></td> </tr> </table></td> <td background="includes/sts_templates/full/images/r_shadoew.jpg">?</td> </tr> </table> <map name="Map"> <area shape="rect" coords="-57,-15,290,59" href="index.php"> <area shape="rect" coords="510,-1,593,60" href="account.php"> <area shape="rect" coords="597,-4,675,60" href="shopping_cart.php"> <area shape="rect" coords="679,-15,744,59" href="checkout_shipping.php"> </map> </body> </html>
  12. ttoomey

    [Contribution] STS v4

    I installed the newest version of STS v4.1 but I'm having a problem still with the login page. The problem is that it's not showing up. Here's a link to my store where you can do everything but login and finish the checkout process. I have no other contributions installed--this is a fresh install as far as I can remember. Any solutions are appreciated: Blank Login page the regular store url is http://www.saltydog.com/oscommerce/catalog thanks -tim
  13. ttoomey

    [contribution] Simple Template System (sts)

    I've installed the newest version of STS V4.1 but I'm having several problems. 1. My product options mysteriously show up twice. Despite having them down only one time in the product_info.php.html template page. Product Options Showing up twice 2. The login page shows up blank Login page blank? You can see examples of both of these crazy phenomona at the links posted. Anyone know how to fix these things? There are no contributions installed--this is a fresh OScommerce install. If anyone has had similiar problems please let me know. Thanks. -T
  14. I'm trying to custom modify the coupons module by adding a field requiring a minimum quantity of 10 items in order for a coupon to be valid. I have tried to grab information out of the $order->products[$i]['quantity'] array and I can't get any informaiton. I'm just trying to echo out basic information at this point on the checkout_confirmation page with no luck. How would I be able to grab the quantity info from each product and add them together? Does anyone know how to just access this information and I can go on from there? any help is appreciated.
  15. ttoomey

    ship to US only

    I searched the forums for a contribution or maybe a configuration setting to adjust shipping for this, but how do I disable, or dissallow people to place orders from outside of the united states? We are receiving orders from West Africa and I am not entirely sure how to disable order placing from outside countries. Ideally we'd like for a popup to appear telling customers to call for international shipping information. Has anyone else found a simple fix for this? Currently we use the UPS XML real time rates shipping module. Any help is greatly appreciated!
×