Jump to content

hro2u

Members
  • Content count

    29
  • Joined

  • Last visited

About hro2u

  • Birthday 07/26/1969

Profile Information

  • Real Name
    Hans R. Olsson
  • Gender
    Male
  • Location
    Stockholm, Sweden & Shanghai, China
  • Interests
    Cars and Car Customization<br /><br />China <br /><br />Export & Import<br /><br />Good Wine
  • Website

Recent Profile Visitors

2,603 profile views
  1. SOLVED IT! MY MISTAKE, SORRY FOLKS. To warm for head here in Shanghai at the moment I guess... (I had forgotten to delete one line in the upgrade...) HOWEVER, Another issue that I would like to address is maybe very simple for U guys. It also has to do with installing this contrib together with other contribs. In my case its in catalog/admin/includes/boxes/reports.php and Im using the contrib for Monthly Sales Summary in OSc. When adding the new lines for Access with Level Account (v. 2.2a), I have to comment out the two lines to make OSc admin display correctly and if not, the tools section dissapears from Admin. How to include the Monthly Sales in reports.php to get them included??? My reports.php looks like this, U see the two lines Ive commented out... ********************************************************** application/x-httpd-php reports.php PHP script text <?php /* $Id: reports.php,v 1.5 2003/07/09 01:18:53 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright © 2002 osCommerce Released under the GNU General Public License */ ?> <!-- reports //--> <tr> <td> <?php $heading = array(); $contents = array(); $heading[] = array('text' => BOX_HEADING_REPORTS, 'link' => tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, 'selected_box=reports')); if ($selected_box == 'reports') { // BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1 // reverse comments to below lines to disable this contribution // $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_VIEWED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_VIEWED . '</a><br>' . // '<a href="' . tep_href_link(FILENAME_STATS_PRODUCTS_PURCHASED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_PRODUCTS_PURCHASED . '</a><br>' . // '<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a>'); $contents[] = array('text' => tep_admin_files_boxes(FILENAME_STATS_PRODUCTS_VIEWED, BOX_REPORTS_PRODUCTS_VIEWED) . tep_admin_files_boxes(FILENAME_STATS_PRODUCTS_PURCHASED, BOX_REPORTS_PRODUCTS_PURCHASED) . tep_admin_files_boxes(FILENAME_STATS_CUSTOMERS, BOX_REPORTS_ORDERS_TOTAL)); // EOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 1 of 1 // '<a href="' . tep_href_link(FILENAME_STATS_MONTHLY_SALES, '', 'NONSSL') . '" //class="menuBoxContentLink">' . BOX_REPORTS_MONTHLY_SALES . '</a>'); } $box = new box; echo $box->menuBox($heading, $contents); ?> </td> </tr> <!-- reports_eof //--> ****************************************************** B)
  2. # Access with Level Account (v. 2.2) for the Admin Area of osCommerce (MS2)# BACKGROUND: Hi guys, I have followed the install by the letter and the only additional additions to the code were in two files (catalog/admin/includes/boxes/tools.php and catalog/admin/includes/boxes/catalog.php) I have other contributions which have added lines to these files (example: PDF_Catalog and Cinesound Video and Audio) It might be a good thing to comment for users what to add to make the installation complete for these situations... Im not 100% sure I have done correctly in these two files, I have simply commented out like in the Access with Level Account addition (//) and added the last piece of code after all the commented lines... CURRENT CRITICAL ERROR: Problem (cant logon to OSc Admin): Parse error: syntax error, unexpected ';', expecting ')' in /home/ruiruish/public_html/admin/index.php on line 109 (i CANT FIND A ';', in these lines, there are several '; BUT WHICH ONE? Or can this be generated from a call from this file to one of the others)? This is from my index.php under Admin (line 100 to 109) // BOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 8 of 10 // comment out below line to disable this contribution 'access' => tep_admin_check_boxes('tools.php'), // EOE Access with Level Account (v. 2.2a) for the Admin Area of osCommerce (MS2) 8 of 10 'image' => 'tools.gif', 'href' => tep_href_link(FILENAME_BACKUP, 'selected_box=tools'), 'children' => array(array('title' => TOOLS_BACKUP, 'link' => tep_href_link(FILENAME_BACKUP, 'selected_box=tools')), array('title' => TOOLS_BANNERS, 'link' => tep_href_link(FILENAME_BANNER_MANAGER, 'selected_box=tools')), array('title' => TOOLS_FILES, 'link' => tep_href_link(FILENAME_FILE_MANAGER, 'selected_box=tools'))))); Greatfull for some help so I can get going! Cheers, Hans
  3. hro2u

    PDF Catalog v.1.5

    Back again....Just discovered that actually the selected product catalogs get generated from the customer interface in my shop, but still I cant generate the full pdf catalog from Osc Admin... So what can be the problem? Cheers, Hans
  4. hro2u

    PDF Catalog v.1.5

    Error in admin/pdf_catalogue.php > click button................. Fatal error: Cannot access empty property in ......................../admin/pdf_catalogue.php on line 625 admin/pdf_catalogue.php?action=save It tells you that the category is empty! :blink: OK, then my question would be: What category is empty...??? Where is the script trying to read or get data? Im sitting in Shanghai and its darn 35 degrees and Ive tried all the last posts here, that is I have vers. 2.0.8 of PDF_catalogue and I have the MYSQL fix in both /admin/pdf_catalogue.php and /pdf_catalogue_info2.....Still get the Fatal error above. I have also checked the php.ini and url_fopen is active and SafeMode is off... Can a single .gif image in the catalog generate this problem? I have tried to follow the posts here to get to the solution but havnt gotten the green light yet...Very thenkful for some input to this Error before my brain melts to a Dumpling Hans or here Oh Han Shi...
  5. hro2u

    PDF Catalog v.1.5

    Hi all, I made an interesting(?) discovery the other day concerning getting pdf´s out of specific categories rather than the complete pdf-catalog. Read in an earlier post in this forum that somebody installed the font catalog in the contribution not only to catalog/admin but also to catalog/! So I gave it a shot and now I can get the template for the pdf page generated and a 2nd page which only has written: PDF_INDEX_HEADER in the top. Conclusion: The is a function working to generate pdf but for some reason it doesn´t get filled by the product info. Any ideas? I also wonder a bit about the coding of the so called "statusbar" that´s supposed to be filled while the pdf is generated??? Anyone looked in to this? Should be about time to solve the categories-pdf function, as I understand noone of the coders have bothered to solve this...If nothing is done I suggest this contribution to be withdrawn from the contributionslist since it creates more problems and takes time from all it´s users than the benefits it gives an online store. >_< If getting the categories selected pdf´s working then I dont have to bother to much about the fact that my catalog nos is to large to be generated as a compete pdf-catalog. Best Regards, Hans
  6. hro2u

    PDF Catalog v.1.5

    Hi again, Now after I´ve had some brainstorming(?) after a hard days work and a good glas of Chardonay - It works for me with just a small (...) 1.) I started with the Image magic contrib of PDF-productcatalog, that´s when I got all sorts of problems including the page columns being haywire... So I decided to go for the version without the added functionality. 2.) It requires the added brackets in the code which you mentioned since MySQL is of later version (this issue is also addressed by the developer in a MySQL-fix included): ******************************************************************************** ******** If you are using MySQL 5 you will need to change line 609 to: $requete_prod="select p.products_id, pd.products_name, pd.products_description, p.products_image, p.products_model, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from (" . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id, " . TABLE_PRODUCTS_DESCRIPTION . " pd) left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_CATEGORIES . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where products_status = '1' and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p2c.categories_id='".$current_category_id."' order by pd.products_name, p.products_date_added DESC"; The only change is the addition of brackets after the FROM clause: (" . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id, " . TABLE_PRODUCTS_DESCRIPTION . " pd) ******************************************************************************** ******** hro2u continued: With this fix the script works to generate the different language based catalogs (complete cataloges that is) I still face the issue of figuring out why the selected categories cataloges are not generated...) As for the layout issue on the site, with this set up it´s no issue, no columns on the downloadpage (then the "big ugly" default OSC button has it´s purpose and that´s fine with me. If anyone has a solution to the split categories productcatalog I would be cheering you with yet another glas of white :-) /Hans
  7. hro2u

    PDF Catalog v.1.5

    Hi, Sorry I havn´t got a solution to you since I´m a few steps behind U. I´d like your help...You state that you have fixed the 1054 error - I´ve just installed the contribution and have all the correct interface in the shop and admin but get the following error message in Admin "Create PDF Catalog": 1054 - Unknown column 'p.products_id' in 'on clause' select p.products_id, pd.products_name, pd.products_description, p.products_image, p.products_model, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from oscommerce_products p left join oscommerce_manufacturers m on p.manufacturers_id = m.manufacturers_id, oscommerce_products_description pd left join oscommerce_specials s on p.products_id = s.products_id, oscommerce_categories c, oscommerce_products_to_categories p2c where products_status = '1' and p.products_id = pd.products_id and pd.language_id = '4' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p2c.categories_id='22' order by pd.products_name, p.products_date_added DESC [TEP STOP] Any suggestiond to correction? After fix I´m curious if ´left with the same experience as you mention here(?) Regards, Hans
  8. Hi all, From my own experience of now having implemented atleast 20 contributions in my shop with good result, I´ve had to address the issue of that many providers and webhotels who provide Oscommerce installations as part of "on click sites" in their packages, do have other names on their databasetables than the default Oscommerce. Example: My Webhotell puts Oscommerce_ before each name (ex: Oscommerce_categories). In many contributions the database call sections are commented with "no editing beyond this line" etc etc. So you see my point. To save lots of time on support, esp. with users not being code or php wizards :-/ it might be a good idea to include a few lines about this issue and how to check that the users database tables correspond with standard or not. In all good meaning, All the best, Hans
  9. I see, Ok let me share my experience, true is that the extraction from the database wont give you a table/column for (in my case) the second language. However by entering the productname (table/column for productname and product description is included in the extracted .txt-file) the product is also registred for the second language. It might ofcourse have been more crystalclear if categories for extra languages were included. The only thing I have encountered as a bit odd is that when I upload, Easypopulate in admin claims that there is no productmodel enetered and that the data is not imported, I have productmodel for every product and it is also imported to the database and each product. Conclusion: for me it all works as intended and described. Regards, Hans
  10. Conclusion and end of subject.... I uploaded including the two tables I have mentioned here and it works just fine! So everything is perfect and works like clockwork. have a nice day! Regards, Hans
  11. And looking at the exported language issue again: I got all the categories exported in both languages as well as all the attributes in english and swedish, seems like the only tabel not inccluded in swedish is the the two I mentioned about download and box...? /Hans
  12. I have about 60 products in the shop at the moment and are now going to add about 1000 more. Yes, I do backup as a routine before any major change or addition. I read your answer on the issue of languages but still wonder what happens when I upload the table with heading ""v_attribute_values_name_4_1_1" ("Download: Windows - English")? /Hans
  13. Hi all, I installed the contribution to my store and it all seems to work just fine, that is: *The installation and Admin interface. *Extract and download from database So far good and smoothly :-) My greetings to do codewizards! When checking the colums in the tab divided .txt file I came across the columnlabel "v_attribute_values_name_4_1_1" Data in it is:"Download: Windows - English" another: "v_attribute_values_name_4_2_1" Data: "Box: Windows - English" I have two languages installed in my shop Swedisg and English. I wonder what the mentioned fields data stand for and why if this is from the English attributes in Catalog why Swedish is not included? Finally if this data should be uploaded to the database again or if it will mess up it all??? Would be greatful for an answer since I have over 1000 products wating to be uploaded to my shop and I havn´t dared yet afraid to screw up the db... All the best, Hans
  14. Hi all, I installed the contribution to my store and it all seems to work just fine, that is: *The installation and Admin interface. *Extract and download from database So far good and smoothly :-) My greetings to do codewizards! When checking the colums in the tab divided .txt file I came across the columnlabel "v_attribute_values_name_4_1_1" Data in it is:"Download: Windows - English" another: "v_attribute_values_name_4_2_1" Data: "Box: Windows - English" I have two languages installed in my shop Swedisg and English. I wonder what the mentioned fields data stand for and why if this is from the English attributes in Catalog why Swedish is not included? Finally if this data should be uploaded to the database again or if it will mess up it all??? Would be greatful for an answer since I have over 1000 products wating to be uploaded to my shop and I havn´t dared yet afraid to screw up the db... All the best, Hans
  15. Is it possible noone has a suggestion how to solve this??? I´m surprised...
×