Jump to content

mdtaylorlrim

♥Ambassador
  • Content count

    2,550
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by mdtaylorlrim

  1. mdtaylorlrim

    [Addon} Theme Switcher

    Actually, I don't remember as it was far too long ago. It does say right in the post that I changed the code so that I would see the detail of the error. i.e. See the full path to the file that could not be found. That is where I saw that the constant DIR_WS_LANGUAGES had not been assigned a value. That should happen in the compatibility add-on but was not, for some reason. So I traced the directory structure for where the file actually was found and forced the value into the variable. It all worked after that, and does to this day. If you don't understand what I said then you should probably stick with the advice from others that are far more experienced in this than am I. Sorry. Mark
  2. mdtaylorlrim

    Sitemap SEO

    Thanks Jack!
  3. mdtaylorlrim

    Sitemap SEO

    @@Jack_mcs In the sitemap page I only get the categories listed. It will list each product if I set it to do so, but with over 1500 items I do not list each item. But, it does not list any other page.... information, privacy, shipping, or any that I created. Should it?
  4. mdtaylorlrim

    Sitemap SEO

    Agreed. It doesn't seem to affect anything at all. I'm fine with letting it go with the way it is. Thanks
  5. mdtaylorlrim

    Sitemap SEO

    @@Jack_mcs That changed the error to: Warning: file() expects parameter 1 to be a valid path, array given in /home/html/admin/includes/functions/sitemap.php on line 205 Line 205 is now: $lines = file($path);
  6. mdtaylorlrim

    Sitemap SEO

    That's fixed... one last problem.... Warning: file(/home/html/includes/modules/boxes/Array): failed to open stream: No such file or directory in /home/html/admin/includes/functions/sitemap.php on line 203 What is causing that? It is returned when you select Update in the Boxes Group Control Thanks Mark
  7. mdtaylorlrim

    Sitemap SEO

    @@Jack_mcs Thanks Jack. Clicking on the Sitemap on the index page returns an error that a table does not exist. Verified with phpMyAdmin. I did run the install script and got a success message, all configuration values were inserted into the configuration table, but the new tables were not created. Any harm in running the install script again? Mark
  8. mdtaylorlrim

    Sitemap SEO

    @@Jack_mcs Ok, the compatibility add on was installed at an earlier date, but my version of Edge (must be the latest as it was installed just last month) must be modular. The index.php has two conditions and a default procedure... First question to determine where to look where it goes would be does it go in the section where $category_depth is "nested", $category_depth is "products", or in the default? Mark
  9. mdtaylorlrim

    Sitemap SEO

    @@Jack_mcs, I was installing this on Bootstrap Edge today and when I got to step 10, the instructions seem to fall apart. The phrase "include(DIR_WS_MODULES" does not appear anywhere in the index.php file. Or am I missing something? Thanks mark
  10. mdtaylorlrim

    New UPS XML Shipping Module available

    Thanks, that was it. Now something new. I get the error Call-time pass-by-reference has been removed in.... Which, I know the reasons, but when xml.php tests for the version of php using if (PHP_VERSION >= '5.0.0') PHP_VERSION returns a null value and therefore executes the code as if it is the older version of php. PHP_VERSION is set by environment variables by php, right? Rather than change all the code, or erase the inapplicable code and force the new code, where can I check for php not setting the value of PHP_VERSION? My Server info in Administration properly shows a current version of php. Mark
  11. mdtaylorlrim

    New UPS XML Shipping Module available

    My problem is the error: Couldn't find constant UPSXML_--none-- in.... However, I did attempt to get the code changed in modules.php as the install directions say, but it was slightly different. I had installed the USPS rates module so the code differed slightly. Here is my present code block: if (tep_not_null($action)) { switch ($action) { case 'save': reset($HTTP_POST_VARS['configuration']); while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { // USPS START if (is_array($value)) $value = implode(', ', $value); // USPS END tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); } If I change the code to include the extra line... if (tep_not_null($action)) { switch ($action) { case 'save': reset($HTTP_POST_VARS['configuration']); while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { // USPS START if (is_array($value)) $value = implode(', ', $value); $value = preg_replace ("/, --none--/", "", $value); } // USPS END tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); } tep_redirect(tep_href_link(FILENAME_MODULES, 'set=' . $set . '&module=' . $HTTP_GET_VARS['module'])); break; I get this error: Parse error: syntax error, unexpected 'case' (T_CASE) in.... So I am thinking it broke the { } syntax. So I added a { if (tep_not_null($action)) { switch ($action) { case 'save': reset($HTTP_POST_VARS['configuration']); while (list($key, $value) = each($HTTP_POST_VARS['configuration'])) { // USPS START if (is_array($value)){ $value = implode(', ', $value); $value = preg_replace ("/, --none--/", "", $value); } // USPS END tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $value . "' where configuration_key = '" . $key . "'"); } So, I then I get back to Couldn't find constant UPSXML_--none-- in.... So nothing seems to work for me. Anyone have any suggestions? Mark
  12. mdtaylorlrim

    USPS Rate V4, Intl Rate V2 (official support thread)

    @@kymation Thanks Jim. It all works great. Off topic but which UPS shipping module works on BS-Edge?
  13. mdtaylorlrim

    USPS Rate V4, Intl Rate V2 (official support thread)

    @@kymation The 2.3.4 folder has one file in it. modules.php So where does it go?
  14. mdtaylorlrim

    USPS Rate V4, Intl Rate V2 (official support thread)

    So the install instructions say to simply upload the directories New files and Files to Modify into your structure. But in the Files to Modify it has two additional folders. 2.3.4 and 2.3.x.x This will create those folders in the directory tree. Is that what is intended or are we to select which matches our installed version and only upload those?
  15. mdtaylorlrim

    [Addon} Theme Switcher

    Anyone use http://bootstrap-live-customizer.com/ Any better tool out there? Mark
  16. mdtaylorlrim

    [Addon} Theme Switcher

    Got it. Thanks Although it is working without me changing the code back. Whatever works I suppose.
  17. mdtaylorlrim

    [Addon} Theme Switcher

    Compatibility Addon? That term is found in the forus in several places but no links to it. Is it in the Add-on store?
  18. mdtaylorlrim

    [Addon} Theme Switcher

    I changed the code to DIR_WS_CATALOG_LANGUAGES and the error went away, but it still says template_top.php has not been modified. I'm thinking I may not be using the right theme_switcher module? I'm using the one out of the Bootstrap directory.
  19. mdtaylorlrim

    [Addon} Theme Switcher

    Ok, I did some troubleshooting and found that DIR_WS_LANGUAGES is not translated to /includes/languages/ so where does that happen? The selected theme was found. template_top.php has not been modified! The language file is missing! /home/mdtaylorlrim/html/DIR_WS_LANGUAGESenglish/modules/header_tags/ht_theme_switcher.php
  20. mdtaylorlrim

    [Addon} Theme Switcher

    No, this is a Bootsrap Edge installed this morning. This is the first add on to be installed. This is what I get: Switch your store theme from the admin. Module Version 1.5.3 Enable Theme Switcher True Sort Order 1 Theme css The selected theme was found. template_top.php has not been modified! The language file is missing!
  21. mdtaylorlrim

    [Addon} Theme Switcher

    Now I am down to it complaining that the language file is missing. But... /html/includes/languages/english/modules/header_tags/ht_theme_switcher.php is there. Is there another language file it is referring to?
  22. mdtaylorlrim

    [Addon} Theme Switcher

    Is it normal to get "The jQuery file is missing" when Theme Switcher is first installed prior to updating anything else? This didn't happen on the stock 2.3.4 install. But did on the BS-Edge version. What needs to be fixed here?
  23. mdtaylorlrim

    [Addon} Theme Switcher

    I'll have to look into it more. I cannot even find minimum requirements for it. Do I have to download it to find that?
  24. mdtaylorlrim

    [Addon} Theme Switcher

    It probably will be far superior. But it ain't finished.
  25. mdtaylorlrim

    [Addon} Theme Switcher

    This is a stock 2.3.4 distro. Not a BS version. (pardon the pun)
×