Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

gerard

Members
  • Content count

    54
  • Joined

  • Last visited

  1. gerard

    cvv2 not storing cvv2 numbers in the database

    It was because I had the register globals patch, if you have aswell try this. in includes/classes/order.php you will need to add around line 30 under link_post_variable('ccexpires'); link_post_variable('cvvnumber'); that did the trick for me.
  2. gerard

    cvv2 not storing cvv2 numbers in the database

    After further testing it is not writing to the databse, If I manually add the number via phpadmin, it stores it and then returns is via the admin/orders, but it is not writing via checkout.????
  3. Have installed the above contirbution, (CVV on cc.php version 1.24 for OsCommerce 2.2 Milestone Release #2) But having a problem with the cvv2 number not being stored in the database, everything else is, number expiry date. this contridb has a excellent way of removing them after use, as i know it is illeagal to store them permantly. Anyone have and ideas to help ift would be appreciated. Gerard
  4. gerard

    Need to add the CVV2 from customer's credit card

    Having the same problem here, is it to do with globals being off??
  5. gerard

    "Dynamenu" for osCommerce

    Have tried adding this /***************** start *************************/ $pattern = '/^29$|^29_\d+$/'; if(isset($cpath_array)){ foreach ($cPath_array as $key => $value){ if(preg_match($pattern, $key)){ unset($cpath_array[$key]); } } } /*****************end *******************************/ below the global $cPath_array, $menu_use_titles, $menu_icon_file, $divide_subcats, but doesnt work?? where is the a href links created and called? Regards gerard
  6. gerard

    "Dynamenu" for osCommerce

    Great contrib, Is there anyway off excluding certain cPath links and sub links from being produced in the menu. I have a menu item called logs, which cPath=25 and I would like it not to show in the menu, it also has a sub menu called wet logs cpath=25_35 Any ideas??
  7. line 34 in product_info <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,re sizable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,l eft=150') } //--></script> thanks again for the pointers G
  8. I guess by now, I will have too figure it out which will do me no harm, but thanks for the contrib, it works well and is a definate plus to os commerce.
  9. <?php // BOF: More Pics 6 ?> if (document.layers) i=40; if (document.images[0]) window.resizeTo(document.images[0].width +30, document.images[0].height+115-i,scrollbars=yes,resizable=yes ); <?php // EOF: More Pics 6 ?> self.focus(); } //--></script> Have tried adding the scrollbars as above but I must have got it wrong?? Thanks Gerard
  10. Benn using this contribution for a while now thanks its a real addition to oscom If I have larger images than the popup size, can a scroll bar be implemented-activated for the popup window. and which lines define the actual width and height in popup_image.php Thanks again. Gerard
  11. thanks for spotting the error?? sorted now, but do you really need to post it to the world?????? a pm would have done the trick. your cooperation has been outstanding, truly proffesional. Thanks
  12. double checked and product_thumb is uploaded.
  13. Thanks for the reply, what I have is an infobox on another site on the same server but different domain, which displays two thumbnails and a link to my catalog. This is a contrib called featured products, it works fine, with the normal html_output.file. part of its code is below 'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $featured_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $featured_products['products_image'], $featured_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $featured_products['products_id']) . '">' . $featured_products['products_name'] . '</a><br>' ); when I replace the tep image function with yours, what happens is that the images disapear and I get two text hyperlinks instead. If I remove SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT from the code $featured_products like below I get full size images being displayed in my info box. $featured_products['products_name'] ) I have tried adding define('SMALL_IMAGE_WIDTH','100'); define('SMALL_IMAGE_HEIGHT','122'); echo SMALL_IMAGE_WIDTH; // -> will show 100 which does echo 100 but does not apply the sizes to the images? I have also tried $image_width = "100"; $image_height = "140"; and replace small_image_width with image_width. also tried just defining the size. Any help would be appreciated. Regards
  14. I am having problems with featured products and OTF and the tep_image function. Which somebody may be able to hep. I had an "ad" on an external website which used the code below to get image size and height and worked fine until I installed OTF??Not blaming here. But now just display hyperlinks> For some reason it doesn't reconize SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT code. $featured_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '< I Have replace the tep_image in html_output so how can I reference height and width using the new tep_image function?? Regards Gerard
×