Jump to content

wace

Members
  • Content count

    31
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Alexander
  1. wace

    [Contribution] Admin Notes

    Great contribution! Maybe I'm missing something, but step 7 and further of the HTML manual doesn't say which file I've got to look for. :)
  2. I've installed this contribution, but there seems to go something wrong. The dropdown menu doesn't show, not when there is an refID in the url and neither when there is no refID. The code in create_account.php is: <!-- //rmh referral start --> <?php if ((tep_not_null(tep_get_sources()) || DISPLAY_REFERRAL_OTHER == 'true') && (!tep_session_is_registered('referral_id') || (tep_session_is_registered('referral_id') && DISPLAY_REFERRAL_SOURCE == 'true')) ) { ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td class="main"><b><?php echo CATEGORY_SOURCE; ?></b></td> </tr> <tr> <td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox"> <tr class="infoBoxContents"> <td><table border="0" cellspacing="2" cellpadding="2"> <tr> <td class="main"><?php echo ENTRY_SOURCE; ?></td> <td class="main"><?php echo tep_get_source_list('source', (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? true : false), (tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '') . ' ' . (tep_not_null(ENTRY_SOURCE_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_TEXT . '</span>': ''); ?></td> </tr> <?php if (DISPLAY_REFERRAL_OTHER == 'true' || (tep_session_is_registered('referral_id') && tep_not_null($referral_id))) { ?> <tr> <td class="main"><?php echo ENTRY_SOURCE_OTHER; ?></td> <td class="main"><?php echo tep_draw_input_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')) . ' ' . (tep_not_null(ENTRY_SOURCE_OTHER_TEXT) ? '<span class="inputRequirement">' . ENTRY_SOURCE_OTHER_TEXT . '</span>': ''); ?></td> </tr> <?php } ?> </table></td> </tr> </table></td> </tr> <?php } else if (DISPLAY_REFERRAL_SOURCE == 'false') { echo tep_draw_hidden_field('source', ((tep_session_is_registered('referral_id') && tep_not_null($referral_id)) ? '9999' : '')) . tep_draw_hidden_field('source_other', (tep_not_null($referral_id) ? $referral_id : '')); } ?> <!-- //rmh referral end --> Is this ok?
  3. Maybe you could explain in short what this contribution can do? It's not really clear to me :)
  4. wace

    [Contribution] Ship In Cart

    Many requests, but unfortunatley unanswerd :(. I absolutely understand that the TSs might be very busy but could somebody please make a good contribution for MS2? I think it's very appreciated by many users.
  5. Problem... On the index.php, no metatags are shown after installing this contribution, it works on all the other pages, but not on the index.php and thereby the most important page. How to fix this?
  6. Originating URL doesn't work at my site. The readme says: Look for: "tep_session_start();" But there are three of these phrases (i've tried all three, but none seems to work). This is the code of application_top.php: // start the session $session_started = false; if (SESSION_FORCE_COOKIE_USE == 'True') { tep_setcookie('cookie_test', 'please_accept_for_session', time()+60*60*24*30, $cookie_path, $cookie_domain); if (isset($HTTP_COOKIE_VARS['cookie_test'])) { tep_session_start(); $session_started = true; } } elseif (SESSION_BLOCK_SPIDERS == 'True') { $user_agent = strtolower(getenv('HTTP_USER_AGENT')); $spider_flag = false; if (tep_not_null($user_agent)) { $spiders = file(DIR_WS_INCLUDES . 'spiders.txt'); for ($i=0, $n=sizeof($spiders); $i<$n; $i++) { if (tep_not_null($spiders[$i])) { if (is_integer(strpos($user_agent, trim($spiders[$i])))) { $spider_flag = true; break; } } } } if ($spider_flag == false) { tep_session_start(); $session_started = true; } } else { tep_session_start(); $session_started = true; } Anybody?
  7. After installing the contribution, when I go to admin/categories.php: Warning: implode(): Bad arguments. in /var/www/domains/7338991942/www/web/store/admin/includes/functions/general.php on line 135 multiple times... I've changed the categories.php, but not the general.php file. What should I do?
  8. I'm getting the following error: 1054 - Unknown column 'products_head_title_tag' in 'field list' select pd.products_name, pd.products_description, products_head_title_tag, pd.products_head_desc_tag, pd.products_head_keywords_tag, pd.products_url, p.products_id, p.products_quantity, p.products_model, p.products_image, p.products_price, p.products_weight, p.products_date_added, p.products_last_modified, date_format(p.products_date_available, '%Y-%m-%d') as products_date_available, p.products_status, p.products_tax_class_id, p.manufacturers_id from products p, products_description pd where p.products_id = '30' and p.products_id = pd.products_id and pd.language_id = '4' what can I do about it?
  9. Unfortunatly, I'm still not able to fix the following, could anybody help?
  10. Thanks to fredfillah, I was able to correct some bugs for my MS2 version. But. It still doesn't work at my webshop. There are two problems: 1. The pictures I had allready attatched to products appear twice now. The upper one is a bit rescaled. Should I delete the image that is attatched to the product before installing this contribution? 2. I can't add images. There are no errors, but if I push the 'add image' button, the 'Image description', 'new image' and 'popup image' form comes up, but if I enter the information and click 'save' nothing happens and I just am redirected to the normal Categories / Products page. Also no green bar appears at the top with 'image uploaded' or so, although I don't know if to expect this. Could somebody help me? Thank you very much.
  11. The products that I want to sell are very little things, more acccessoires for my existing products. I was wondering if the following is possible: I would like to have no link to the productinfo page attatched to the picture and text, so only let the 'buy now' button work. This is because no extra information is needed for these products in my store. This is the code now: 'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $xsell['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $xsell['products_image'], $xsell['products_name'], '', '') . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $xsell['products_id']) . '">' . $xsell['products_name'] .'</a><br>' . $xsell_price. '<br><a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $xsell['products_id'], 'NONSSL') . '">' . tep_image_button('button_buy_now.gif', TEXT_BUY . $xsell['products_name'] . TEXT_NOW) .'</a>') What changes should I make to make this possible?
  12. Allready fixed the problem :) (an extra ); the line above)
  13. Contribute seems to be great, but unfortunatly, it doesn't work very good for me. After installing I get this warning when I try to visit the 'catalog' tab in the admin: Parse error: parse error, expecting `')'' in /var/www/domains/7338991942/www/web/store/admin/categories.php on line 225 I'm a bit of a php newb, but I was hoping someone could help me. Thank you very much. :)
  14. Thanks! Okay, i've got it with winrar, but now. Where do I have to place the file and what adjustments do I have to make to the tools file?
  15. I'm sorry, but i'm a bit of a beginner. How do I 'gunzip' and 'untar'? And what needs to be changed in the tools menu file? Excuse me for my beginners question.
×