Jump to content

sackling

Members
  • Content count

    278
  • Joined

  • Last visited

Everything posted by sackling

  1. Thanks for the work everyone. Why not post that as an addon or an update to the addon? Trying out the admin panel on a fresh site. I noticed the who's online feature is not showing the customers cart properly. Is anyone working on that I might take a dive into that and see if I can get it to work.
  2. In the same boat as you. Wondering if I need to upgrade to AIM 2.1 (I am currently on 1.0)
  3. sackling

    canada.post.rest.rate.service.oscommerce.V2.3

    Yep Still not online. I activated fedex calculator in the mean time even though we ship with canada post, just so that we can get the orders pushed through online. I eventually got this reply from them admitting there might be an issue with sellonline: "We are working hard to get to the bottom of the issue. We are aware of a technical constraint when using TCP protocol - do you fall into that category? If so, we're investigating a viable workaround to save customers a few hours of recoding. Http protocol seems to be working fine." Not sure if that applies. I had to update my server to php5.4 as well as update my oscommerce site to the newest version to comply with the new php. All of that was due anyways (though I am probably switching to magento within the year),. but it would have been nice to have some warning and not just downtime with no fix.
  4. sackling

    canada.post.rest.rate.service.oscommerce.V2.3

    Hey Scott, Canada post sellonline has been down since saturday for us. They announced they would be down for the weekend but have been down since (it's tuesday now) Our online shipping has been totally busted. I just saw you posted this new version. Is this a coincidence? Do you have it functioning right now? Thanks, Rob EDIT: Sorry I just read the rest of the posts I got anxious and wrote in right away. So do you think that sellonline will be coming back? Or since hte blackout have they moved onto only the REST module?
  5. Also on 2.3.2 and getting the same error: atal error: Call to a member function query() on a non-object in /home/mysite/mysite.com/admin/advanced_statistics/general_functions.php on line 47
  6. sackling

    Header Tags SEO

    And I just checked, Login.php is defined in filenames.php and there is also a login.php file in languages/english/ Login.php is not showing up in the page control admin page. If I rename login.php to login2.php then it shows up in the drop down, But if I change it back to just login.php it is gone again! EDIT: I just found your post. I made a stupid:
  7. sackling

    Header Tags SEO

    on page control in admin. There are certain pages that are missing, I am guessing because I have not included the code on them as it says right on that page? But I don't see any mention of a specific code to include on pages in install_catalog.txt Further, I have looked at some of the pages that are included in the drop down on page control, and I don't see any code on them that would make them be included? What am I missing?
  8. sackling

    [Contribution] Products Specifications

    Yea to be honest it was not such a problem for me since there are not many specifications at the moment so just inserting via sql was pretty easy. But I can see it being a big pain if in the future I would need to add a new language like that.
  9. sackling

    [Contribution] Products Specifications

    Right that makes sense, The only thing that I think is a "bug" is that if I type a name in the second blank language box, It should then be added. So right now I have English and French, the English says color, the french is blank. If I add color to the french box, it should add it as language_id 2 but it just stays blank. I think that is buggy.
  10. sackling

    [Contribution] Products Specifications

    I think I found a bug. If you defined a specification in 1 language, save it, and then edit it and add a second language the second language does not get added to the database. I am guessing because the form submits as an UPDATE query but since that specification does not exist in the database yet it is not being added. I am in the process of turning my store into a multi lingual one, That is why I am facing this issue. I can duplicate the entries in the database directly and change the language ID but that takes a lot of time, and is not the cleanest. So maybe I will look into fixing it in the code/
  11. sackling

    Skip Payments Page - Support Page

    @@geoffreywalton I ended up making the changes myself in the payment module, the redirect url was simply the payment page. Changed it to the confirmation page. I am actually trying to add the comments box to the checkout_confirmation page now with no success. (since it is skipped on the payment page). basically I have: if (!tep_session_is_registered('comments')) tep_session_register('comments'); if (isset($_POST['comments']) && tep_not_null($_POST['comments'])) { $comments = tep_db_prepare_input($_POST['comments']); } In the header and then in the form: <?php echo tep_draw_textarea_field('comments', 'soft', '60', '5', $comments, 'style="width:99%;"'); ?> I'm not sure where else to look. Any ideas? EDIT: done by changing comments in checkout_process to 'comments' => stripslashes($_POST['comments']));
  12. sackling

    Skip Payments Page - Support Page

    Hi Geoffrey, I'm looking to skip the payments page (since there is only 1 option). I would like the payment errors to be shown on checkout confirmation though. I don't think your addon would work for this would it? Also the total would never be 0 when getting to the payment page.
  13. sackling

    authorize.net problems

    Thanks Jeff for the error message code! As it turns out (I am in Canada) and even though my authorize.net account is in canadian funds it uses USD and the CAD was throwing it off. I think this is actually a problem with authrorize.net since I am a canadian account why would they show USD. Anyways works now
  14. sackling

    FedEx - Web Services v9

    I am getting an added fee at checkout_confirmation on deliveries to home addresses and I am not sure why. the rate on checkout shipping shows 10.47 for ex. then if the address has no company the amount on checkout confirmation shows 13.84 I have the home delivery fee set to 0 in the admin. If I add a company during checkout shipping, the rate remains 10.47. I am using a simple checkout addon so it very well could be that, and while I'm typing this I'm more confident it is that, but I was curious if there is any place you know I should look or if you ever experienced anything similar. Thanks
  15. sackling

    FedEx - Web Services v9

    Thanks for clearing that up roaddoctor, makes sense. So now everything is working. This addon has none of the label printing/ tracking capabilities of the older fedex module does it? and if not, is there one that is best to install that works with oscommerce 2.3? or should I start hacking away at: http://addons.oscommerce.com/info/2244 to try and get it to work?
  16. sackling

    FedEx - Web Services v9

    Hi, I just installed the module and all is working well. I have a couple questions: 1) how is the home delivery option calculated? I set it to 3 in the admin, but how does the module "know" when it is a home address? It would be great if it were automatic, but that does not seem to be the case. 2) is there a way to show ETA? If I keep all the options the users might not know the difference between all the options. Thanks
  17. sackling

    [Contribution] Products Specifications

    I found it in my functions/general.php tep_get_all_get_params was not the same as in the contrib.
  18. sackling

    [Contribution] Products Specifications

    I'm getting a problem with the X url for the filter. When I click the x the page just reloads. I did some digging and I echod the url of the X, and it looks as if it is encoded but not decoded: /products_filter.php?f4%5B0%5D=0-50&cPath=21 The URL of the page after clicking a filter (checkbox) is exactly that as well. If I remove the encoding from the url and just refresh the page to: /products_filter.php?f4=0-50&cPath=21 then clicking the X works. I also have a filter that is images (exact) and when clicked the url is fine and everything works. So it is related to the checkboxes. I've tried looking all over but can't seem to fix it. Any help is appreciated!
  19. What happened to the updates to this addon?
  20. sackling

    Credit Class & Gift Vouchers (CCGV) for 2.3.1

    aannnd I just realized I never checked out gv_send.php looks good!
  21. sackling

    Credit Class & Gift Vouchers (CCGV) for 2.3.1

    Just an addon to my last post. According to the add-on description it says the following: Customers can send GC Balances to friends via email Am I missing out on how this is done? I bought a test gift certificate and then approved in in the admin. But now I can only seem to apply it to my orders on checkout.
  22. sackling

    Credit Class & Gift Vouchers (CCGV) for 2.3.1

    I have the module installed and working. I have a question about gift cards though. Right now how it works is, someone pays for the gift card. then the card is approved and the amount is credited to their account. I'm not sure anyone will do this though? At least not for my store which is selling physical goods. The way I pictured it is people would have the ability to enter someone's email, and then the gift card would be emailed to them with the ability to create the account or use an already created account. Is this possible without further modification? Or do people use gift cards differently?
  23. sackling

    CCGV Shipping error ( skipping all together )

    Hey thanks for the post. You were right probably. I just had the same problem and it was because the weight of the items were all 0 (which I had because we use flat rate shipping and never bothered to change it.
  24. sackling

    Discount Coupon 2.3 not quite working

    I am having the same "problem" with this add-on. It took me a while but I figured out what was going on. The "number of use" should really be renamed to: "number of use per user" So if it is 1, the same user can only use it 1 time, but anyone else can use it. This is not the functionality that I want per se.. I need the codes to sometimes act as gift codes. I will have to look into either another add- on or try to hack something in. but just a heads up for anyone else if it's hard to understand what is going on/ why it sometimes seems to work.
×