Jump to content

sackling

Members
  • Content count

    298
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by sackling

  1. sackling

    FedEx Direct 2.06 Support thread

    I have this module installed. It is reporting the quotes correctly. Is there anyway to actually have it connect with fedex though so that when the order is processed it gets attached with my fedex account? Is that supposed to be happening?
  2. I submitted just one page into the fetch as googlbot option. the page I put in was this: http://www.mysite.com/baffin-derrick-work-boots-p-401.html the error I got was this: HTTP/1.1 302 Moved Temporarily Date: Sun, 06 Feb 2011 00:11:46 GMT Server: Apache X-Powered-By: PHP/5.2.15 Location: http://www.mysite.com/cookie_usage.php Vary: Accept-Encoding Content-Encoding: gzip Keep-Alive: timeout=2, max=100 Connection: Keep-Alive Transfer-Encoding: chunked Content-Type: text/html does that imply something was wrong with my cookie_usage.php file?
  3. Here is the sitemap in question: http://bit.ly/fYaFRX (shortened so google doesnt pick this up sorry) I just resubmitted that same file again but without the SEO Urls to see if it helps. I turned on SEO urls again though so it might still give the error even though the sitemap is showing the ID's in the url. I don't see any missing www. I am pretty sure it is because the urls are redirecting via 301s?
  4. This contribution is working on my site in terms of making the product urls look good. however after about 2 weeks I have this warning on google webmaster about my sitemap: URLs not followed When we tested a sample of URLs from your Sitemap, we found that some URLs redirect to other locations. We recommend that your Sitemap contain URLs that point to the final destination (the redirect target) instead of redirecting to another URL. This is exactly what the contribution does, it uses htaccess to redirect to a nicer link but I am questioning if it actually has a negative effect on SEO. Can anyone shed some light on this? Am I doing it wrong? Should I be using the none seo urls in the sitemap?
  5. sackling

    Header Tags SEO

    After transferring over to my live site it seems as though the favicon is no longer popping up. Is this related to this contribution?
  6. sackling

    Header Tags SEO

    well after dropping all the rows I clicked find missing pages. This sort of worked.. It added all the files to header_tags.php but for some reason cut off a large portion of the names so I had to go in and manually edit the names.
  7. sackling

    Header Tags SEO

    looks like dropping the rows in the database works and is a lot quicker.
  8. sackling

    Header Tags SEO

    Ok I changed all the filename definitions however I need to "delete" and re-add all of them through the admin. Is there a quicker way to do that than to do each one individually?
  9. sackling

    Header Tags SEO

    It actually won't take long at all to replace all the filenames to look like that as its only in filenames.php and my header. I just didn't know the naming scheme it had to be.
  10. sackling

    Header Tags SEO

    Ok well I found the problem. It is due to my filename.php naming scheme being different then the standard I believe. So for instance one of my pages was defined in filenames.php as: define('CAT_BAFFIN_ALL', 'cat_baffin_all.php'); And then in header_tags.php it show up as follows: // cat_baffin_all.php case (basename($_SERVER['PHP_SELF']) === FILENAME_N_ALL): if (! ReadCacheHeaderTags($header_tags_array, basename($_SERVER['PHP_SELF']), $language, '')) { $header_tags_array = tep_header_tag_page(FILENAME_N_ALL); WriteCacheHeaderTags($header_tags_array, basename($_SERVER['PHP_SELF']), $language, ''); } break; If I change the FILENAME_N_ALL it works. Is there a way to somehow automate that? I kind of doubt it.
  11. sackling

    Header Tags SEO

    I just got done installing this contribution and it went smooth as butter. My product pages and index are working perfectly. Almost everything is working perfectly. The problem I am having is that on my custom pages which I have added the code to the header and are in the root of my site. They are only displaying the default header tags. So anything I type in the page control admin has no effect on them. This is not true for product_info.php or for index.php but all of my custom pages are like that. I unchecked the three default checkboxes as well. this is the only code I added to the page maybe there is something else I need? <?php /*** Begin Header Tags SEO ***/ if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) { require(DIR_WS_INCLUDES . 'header_tags.php'); } else { ?> <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <title><?php echo TITLE; ?></title> <?php } /*** End Header Tags SEO ***/ ?> Is there something I am missing?
  12. sackling

    [Contribution] Additional Images Module

    Hello all, I just installed this contribution on my test site and have a couple of problems. 1. All of my product_info main images are not showing up unless I add a second image. Once I add a second image as the "Thumb or Single Large Image" then the original image and the second image show up correctly. But I'd like to have all my images show up without doing this in case there is no alternate image needed. 2. when I add a second image to the "Products Info Image" instead of the "Thumb or Single Large Image" the image is just a shrunken version of the main image no matter what I choose. Any idea on what could be causing this?
  13. **Solved** was a problem with creating the file in notepad without using quotations around my file name. It is working perfectly now.
  14. So I've got some help from someone on that thread and my configure file is now changed like so: <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.sackling.com'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'www.sackling.com'); define('HTTPS_COOKIE_DOMAIN', 'www.sackling.com'); define('HTTP_COOKIE_PATH', '.sackling.com'); define('HTTPS_COOKIE_PATH', '.sackling.com'); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_IMAGES_CAT', 'images/product_mid/'); define('LARGE_IMAGES', 'images/product_big/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_WS_CATALOG', '/catalog/'); define('DIR_FS_CATALOG', '/home/gostwear/www.sackling.com/catalog/'); define('DIR_FS_DOWNLOAD', DIR_FS_catalog . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_catalog . 'pub/'); // define our database connection define('DB_SERVER', 'mysql.site.com'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'user'); define('DB_SERVER_PASSWORD', 'pass'); define('DB_DATABASE', 'database'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' ?> everything seems to be fine in here. except when I add the htaccess file the directory still "dissapears" from the index of files you see if you go to sackling.com right now the htaccess is deleted so you can go to the catalog here for instance: http://www.sackling.com/catalog/cat_coveralls_pollycotton.php and there are no issues. is there anything you can suggest I look at? my htaccess is still the same as before: # Begin Ultimate SEO V2.2d Options +FollowSymLinks RewriteEngine On # RewriteBase instructions # Change RewriteBase dependent on how your shop is accessed as below. # http://www.mysite.com = RewriteBase / # http://www.mysite.com/catalog/ = RewriteBase /catalog/ # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ # Change the following line using the instructions above RewriteBase /catalog/ RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING} # End Ultimate SEO V2.2d
  15. Thanks for the reply. I have been to that thread for a large portion of the day. I will post there now. Is there anywhere in particular that you see my config file is not setup correctly? I feel like I'm taking crazy pills it all looks good to me!
  16. I am having some issues with "the most common problem". I have ultimate SEO working on my localhost (except for the fact that the OsIds are staying between pages, but that is why i need to test online) but I am trying to get it working on my online test site. you can see the test site here: http://www.sackling.com/catalog/cat_coveralls_all.php (dont go to sackling.com/catalog directly because there is a redirect there still i was lazy to remove) I passworded the test site login: sackling password: testsite the second I add the .htaccess file to the catalog directory all of my pages inside the catalog directory go 500 internet error. if you go to the site root www.sackling.com the catalog folder completely disappears when adding the .htaccess file. I have tried reviewing/ comparing my two configure.php files to no avail. I can't for the life of my figure out why this is working on my localhost but not online! any help is greatly appreciated! here are my files with the database login info changed up. catalog/includes/configure.php: <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.sackling.com/catalog/'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'www.sackling.com'); define('HTTPS_COOKIE_DOMAIN', 'https://www.sackling.com'); define('HTTP_COOKIE_PATH', '/www.sackling.com/catalog/'); define('HTTPS_COOKIE_PATH', '/catalog/'); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_IMAGES_CAT', 'images/product_mid/'); define('LARGE_IMAGES', 'images/product_big/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_WS_CATALOG', '/catalog/'); define('DIR_FS_CATALOG', '/www.sackling.com/catalog/'); define('DIR_FS_DOWNLOAD', DIR_FS_catalog . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_catalog . 'pub/'); // define our database connection define('DB_SERVER', 'server'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'user'); define('DB_SERVER_PASSWORD', 'password'); define('DB_DATABASE', 'database_name'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> admin/includes/configure.php: <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.sackling.com'); // eg, http://localhost - should not be empty for productive servers define('HTTP_CATALOG_SERVER', 'http://www.sackling.com/catalog/'); define('HTTPS_CATALOG_SERVER', 'https://www.sackling.com/catalog/'); define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT', '/www.sackling.com/catalog/'); // where the pages are located on the server define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required define('DIR_FS_ADMIN', '/www.sackling.com/catalog/admin'); // absolute pate required define('DIR_WS_CATALOG', '/catalog/'); // absolute path required define('DIR_FS_CATALOG', '/www.sackling.com/catalog/'); // absolute path required define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . '/images/'); /* not sure why I ever added these two define('DIR_WS_IMAGES_CAT', 'images/product_mid/'); define('', 'images/product_mid/'); */ define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'admin/backups/'); // define our database connection define('DB_SERVER', 'database'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'user'); define('DB_SERVER_PASSWORD', 'pass'); define('DB_DATABASE', 'database_name'); define('USE_PCONNECT', 'false'); // use persisstent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' ?> .htaccess file: # Begin Ultimate SEO V2.2d Options +FollowSymLinks RewriteEngine On # RewriteBase instructions # Change RewriteBase dependent on how your shop is accessed as below. # http://www.mysite.com = RewriteBase / # http://www.mysite.com/catalog/ = RewriteBase /catalog/ # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ # Change the following line using the instructions above RewriteBase /catalog/ RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING} # End Ultimate SEO V2.2d
  17. sackling

    [contribution] Simple Template System (sts)

    I got it removed from teh product pages. I had to make a copy of header.php and application_top.php then link to the new versions with the 4 lines of sts code in them removed. I am not sure how this was installed originally so I don't know why disabling it in admin did not just work right off the bat, not faulting the contribution.
  18. sackling

    [contribution] Simple Template System (sts)

    Sorry just a small update, It actually appears to be version 4.1 that is installed. However the disabling and removal of the product_info templates still obviously has no effect... Any ideas on where I could look?
  19. sackling

    [contribution] Simple Template System (sts)

    yes it is highly likely there is an older version installed. though the options are in the admin area. Is there any chance there is something I should look for in the configure file to only disable the product info pages? Or am I looking to be out of luck?
  20. sackling

    [contribution] Simple Template System (sts)

    Sorry forgot to mention that disabling the module in admin disable the product pages as well as everything else.
  21. sackling

    [contribution] Simple Template System (sts)

    Thanks for the reply, I do want to continue to use sts and disable the product info portion as you say. In the admin area I have the product info module uninstalled. I have deleted all of the product_info templates in the sts folder in includes including the one in the content folder yet my site continues to launch the product pages in my old template. What can I be missing? You can see it in action here: http://bit.ly/c0RSUl Only the first product though 1445B because the others have urls
  22. sackling

    [contribution] Simple Template System (sts)

    Hi all, I am trying to move away from using STS on my new site overhaul. One thing that I cannot do in the interrum is disable sts from working on my product info pages unless I disable the module in its entirety. I do not want to do this as it would break the functionality of my current store. Under module>s sts in the admin area I disabled the product info portion as well as the index but both have no effect. Can anyone give me some guidance on how I would go about disabling sts only on my product info page so that I can use the regular product_info.php? This won't effect my site because I never used the oscommerce page for my product pages they were all manually made to link to the shopping cart which was then taken over by sts. So any ideas would be greatly appreciated. Thanks so much.
  23. I cam back here after not touching this contribution for a while in hopes of finding some help to the issue I was having on one of my sites. To refresh *ahem* my problem was/is that the coupon code does not show up or apply to the subtotal unless the checkout_confirmation page is refreshed. I have tried this with stock checkout_payment and stock checkout_confirmation pages as well and it works the exact same way! it always needs a refresh. One very odd thing is if I leave the checkout_confirmation page and continue to shop around or whatever then go back and try to apply the code it works without a hitch! I can't for the life of me figure this out.. The refresh "trick" does not work either because it gives the user the popup message saying that the information needs to be resent. then gives the option to resend or cancel. That is not something I can have popping up everytime someone advanced to checkout_confirmation. Any help is GREATLY APPRECIATED! If you want to play around on the site to see the problem in action here is the domain I am working on: http://bit.ly/bbFdFi coupon code is test1
  24. sackling

    OSC-Affiliate

    Hello, I am pretty new to this contribution though I have had it installed for a while. What I don't like about it is that it requires the user to sign up for a second account when they already have signed up for an account on my site. I was wondering if there was already someone out there who has made it so that when the user signs up for an account originally an affiliate account would be created as well. And if anyone has the procedure to share so that I can do it to that would be amazing! Thanks. If you have any tips on getting started on this I would greatly appreciate that as well. Rob
  25. One more thing to say about this right now.. I am pretty sure the problem does not have to do with checkout_confirmation page so much as it does checkout_payment. I say this because if I am in the same session after going to checkout confirmation once, then back to the card, I can change quantities and then the coupon code and checkout_confirmation will not require a refresh again. it takes the new coupon code. Actually typing this out I don't think that narrows it to checkout payment. But just saying..
×