Jump to content

smashing_machine

Members
  • Content count

    9
  • Joined

  • Last visited

Posts posted by smashing_machine


  1. Hi there. I have it working with only one problem... When I change a product's model number I would have expected it to remove the old (since it didn't exist in my file) and add the new product with the new model numbers. It doesn't and actually adds the new one but doesn't do anything to the old.....

     

    Is there any easy fix (okay not a fix but an answer to my question)? Right now of course I can just go in and remove the products I do not want. I just figured there might be a way to always have a master list because in my case there are very few products for sale on our site.

     

    Thanks for your help.

     

    ep will add a new product if there's a new model number for the product or if it's placed in a new category. but i believe you can remove the old product by typing "Delete" instead of "Active" in the v_status field, or you can set it as "InActive" to keep the item in your ep file without having it show up on your site.

     

    HTH.

     

    Mike


  2. Hi,

     

    It talks about Table 'MyoScommerceDatabase.MyphpListDatabasephplist_user_user'. Is PHPList using the same database as your OsCommerce database?

    PHPList NEEDS to be on its own database. Is PHPList already running properly for you?

     

    I believe there is a config file for PHPList where you need to set the hostname and database name. The hostname should simply be 'localhost' as the MySQL server is running on your web server.

     

    Cheers,

    Chris

     

    Chris,

     

    I checked out the phplist forums, and found the topic where this contribution started out. It looks like there were some changes to the code to simplify things if you have phplist in the same database. Do you have the original files prior to those changes. If so, I'd appreciate if you could send those to me. I've got a solution for signing up via the home page without an account, and administration once they have an account, but I don't have a solution for the create account part of the process.

     

    Thanks for your help Bro :thumbsup:,

     

    Mike


  3. Hi,

    Just installed article manager 1.2b) with spanish translation and it works great admin side but the articles box displays this:

     

    1054 - Unknown column 'a.authors_id' in 'on clause'

     

    select a.articles_id from articles a, articles_to_topics a2t left join topics_description td on a2t.topics_id = td.topics_id left join authors au on a.authors_id = au.authors_id, articles_description ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '10' and td.language_id = '10' and a.articles_date_added > SUBDATE(now( ), INTERVAL

     

    If I take out the a. then it displays ok but each article is multiplied by the number of authors and then i have this message:

    1054 - Unknown column 'a.authors_id' in 'on clause'

     

    select count(*) as total from articles a, articles_to_topics a2t left join topics_description td on a2t.topics_id = td.topics_id left join authors au on a.authors_id = au.authors_id, articles_description ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '10' and td.language_id = '10' and a.articles_date_added > SUBDATE(now( ), INTERVAL '30' DAY)

    Since i don't know anything about SQL , can someone help me on this?

     

    Thanks

     

    I had this problem. I wrapped the FROM statements in () and it works fine now. Something to do with the way the new MySQL 5 functions are prioritized.

     

    before - ("select count(*) as total from " . TABLE_TOPICS . " where parent_id =

    after - ("select count(*) as total from (" . TABLE_TOPICS . ") where parent_id =

     

    HTH


  4. Hi,

     

    It talks about Table 'MyoScommerceDatabase.MyphpListDatabasephplist_user_user'. Is PHPList using the same database as your OsCommerce database?

    PHPList NEEDS to be on its own database. Is PHPList already running properly for you?

     

    I believe there is a config file for PHPList where you need to set the hostname and database name. The hostname should simply be 'localhost' as the MySQL server is running on your web server.

     

    Cheers,

    Chris

     

    Hey Chris,

     

    PHPList is working fine and it's installed in a seperate database. After seeing the oscommerce database at the beginning of the that error I'm beginning to think it's a problem with the way the sql queries are put together in account_newsletter.php, but I'm not sure.

     

    The host name isn't localhost for this installation because I'm in a shared server environment. When you create a new database you have to create a new hostname for that database, so no two are the same. That's why I thought that might be an issue.

     

    Thanks again,

     

    Mike


  5. Can you please explain what you mean a bit further?

     

    Regards,

    Chris

     

    Absolutely, I have a different hostname for my phpList database, and I didn't see anywhere in the configuration where you could specify the database hostname. That leads me to believe that for the database queries it's using the DB_Server define from the configure.php. I could be wrong, the error I'm recieving is an 1146 Table 'MyoScommerceDatabase.MyphpListDatabasephplist_user_user' doesn't exist. This is happens when I access the account_newletter.php from account.php.

     

    Hope that helps, let me know if you need more info.

     

    Cheers,

     

    Mike

×