Jump to content

Micke

Members
  • Content count

    193
  • Joined

  • Last visited

Everything posted by Micke

  1. Micke

    Seperate Pricing Per Customer v3.5

    Is it as simple as this - if the ID of the group is 13? update products set products_hide_from_groups = concat(products_hide_from_groups, ',13') update categories set categories_hide_from_groups = concat(categories_hide_from_groups, ',13'); ...or am I missing something?
  2. Micke

    Seperate Pricing Per Customer v3.5

    This worked fine for me too. Now I'll be adding a few customer groups who will only see 20 or 30 different products of the total of approximately 1500. I would really want to start with a customer group where all products (and maybe categories too) are hidden and then manually "unhide" them at product level. Having a checkbox for "Hide all products" when adding a new customer group would be ulitmate for me but I'm sure there must be a neat query for that too. How would a query for that look? //Micke
  3. Micke

    Seperate Pricing Per Customer v3.5

    Hi Jan! You are right. I don't want a checkbox for each customer group. Only one checkbox per product in the selected customer group. Just like the price field. The SQL-trick works just fine, but that's not what I need. Thats more like a "hide product by default" function(which of course is quite nice)... //Micke
  4. Micke

    Seperate Pricing Per Customer v3.5

    Hi all! I've got 11 customer groups and more than 1000 procucts. Everytime I create a new customer group I select it and type in the prices in Quick Updates (for SPPC). Then I have to hide a couple of hundred of products for that customer group. Can Quick Updates be modified so that it can handle hiding of products too? That would save a lot of hours... //Micke
  5. Micke

    Seperate Pricing Per Customer v3.5

    Hi All! Trying to contol currency from customer group I have put the following in my includes/languages/english.php $aresult = tep_db_query("select customers_group_name from " . TABLE_CUSTOMERS_GROUPS . " where customers_group_id = '" . (int)$customer_group_id . " '"); $aresult_array = tep_db_fetch_array($aresult); if ($aresult_array['customers_group_name'] != "Some Group") { define('LANGUAGE_CURRENCY', 'GBP'); } else { define('LANGUAGE_CURRENCY', 'SEK'); } Does'nt work. Is it possible to pull this off somehow? //Micke
  6. Micke

    Seperate Pricing Per Customer v3.5

    Hi All! I'd like to take away the language and currency box from the store front and put it in admin/customers_groups.php. A logged in customer will then have the right price, currency and language (besides the other features like tax, payment and shipping modules). It's not "the taking away from store front"-part that is difficult. It's the adding to the admin/customers_groups.php that I don't know how to solve - if at all possible... or would it be easier to do it in admin/customers.php? //Micke
  7. Got it working! :) The problem was I had another contribution installed called FWR Security Pro. I disabled it and the installation worked like a charm! I have turned FWR Security Pro on again and now I'll see what happens. I hope these two contributions can interact in a good way. If you think I'm wrong - please tell me.
  8. I have done the installation procedure from the beginning - not changing any files. The database is not created and I can not see any messages after setting: $show_result = 'true'; and "attacking" with the URL parameters in the installation instructions. Would it do any good to create the database table manually in phpMyAdmin?
  9. I changed PHP version to PHP 5.2.6 and now the page loads. Must have done something wrong though - I have set: $show_result = 'true'; but no message is showing when I add to the url: and when I look at the admin log report it says: I'll go through the steps all over again.
  10. Hi All. I get this after installing: Any idea whats wrong? //Micke
  11. Micke

    One Page Checkout Support

    Hi All! How do I update from the last version? Is there a few files I should upload to the server or do I need to change core files / edit database? Micke
  12. Hi All! This Suppliers Product Administration Solution is really a combination of other contributions that, with a small addition, will make it possible for you to let your supplier's maintain their products on your site themselves. There is a lot of hard work here if you have a fresh install of osCommerce, but it's a sought after feature. The supplier will be able to: - change the properties you want them to. (Including their price to you) - add their products if you want them to. (You will have to approve and set a selling price for the product yourself though before they go public) - delete the products they supply if you want them to. //Micke
  13. Micke

    [Contribution] STS v4

    Hi All! Sorry to barge in like this here... Just wondered if anyone has made an attempt at a "separate template per customer"... //Micke
  14. Micke

    Cool Flash Carousel Menu

    Thank you! It looks great! The links to the products don't work right now but I'm sure it's fairly easy to fix.
  15. Micke

    Cool Flash Carousel Menu

    Hey Mat! You've got the same SQL problem too? If not I can rule that out... (Maybe we'll find the answer in one of the featured products threads in this forum?) //Micke
  16. Micke

    Cool Flash Carousel Menu

    Did it all over again (exept that last line in the SQL that wont work). Still the same problem. No data in the xml-file and no movie. Maybe I should roll back to 2.0? Or maybe I need to install featured products somehow?
  17. Micke

    Cool Flash Carousel Menu

    The SQL import went fine but the module still will not show the movie... The XML-file in the images directory is still empty. This happened after upgrading to 2.0a. I think I will install 2.0 all over again just to see if I have made a mistake. (Maybe the xml-file will come to life again...)
  18. Micke

    Cool Flash Carousel Menu

    I think it's something else, Phil. What's in your kampanya.xml? emmetje: Nothing we should add in application_top.php or something?
  19. Micke

    Cool Flash Carousel Menu

    You may be right. I can´t run the sql for featured products either... I have another site that runs on the same host using featured products but I thing thats version 1.5.9. The SQL in that is: wich apparently works on my host.
  20. Micke

    Cool Flash Carousel Menu

    Here's an export of my rotator table: ... and it's included in both database_tables.php
  21. Micke

    Cool Flash Carousel Menu

    The first version I tried to install was your 2.0. I liked it because you had developed the admin feature and that it did not seam to be tangeled up with other contributions. 1. I was never able to import the last line in the SQL statement - See earlier post. 2. The structure of my 2.0a update is copied over the 2.0 install. Should i do it all over again according to the 2.0a install instructions?
  22. Micke

    Cool Flash Carousel Menu

    Yes. It's 777.
  23. Micke

    Cool Flash Carousel Menu

    Hi Upgraded to 2.0a. Still not working. Now the XML-file in the image directory is empty and the movie is not loaded. I borrowed Dive Right In Scubas kampanya.xml and edited it to reflect my site with a few products - uploaded it and downloaded it again. Now it reads: <?xml version="1.0" encoding="iso-8859-1"?> <products> </products> The system wipes the file clean it seams... Too bad! This would be such a nice feature!
  24. Micke

    Cool Flash Carousel Menu

    You are not doing anything wrong. I get a "movie not loaded" too... We'll have to find out why the movie does not load. Moreover, looking in the xml-file - the prices are all 0.00 Does not matter that you chmod kampanya.xml to 777 Somehow the system sets all prices to 0... //Micke
  25. Micke

    Cool Flash Carousel Menu

    Hi! Very promising! However, I get this while trying to run the SQL in phpMyAdmin: Anyone got a clue what's wrong?//Micke
×