Jump to content
Latest News: (loading..)

Kelly_Hero

Members
  • Content count

    39
  • Joined

  • Last visited

  1. Kelly_Hero

    [Addon} Modular Front Page

    @ and @@kymation. Thanks for the quick responses! Very helpful!
  2. Kelly_Hero

    [Addon} Modular Front Page

    Hi Jim. RE: Featured Products Carousel Content Module http://addons.oscommerce.com/info/9439 I'm having a problem getting this addon to display on my front page. I've installed the addon in my admin, enabled it and given it an appropriate sort order. While trying to troubleshoot the problem, I noticed that in the User Manual.pdf file, the instructions say to upload the new files to the following directories: catalog/includes/languages/english/modules/front_page/cm_fp_featured_products_carousel.php catalog/includes/modules/front_page/cm_fp_featured_products_carousel.php catalog/includes/modules/front_page/templates/cm_fp_featured_products_carousel.php However, in the zip file, the directory structure has the new files in the content folder, likeso: catalog/includes/languages/english/modules/content/front_page/cm_fp_featured_products_carousel.php catalog/includes/modules/content/front_page/cm_fp_featured_products_carousel.php catalog/includes/modules/content/front_page/templates/cm_fp_featured_products_carousel.php Which is correct? FWIW, I did upload the files into the content folder and installed the addon in the "Content" section of admin, as opposed to the "Front Page" section, the way that I installed other addons for the Modular Front page.
  3. Kelly_Hero

    [Addon} Modular Front Page

    Thank you for your effort, Jim. The code above seems to be working. If I come across anything else, I'll post it here.
  4. Kelly_Hero

    [Addon} Modular Front Page

    I've made another discovery which indicates the issue may not be isolated just to this contribution. I used this code in my header to hide the breadcrumb on the front page: <?php if ($PHP_SELF == 'index.php' && $cPath == '') { echo ''; } else {?> <div class="grid_24 ui-widget infoBoxContainer"> <div class="ui-widget-header infoBoxHeading"><?php echo ' ' . $breadcrumb->trail(' » '); ?></div> </div> <?php } if (isset($HTTP_GET_VARS['error_message']) && tep_not_null($HTTP_GET_VARS['error_message'])) { ?> Sure enough, we get the same behavior. When the site is accessed using index.php, the breadcrumb disappears. When called with "www.mysite.com/" the breadcrumb remains. I don't know if any of this is helping or not, but maybe it will trigger something for someone with more knowledge than me. I realize I know only just enough to be dangerous! LOL
  5. Kelly_Hero

    [Addon} Modular Front Page

    If I've gotten my head around the problem correctly, the problem arises when the condition "this page = index.php" is true. When the site is called without index.php, as in just "www.mysite.com/" the statement = false. We need to be able to determine that this is the front page without saying it is index.php. Once that's determined, then we narrow it down to the state where we haven't accessed any category levels yet. Did that make any sense? In my code above, one of the statements must do the trick. We really don't need the else bit. I just left it in for testing.
  6. Kelly_Hero

    [Addon} Modular Front Page

    OK. I've gotten a little further maybe? I commented this out of all of the module pages: if ($PHP_SELF == 'index.php' && $cPath == '') { To index.php, I changed to this: <?php if ((basename($PHP_SELF) == FILENAME_DEFAULT) || ($category_depth == 'top') || (!isset($_GET['manufacturers_id'])) || $cPath == '') { echo $oscTemplate->getBlocks('front_page'); } else { echo $oscTemplate->getBlocks('boxes_column_left'); } ?> The front page blocks are now showing. I think it must have something to do with using or operators instead of and operators. I tried the same statement above with the &&'s but it didn't work either. The only question now is while this seems to be working on the home page, will it have any adverse effects on any other pages?
  7. Kelly_Hero

    [Addon} Modular Front Page

    Thanks Jim for the super-fast reply! I only told it to display the left-column blocks because I needed something to display if the condition was false, and I knew the left column blocks worked with "www.mysite.com/". You could put in a simple text string and the behavior is the same. I did do a test to see if any particular block could be causing the problem. I installed all of the front page modules and then disabled them one by one, reloading the page(s) in between. The behavior persisted no matter which blocks were enabled/disabled. I'll keep looking and testing and post any results back here.
  8. Kelly_Hero

    [Addon} Modular Front Page

    OK, I may be getting somewhere. I've modified this code in index.php: <?php if ($oscTemplate->hasBlocks('front_page')) { echo $oscTemplate->getBlocks('front_page'); } else { echo $oscTemplate->getBlocks('boxes_column_left'); } ?> With this code added, the left column's boxes display where the front page content should display when the site is called as "www.mysite.com/". The front page blocks display when the site is called as "www.mysite.com/index.php". Any ideas? I can PM you links to my development site if it will help.
  9. Kelly_Hero

    [Addon} Modular Front Page

    Has any progress been made for this issue? I am having the same problem. The Modular Front page only displays if the site is accessed by index.php. I really want to use this contribution, but it concerns me that people visiting my site by just typing in "www.mysite.com" won't be able to see my beautiful homepage, except what's in the header and footer. If I knew more about v2.3.1, I might know where to start looking to solve the problem. I've been working with osC for years, and had gotten pretty good with installing addons and creating custom templates with STS, but figuring things out for v2.3.1 is like learning to ride a bike all over again! Assistance is much appreciated.
  10. Kelly_Hero

    Time Out After Order

    Hi, I need help pinpointing a problem with timing out after confirming an order. When I place a test order and click "Confirm Order", I get: Even though the script times out, the order does write to the orders table and the emails are sent to the customer and all email addresses set in my store's configuration. I think I've narrowed it down to a problem with having a value in the "Send Extra Order Emails to" field. If I delete the value, or if I comment out the lines below in checkout_process.php, it doesn't time out. // send emails to other people if (SEND_EXTRA_ORDER_EMAILS_TO != '') { tep_mail('', SEND_EXTRA_ORDER_EMAILS_TO, EMAIL_TEXT_SUBJECT, $email_order, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS); } The only contribution that I have installed that require changes to checkout_process.php is Zappo's Option Types V2. Any ideas where else I can look to solve this? Thanks.
  11. Kelly_Hero

    Official PayPal IPN Support Thread

    No, this is the first email of this type that I have ever received from any of my clients' stores. The email was sent to my email address as that is the address that is listed in the debug field. The email shown above is not the actual one I received. I just quoted it from this thread because except for the user/order details, it is identical to the email I received. I apologize for not making that clear. The email address listed for the customer in my client's store does not have a dot in it. The weird thing is, upon further investigation, the transaction did eventually get processed. It is marked as a completed transaction in Paypal; it is showing up in the client's Admin under Orders. Here is the information from the order status, if that will give any clues about what happened: 11/06/2006 12:49:50 False Pending PayPal IPN Invalid [Pending; address] 11/06/2006 13:20:49 True Processing 11/06/2006 13:24:30 False Pending PayPal IPN Verified [Completed (Unverified; $49.50)]
  12. Kelly_Hero

    Official PayPal IPN Support Thread

    One of my clients' stores received this email yesterday as well. I've never seen it before. Can anyone shed any light on why this is happening? I have not made any modification on this store in months.
  13. Kelly_Hero

    Seperate Pricing Per Customer v3.5

    Any idea on when SPPC will be updated for the latest release of osC? I'm sorry to be a PITA, but I still have not been able to fix my problem mentioned HERE. I've tried to figure out the query statements myself, but they're just too complex for my brain. Please help.
  14. Kelly_Hero

    Seperate Pricing Per Customer v3.5

    I was also having the same problem. Using the code from this post, I was able to get SPCC running, although it broke 2 other contributions - Featured Products (which I fixed using code found in this post) and Description in Product Listing Hack MS2 v.2.4 (found here). I've been through every file and I think I've narrowed the problem down to this code that Products Description add to index.php Find: case 'PRODUCT_LIST_NAME': $select_column_list .= 'pd.products_name, '; break; Below add: // Products Description Hack begins case 'PRODUCT_LIST_DESCRIPTION': $select_column_list .= 'pd.products_description, '; break; // Products Description Hack ends Find: case 'PRODUCT_LIST_NAME': $listing_sql .= "pd.products_name " . ($sort_order == 'd' ? 'desc' : ''); break; Add below: // ########### Products Description Hack begins ########### case 'PRODUCT_LIST_DESCRIPTION': $listing_sql .= "pd.products_description ". ($sort_order == 'd' ? "desc" : ""); break; // ############## End Added ################# and to advanced_search_result Find: case 'PRODUCT_LIST_MODEL': $select_column_list .= 'p.products_model, '; break; Below add: // Products Description Hack begins case 'PRODUCT_LIST_DESCRIPTION': $select_column_list .= 'pd.products_description, '; break; // Products Description Hack ends Find: case 'PRODUCT_LIST_NAME': $order_str .= "pd.products_name " . ($sort_order == 'd' ? "desc" : ""); break; Add below: // Products Description Hack begins case 'PRODUCT_LIST_DESCRIPTION': $order_str .= "pd.products_description " . ($sort_order == 'd' ? "desc" : ""); break; // Products Description Hack ends Any help getting this sorted would be greatly appreciated.
  15. Kelly_Hero

    [contribution] STS PLUS v4

    Fantastic contribution by the way. This has made my life much easier! Thank you.
×