Jump to content

perfectpassion

Members
  • Content count

    1,317
  • Joined

  • Last visited

Everything posted by perfectpassion

  1. perfectpassion

    Protx Direct v2.22

    With the protx direct module all the processing is invisible to the user. After confirming the details the customer should be returned to an order success page or back to the checkout payment page with an error message as applicable. The debug message looks fine except there's no return info from the protx server - presumably becuase the vendor account isn't up yet. HTH, Tom
  2. perfectpassion

    Protx Direct v2.22

    It does sound like this might be because you are still setting up the account with protx. If you enable DEBUG mode in admin area then test an order - what does it report back? Which server mode are you using (live, test or simulator). Tom
  3. perfectpassion

    Protx Direct v2.22

    Hi Mary, in protx_direct.php the line: $order->info['cc_number'] = substr($HTTP_POST_VARS['protx_direct_cc_number'], 0, 4) . str_repeat('X', (strlen($HTTP_POST_VARS['protx_direct_cc_number']) - 8)) . substr($HTTP_POST_VARS['protx_direct_cc_number'], -4); produces the 1234XXXXXXXX1234 version of the card number. changing it to: $order->info['cc_number'] = $HTTP_POST_VARS['protx_direct_cc_number']; would cause the full number to be stored in the database. You must note that this will cause the full cc number to be recorded in the order status/order emails thus a security risk. I appreciate that you have your database on a secure server however both mastercard & visa rules state that if you are storing cc details in your own database you must be subject to regular independant inspections of the security - you may wish to discuss this issue with either protx or your card merchant. HTH, Tom
  4. perfectpassion

    Stock Check/Money Order Module

    No file editing needed - look in admin under Configuration -> My Store -> Store Address & Phone HTH, Tom
  5. perfectpassion

    Protx Direct v2.22

    Hi Sam, What order total modules do you have installed and what is the sort order for them? Tom
  6. perfectpassion

    Protx Direct v2.22

    glad to hear it's sorted! Tom
  7. perfectpassion

    Protx Direct v2.22

    I'm not sure what ip it is after then if it's still not working, the latest error you've been getting is definately because of this - i would try experimenting adding both ip address etc. If still no success then Protx will be able to set it up directly with the information from the Server IP test. HTH, Tom (just a quick thought - it was the test server admin you added the ip to as it needs to be done separately for the test / production servers).
  8. perfectpassion

    Protx Direct v2.22

    ok, that is caused by Protx requiring requesting server IP addresses to be recorded in your vendor admin area for security reasons. Protx can set this up for you but it's simple enough. Run through a transaction after changing to "Server IP Test" in module admin area Look for the line "REMOTE_ADDR=" or "REMOTE_HOST=" followed by an IP address - note this down Login to the protx admin area (you'll have to do it twice - once for test server and again for live server). Goto Administration->Account Parameters, about half way down the page enter the ip address from above (subnet mask normally 255.255.255.255) then click add. Retry the transaction (don't forget to change back to test server first!) and hopefully it'll be working! HTH, Tom
  9. perfectpassion

    Protx Direct v2.22

    ok from that debug info I can see the problem. The TxType field sent from your store to Protx is "Immediately Charged" - this is not a valid "payment type". It should be set to either PAYMENT, PREAUTH or DEFERRED. This setting is stored in the database and I can only think that this has been left over from a different version. Do you get errors if you change the payment type in admin to either of the other options? I think that it may need you to un-install the module in admin, use phpmyadmin to check and remove any enteries prefixed (MODULE_PAYMENT_PROTX_DIRECT) in the configuration table if any are left over (make sure you backup first) then reinstall the module in admin. let us know how it goes, Tom
  10. perfectpassion

    Protx Direct v2.22

    The reason i suggested cc_validation.php is from the error you are describing Protx is being told that the card type is different to what it should be. If you enable the 'DEBUG' option in admin and then paste the info given after trying a test transaction that may give us some more clues. Thanks, Tom
  11. perfectpassion

    Protx Direct v2.22

    Hi, 1) I can't comment about v1 of Protx Direct - I started at v2. There certainly isn't an option to choose between different cards in the current version of the module. 2) The card numbers given in admin work fine for me, it might be an issue with your includes/classes/cc_validation.php file - have this been copied from the contribution? If the above doesn't help let us know. Tom
  12. perfectpassion

    Protx Direct v2.22

    Glad to hear you got it working, the extra options you've added turnoff the checking of the SSL certificate against the host which in theory reduces the security of the connection but practically I don't see that it will cause problems (if you look through the forums there's a quite a few other people who have done the same thing for different modules - it depends on your server). Good luck! Tom
  13. perfectpassion

    Protx Direct v2.22

    Firstly I've just uploaded an amended package as the previous had the file include/languages/english/cvs_help.php missing. This missing file shouldn't have caused the problems that Guyver & jdenkaat are having. I've got this module install on a live site with 'Cheque' as the only other payment module. I can confirm that it does works successfull but obviously for you both there's something else going on. jdenkaat - the debug string posted looks fine - the CAVV, EIC, XID & 3DSecureStatus variables are all empty at the moment until Protx impement 3D Secure (around April), however you should have more fields, I get: As you can see this includes the reply from Protx's servers. Do you have cURL installed on your server (look in Server Info in admin)? Does anything show in Protx admin if you select 'Failed' and 'Invalid' Transactions? What other payment modules do you have installed? Tom.
  14. perfectpassion

    Protx VSP Direct - MS2.2 Support

    I have just uploaded an update to the module. This combines Vger's changes and also updates the module to Protx's protocol v2.22. This will allow easier integration of 3D-Secure when it is launched (I'm told April 2006 by PRotx). I also found there were problems with the module correctly storing the customer_id & order_id in the protx_direct table that I've fixed - I plan to use this to build in functions to release/repeat/refund payments etc via osCommerce admin. Any probs let me know, Tom
  15. perfectpassion

    Protx VSP Direct - MS2.2 Support

    Hi Vger, I believe you can ignore the client number - I have the integration documents for vsp protocol 2.22 (the latest) and they do not use this with this version so I think it is an obsolete feature. Protx are aiming to launch 3D-secure for VSP direct around april time and i am keen to implement this for my shop so I am currently updating the contribution to v2.22 (from v2.20 protocol) in anticipation. HTH, Tom
  16. perfectpassion

    3DSecure

    As far as I know 3D secure only works with VSP Server and currently there is only OSC support for the VSP form & Direct methods. Protx say that 3D secure will be up and running mid-april so not too long to wait! Tom
  17. perfectpassion

    3DSecure

    Hi janice171, I have the Protx direct contribution installed sucessfully - howeve it is v2.20. I have obtained the specs for v2.22 and (as time allows) I am modifying the protx direct module to v2.22. I have spoken to Protx directly and they inform me that 3D-Secure is not yet implemented by them for VSP direct for any customers yet and they hope to launch it around April time - i will be keen to work on the 3d-secure at that time. HTH, Tom
  18. perfectpassion

    [SUPPORT] HTML Editor and UltraPics by MaxiDVD

    Hi, I have installed it fine but when using the image manager it loads up the image file list fine but when clicking on the filename I get an 'access denied' javascript error. The preview pic show ok but the url link at the bottom stays as "http://". Using a script debugger the problem seem to be in the line: var manager = findAncestor(window.frameElement, 'manager', 'TABLE'); that comes from lister.php, an it's the window.frameElement that has access denied. Any ideas how to remedy this? Thanks, Tom
  19. Hi, Sorry if this had been answered before but i have spent days reading through this forum trying to get things sorted. After having all sorts of problems with this contrib I started with a fresh install of osC and installed only the latest version of this contrib (5.15a1) but it still doesn't work. I only really need the coupon part (at the moment anyway). I installed it using the easy install (since i had a fresh osc install) now when i use a coupon it is correctly applied but I need to get around the payment options problem - that is that a customer enters their credit card details, enters the coupon code, clicks redeem - this applies the discount but then wipes the details and they have to re-enter the credit card details again!! The same happens if you enter payment details and a coupon code but click continue not redeem - it redeems coupon but wipes payment details which have to be entered again. Has anyone come up with a solution for this? Thanks. PS - i have also done an install of zen cart to play with - this has the coupons/gift vouchers per-installed a works without any problems but i'd rather stick with osC - i personally prefer it and it's better supported by you guys.
  20. perfectpassion

    Easy Populate & Products Attributes

    Hi, I sucessfully installed EP on my development server at home and it worked brilliantly. However now i have uploaded the site to a shared server it no longer works! There logged errors are: /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 281 (Notice) Undefined variable: dltype /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 294 (Notice) Undefined variable: download /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 294 (Notice) Undefined variable: download /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 692 (Notice) Undefined variable: localfile /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 692 (Notice) Undefined variable: usrfl /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 762 (Notice) Undefined variable: usrfl /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 1308 (Notice) Undefined variable: products_attributes_stock /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 341 (Notice) Undefined index: v_products_image /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 412 (Notice) Undefined index: v_categories_id /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 454 (Notice) Undefined index: v_categories_name_6 /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 592 (Notice) Undefined index: v_tax_class_id /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 593 (Notice) Undefined index: v_tax_class_id /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 594 (Notice) Undefined index: v_products_price /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 595 (Notice) Undefined index: v_products_price /homepages/10/d148958661/htdocs/store/admin/easypopulate.php: 599 (Notice) Undefined index: v_status The undefined index errors repeat over and over. Any help appreciated - thanks, Tom
×