Jump to content

warrenerjm

Members
  • Content count

    1,143
  • Joined

  • Last visited

Everything posted by warrenerjm

  1. warrenerjm

    Manufacturers Dropdown Anywhere

    Yes thanks Scott So a new infobox would be needed, but it doesn't sound like it would appear in the new product admin page? If I knew all the steps for a complete manufacturers box, dropdown, search etc then I could duplicate it all but with a new names as happens when you want a new page. Julie x
  2. warrenerjm

    Manufacturers Dropdown Anywhere

    Scott Will this duplicate the manufacturers dropdown menu, in the catalogue side & in the admin side, ie when I create a new product it will give me the same there? I want it to say "Shop by Theme" instead of manufacturers & have the themes instead of manufacturers names. BUT I do not want to replace the Manufacturers just create the same facility again. If so great...I would also need the existing products to show a default so I can then go in & allocate any suitable ones to the different themes. Here's hoping... Julie
  3. warrenerjm

    Customer Testimonials v1.0

    I was getting this alot too, so to save me any worry I've removed this contribution. I had the security fix & they weren't getting anywhere but you never know one day they may. It also pushed my site wider so didn't look nice. Back to doing it manually on a normal page.
  4. warrenerjm

    Customer Testimonials v1.0

    Mine isn't doing this but it is pushing the fixed width left & right. I can't find where to reduce the width so the middle column stays the correct size. I have played with a few 100% but I can't get it to affect all of the customer_testimonial page?
  5. warrenerjm

    ULTIMATE SEO URLs avoid google penalties

    Hi Robert I have installed your contribution using v.2.1c & it appears to work exactly as you say & as per testing notes. :thumbsup: Thanks Julie
  6. warrenerjm

    Customer Testimonials v1.0

    Understand. :) I may go down the "contact us page" route as I can still use the admin to add them myself. Thanks Julie
  7. warrenerjm

    Customer Testimonials v1.0

    Hi Robert Could you explain how I could do the above please? 1) I looked at capcha but don't understand how to impliment it. 2) :huh: 3) :huh: I guess the alternative would be to direct the submit button to the contact us form (with a dropdown feedback) instead of to the customer_testimonial_write.php Thanks Julie
  8. warrenerjm

    Customer Testimonials v1.0

    version 3 allows customers to add their own but they have to be agreed by admin before they are made live. This doesn't stop someone overloading it. :angry: Is the above possible for someone like me? :lol: :blush: Thanks Julie
  9. warrenerjm

    Customer Testimonials v1.0

    :lol: I never ask & my husbands never brave enough to say :lol: <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); // Get rid of the nasty people (how does my bottom look?) function ct_sanitise($vartosanitise) { $vartosanitise = preg_replace("/[^0-9]/i", "", $vartosanitise); return $vartosanitise; } ?> Now I have a neater one thanks :thumbsup: Are the other pieces of code optional if you want the hackers to know what you think, or should I add these too? Thanks Julie
  10. warrenerjm

    Customer Testimonials v1.0

    Hi Robert My bottom :blush: now looks like this!! <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> <?php function ct_sanitise($vartosanitise) { $vartosanitise = preg_replace("/[^0-9]/i", "", $vartosanitise); return $vartosanitise; } ?> ie I added it complete Hope that's ok? :) thanks Julie
  11. warrenerjm

    Customer Testimonials v1.0

    Hi Robert I now have: <?php if ($testimonial_id != '') { $full_testimonial = tep_db_query("select * FROM " . TABLE_CUSTOMER_TESTIMONIALS . " WHERE testimonials_id = " . ((int)$testimonial_id) . " ORDER BY RAND()"); } else { $full_testimonial = tep_db_query("select * FROM " . TABLE_CUSTOMER_TESTIMONIALS . " WHERE status = '1' order by rand()"); } while ($testimonials = tep_db_fetch_array($full_testimonial)) { $testimonial_array[] = array('id' => $testimonials['testimonials_id'], 'author' => $testimonials['testimonials_name'], 'title' => $testimonials['testimonials_title'], 'testimonial' => $testimonials['testimonials_html_text'], 'word_count' => tep_word_count($testimonials['testimonials_html_text'], ' ')); } require(DIR_WS_MODULES . 'customer_testimonials.php'); ?> so do I put your line as below? <?php if ($testimonial_id != '') { $testimonial_id = ct_sanitise($testimonial_id); $full_testimonial = tep_db_query("select * FROM " . TABLE_CUSTOMER_TESTIMONIALS . " WHERE testimonials_id = " . ((int)$testimonial_id) . " ORDER BY RAND()"); } else { $full_testimonial = tep_db_query("select * FROM " . TABLE_CUSTOMER_TESTIMONIALS . " WHERE status = '1' order by rand()"); } while ($testimonials = tep_db_fetch_array($full_testimonial)) { $testimonial_array[] = array('id' => $testimonials['testimonials_id'], 'author' => $testimonials['testimonials_name'], 'title' => $testimonials['testimonials_title'], 'testimonial' => $testimonials['testimonials_html_text'], 'word_count' => tep_word_count($testimonials['testimonials_html_text'], ' ')); } require(DIR_WS_MODULES . 'customer_testimonials.php'); ?> and does the bottom mean after the footer code or at the end of the body? I'm not blonde but you can tell I don't get the joke! :lol: ps catalog/customer_testimonial.php is where I'm looking. Thank you Julie :blush:
  12. warrenerjm

    Customer Testimonials v1.0

    Hi Mike Me too :blush: As you said to change this piece of code & it appears to have fixed a security issue with the customer testimonial contribution (& one other has agreed it worked for them) I was wondering if I should make the change too, as I have found it in the new file that was added. :huh: I'm sure version 3 can't be too different as it was based on version 1, which has had a lot of additions. I'm just hoping to learn what the fix is, as I am unable to understand the full implications of this myself. I can change it but I wouldn't know how to test it. Thanks :thumbsup: Julie
  13. warrenerjm

    Customer Testimonials v1.0

    Hi Mike I have found your code in catalog/customer_testimonials.php from v3 Is it right that I make that change too? Thanks Julie
  14. warrenerjm

    Customer Testimonials v1.0

    Hi Does this apply to Customer Testimonials v3 which is a seperate contribution (or has it just been taken from this one?) Thanks Julie
  15. warrenerjm

    Dynamic SiteMap

    Hi Jack I hope you are still supporting yours, as like Robert, I have chosen alot of your contributions down to great coding/install instructions & support. ps I thought you did a articles manager one & I cannot find it! Thanks Julie
  16. I just added the p.products_msrp, to the two following lines I was wondering about this one particularly, as I too cannot find it at all & I have the OSC 060817 version & not RC1 Does anyone know what this code is for please? Can it just be ignored! or is there an alternative code to change? Thanks Julie
  17. Hi I have installed 'On the fly' autothumbnailer V 1.5.1 nate 02631 15/12/05 I know it is an older one, but it worked on my previous site & the ones after are so confusing with add-ons etc. I just wanted on that works. I have oscommerce download 0806, whereas the other site was updated to this version. I have A4 size images ie rectangle landscape & verticle as well as square images, so in the configuration I have the following set 1 1 80 sub categories 80 100 small products 100 100 all products 100 true true In my products_info.php I have set it up to show the whole image, so no thumbnail or "click to enlarge" & the image shows fine, BUT in the products listing of the categories & new products & all products they are all distorting to a square. Please could someone tell me why they are not resizing to the right proportions? I have played around with the configuration & checked the code, but cannot see any differences between the old & new site? Thanks Julie
  18. warrenerjm

    Wishlist 3.0 Support Thread

    Oh well thanks...can't I have your whole site instead then :lol: There are a couple of features I would like to install but the contributions are so muddled that it puts me off. I think I'll leave this for the moment. julie
  19. warrenerjm

    Wishlist 3.0 Support Thread

    Hi Robert Your Wish List is fab on your site. Any chance you can make a contribution, as I am guessing that the password & removing from the wish list are all your own add ons. I too was getting confused which version to use & what are the default features. Thanks Julie
  20. I guess it depends upon which version you are using? I used v1.5.1 because I know that Nates one worked before & the problems I had were resolved. I cannot say for the future ones. This is the one I chose for the second install as I wasn't too sure about the others. Answer to my question...yes *2 does work at increasing the products_info.php images only (as stated in the instructions but I had missed them) Ruth I looked at your site, got warning messages (security) & when I clicked on a category & product everything froze?? Julie
  21. warrenerjm

    Links Manager II

    Happy New Year Jack I'm not too worried about what has been already written as I am still in testing mode & have only added a few. Thanks for your support :thumbsup: Julie ps Much faster now the changes have been made in admin, so all is well :thumbsup:
  22. warrenerjm

    Links Manager II

    Ohhh changed to vertical listing & no image & it's getting faster!! Sorry :blush: so you mean ?? admin/links.php admin/link_categories.php admin/link_contact.php admin/link_featured.php admin/link_status.php Have I missed any? Thanks Julie
  23. warrenerjm

    Links Manager II

    This works for the email link. :thumbsup: Trying to change the settings to see if that helps, such as no image & only the title & url as links (6 total) but still no difference. :(
  24. warrenerjm

    Links Manager II

    Hi Jack I turned Ultimate SEO off but that made no difference. I was told c was the last one working from chemo or to use the one from yesudo? Same as when I tried to use a version of dynamic sitemap that wasn't yours & it failed, so I went back to a version of yours that worked perfectly! What does the errors on the page mean please? Are they slowing it down? This is 389 to 393 in the /catalog/links.php case 'LINK_LIST_TITLE': $listing_sql .= "ld.links_title " . ($sort_order == 'd' ? 'desc' : ''); break; case 'LINK_LIST_URL': $listing_sql .= "l.links_url " . ($sort_order == 'd' ? 'desc' : '') . ", ld.links_title"; Is this how the correct path should look like? http://www.mysite/catalog/links.php?parentid=0&lPath=2 When I check the link in admin it says: Check Result: Error Reading URL They also have the X in the edit area, but when I use the same url in my browser it's ok I think I may need to check my host from reading the thread, but I still can't figure the "unterminated string constant" For the update I can't find a links_manager.php ? Thanks Julie
  25. warrenerjm

    Links Manager II

    ps I have Chemo Ultimate SEO URLs v2.1c as recommended Search engine safe to false My email links show link without catalog in link (can't see solution but found it mentioned) Only 3 links added so far I have downloaded your new v1.8 but cannot find an upgrade from v1.6 or v1.7 to the v1.8 instructions Thanks
×