Jump to content

JaaMor

Members
  • Content count

    85
  • Joined

  • Last visited

Everything posted by JaaMor

  1. Hi there. I am getting this error when I try to view products when on the catalog and clicking a category, then a subcatagory: 1064 - You have an error in your SQL syntax near 'select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p' at line 1 select count(select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = \'1\' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = \'1\' and p2c.categories_id = \'37\' order by pd.products_name) as total [TEP STOP] Can someone tell me where to find this error ( I believe it is admin/categories). Can someone also tell me what the error is? I have been trying to fix this for days now and am at my wits end. Thanks so much for any help. Right now, my site is snafu. www.jewelrycabin.com
  2. Hi Strider. The download enabled is set to true. Anything else you can think of?
  3. Does anyone have any suggestions on how to fix the above error? Thanks.
  4. Ok. I would appear that I have managed to fix the admin/categories.php problem. I do still have this error when I try to view products in a sub-category. 1064 - You have an error in your SQL syntax near 'select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p' at line 1 select count(select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = \'1\' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = \'1\' and p2c.categories_id = \'29\' order by pd.products_name) as total [TEP STOP] If someone could tell me where this error is located and what the error is, I would really appreciate it. I am close to tears now. Thanks.
  5. Ok, I managed to fix the parse errror but I still have the SQL error. Also, now when I go to add a product, I no longer have the boxes to add title tag, products description tag, and product keywords. These are very important features I can't afford to lose. If anyone could help me with the sql error and wouldn't mind checking my admin/catagories file to see what I have messed up, I would be so thankful.
  6. Hi Linda. I sure hope you see this soon as I have done something terribly wrong while installing this fabulous contribution and now my store is snafu lol. I had a real tough time modifying some files and am not surprised that I made a mistake (could be one of many). After reading through the forums and taking several looks at my code, I cannot spot the error. Here are the errors I am getting. When you click on a catagory in the catalog, you get this: 1064 - You have an error in your SQL syntax near 'select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p' at line 1 select count(select p.products_image, pd.products_name, p.products_id, p.manufacturers_id, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = \'1\' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = \'1\' and p2c.categories_id = \'32\' order by pd.products_name) as total [TEP STOP] Now does this mean that I messed up a table? If so, which one and where is the error. Here is the other error I am getting. When I click on store admin, and then catalog, this is what comes up: Parse error: parse error in /hsphere/local/home/jade2001/jewelrycabin.com/admin/categories.php on line 392 I do have your header tags controller contribution installed in categories.php, so I wanted to make sure that I didn't mess up that contribution. Had to modify this file manually. Line 392 is case 'new_product_preview': in the following piece of code. tep_redirect(tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $categories_id . '&pID=' . $products_id)); break; case 'new_product_preview': // copy image only if modified $products_image = new upload('products_image'); $products_image->set_destination(DIR_FS_CATALOG_IMAGES); if ($products_image->parse() && $products_image->save()) { $products_image_name = $products_image->filename; } else { $products_image_name = (isset($HTTP_POST_VARS['products_previous_image']) ? $HTTP_POST_VARS['products_previous_image'] : ''); } break; } } // check if the catalog image directory exists if (is_dir(DIR_FS_CATALOG_IMAGES)) { if (!is_writeable(DIR_FS_CATALOG_IMAGES)) $messageStack->add(ERROR_CATALOG_IMAGE_DIRECTORY_NOT_WRITEABLE, 'error'); } else { $messageStack->add(ERROR_CATALOG_IMAGE_DIRECTORY_DOES_NOT_EXIST, 'error'); } ?> I cringe to think of what else I have done wrong. Any help you can give is greatlly appreciated. Thanks so much Linda.
  7. Thanks for pointing me in the right direction. It was the checkout_process file. Now everything is queueing great. The link is in the e-mail and everything seems fine on that end. The problem I have just noticed is this: I have the gv weight set to 0. All other products do have weights attached to them, although I am using table rate. When I purchase JUST a gift voucher, no shipping is added, which is correct. When I purchase JUST a tangible product, the proper shipping is added. When I purchase a gv AND a tangible product, the shipping reflects the total order, not just the tangible product. I.E. My table rates are based on price. If total purchases equal $15.00, then shipping is $2.95. So when I purchase an item for $15.00 AND a gv for $50.00, I would still like the shipping cost to be $2.95 since only the tangible product is charged shipping. Right now, when you purchase a $15.00 item AND a $50.00 gv, since the total is now $65.00, the shipping reflects the higher total and charges $4.95 shipping. Is there any solution to this?
  8. Hi VJ. I am still trying to get this contribution to work on my ms1 store. Here is my problem. Someone submits a link for consideration. I review the link and then click accept and then submit. Here is the warning I am getting: call to undefined function: tep_validate_email() in admin/links.php on line 83. Now I see where someone else was having this problem. I added the validations.php to my admin/includes (I had already done that). I then added the code you told that person to add in admin/includes/application_top.php. Now here are the warnings I am getting. Warning: file(includes/tld.txt): failed to open stream: No such file or directory in /hsphere/local/home/jade2001/jaamor.com/admin/includes/functions/validations.php on line 85 Warning: Variable passed to each() is not an array or object in /hsphere/local/home/jade2001/jaamor.com/admin/includes/functions/validations.php on line 86 Warning: eregi(): REG_EMPTY in /hsphere/local/home/jade2001/jaamor.com/admin/includes/functions/validations.php on line 97 Therefore, I took out the code that I had added to admin/includes/application.php (I much prefer one warning to three lol). Any suggestions on what to do about the call to undefined function: tep_validate_email() in admin/links.php on line 83 warning? Thanks VJ. I hope to get this up and running soon.
  9. Hi Strider. No I don't have access to the gv after it is purchased.
  10. Hi Strider. The configure code has been fixed. Thanks. As far as the gift voucher queue - My gift voucher model numbers are GIFT100, GIFT50, and GIFT25. I believe I have the models numbers fine so that is not the problem. Any other advice? Thanks Strider.
  11. Anyone have any idea about what to do about my queue problem?
  12. Ok. Unfortunately, I think we all knew I would be back lol. I have read all 77 pages of this topic and have not seen where there is a definite fix for the queueing problem. I have queues set to true. But after I purchase a gift voucher, nothing shows in the queue for me to ok. Because of this, I haven't gotten any further to see if everything goes ok after this fix. Any help would be greatly appreciated. Here is my sort order Discount Coupons 740 Gift Vouchers 760 Low Order Fee Shipping 2 Sub-Total 1 Tax 3 Total 900 Here are the other parameter settings: Display Total true Sort Order 760 Queue Purchases true Include Shipping true Include Tax true Re-calculate Tax None Tax Class --none-- Credit including Tax false
  13. Ok. Actually, line 48 is this line ?> Entire block of code: // define our database connection define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> This has really messed up my site so I am desperately hoping someone can figure out why I am getting those warning messages. Thanks. Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:48) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:48) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67
  14. Thanks!! Between Strider and Fred, I was able to understand exactly what everything meant and I no longer have this on my front page. Warning: The downloadable products directory does not exist: /hsphere/local/home/jade2001/jewelrycabin.com/catalogdownload/. Downloadable products will not work until this directory is valid. Unfortunately, I must have messed something else up because I am still getting this error: Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:48) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:48) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67 Here is where the error apparantly is (Line 48 is define('DB_SERVER_PASSWORD', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> Once I fix this error, I believe all will be well. Can anyone spot the problem. Thanks again!
  15. Actually, here is the block of code that is giving me the above errors. define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> The line in question is define('DB_DATABASE', 'osCommerce'); Can anyone see what is wrong here? I am at my wits end with all of this. Thanks.
  16. Thanks Strider. I will try to fool around with that and see what I can accomplish. Before I do though, I have to fix this new error on my front page. Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:49) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/configure.php:49) in /hsphere/local/home/jade2001/jewelrycabin.com/catalog/includes/functions/sessions.php on line 67 Line 49 is the ?> // define our database connection define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> I have seen this before and have fixed it before by taking out any empty lines before the ?> but this time, there are no empty lines. Any suggestions on what I have messed up now? Thanks Strider.
  17. Thanks for trying to help Fred. I really appreciate it. Strider mentioned these two defines in his reply: define('DIR_FS_CATALOG', '/home/oscworks/work/new_oscworks/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); You pointed out that now I have the constant DIR_FS_CATALOG defined twice. Which should I remove? Also, when you say: Also note the comment "// * DIR_FS_* = Filesystem directories (local/physical)", this means that all constants starting with "DIR_FS_" are local directories of your server. Make sure you have these directories created and that they are configured correct due to security etc. Use "chmod" or similar on Windows to change the permission. Now this define: define('DIR_FS_CATALOG', '/home/oscworks/work/new_oscworks/'); I have no idea where this is supposed to be pointing to. My catalog is where most peoples are: jewelrycabin/catalog (jewelrycabin being the store name). Should I be replacing the /home/oscworks/work/new_oscworks/ with jewelrycabin/catalog ? As far as the download.php is concerned, this is here: jewelrycabin/catalog/download.php Permissions have been set. What do I have to change in configure.php to match where my files are? If you could give me an example, that would be great. I am sorry to be such a pain. I have thought about just uninstalling this contribution so that I don't need the download.php to work but I really like this contribution, so I am very thankful for your quick replies.
  18. I am feeling pretty dense right now. The define('DIR_FS_CATALOG', '/home/oscworks/work/new_oscworks/'); line wasn't there, so I added it. I am not sure what is mean't by adjust to my settings? How should I do this. I have never played with this file before. Any help would be great. Here is what the code now looks like. <?php /* $Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright © 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', ''); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME'])); define('DIR_FS_CATALOG', '/home/oscworks/work/new_oscworks/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); // define our database connection define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?>
  19. Thanks so much for getting back to me so quickly. I am quite a novice at all of this. Am I supposed to add: define('DIR_FS_CATALOG', '/home/oscworks/work/new_oscworks/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); somewhere? Please let me know where to add those lines or modify the lines that exist to match the lines you have supplied. Thanks again Strider. I would like to add a big Thank You for making this contribution fairly simple to install. Your install instructions are so easy to follow, that even a novice like myself was able to follow everything step by step without having any problems.
  20. JaaMor

    Recover Cart Sales

    In my opinon, if they purchase from someone else in that 24 hour period, then they just decided they didn't want to purchase whatever it was from your store. Most people wouldn't have forgotten in that short period of time. I don't think reminding them after a few hours will make a difference. It may, however, seem very intrusive and pushy. I would be turned off if I received such an e-mail within hours. Perhaps the customer is planning on going back in a few days. I prefer to send this message 3-4 days after they have abandoned their cart, just as a friendly reminder.
  21. I have just installed this fabulous contribution and am getting this on my front catalog page. Warning: The downloadable products directory does not exist: /hsphere/local/home/jade2001/jewelrycabin.com/catalogdownload/. Downloadable products will not work until this directory is valid. Now I have enabled downloadable products in admin. Not sure why this message has appeared. Any help would be greatly appreciated. www.jewelrycabin.com
  22. JaaMor

    family 3.0 problems

    Is there a way to use sef urls and still use this contribution? Thanks.
  23. JaaMor

    family 3.0 problems

    I spoke too soon. Everything seems to be working fine. The admin section looks perfect and I can add families and products. When I check them in admin everything looks fine and even when I click on a product in admin that belongs to a family and it takes me to catalog view, the family products show great. However, when I access my products from the catalog section by typing www.jewelrycabin.com, and then going to the products (let's say the elephant jewelry) that I know I have created family for, no family products are shown underneath. I am not getting any errors. Just nothing at all (no family products). Any help would be appreciated. Thanks.
  24. JaaMor

    family 3.0 problems

    I just finished installing this and it works perfectly. Thanks so much for this wonderful contribution.
  25. Hey I fixed the parse error and everything works perfectly. Thanks for the great contribution!
×