Jump to content

billcbos

Members
  • Content count

    28
  • Joined

  • Last visited

Profile Information

  • Real Name
    Bill Champitto
  • Gender
    Male
  • Location
    Boston, MA, USA
  1. billcbos

    [Contribution] Option Types v2

    After scraping through this topic I found a reference to the includes/classes/shoping_cart.php where the author suggests using a previous version of that file. I took the file from his v2 contribution and the products are now being added to my cart. The files can be found at http://addons.oscommerce.com/info/6818. I hope that helps. If you do a search on the topic for "shopping" you will see a number of posts with a variety of different answers. It would have been nice for the author to provide a quick response since this is a known issue but I guess its beneath him, as apparently is the idea of providing some direction around the install steps, which has been posted as a question many times and the only response I saw from him was an attitude filled response that he has better things to do with his time. It's a shame, this contribution is nice and I will hopefully be able to get it to run in production, and he seems to respond to other questions quickly and with great detail. I guess my question wasn't up to his standards. Good luck with your install. shopping_cart.php file
  2. billcbos

    [Contribution] Option Types v2

    I would have liked a response to this post. I have installed the constribution but now products are not being added to the shopping cart. Has anyone experienced this? I've gone through line by line to check the files that I think would be causing this issue and can not find an issue. Any direction would be helpful.
  3. billcbos

    [Contribution] Option Types v2

    I've managed to get this mostly working except right now my shopping cart is not getting populated at all. I can view the product, I get the correct options including the text input field, but when I click add to cart I am sent to an empty shopping cart. Any ideas or thoughts? If this is too vague of an issue, then please elaborate on the appropriate installation procedures. You download includes two main directories, and two different instruction files (txt and html). I initially followed the txt file instructions and reviewed the directories but am confused. The directories include duplicate files, would overwrite my configuration files with incorrect parameters and negate the changes made by following the txt file instructions. I uploaded your catalog directory and then re-applied the changes made using your txt file and html file, but now I am at a state where the shopping cart isn't getting populated. If I have to start over from the top I would like to know the correct installation procedure to follow. Also, I have made changes to the application_top, stylesheet and header files to accommodate a design. So I would prefer to use a process like the instructions in the txt file rather than simply replacing those files. Whatever you can do to help me resolve this I would appreciate.
  4. billcbos

    costs assocaited with use

    I am having trouble figuring out whether there is a charge for using Authorize.net as the gateway. Perhaps this should be obvious but I can not figure this out. My bank rep is trying to find out (they didn't know much at all about merchant services). I am hoping you can give me a quick answer - if I install authroize.net module and set up the merchant account with my bank, will I need to set up another service account with authorize.net with seperate fees and charges? Thanks for helping me out.
  5. I have installed and am successfully using Payment Pro (direc pay). As directed I've also enables PayPal Express. PP works fine, but with express, the following happens. During the checkout I am able to login to PayPal without any issues. When I click the button to return to my website, the page on the shopping cart displays a blank white screen. This is the URL excluding the PayPal token and payerID that was generated on the return. The shopping cart service failed to load the next page based on the return. http://www.freshcutglass.com/osCommerce/ca...rID=XXXXXXXXXXX Can anyone provide some insight?
  6. billcbos

    Just installed Payment Pro... not working

    Correct. I still had some kind of issue with the sandbox however (some account configuration error), but the production is working great.
  7. billcbos

    Just installed Payment Pro... not working

    I want to thank you for all your help. I was still not able to get the sandbox to work BUT the good news is I decided to test out the production version and it worked great. So thanks.
  8. billcbos

    Just installed Payment Pro... not working

    I am using the signature. There is one config setting that I am not sure of. The cURL program location. What is the cURL program and where do I find it. (again sorry for my ignorance on the topic).
  9. billcbos

    Just installed Payment Pro... not working

    Hi, Thanks for the response. I am looking through the checkout_confirmation.php code to determine the change you are suggesting. I am not the most proficient script guy so please forgive my ignorance but can I ask you to verify how I can execute this change. I am enclosing the I think you are targeting. Since there is no form tag in the file, I am uncertain of the change at the top of the nesting. Am I working in the right area? Thanks. Bill C First lines of code in the body: <!-- body //--> <table border="0" width="100%" cellspacing="3" cellpadding="3"> <tr> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- left_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> <!-- left_navigation_eof //--> </table></td> <!-- body_text //--> <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td> <?php if (isset($$payment->form_action_url)) { $form_action_url = $$payment->form_action_url; } else { $form_action_url = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL'); } Last few lines of code in the file: </table></form></td> <!-- body_text_eof //--> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- right_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_right.php'); ?> <!-- right_navigation_eof //--> </table></td> </tr> </table> <!-- body_eof //--> <!-- footer //--> <?php require(DIR_WS_INCLUDES . 'footer.php'); ?> <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
  10. billcbos

    Just installed Payment Pro... not working

    Satish, Thanks for getting back to me. I cut and paste the credentials into my configuration so I am pretty certain they are not wrong. Is there a different setup required for sandbox? If you are certain this is the issue I can take it up with Paypal. Please respond. Thanks. Bill C
  11. billcbos

    PayPal Pro error testing...

    I have no idea what this error is supposed to mean and am hoping that someone can give me a clue. I have Pro 1.1 installed with OsC 2.2 RSC2a
  12. billcbos

    Just installed Payment Pro... not working

    John, Thanks. I found the right version. I uninstalled and reinstalled the module. Once I set the card information collection to the payment page the error went away. I am still in the sandbox right now. When I execute the conformation it returns me to the cart contents page along with the error "Security header is not valid" I will check the forum again but if you have any suggestions please send them along.
  13. billcbos

    Just installed Payment Pro... not working

    I am using OsC 2.2 RC2. In the Admin console of OsC it lists the PayPal pro version as 1.0. I just downloaded the file from PayPal developer central about 3 days ago. There's a version file in the zip folder. All is says is 0.1 The module is PayPal Website Payments Pro (US) Direct Payments. Thanks for checking this out.
  14. Trying to test, but also tried to turn off sanbox. I get the folowing error reagerdless of what is put in the form.... . Error: All payment information fields are required. Eny clues where I can start?
×