Jump to content


  • Content count

  • Joined

  • Last visited

  1. In the cofiguration settings for SEO URLs there is an option called Output W3C valid URLs (parameter string)? which should be set to false. There is a small bug which was corrected on the improved (but not released) versions of Ultimate SEO URLs.
  2. You should NOT remove the rewritebase as that tells the server where to rewrite the URLs! Instead, it'll look like your original code (a forward slash) so that it denotes the root.
  3. If you have checked each directory and the only one present is in the catalog directory try these settings: Options +FollowSymLinks RewriteEngine On RewriteBase /torostore/catalog/ The rewrite rules look good but the base is not correct.
  4. Make sure that you have that rewrite rule in your .htaccess file. The v2.X contribution rewrites more pages than just the categories and product pages...so be sure that you also updated your .htaccess file to accomodate these extra pages.
  5. You're right...the issue is related to the .htaccess files that reside in each directory. For your site it look there are going to be 3 files that you'll have to check. The first is in the root...second in the torostore...and the last one in the catalog directory. The behaviour of .htaccess files is cascading. For example, you can (and probably do) have conflicting rewrite rules in one or more of those .htaccess files. Download each of the files and post them here (making sure to denote which directory each came from). Let's see if we can get this worked out for you.
  6. There is an option under the SEO URLs configuration settings that toggles whether or not to output W3C valid URLs. Turn this setting off (false) and the links should work again.
  7. In addplication_top.php find this code: // Ultimate SEO URLs v2.1 include_once(DIR_WS_CLASSES . 'seo.class.php'); if ( !is_object($seo_urls) ){ $seo_urls = new SEO_URL($languages_id); } and UNDER it paste this code: //// Redirect code for changing product names // 10 January 2006, Bobby Easland // Run a regex to see if there are matches preg_match_all("/(.*)-p-(.*)\.html/", trim($_SERVER['REQUEST_URI'], '/'), $matches, PREG_PATTERN_ORDER); if ( sizeof($matches) > 0 ){ // a match was found // remove the -'s and convert to upper case $uri_name = $matches[1][0]; // get the products ID and case as integer $products_id = (int)$matches[2][0]; if ( defined('PRODUCT_NAME_' . $products_id) ){ // defined name $defined_name = seo_urls->short_name(constant('PRODUCT_NAME_' . $products_id)); // if they don't match let's redirect if ($products_id != 0 && $uri_name != $defined_name){ $url = tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products_id, 'NONSSL', false); header("HTTP/1.0 301 Moved Permanently"); // send the 301, moved permanently header // close session (store variables) tep_session_close(); header ("Location: " . $url); // redirect...bye bye } # end if } # end if } # end if It's not tested but should get you most of the way there...
  8. Most likely you have CGI mode PHP installation (versus SAPI) and the redirect code will need a few minor tweaks. Check your configure.php file and make sure the cookie settings are correct. The contribution should not affect the login portion of the site nor the sessions. You'll most likely have to debug the installation to find out what is going on.