Jump to content

mcbsolutions

Members
  • Content count

    170
  • Joined

  • Last visited

Everything posted by mcbsolutions

  1. mcbsolutions

    HoneyPot Captcha

    Hello, I'm getting a few spams that got through with just one character and also long junk strings like this +ROW(1%2c1)%3e(SELECT+COUNT(*)%2cCONCAT(CHAR(95)%2cCHAR(33)%2cCHAR(64)%2cCHAR(52)%2cCHAR(100)%2cCHAR(105)%2cCHAR(108)%2cCHAR(101)%2cCHAR(109)%2cCHAR(109)%2cCHAR(97)%2c0x3a%2cFLOOR(RAND(0)*2))x+FROM+INFORMATION_SCHEMA.COLLATIONS+GROUP+BY+x)a)%2b% Also what is best way to add an array of domains to block, such as domain.com, example.com, etc. Thank you for the help!
  2. mcbsolutions

    HoneyPot Captcha

    Thanks for this add on Jack. It has cut down alot on spammers and works well for me. I would like to block any spammer using gmail.com. Could you shed some light on how to add this in? Thank you.
  3. mcbsolutions

    PayPal Website Payments Pro Hosted Solution (Official)

    Hi all, I'm using this on a modded 2.2 site. Everything is fine but the order comments I receive from the customer are being cut off. I will not get more than one line of text in the comments. Usually the customer types multiple lines of text because the comments are used on every order this store receives. Thanks for any help! Dan
  4. mcbsolutions

    Testing New PayPal Express Checkout Module

    Paypal now has a new In-Context Checkout Experience. I would like to offer this to my customers in hopes of better conversions. Please advise if there are plans to update this module. In speaking with Paypal, they may be willing to help with updating the module code as well, so it remains certified. Here is the link for more information https://developer.paypal.com/docs/classic/express-checkout/in-context/integration/ Thanks!
  5. mcbsolutions

    Testing New PayPal Express Checkout Module

    I'm using this on a 2.2RC2A store. From this thread http://forums.oscommerce.com/topic/377501-paypal-will-not-convert-description-with-payment/?p=1594287 tried the following code //DESC $params['L_PAYMENTREQUEST_' . '0' . '_' . 'DESC' . $line_item_no] = ''; for ($j=0, $o=sizeof($product['attributes']); $j<$o; $j++) { $params['L_PAYMENTREQUEST_' . '0' . '_' . 'DESC' . $line_item_no] .= $product['attributes'][$j]['option'] . ':' . $product['attributes'][$j]['value'] . ', '; it adds the product name correctly to the PP confirmation email but not the attributes. They appear as Item # 25{4}215{3}203{1}47{2}201 where each value is an id. i want the production options name and its value, ie Size: Large. Thanks for any assistance!
  6. mcbsolutions

    Installation of PayPal Express (Payflow Edition)

    In your test site, (not live), I would uninstall the old modules, delete the old files, and revert any code changes they required. then make sure you have installed the new ones correctly one more time. use file comparison tool makes it go smoothly and you don't miss anything. Personally i also delete any of those payment modules i know i will never use. They just add clutter in the way of modules area in admin. I say test site as you dont want to break your live site until you have the test site modules appearing. if they appear then you should be able to install, configure, and test in sandbox mode on the live site, until you are ready to switch to live mode.
  7. I finally got the mobile site loading, the problem ended up being trying to use local/configure.php. Despite my change of the code below it wasnt working. Only after i edited includes/configure.php did it work. // load server configuration parameters if (file_exists('includes/local/configure.php')) { // for developers require((defined('MOBILE_SESSION') ? '../includes/local/configure.php' : 'includes/local/configure.php')); } else { require((defined('MOBILE_SESSION') ? '../includes/configure.php' : 'includes/configure.php')); } Site loads but now when I click on something, nothing happens, just the little spinner goes round without any page movement.
  8. Well, in looking at someone else's configure.php i fixed it so my site loads ok, but after loading the /mobile directory, I'm now getting Warning: require(includes/functions/compatibility.php): failed to open stream: No such file or directory in /var/www/it2334/includes/application_top.php on line 41 Fatal error: require(): Failed opening required 'includes/functions/compatibility.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/it2334/includes/application_top.php on line 41 in reviewing this thread raiwa, you mentioned about fixing code in application_top, but the documentation for the most recent version did not reflect that change. you mentioned this is the fix $mobile_site = (($request_type == 'SSL') ? DIR_WS_HTTPS_MOBILE : DIR_WS_HTTP_MOBILE) . $mobile_site . '?' . rtrim (tep_output_string(tep_get_all_get_params()), '&'); } else { $mobile_site = (($request_type == 'SSL') ? DIR_WS_HTTPS_MOBILE : DIR_WS_HTTP_MOBILE) . $mobile_site; but code in the documentation has a different variable, $mobile_url I want to be sure which is correct?? Thank you!
  9. Hi, i appreciate your work on this! I can't seem to get past an error with my configuration. I'm working with 2.3.3.4 on a linux vm for testing (its not a live environment). Warning: require(/mobile/includes/classes/mobile_redirect.php): failed to open stream: No such file or directory in /var/www/it2334/includes/application_top.php on line 518 Fatal error: require(): Failed opening required '/mobile/includes/classes/mobile_redirect.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/it2334/includes/application_top.php on line 518 so line 518 says this: require(DIR_FS_MOBILE . 'includes/classes/mobile_redirect.php'); My DIR_FS_MOBILE IS defined as define('DIR_FS_MOBILE', DIR_FS_CATALOG . 'mobile/'); and DIR_FS_CATALOG is define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/'); I dont understand why this code does not point me to the correct path. The file is indeed in the path. What am i missing? Thank you!
  10. mcbsolutions

    The Feedmachine Solution

    Hi, I'm having same issue running a cron job. The cron job runs but the report says update status: feed not updated(0) upload trigger status: feed upload not triggered(0) upload status: feed was not uploaded(0) I have to upload manually for time being. What am I missing here? I'm running the version for Osc 2.2 which is v 5.03 it appears. Thanks!!
  11. mcbsolutions

    The Feedmachine Solution

    Is this compatible with 2.3? This is a must have for me if i upgrade to 2.3. Thanks!
  12. Hi, I'm using the OSC-CSS add on, and trying to implement some of Yahoo's YUI modules, etc. I'd like to get a YUI3 menu working with my store such as this one. http://yuilibrary.com/yui/docs/node-menunav/menunav-leftnav.html Anyone done this yet with YUI3? I'd be thankful for someone to help me out on getting this my categories menu talking to this. Thanks!! Steve
  13. mcbsolutions

    Official Dwolla Support Thread

    Hi, installed the new version. Signed up for my business dwolla acct. Under payment mod config it asks for the The API hash value to verify transactions with. All I get from Dwolla is the API key and code which I entered. Is the API hash value necessary and if so where do i get it? Thanks!! Steve
  14. mcbsolutions

    OSC to CSS v2

    Got it resolved, I just had something in a custom infobox in the right column that was the problem. Took awhile to figure that out. Maybe this helps someone if they have a similar issue.
  15. mcbsolutions

    OSC to CSS v2

    I'm implementing this on a 1200 pixel grid. I updated my 960.css file accordingly. I'm having just an issue with my grid breaking down somewhere and can't figure out where. This is causing the footer to not display. In my working test install I should be getting html like this. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html lang="en" dir="LTR"> <head> <body> <div class="container_24"> <div id="header" class="grid_24"> <div class="clear"></div> <div id="column_left" class="grid_5"> <div id="content" class="grid_14"> <div id="column_right" class="grid_5"> <div class="clear"></div> <div id="footer" class="grid_24"> <div class="clear"></div> </div> <div class="ui-dialog ui-widget ui-widget-content ui-corner-all " style="display: none; z-index: 1000; outline: 0px none;" tabindex="-1" role="dialog" aria-labelledby="ui-dialog-title-1"> </body> </html> But what I get is this below in a site I am converting to this new version of osc-css with a 1200 grid. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html lang="en" dir="LTR"> <head> <body> <div class="container_24"> <div id="header" class="grid_24"> <div class="clear"></div> <div id="column_left" class="grid_5"> <div id="content" class="grid_14"> <div id="column_right" class="grid_5"> </div> <div class="cart_status" style="display: none;"></div> </body> </html> You might need to paste these into your favorite file comparison tool to see the difference. I'm also not sure why the div class for cart_status is not pulling in the correct results. I checked my working code vs. non working code in the relevant areas and all is the same. So I am missing something but not sure where the problem lies. Thanks for any assistance.
  16. mcbsolutions

    OSC to CSS v2

    Hi George, thanks for reply and your work on this contribution. I'm getting my head around it now and so far so good. I'll keep my eye on those two divs you mentioned as yes I'm aware that they are set by the code in boxes.php The code I posted is working for me, just wasn't sure if this was the best workaround.
  17. mcbsolutions

    OSC to CSS v2

    Not sure this is the best way to do this, but here's how I made it work. in styles.css, added .custominfoboxcontents{ text-align: center; } then in the custom info box added in new cssinfoBoxHeading($info_box_contents, false, false); $info_box_contents = array(); ?> <div class="custominfoboxcontents"> <?php $info_box_contents[] = array('text' => 'bla bla bla'); new cssinfoBox($info_box_contents); } ?> </div> If anyone has a suggestion please post. Otherwise I hope it helps someone else.
  18. mcbsolutions

    OSC to CSS v2

    Hi, what version of IE are you referring to? In IE9 it seems ok. In answer to number 2, you can change the Tabs in product_info.php Find this code around line 220. <!--start ui tabs--> <ul class="tabs"> <li><a href="#tab1">Reviews</a></li> <li><a href="#tab2">Manufacturer Info</a></li> <li><a href="#tab3">Notifications</a></li> <li><a href="#tab4">Tell a Friend</a></li> </ul>
  19. mcbsolutions

    OSC to CSS v2

    Hello, In an infobox, what is the best way to center an image using this CSS version? Pulling my hair out trying several things and its not centering. I'm sure there is an easy fix. Thanks!! Steve
  20. mcbsolutions

    Facebook Connect Support Thread

    Hi, A few questions here. Does this work well with the PWA (purchase without account) mods and I'm assuming it won't interfere with any payment modules such as Paypal IPN or Authorize.net, right? If I understand how this works, a customer can use their Facebook login details to speed up the checkout process? Is this all it does? Thanks for the help! Steve
  21. mcbsolutions

    [CONTRIBUTION] Authorize Net AIM module

    Thanks Kevin for the quick reply. Yikes, the one I am using does store the cc info still. I installed a manual way to zero the cc info out, but this is not ideal. Is the best one to use the AIM module contribution by Harald Ponce de Leon? I figured it might as I just saw his today while searching through them. I installed the "other" one.
  22. mcbsolutions

    [CONTRIBUTION] Authorize Net AIM module

    Hi all, Back in November 2007 Authorize.net came out with CIM, customer information manager, see release info below. It's $20 a month, but seems well worth it as a PCI issue can put you out of business overnight if your not careful. Not to mention possible lawsuits. How do other solutions compare to this? It sounds good but maybe there are better options for PCI compliance. I like the fact that we won't be storing credit card info on the server. If anyone is using this, is there code out there for this? Thanks for your help! Steve
  23. mcbsolutions

    RSS News

    Thanks Jack, that worked good for now! Steve
  24. mcbsolutions

    RSS News

    Hi Jack, thanks for the contribution. I was wanting to display feeds in a regular page such as information.php as opposed to the infobox. Not sure best way to code this. Thanks for the help! Steve
  25. created new topic by mistake..ignore post sorry
×