Jump to content

masat

Members
  • Content count

    296
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Tim Fortune
  1. masat

    Paypal Payments Standard - Issue with shipping address

    Has this been resolved? If so what happened. btw the link on product pages click here to see sample posters is a 404
  2. masat

    Margin Report v1.00

    Chris I think the added functionality would work well and allow for easier analysis of the numbers. I really liked that idea that was posted back in the original support thread about being able to plug a number into any one of the spots and have osc generate the other numbers for you. I have talked with alot of people that seem to have no concept of profit/loss, margin, markup, discount. This was the main reason I jumped on this contrib the minute I came across it. Very nice job indeed. The store owners I have built stores for really appreciate having that module available. I think it is one of the most impressive modules in the admin panel. To be able to see that info at a glance is very very cool and can be a real butt saver if you happen to make a typo and don't catch it. Your module kind of waves a flag and says "Hello we have a problem here Houston". Speaking of that maybe you could add in a color coded marker if a product is set belowa certain margin that can be defined in admin. Tim
  3. masat

    Margin Report v1.00

    Hi Chris, As you can see we have been battling with this thing all morning and have resolved several issues. I just came across your original thread and posted there. We are not able to download to our local machines from the web. My store and the contrib work great on my local server but trying to download from the web fails. Could you bail us out? Thanks, Tim
  4. masat

    [Contribution] Cost Module v1.00

    Hi Chris, Great contrib. I develop on my local server and have had no problems other than the defines deal. I was working in another thread this morning and ended up discovering that I am not able to export to my local machine from a www site. I kept getting the failed to open, permission denied, etc. errors mentioned a few posts back. I was able to get the script to save to a folder in my admin panel but I agree with the one post you made about having the file readily available on my local machine. Can you tell me where I'm going wrong? Thanks Tim
  5. masat

    Margin Report v1.00

    Well I think we have a functional solution I created a directory under admin called log and chmod 777 I changed $Base_folder = "log/"; and got rid of the errors and the file backed up to admin/log/ I am not happy with this though. I think it should be downloaded to my local machine. How can this be fixed? I tried several methods of defineing that $Base_folder Tim
  6. masat

    Margin Report v1.00

    I have to make another small apology. After reading the post by safoo I recall a long while back fixing my script to reflect the file name issue and while I was in there I changed it to be defined in filenames .php hence the post I made above. Evidently I changed the original contrib file I downloaded also and I normally don't do this so I always have an original script. My most humble apologies to all. Maybe it's time to throw in the towel for the day. My typing is terrible and my questions are not getting answered. I have learned a few things today so all is not in shame. Tim Fortune
  7. masat

    Margin Report v1.00

    oops sorry It downloaded to c:\\inkoop\inkoop.csv I often typo / and \ Tim
  8. masat

    Margin Report v1.00

    I copied and pasted your code into my file created a directory on my c drive called inkoop hit the export button and typed in inkoop.csv and the script successfully generarted my margin report and downloaded it to c://inkoop/inkoop.csv So if you are still having problems that section of code is not the problem Tim Fortune
  9. masat

    Margin Report v1.00

    Sorry I made a typo up above. The file is in admin/includes/filenames.php When you sort in margin report or export the CSV file the script margin_report.php is calling helper script within the same file so there is absolutly noway the file could be missing. Now take a look at the install instructions and the margin_report.php script and you will see why this occurs. In boxes reports.php the script calls the file like so: '<a href="' . tep_href_link(FILENAME_STATS_MARGIN_REPORT, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_MARGIN_REPORT . '</a><br>' . and the install instructions, at the end say to put this line into filenames.php like so: /includes/filenames.php Add: // Cost Module v1.11 define('FILENAME_STATS_MARGIN_REPORT', 'margin_report.php'); Now if you look at the script margin_report.php around line 525 you will clearly see they call the export button script as such: tep_draw_form('export_to_file', FILENAME_MARGIN_REPORT, 'get', '') . but if you followed the installation the call named FILENAME_MARGIN_REPORT was never defined in the filenames.php. The install said to define it as: define('FILENAME_STATS_MARGIN_REPORT', 'margin_report.php'); see the difference. This has to be your problem. Open admin/includes/filenames.php and insert this line: define('FILENAME_MARGIN_REPORT', 'margin_report.php'); and it will work. You must define margin_report both ways: 'FILENAME_MARGIN_REPORT', 'margin_report.php'); 'FILENAME_STATS_MARGIN_REPORT', 'margin_report.php'); or change the script margin_report.php Tim Fortune
  10. masat

    Margin Report v1.00

    Hey thanks for bringing this up. I have never sorted before so I had not noticed it not working. After I read your post I went to take a look and sure enough, when I use the drop down sort box I got a page not found. So I fixed it. Place this line in admin/includes.filenames.php define('FILENAME_MARGIN_REPORT', 'margin_report.php'); If my problem is the same as yours that should fix you up. Tim Fortune
  11. masat

    title error in google

    I beleive that line is in the original header tags controller contrib. Yes it is in catalog/includes/languages/english/header_tags.php That's a great contrib. Well you know two things... 1. The contrib works 2. Google defiantely uses <title>Tags</title> Fix your language file mentioned above and you should check all the other settings there too. Google usually visits fairly often so the changes should be picked up during the next spider. Tim Fortune
  12. masat

    Admin Access w/ Levels

    I had this problem a long time ago and I can't remember what fixed it but since you backed up you can just reinstall the old files and start over. You probably missed something somewhere. If you are running ms2 be sure you have Admin Access with Levels v1.6 for ms2. I have successfully installed this contrib several times. Tim
  13. masat

    XSELL - Updated Product Listing

    Hey John, Your right it is confusing. I have been working on this mod for about three days now. It looks like I installed the ms2 contrib and the add to cart contrib. Load those up on your ms2 cart and test them out. You may need the add to cart fix. I don't remember what it did exactly. If you use the registry contrib be careful. There are numerous obstacles to overcome. I have completely lost track of the changes I've made with those two contribs sharing the cart. Both are excellent contribs and my hat is off to the folks that supplied them. Once xsell is installed it works great. I still have a bug in shopping_cart.php with the registry though but it's something I can overlook for now. If I may I would like to supply some advice to all. Download a fresh ms2 and make a backup copy of it. Install your mods into the copy and make sure it works first. Make a fresh backup of your store before making any changes. Then, using some compare program, integrate the changes paying close attention to what you are adding, deleteing, or changeing. I have many contribs installed and I have found some of them just don't like to play together.
  14. masat

    XSELL - Updated Product Listing

    I have limited number of products showing in admin also... 3750 products total... when using my test bed on apache2triad on localhost. But when the cart is loaded to the web all products are presented and the admin side works great. I think the problem may lie in the setup of apache/php and mysql. Could this be the situation? Before you go... I have a problem on the cart side... The contrib is functionally primo in shopping_cart.php but in product_info when a xsell checkbox is marked and add to cart is pressed the xsell item is not added to the cart. The trouble appears to be the coding in application_top.php. I have attempted to move the include out of cache in product_info but it doesn't seem to solve the problem at all. I would like to have the contrib function in product_info where when the check box is checked and add to cart is activated both items are placed in the cart and the upsell no longer appears in shopping_cart or on the product_info pages. Any words or thoughts on this post? Thanks, Tim
×