Jump to content

e_piz

Members
  • Content count

    13
  • Joined

  • Last visited

Profile Information

  1. e_piz

    family 3.0 problems

    hi, having a small problem here. i have created a family and assign the products for that family but my question is, how do i assign the family products i've created to my products. need help please
  2. e_piz

    [Contribution] Specials_Module

    hi, mind to post a screenshot or live demo.. really appreciate it. thanks.
  3. seen your site, great pic you have there... i also have that prob at first but mine is because carelessness which i did not create a folder called thumbnails or whatever as configured in your admin panel.. before creating the folder, i'm getting all broken link images but after created the folder with 777 mod, pictures start to come out and so does the watermark. try double checking. just a thought of mine. for all who are still facing problem installing this great contribution..bear in mind...READ THE README FILES FROM A-Z. DON'T JUST SKIP TO THE INSTALLATION PART. nice~~ p/s: tom..i read that someone is piss off with you? what's his problem? hehehe
  4. it's totaly simple to make it watermark for non members only... open file catalog/includes/functions/html_output.php original coding that is given in readme... // BOF Image Magic function tep_image($src, $alt = '', $width = '', $height = '', $params = '') { global $product_info; //Allow for a new intermediate sized thumbnail size to be set //without any changes having to be made to the product_info page itself. //(see the lengths I go to to make your life easier :-) if (strstr($_SERVER['PHP_SELF'],"product_info.php")) { if (isset($product_info['products_image']) && $src == DIR_WS_IMAGES . $product_info['products_image'] && $product_info[products_id]==$_GET['products_id']) { //final check just to make sure that we don't interfere with other contribs $width = PRODUCT_INFO_IMAGE_WIDTH == 0?'':PRODUCT_INFO_IMAGE_WIDTH; $height = PRODUCT_INFO_IMAGE_HEIGHT == 0?'':PRODUCT_INFO_IMAGE_HEIGHT; $product_info_image=true; $page="prod_info"; } } //Detect whether this is a pop-up image if (strstr($_SERVER['PHP_SELF'],"popup_image.php")) $page="popup"; //do we apply the IE PNG alpha transparency fix? if (strstr(strtolower($src),".png") && CFG_PNG_BUG=="True") $fix_png = true; //send the image for processing unless told otherwise $image = '<img src="' . $src . '"'; //set up the image tag just in case we don't want to process if (CFG_MASTER_SWITCH=="On") $calculate = true; else $calculate=false; // Don't calculate if the image is set to a "%" width if (strstr($width,'%') == true || strstr($height,'%') == true) $calculate = false; // Dont calculate if a pixel image is being passed (hope you dont have pixels for sale) if (strstr($image, 'pixel')) $calculate = false; $image_size = @getimagesize($src); // Decide whether or not we want to process this image if (($width == '' && $height == '' && $page != 'popup' ) || ($width == $image_size[0] && $height == $image_size[0] && $page != 'popup')) { if (CFG_PROCESS_GRAPHICS=="False") $calculate = false; //looks like this is a store graphic rather than product image } // Is this image good to go? if (CONFIG_CALCULATE_IMAGE_SIZE && $calculate) { if ($image_size) { $ratio = $image_size[1] / $image_size[0]; // Set the width and height to the proper ratio if (!$width && $height) { $ratio = $height / $image_size[1]; $width = intval($image_size[0] * $ratio); } elseif ($width && !$height) { $ratio = $width / $image_size[0]; $height = intval($image_size[1] * $ratio); } elseif (!$width && !$height && !$over_ride) { $width = $image_size[0]; $height = $image_size[1]; } //Encrypt the image filename if switched on if (CFG_ENCRYPT_FILENAMES == "True" && CFG_ENCRYPTION_KEY !="") { $result = ''; $key=CFG_ENCRYPTION_KEY; for($i=0; $i<strlen($src); $i++) { $char = substr($src, $i, 1); $keychar = substr($key, ($i % strlen($key))-1, 1); $char = chr(ord($char)+ord($keychar)); $result.=$char; } $src=urlencode(base64_encode($result)); } //Return the html $image = '<img src="imagemagic.php?img='.$src.'&w='. tep_output_string($width).'&h='.tep_output_string($height).'&page='.$page.'"'; } elseif (IMAGE_REQUIRED == 'false') { return ''; } } //If the size asked for is greater than the image itself, we check the configs to see if this is allowed and if not over-ride if ($width > $image_size[0] || $height > $image_size[1]) { if (CFG_ALLOW_LARGER != 'True'){ $width=$image_size[0]; $height=$image_size[1]; $over_ride = true; } } // Add remaining image parameters if they exist if ($width) { $image .= ' width="' . tep_output_string($width) . '"'; } if ($height) { $image .= ' height="' . tep_output_string($height) . '"'; } if (tep_not_null($params)) $image .= ' ' . $params; $image .= ' border="0" alt="' . tep_output_string($alt) . '"'; if (tep_not_null($alt)) { $image .= ' title="' . tep_output_string($alt) . '"'; } if ($fix_png && CFG_MASTER_SWITCH=="On") { $image .= ' onload="fixPNG(this)"'; } $image .= '>'; return $image; } //EOF Image Magic the one in red colour I highlight above, replace with this code: if (!tep_session_is_registered('customer_id') && CFG_MASTER_SWITCH=="On") $calculate = true; else $calculate=false; THAT'S ALL...AND NOW WATERMARKS ARE APPLIED NON MEMBERS ONLY. p/s: maybe some of you are wondering, what are the difference making watermark for non members when they can register for free. let me tell you. in my site , before becoming a member, they need to be approve first. you can find contribution members approval at the contribution section. THERE YOU GO..SIMPLE BUT EFFECTIVE.
  5. yes...success again, now my site image is watermark for non members only...when members logon, watermark dissapear. tom...thx for the great contribution. it really helps me alot, especially in time savings.. for those who are still working on it...keep trying, follow the readme given properly and i can guarantee you will get it. post the question up and i will try my best to solve as i did it to my site.. nice~~
  6. ok... work it out already... everything is working fine now...and is good, save me a lot of time. thx for the contribution man. if you programmer have time..help me to add new function on this... i would like the watermark is there only for those who are not member...when log in(registered user)..all watermark is gone...can you do it eh? heheh..hope to give good news. thx alot
  7. hi all, superb contribution added... but seems to have minor problem (which i hope so) i've installed the script...and the watermark seems to be working on the thumbnail image and pop up enlarge image. but it doesn't work on image at the product description page....when i right click and the propeties, it shows /catalog/images/xxx.jpg while the thumbnail and popup image shows /catalog/imagemagic.php?.....and so on. can anyone help me solve the problem? help or suggettion would be very appreciated.. thx
  8. e_piz

    Customers extra fields

    hi, first of all..great contribution, helped me alot. i've used this contribution since last month. recently i realize the that when i add new field (with requirements). in the registration page, customer can actually submit the form without entering anything at the requirement field that i add. can someone help me on this, where to look for the mistake. thanks.
  9. hello, i'm a newbie and i've installed this two contribution which have helped me a lot. i need to combine this contribution: http://www.oscommerce.com/community/contri...ch,multi+vendor with this: http://www.oscommerce.com/community/contri...ch,quick+update (using Quick Updates 2.5b full version) any idea.. so i can update the shipping price in the quick update page... thx
  10. e_piz

    beta release extra questions

    hey... i can't do it...i seem not to know where is my error...hope someone can help me with this. when i put: //extra questions start if (ASK_QUESTION == 'true') { $display_answer = 1; require('display_answer_after_order.php'); } //extra questions end to display the answer...what came out was only this :FIRST_TITLE what i understand is is able to fetch the title from : display_answer_after_order.php but i can't get it why it wont fetch the answer ... need help on this please.. can YM me at e_piz@yahoo.com thx a lot
  11. e_piz

    beta release extra questions

    hello, pause for a moment...i'm getting confused, in checkout_confirmation.php it was using this code is it: //extra questions start if (QUESTION_LOCATION == 'orders') require('display_answer_after_order.php'); //extra questions end but why it become: if (ASK_QUESTION == 'true') { $display_answer = 1; require('display_answer_after_order.php'); } //extra questions end in nana explanation...have i be missing something here?? plz help. which file must be rename? when i add: </tr><?php if (ASK_QUESTION == 'true') require('display_answer_box.php'); ?> what comes up is only FIRST_TITLE any suggestion? or if possible someone to explaned me step by step: what i have done is: add an extra question in customer create account.. and what i want is: to display the value/answer from the customer in /admin/customer.php thx for your support..
  12. e_piz

    beta release extra questions

    hello, i'm a newbie here... anyway thx for the contribution, its fantastic... by the way, ihave a question regarding it..i added an extra question at the create new acc. page for members...which is succesfull..thx again for the contribution!! my question is, how do i retrieve the values/answers entered by the customers at the admin page... eg:catalog/admin/customers.php what code should i put so that it can retrieve the values which is submitted by the customers? a help on this would be very greatfull!!
×