Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

MarthaD

Members
  • Content count

    90
  • Joined

  • Last visited

Everything posted by MarthaD

  1. MarthaD

    New Attribute Manager Released..

    anyone have this working with register globals OFF?
  2. The only way this mish mash of code could work is on a 100% virgin store.... Thanx for nothing really.
  3. Where can i change the name of the data feeds page (leapfrog_feed.php) please? I really love the contribution but hate the naming to be quite honest...
  4. NICE UPDATE!!!! Installed no probs and took care of a few minor issues like SEO... great work!
  5. Nice contrib - thank you. Any chance of adding a split page result for those shops with a ton of manufacturers to list?
  6. Hi all... Need a hand with some if esle stuff please. I have installed the movie details contribution found here: http://www.oscommerce.com/community/contributions,4202/ The author is not around or doesn't care to assist, so I am stuck with a couple of things... The base contribution allows for showing an image when you mouse over a director or actor name in the product info page. What it doesnt account for is if there is no image for said actor or director... Original code for this particular item is below. Can anyone help me with the code to show nothing if no image is in the db? $actor_query = tep_db_query("select mp.people_id, mp.actor, mp.picture from " . TABLE_MOVIES_PEOPLE . " mp natural join " . TABLE_MOVIES_INFO . " mi where mi.people_id = mp.people_id and mi.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and mp.actor != '' order by mi.movies_info_id"); if (tep_db_num_rows($actor_query) > 0){ echo TEXT_ACTOR; $coma = 1; while ($actor = tep_db_fetch_array($actor_query)){ echo '<a href="' . tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, 'people=' . $actor['people_id']) . '" onMouseOver="showWMTT('. $actor['people_id'] .')" onMouseOut="hideWMTT()" alt="' . TEXT_SEE_ALL_MOVIES . $actor['actor'] . '" title="' . TEXT_SEE_ALL_MOVIES . $actor['actor'] . '">' . $actor['actor'] . '</a>' . (($coma < tep_db_num_rows($actor_query)) ? ', ' : ''); echo '<div class="tooltip" id="'.$actor['people_id'].'"><img src="' . DIR_WS_IMAGES . $actor['picture'] . '" /></div>'; $coma++; My next issue is in trying to take the same code and use it as in the manufacturers box so that a drop down list is generated that links over to the advanced search results page as in the original contribution.... Again, could use a helping hand here as this is what I have, but it comes up short (wont direct to advanced serahc with a good result and wont quite display properly - leaves some blank lines in between actor names for some reaso - which i think is a result of the directors listings being tied in to the people id.... <?php $actor_query = tep_db_query("select people_id, actor from " . TABLE_MOVIES_PEOPLE . " order by people_id"); if ($number_of_rows = tep_db_num_rows($actor_query)) { ?> <tr> <td><?php // Display a drop-down $actor_array = array(); if (tep_db_num_rows($actor_query) < 2){ $actor_array[] = array('id' => '', 'text' => 'Browse By Actor'); } while ($actor = tep_db_fetch_array($actor_query)) { $actor = ((strlen($actor['actor']) > MAX_DISPLAY_MANUFACTURER_NAME_LEN) ? substr($actor['actor'], 0, MAX_DISPLAY_MANUFACTURER_NAME_LEN) . '..' : $actor['actor']); $actor_array[] = array('id' => $actor['actor'], 'text' => $actor); } $info_box_contents = array(); $info_box_contents[] = array('form' => tep_draw_form('actor', tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, 'people=' . $actor['people_id']), 'get'), 'text' => tep_draw_pull_down_menu('actor', $actor_array, (isset($HTTP_GET_VARS['actor']) ? $HTTP_GET_VARS['actor'] : ''), 'onChange="this.form.submit();" size="' . MAX_MANUFACTURERS_LIST . '" style="width: 95%"') . tep_hide_session_id()); } new infoBox($info_box_contents); ?> </td> </tr>
  7. MarthaD

    Attribute Qty Product Info

    odd - the only price that is showing up for me is the actual product price - if i set it to $0 then thats the price - if I set it to $8 then thats the attribute price....
  8. MarthaD

    Attribute Qty Product Info

    Hmmmmmmmm.... thanx Jack. Will start from scratch again till i get this sorted ;) I "think" this is an issue that has arrisen after adding FEC... will backstep a bit and see.
  9. MarthaD

    Attribute Qty Product Info

    Slight problem with this otherwise fine contrib - i need to show prices that are in fractions of a dollow (ie .10) and unfortunately - they all show as $0. Even a price of $1.50 is only calculated as $1. Please help.
  10. MarthaD

    [Contribution] Task Manager (Admin)

    Am also getting a division by zero warning in admin_tasks_report.php on line 320. Any body have a cure for this?
  11. MarthaD

    OSC-Affiliate

    And so, with BIG IDIOT tattood on my forehead I shall anounce the final solution which got it working... "turn off debug mode" in config. :-" :-" :-" :-" :-" :-" :-"
  12. MarthaD

    OSC-Affiliate

    The code is correct Chooch... <img src="' . HTTP_SERVER . DIR_WS_HTTP_CATALOG . DIR_WS_IMAGES . $affiliate_banners['affiliate_banners_image'] . '" border="0" alt="' . $affiliate_banners['affiliate_banners_title'] . '"></a>' I even modified it to mach my config file which calls to WS_HTTP_CATALOG thinking that was the issue.... define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_IMAGES', 'images/');
  13. Okay - i got it working finally with abra's code - i must have missed something late last night but BIG thanx to all who assisted! However, I seem to have a new issue which I think is from the CSS/dhtml menus i am using.... If i click the product name from the dynamic menu, it now shows up twice in the leapfrog page, but only the second instance shows an image.... If i click a link from say a category listing, it works fine with only one instance being recorded...
  14. A semi colon character was expected. Error processing resource 'http://www.mysite.net/admin/leapfrog_feed.php?act... Says source is not available for viewing...
  15. Seems i cant edit me own post - so ignore the edit the wording part - got that LOL - just need an images fix for SEO urls and PHP 5....
  16. I tried both the no images fixes on previous page with no louck. Am also curious how one can change the text in the flash file... I would prefer to name it "real Time tracking" instead of leap frog - no offense but for a client i would not like to explain "leapfrog"
  17. MarthaD

    OSC-Affiliate

    Well - seems this is asked and sort of answered, but none of the answers are working for me so here goes: My host is running PHP 5 which i suspect is part of the issue based on a LOT of reading... My show banners gives me great stuff in debug mode: Check the pathes! (catalog/includes/configure.php) absolute path to picture: /home/xxxxxxx/public_html/buildx/images/cameron_diaz.jpg build with: DIR_FS_CATALOG . DIR_WS_IMAGES . $banner DIR_FS_CATALOG /home/xxxxxxx/public_html/buildx/ DIR_WS_HTTP_CATALOG /buildx/ DIR_WS_IMAGES images/ $banner cameron_diaz.jpg SQL-Query used: select affiliate_banners_image, affiliate_products_id from affiliate_banners where affiliate_banners_id = '3' and affiliate_status = 1 Try to find error: SQL-Query: Got Result Locating Pic /home/xxxxxxx/public_html/buildx/images/cameron_diaz.jpg success I can preview the banner in admin... The problem lies in that a placed banner (link copied in to a test html page) and a banner in the affiliate section simply wont show up... Anyone have any good answers on this one? Please?
  18. MarthaD

    Member Approval

    Am suffering from it right now - need a better fix than to switch to php 4 I'm affraid....
  19. MarthaD

    [contribution] Super Download Store

    Great! Lets give this puppy a workout! Feedback to follow :)
  20. Chooch - i went a few more pages back and we are now cooking with gas! http://forums.oscommerce.com/index.php?s=&...st&p=817233
  21. Thanx Chooch - am already doing the same thing... so far - nadda :(
  22. BTW... 5.14/5 Voucher Fix for cart total less than voucher amount solves the problem of not going to a payment processor BUT now wont allow me to use the vouchers even if selected in payment screen.... Argggg! LOL
×