Latest News: (loading..)

jdelgado

Members
  • Content count

    73
  • Joined

  • Last visited

1 Follower

About jdelgado

Profile Information

  1. Hi everyone! I've become very interested in the Basic Template Structure but found it a little tricky to install since there were several versions and patches and bug fixers that I had to download and install one by one. I guess you've already realised that I am not a good programmer ... and you're 100% right! :D The thing is that browsing around this forum I've seen some member website that provides a full OSC package that integrates more than 30 nice contributions all ready to use after you've done the usual OSC installation. They offer that special OSC to their webhosting clients but also give it (obviously for free since it is still 100% OSC product) to anyone else that goes to their website. IMPORTANT: I must say that I am not related at all with them. I am not either I client of them (I manage my own servers) and I don't even know who they are. But I've found very interesting that this OSC package (called by them: OSC MS2 + CRE Loaded v.6) is becoming very well known around our OSC community and there are even Templates Developers interested in working for this particular OSC Package. Here it is where you can get it: http://osc.chainreactionweb.com/demo/november-loaded/november-loaded.zip These are the 34 Contributions preloaded in it: http://phesis.co.uk/modules.php?name=Conte...=showpage&pid=1 I've just installed it (it is really amazing how easy it all went) and works very well. So far (I'm just playing with it for an hour or so) I really must say that it is very recommandable. And now my question: Do you know of a set of Templates that I could add to my OSC? This OSC package comes with 3 or 4 but I would like to add some more. I'll also make my own and share it with the OSC community if you find them interesting. Regards, Jose
  2. Hi! Is any of you using Admin Access and EasyPopulate together? I mean, are you using Admin Access and then decided to add EasyPopulate to your Admin Panel? I'm trying to do so but I'm stuck with something that must be very simple for most of you, but it is such a huge problem for a new PHP user like me: I CAN NOT ADD THE LINK TO EASYPOPULATE because my catalog.php file was modified for using Admin Access with Level and I don't know how I am supposed to set the link to EasyPopulate now. :oops: I've opened a topic were I explain with details all the things I've tried. It is here: http://forums.oscommerce.com/viewtopic.php?t=50017 Please, I really need your help! I'm in deep trouble if I don't upload my client list of products asap. Thanks in advance,
  3. ok, I've done some things but as I said I'm not a PHP expert at all and I probably didn't shoot in the right direction because it ain't working. :? - /admin/includes/boxes/catalog.php : I've added the following if ($selected_box == 'catalog') { $contents[] = array('text' => tep_admin_files_boxes(FILENAME_CATEGORIES, BOX_CATALOG_CATEGORIES_PRODUCTS) . tep_admin_files_boxes(FILENAME_SPECIALS, BOX_CATALOG_SPECIALS) . tep_admin_files_boxes(FILENAME_PRODUCTS_EXPECTED, BOX_CATALOG_PRODUCTS_EXPECTED) . tep_admin_files_boxes(FILENAME_PRODUCTS_ATTRIBUTES, BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES) . tep_admin_files_boxes(FILENAME_EASYPOPULATE, BOX_EASYPOPULATE) . tep_admin_files_boxes(FILENAME_MANUFACTURERS, BOX_CATALOG_MANUFACTURERS) . tep_admin_files_boxes(FILENAME_REVIEWS, BOX_CATALOG_REVIEWS)); } - /admin/includes/languages/espanol.php (my website is only set in Spanish): I've added the following define('BOX_EASYPOPULATE', 'EasyPopulate'); - /admin/includes/application_top.php : I've added the following define('FILENAME_EASYPOPULATE', 'easypopulate.php'); Then I login as Administrator but I can not find a link on the left menu to EasyPopulate inside Catalog or inside any other option. And when I try to go directly to directions like: http://www.-MyWebsite-.com/tienda/catalog/...asypopulate.php or: http://www.-MyWebsite-.com/tienda/catalog/...ted_box=catalog I always get redirected to: http://www.-MyWebsite-.com/tienda/catalog/...n/forbidden.php Any clue? I'm really desperate with this thing. I got to upload 300 products and I'm already late. Please help! Thanks for your time,
  4. Hi again Loxly, Yes, I had logged in first, but I forgot to mention that. It is weird because once I'm logged in as Administrator I can browse directly to URLs like: http://www.-MyWebsite-.com/tienda/catalog/...in/specials.php http://www.-MyWebsite-.com/tienda/catalog/...nufacturers.php http://www.-MyWebsite-.com/tienda/catalog/...dmin/backup.php And many others, but if I try to go to: http://www.-MyWebsite-.com/tienda/catalog/...asypopulate.php I get redirected to: http://www.-MyWebsite-.com/tienda/catalog/...n/forbidden.php Note: oh, and of course the file easypopulate.php is uploaded inside the root of /admin folder. I'm willing to hear your coments. Thanks again.
  5. hi iiinetwork! I did what you suggested but it didn't wok. I also uploaded easypopulate.php from /admin to /admin/includes and to /admin/includes/boxes but didn't work either. Loxly, your advice didn't work either because if I try to browse directly to: http://www.-MyWebsite-.com/shop/catalog/ad...asypopulate.php I get redirected to: http://www.-MyWebsite-.com/shop/catalog/ad...in/forbiden.php Any other idea will be welcome. Thanks for your time!
  6. Hi, I set in my OSC website AdminAccess with Levels but I got the following silly problem (as you've probably guessed already I'm not a php expert at all): - AdminAcess forced me to change the file: admin/includes/boxes/catalog.php from the original: <?php $heading = array(); $contents = array(); $heading[] = array('text' => BOX_HEADING_CATALOG, 'link' => tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('selected_box')) . 'selected_box=catalog')); if ($selected_box == 'catalog') { $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' . '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' . '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>'); } $box = new box; echo $box->menuBox($heading, $contents); ?> to this new one: <?php $heading = array(); $contents = array(); $heading[] = array('text' => BOX_HEADING_CATALOG, 'link' => tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('selected_box')) . 'selected_box=catalog')); if ($selected_box == 'catalog') { $contents[] = array('text' => tep_admin_files_boxes(FILENAME_CATEGORIES, BOX_CATALOG_CATEGORIES_PRODUCTS) . tep_admin_files_boxes(FILENAME_SPECIALS, BOX_CATALOG_SPECIALS) . tep_admin_files_boxes(FILENAME_PRODUCTS_EXPECTED, BOX_CATALOG_PRODUCTS_EXPECTED) . tep_admin_files_boxes(FILENAME_PRODUCTS_ATTRIBUTES, BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES) . tep_admin_files_boxes(FILENAME_MANUFACTURERS, BOX_CATALOG_MANUFACTURERS) . tep_admin_files_boxes(FILENAME_REVIEWS, BOX_CATALOG_REVIEWS)); } $box = new box; echo $box->menuBox($heading, $contents); ?> but now, EasyPopulate Readme file says: but as I said I don't have those lines anymore since I chnaged those for using AdminAccess! What can I do now? How must I set the link to EasyPopulate in my Admin Panel??? Thanks in advance,
  7. Hi there! I need to know what's the encryptation method used for the passwords in the Admin Level Contribution. I changed my passwords from the Admin Control Panel the other day. Now I don't remember them I when I try to receive them by email all I get is: - Subject: ADMIN_EMAIL_SUBJECT - Body: ADMIN_EMAIL_TEXT So I now pretend to set the passwords using phpMyAdmin but don't know what encrytation method I must use. I've tried with MD5 but it doesn't seem to work, and I haven't been able to find any information about this matter in the forums. All I get is very confussing advices about the email problem but I haven't been able to solve it either. So I have 2 separate problems: A) - Can I set new passwords manually from phpMyAdmin? B) - How can I receive new passwords correctly by email? Regards, Jose
  8. hi everyone, I still have that same problem: I get to: /admin/login.php?in_login=yes&retpage=/tienda/catalog/admin/index.php&selected_box=administrators and see: Then I try with 'admin / admin' but it keeps showing me that log form. I've tried deleting from phpMySQL the admin password ... same thing! I've tried setting 'PASSWORD' instead of plain text and it gets saved encrypted but ... same result! Also selected 'MD5' as encriptation method ... no changes! I've created a second account name/password ... no luck either! Any ideas? Thanks in advance.
  9. Hi, I guess I must have done something wrong at installing this Administrators contribution because it isn't working for me. I see: Log In To Administer Administrator UserID: Administrator Password: And try to log as user: 'admin' and password: 'admin' (as it is set in the DB) but I can't get logged in. Any idea? Thanks in advance, Jose