Jump to content

stevenrwoolley

Members
  • Content count

    111
  • Joined

  • Last visited

Everything posted by stevenrwoolley

  1. stevenrwoolley

    Easy populate and MSRP

    I think I need to edit the easypopulate.php file to allow for the MSRP price to be uploaded to the site. I believe I need to do something like this, but can not seem to get it to work. #'v_products_msrp_'.$l_id => $iii++, Does anyone have any suggestions? Thank you, Steven R. Woolley
  2. I know you covered this on the fist page of this forum, but I have the latest download and the changes you suggested has already been made. This is the error that I am getting: Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /hsphere/local/home/steven/onlinetransmissionparts.com/catalog/includes/functions/database.php on line 19 Unable to connect to database server! This is the code on line 19 of my database.php 13 function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') { 14 global $$link; 15 16 if (USE_PCONNECT == 'true') { 17 $$link = mysql_pconnect($server, $username, $password); 18 } else { 19 $$link = mysql_connect($server, $username, $password); 20 } What do you think? Thanks Steve
  3. stevenrwoolley

    Easy Populate & Products Attributes

    I have never had this error happen. When I go to upload a txt file this is the error: File uploaded. Temporary filename: /tmp/phpIqmYQd User filename: electrical.txt Size: 82521 | T-9006M | ELECTRONIC | ROSTRA | | ROSTRA | | 15 Pin Ma | 15 Pin Ma | 15 Pin Ma | Miscellane | 121.25 | 100.32 | 3 | 1000 | Taxable Go | Active | 1/1/2006 1 !New Product! 1048 - Column 'products_date_added' cannot be null INSERT INTO products ( products_retail_price, products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '', 'T-9006M', '94.6415', '1', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '1', '3', '1000', '121.25', '21') And when I try to download a text file this is the error: 1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM products as p, categories as subc, products_to SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status, p.products_retail_price as v_products_retail_price, FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id Anyone have any idea? Steven
  4. stevenrwoolley

    beta release extra questions

    Sorry to rehash an old question, but I am unable to follow the answers to the question, ?how do you get the customers answers to show up on the invoice and on the confirmation pages? The questions show up ok, but not the answers. ? Thank you, steve
  5. stevenrwoolley

    Easy populate and MSRP

    Thank you very much, I found the contribution. http://www.oscommerce.com/community/contri...ch,extra+fields Thanks again steve
  6. stevenrwoolley

    Display MSRP & Savings

    I have installed the Display MSRP & Savings contribution and my percent savings looks like ? You Save: $15.50 (60.75431372549%) I have looked throught the code and tried to find where on the MySql database this can be changed to read 60% or even 60.75%. Does anyone have any suggestions where I might be able to make the change? Thank you, Steven R. Woolley
  7. stevenrwoolley

    Display MSRP & Savings Problem

    I think they are talking about the stylesheet.css file. Not sure why they are havine you insert the code into the stylesheet in the admin section. Im going to install this contrib this weekend and I will let you know. Better late then never I guess.
  8. stevenrwoolley

    Support thread for "Easy Call for Price"

    I found that the page to edit is product_info.php instead of the product_listing.php. I can get it to work, but can not have the Product name, Id, and URL show up. I know I have posted a simaler questen, but I thought this thread gave more history of the probelm. It was suggested to look into the value of $listing_values. I can not find any other reference to $listing_values at all in my site.
  9. stevenrwoolley

    Call for Price

    I have been working on the call for price contribution more specifically the call for pricing link where you click the link and the contact us page opens up and the customer can get pricing without having to type the product information. I can get everything to work, but the product information is not encluded. It is supposed to show the product Id and so on. Instead it just shows http://onlinetransmissionparts.com/catalog...id=%0D%0A%0D%0A This is the code I have, Can you see what I am missing? 103 <tr> 104 <td class="pageHeading" valign="top"><?php echo $products_name; ?></td> 105 <td class="pageHeading" align="right" valign="top"><?php if ($product_info['products_price'] == 0){ echo '<a href="' . tep_href_link(FILENAME_CONTACT_US, 'enquiry=Price Inquiry%0D%0A%0D%0AProduct Id: ' . $listing_values['products_id'] . '%0D%0AProduct Name: ' . $listing_values['products_name'] . '%0D%0AProduct Url: ' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $listing_values['products_id'] .'%0D%0A%0D%0A') . '') . '">Call For Price</a>'; }else{ echo $products_price;} ?></td> 106 107 </tr> 108 </table></td> Any information would be great, Thank you, Steve
  10. stevenrwoolley

    Call for Price

    Thank you for the reply, I will search the contribution to see if their is any mention of listing_values along with the rest of the files. Thanks, Steve
  11. stevenrwoolley

    Call for Price

    Any idea's? This would be a great help for the customers.
  12. stevenrwoolley

    call for pricing

    I?m looking for updates for the call for price contribution. I want to make a link on the category page like ?Buy Now!? instead of having to go to the product description and clink on the text ?call for pricing? I also want to have the product information automatically fill in the email field so the customer will not have to type the product information. Any info about this would be great. Thanks, Steve
  13. stevenrwoolley

    Support thread for "Easy Call for Price"

    I am having the same problem getting Paul Barrera upgrade to work. It states to Just replace the <a href=>call for pricing</a> with the code above in "product_listing.php", but when I look in theproduct_listing.php i do not have <a href=>call for pricing</a>. Is that the right file to edit? I was able to make $0.00 work by changing $999,999 to $0.00 when installing the contrib.
  14. stevenrwoolley

    Call For Pricing / Negotiable Pricing

    If anyone has any more info on this contrib, please point me in the right direction...
  15. I have installed the Call For Pricing / Negotiable Pricing contribution http://www.oscommerce.com/community/contributions,2500 and I would like to change the text/link on the product info page to an image or at the least ?click here to check on price?. I also noticed that I also noticed that you have to go to the products description in order to press the link for ?call for price? It would be nice if I can make a link like Buy Now! The second thing is that I noticed a contribution on the same sting as the Call For Pricing / Negotiable Pricing that edited the contact us form field and added the product information. It looks like that contrib edits a previous version of the contribution, does anyone know how to make it work for the latest version. Any help on any part of this would be great. Thank You, Steve
  16. stevenrwoolley

    Easy Populate & Products Attributes

    I am having problems splitting my EP file. I have about 22k products and I saved as a tab text and tried to split it in admin. I even divided it up into 5k and tried to split in admin and nothing ever shows up in my temp folder. I never get any errors. I did changed the $maxrecs to 200 to see if it would make a change. Any suggestions on uploading would be great. Thank you, Steve
  17. stevenrwoolley

    Easy Populate 2.76-MS2

    I installed EP and had no problems during the install. I downloaded the text file and edited the file in excel to update my model numbers because I left several of them out when I added the products in the first place. I then went to EP on the admin section of the site and uploaded the text file and inserted it into the db. I even tried to insert it from the temp dir and I can not see any changes to the site and I am not getting any errors. I know it is hard to see the model number but when I look at the product in the admin section I noticed that the model number is still not their. Does anyone see what I might be doing wrong, or is EP only set up to upload new products and not help edit existing products. I have read the EP manual and tried everything in the troubleshooting section and tried to search the forum but it has not seemed to help. Any suggestions would be grateful. Cheers, Steve Woolley
  18. stevenrwoolley

    Easy Populate 2.76-MS2

    I would look at the file you just uploaded and make sure that you did not past the wrong categories. I found that I space the cells out in excell to make it easy to read and I upload one product first, check the result and then do the rest. I also found that I make less mistakes by uploading one category at a time and that way it does not impact my site when I do make a mistake.
  19. stevenrwoolley

    Easy Populate 2.76-MS2

    My problem was that I needed to change the "tabs" to ";", but now I have two of every part, the old parts with no product number and the new ones. owell at least it is working thanks for the help
  20. stevenrwoolley

    Easy Populate 2.76-MS2

    I just finished trying one product and I even made sure I had a unique model number. I also allowed For use with Linda's Header Controller v 2.0 contrib even through the contrib did not say linda's and turned off the "zero qty products are made inactive automatically" Everything looks like it uploads and a file is created in the temp folder, but no change to the site. Do I need to Run something on the database or could I be missing a step. I have been following the directions, but I must be missing something...
  21. stevenrwoolley

    Header Tags Controller

    It took me several changes, and I had to install it twice before it kinkof worked.Did you make the changes in the admin readme file that came with the contribution. I have had some trouble with this contrib and I found out that most of the people that are good at this stuff are logged in later int he day. between 6pm to 2am... you might want to wait a little, they will respond and be able to help you.
  22. I installed the headers tag collaboration and everything was working great. I was able to edit the header information in my admin section , but today when I go to click on my header tag in the admin this error comes up. I?m not sure what it means and what could have changed from last night until this morning. I did update category?s at the catalog section of my store and filled in headers at the category menu. If you have any suggestions please let me know. Fatal error: Cannot redeclare tep_db_connect() (previously declared in /hsphere/local/home/steven/onlinetransmissionparts.com/admin/includes/functions/database.php:13) in /hsphere/local/home/steven/onlinetransmissionparts.com/admin/includes/functions/database.php on line 13 5 osCommerce, Open Source E-Commerce Solutions 6 http://www.oscommerce.com 7 8 Copyright © 2003 osCommerce 9 10 Released under the GNU General Public License 11 */ 12 13 function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') { 14 global $$link; 15 16 if (USE_PCONNECT == 'true') { 17 $$link = mysql_pconnect($server, $username, $password); 18 } else { 19 $$link = mysql_connect($server, $username, $password);
  23. stevenrwoolley

    Header_Tags_Controller_and_corrections

    sorry, forget my last post here. I figured it out. thank you
  24. I tried to install Header_Tags_Controller_and_corrections for the first time. I used the auto install script and believe that everything went ok. Now I have several errors. Warning: main(DIR_WS_LANGUAGES/FILENAME_DEFAULT): failed to open stream: No such file or directory in /hsphere/local/home/steven/onlinetransmissionparts.com/catalog/index.php on line 33 Warning: main(DIR_WS_LANGUAGES/FILENAME_DEFAULT): failed to open stream: No such file or directory in /hsphere/local/home/steven/onlinetransmissionparts.com/catalog/index.php on line 33 Fatal error: main(): Failed opening required 'DIR_WS_LANGUAGES/FILENAME_DEFAULT' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/steven/onlinetransmissionparts.com/catalog/index.php on line 33 33 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_DEFAULT); 34 ?> 35 <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> 36 <html <?php echo HTML_PARAMS; ?>> Does this look like a common problem? Is their any documentation that walks me through the install? Anything would help. Thank you
  25. stevenrwoolley

    Header_Tags_Controller_and_corrections

    thank you, I did notice that my english flag came back. I renamed it and changed it to a us flag. Seems like something happened, maybe a file that is pointing to something else. If anyone knows how I can check the database to make sure line 13 is still pointing to what ever it points to please let me know. Thank You.
×