Jump to content

matrix2223

Members
  • Content count

    852
  • Joined

  • Last visited

Everything posted by matrix2223

  1. As Jack_mcs stated you can't do that with this contribution as it is currently. However I am currently working on a more modern update to this contribution. That will display a more standardized url formatting like mysite.com/tools/20oz-hammer/ for example. The initial release will be soon I hope, if all goes well. But, this will only be a beta version for testing and updating and such.
  2. For those wishing to remove the .html extension from the url here is what needs done. This will get the url to look like this: myshop.com/samsung-galaxy-p-28/ Keep in mind this still needs further testing on shops but works on un-modified shops. 1) In seo.class.php search for .html and replace with / 2) In your .htaccess file remove all instances of .html so it looks like this RewriteRule ^(.*)-p-(.*)$ product_info.php?products_id=$2&%{QUERY_STRING} On a side note, I think the (.*) could be updated as it very well could make a server go into an infinite, not sure which would be better for this though if any???? Eric
  3. Next on the list to do is to remove the php extensions site wide so that they all are like site.com/contact/ or /conditions/
  4. Jack, I sent you a pm with some info on this. Thanks, Eric
  5. I am thinking that the way the seo-class.php identifies the products ie -p- in the htaccess file would need to be re-written. Still trying to read 3,000 lines of code to see exactly what does what.
  6. Update, I have manage to get the html extension removed from all URI's now the look like this /osc/samsung-galaxy-p-28/
  7. I'm working on that now. Your right though, the seo.class.php probably would have to be updated. I had noticed that if you type the url in it works but when you click on the product link it dont. It still has the -p-xx.html attached. Perhaps a database reset would work, not sure thou. I am sure that I am determined to get this to work, one way or another. osC is way behind the curve on seo urls. Thanks to all of your work thats the only thing going good for it. I will keep you posted on any updates I encounter with this. If all else fails one could just use RewriteRule ^(.*)-p-(.*)/$ product_info.php?products_id=$2&%{QUERY_STRING} That would for sure remove the .html bit at least. Thanks, Eric
  8. Hi Jack, I think I found a way to use the re-write rules to remove the -p-xx.html bit from the url. It seems to work on my server but haven't fully tested it yet. Perhaps during your testing you could try it out. This basically makes the URL look like this http://www.myshop.com/my-cool-product/ Which is the same kind of re-writes as Word Press and other open source projects already have in place. # Begin Ultimate SEO V2.2d Options +FollowSymLinks RewriteEngine On # RewriteBase instructions # Change RewriteBase dependent on how your shop is accessed as below. # http://www.mysite.com = RewriteBase / # http://www.mysite.com/catalog/ = RewriteBase /catalog/ # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ # Change the following line using the instructions above RewriteBase / RewriteRule ^(.*)(.*)/$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)([0-9]+)/$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)(.*)/$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)([0-9]+)/$ pollbooth.php?pollid=$2&%{QUERY_STRING} # End Ultimate SEO V2.2d I do know that this does work for sure but one would have to add it to every last product and so on. RewriteEngine on RewriteRule ^my-product/$ my-product-p-27.html Thanks for your work, Eric
  9. matrix2223

    [Contribution] STS v4

    Skip all that code, please try this: (add before the final ?>) require(DIR_WS_BOXES . 'builder.php'); $sts->restart_capture ('builderbox', 'box'); // Get builder box Then where ever you would like the contents of the box to be displayed use $builderbox
  10. This code is Sams contact us page with recaptcha added <?php /* $Id: contact_us.php,v 1.5 2010/02/02 Spooks Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2010 osCommerce Released under the GNU General Public License */ // anti-hacker account require('includes/functions/account_secure.php'); clean_post (); // EOF anti-hacker account require('includes/application_top.php'); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CONTACT_US); $error = false; if (isset($_GET['action']) && ($_GET['action'] == 'send')) { $name = tep_db_prepare_input($_POST['name']); $email = tep_db_prepare_input($_POST['email']); $enquiry = tep_db_prepare_input($_POST['enquiry']); $subject = tep_db_prepare_input($_POST['subject']); $phone = tep_db_prepare_input($_POST['phone']); $date = 'Date Sent: ' . date("d M Y H:i:s"); $orders_id = tep_not_null($_POST['orders_id']) ? $_POST['orders_id'] : false; $xipaddress = $_SERVER["REMOTE_ADDR"]; $subject = $subject ? $subject : EMAIL_SUBJECT; $captchaurl = "captchaerror.php" ; require_once('captcha/recaptchalib.php'); $privatekey = "private key goes here"; $resp = recaptcha_check_answer ($privatekey, $_SERVER["REMOTE_ADDR"], $_POST["recaptcha_challenge_field"], $_POST["recaptcha_response_field"]); if (!$resp->is_valid) { // What happens when the CAPTCHA was entered incorrectly die ("The reCAPTCHA wasn't entered correctly. Go back and try it again." . "(reCAPTCHA said: " . $resp->error . ")"); } else { // Your code here to handle a successful verification } //$enquiry = preg_replace('/\r/','\', \'',$enquiry); //$enquiry = preg_replace('/\(|\)/','\'',$enquiry); //$_POST['enquiry'] = $result; if (strlen($name) < ENTRY_LAST_NAME_MIN_LENGTH) { $error = true; $messageStack->add('contact', ENTRY_LAST_NAME_ERROR); } if (strlen($enquiry) < 8) { $error = true; $messageStack->add('contact', ENTRY_ERROR_ENQUIRY); } if (!tep_validate_email($email)) { $error = true; $messageStack->add('contact', ENTRY_EMAIL_ADDRESS_CHECK_ERROR); } if (!$error) { $enquiry = MESSAGE_FROM . $name . "\n" . $date . "\n" . ($phone ? ENTRY_TELEPHONE_NUMBER . $phone . "\n" : '' ) . ($customer_id ? MAIL_CLIENT_ID . $customer_id . "\n" : '') . ($orders_id ? MAIL_ORDER_ID . $orders_id . "\n" : '') . "\n" . MAIL_IP . $xipaddress . '.' . "\n\n" . ENTRY_ENQUIRY . "\n" . $enquiry; tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, $subject, $enquiry, $name, $email); tep_redirect(tep_href_link(FILENAME_CONTACT_US, 'action=success')); } } $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_CONTACT_US)); $account = array();$orders = array();$name = '';$email = '';$phone = ''; if (tep_session_is_registered('customer_id')) { $account_query = tep_db_query("select customers_firstname, customers_lastname, customers_telephone, customers_id, customers_email_address from " . TABLE_CUSTOMERS . " where customers_id = '" . (int)$customer_id . "'"); $account = tep_db_fetch_array($account_query); $name = $account['customers_firstname'].' '.$account['customers_lastname'] ; $email = $account['customers_email_address'] ; $phone = $account['customers_telephone'] ; $history_query = tep_db_query("select orders_id, date_purchased from " . TABLE_ORDERS . " where customers_id = '" . (int)$customer_id . "' order by orders_id DESC"); $orders[0] = array('id' => '0', 'text' => ENTRY_ORDER_ID); while ($history = tep_db_fetch_array($history_query)) { $orders[] = array('id' => $history['orders_id'], 'text' => $history['orders_id'] . ENTRY_ORDERED . tep_date_short($history['date_purchased'])); } } ?> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html <?php echo HTML_PARAMS; ?>> <head> <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <title><?php echo TITLE; ?></title> <base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>"> <link rel="stylesheet" type="text/css" href="stylesheet.css"> </head> <body> <!-- header //--> <?php require(DIR_WS_INCLUDES . 'header.php'); ?> <!-- header_eof //--> <!-- body //--> <table border="0" summary="" width="100%" cellspacing="3" cellpadding="3"> <tr> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" summary="" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- left_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> <!-- left_navigation_eof //--> </table></td> <!-- body_text //--> <td width="100%" valign="top"><?php echo tep_draw_form('contact_us', tep_href_link(FILENAME_CONTACT_US, 'action=send')); ?><table border="0" summary="" width="100%" cellspacing="0" cellpadding="0"> <tr> <td><table border="0" summary="" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="pageHeading"><?php echo HEADING_TITLE; ?></td> </tr> </table></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <?php if ($messageStack->size('contact') > 0) { ?> <tr> <td><?php echo $messageStack->output('contact'); ?></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <?php } if (isset($_GET['action']) && ($_GET['action'] == 'success')) { ?> <tr> <td class="main" align="center"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_man_on_board.gif', HEADING_TITLE, '0', '0', 'align="left"') . TEXT_SUCCESS; ?></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td><table border="0" summary="" width="100%" cellspacing="1" cellpadding="2" class="infoBox"> <tr class="infoBoxContents"> <td><table border="0" summary="" width="100%" cellspacing="0" cellpadding="2"> <tr> <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td> <td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td> <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td> </tr> </table></td> </tr> </table></td> </tr> <?php } else { echo tep_draw_hidden_field('phone',$phone); ?> <tr> <td><table border="0" summary="" width="100%" cellspacing="1" cellpadding="2" class="infoBox"> <tr class="infoBoxContents"> <td valign="top" width="40%"> <table> <tr> <td class="main" > <b><?php echo nl2br(STORE_NAME_ADDRESS); ?></b><br><br> <?php echo (OPENING_HOURS); ?> </td> </tr> </table> </td><td valign="top" width="50%"><table border="0" summary="" width="100%" cellspacing="0" cellpadding="2"> <tr> <td class="main"><?php echo ENTRY_NAME; ?></td> </tr> <tr> <td class="main"><?php echo (isset($account['customers_lastname']) ? $name . tep_draw_hidden_field('name',$name) : tep_draw_input_field('name', $name, 'size="28"')); ?></td> </tr> <tr> <td class="main"><?php echo ENTRY_EMAIL; ?></td> </tr> <tr> <td class="main"><?php echo tep_draw_input_field('email', $email, 'size="28"'); ?></td> </tr> <tr> <td class="main"><?php echo BOX_HEADING_SUBJECT; ?></td> </tr> <tr> <td class="main"><?php echo tep_draw_input_field('subject', '', 'size="28"'); if (sizeof($orders) > 1) { echo ' ' . tep_draw_pull_down_menu('orders_id', $orders); } ?></td> </tr> <tr> <td class="main"><?php echo ENTRY_ENQUIRY; ?></td> </tr> <tr> <td><?php echo tep_draw_textarea_field('enquiry', 'soft', 40, 15); ?></td> </tr> <tr> <td class="main"><?php echo SPAM_CODE; ?></td> </tr> <tr> <td><?php require_once('captcha/recaptchalib.php'); $publickey = "Public Key Goes Here"; // you got this from the signup page if ($request_type =='SSL') echo recaptcha_get_html($publickey, 0, $request_type); else echo recaptcha_get_html($publickey); ?></td> </tr> </table></td> </tr> </table></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td><table border="0" summary="" width="100%" cellspacing="1" cellpadding="2"> <tr> <td><table border="0" summary="" width="100%" cellspacing="0" cellpadding="2"> <tr> <td align="middle"><a href="javascript:onclick=history.go(-1)"><?php echo tep_image_button('button_back.gif', IMAGE_BUTTON_BACK); ?></a></td> <td width="10px"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td> <td align="middle"><?php echo tep_image_submit('button_continue.gif', IMAGE_BUTTON_CONTINUE); ?></td> <td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td> </tr> </table></td> </tr> </table></td> </tr> <?php } ?> </table></form></td> <!-- body_text_eof //--> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" summary="" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- right_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_right.php'); ?> <!-- right_navigation_eof //--> </table></td> </tr> </table> <!-- body_eof //--> <!-- footer //--> <?php require(DIR_WS_INCLUDES . 'footer.php'); ?> <!-- footer_eof //--> <br> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> Change the 2 public key and private key sections to include your keys
  11. Also while changing password within the front end it keeps telling me that, Your Current Password did not match the password in our records. Please try again.
  12. Hi Jack, I tried using the character conversion to convert _=>- This did not work. This isn't imperative to work I just thought I would try it. Thanks
  13. Hello all, Has anyone got this to work with master password 1.0? Every time I enter the master password it tells me that it is incorrect. Thanks
  14. Thanks Jack, I really appriciate that, Thank you
  15. Hi Jack, Sorry to be a pain about this. I thought I had fixed the config file right but evidently I must have done something else. I am still getting the oscids appended to urls On my mac where I did all the work it works like its supposed to but using 2 other pcs with multiple browsers it doesn't work here is my two config files so you may look <?php define('HTTP_SERVER', 'http://www.domain.com'); define('HTTPS_SERVER', 'https://www.domain.com'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', 'www.domain.com'); define('HTTPS_COOKIE_DOMAIN', 'https://www.domain.com'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/home/user/public_html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); <?php define('HTTP_SERVER', 'http://www.domain.com'); define('HTTP_CATALOG_SERVER', 'http://www.domain.com'); define('HTTPS_CATALOG_SERVER', 'http://www.domain.com'); define('ENABLE_SSL_CATALOG', 'false'); define('DIR_FS_DOCUMENT_ROOT', '/home/user/public_html/'); define('DIR_WS_ADMIN', '/admin/'); define('DIR_FS_ADMIN', '/home/user/public_html/admin/'); define('DIR_WS_CATALOG', '/'); define('DIR_FS_CATALOG', '/home/user/public_html/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); Like I mentioned earlier it works 100% correct on the test account but once I moved all files to there account this happened. Its driving me crazy. Thanks for your time and all of your help.
  16. matrix2223

    News Blog V1.0

    Hi all, for some reason the date for the posts is about 5 months of. I posted today and its displaying, Date Created: 06.12.2010 Any ideas? Thanks
  17. Thanks Jack I did goof on the config file. Thanks for your time.
  18. This would be hard to do with no information If your hard coding all of your links you have to use standard php link ie <?php echo '<a href="' . tep_href_link('your_directory/your_page.php') . '">Your Text Here</a>'; ?>
  19. Your site and links, work on my end. It appears you don't have Ultimate SEO url turned on.
  20. Sorry Jack, it was a late night. That problem was sorta my problem but not totally. The is, I had created a site, and once finished I compressed it, downloaded, and then uploaded it to the clients web hosting account. Once I uploaded it uncompressed, installed the DB, and made the necessary config.php file changes. The whole site works perfect but the urls. All of the product urls are the same, links are the same, and so on. I don't know for sure what the issue is being its the same files, same database structure, the same everything... Its just within a different account. What happens is the urls append the oscidxxxxx to the end of the seo urls so you get this my-cool-product-p-9.html?oscid=xxxxxxxx included on every url, no matter how many times you click around. The above solution may still be the answer, I shall try. If you would like I could pm you with a link, I'd rather not post it. Thank you so much for your time
  21. I know this sounds silly but my brain isn't functioning well at the moment... Are you referring to php links? If so then this is all I use. Thanks Jack
  22. I'm getting the same issue while moving a shop from one account to another on the same server. Works on the first but not the second. I tried reset cache, deleting the database and re creating it. Double checked install, and so on...
  23. matrix2223

    ask a product question

    This should be what your looking for Ask a question
  24. matrix2223

    STS + template + stretched width

    My guess is that's your issue. Try using the default size. I can assure you that all templates work within the current version of sts.
  25. matrix2223

    [Contribution] STS v4

    Make sure in your sts template your head section look like this <head> <!--$headcontent--> <link rel="stylesheet" type="text/css" href="$templatedir/stylesheet.css"> </head> Only the <!--$headcontent--> needs to be there to get all the header tag code and head information to display
×