Jump to content

supra661

Members
  • Content count

    10
  • Joined

  • Last visited

About supra661

  • Birthday 12/16/1976

Profile Information

  1. Sorry, as far as I understand it, you will not be able to get SEO URLs to work exactly like that. The product information included already can be used for this purpose, i.e. the "xmodel" information can be included in the product title when you enter the product into the catalog so that the url comes out as http://www.domain.com/mp3-player-xmodel-p-42.html ... HOWEVER, the "-p-42' part is necessary because the current version of SEO URLs requires this information to be present in order for the mod-rewrite functionality to work on your server (i.e. the mod_rewrite functions added to your .htaccess file)... Without that, the rewrite URL would not work correctly. Darn, I wish Chemo wasn't banned... He's probably already got a better fix in place by now :rolleyes:
  2. This is one of the "problems" I ran into on my test set up as well.... Has nothing to do with any editing of any files on my part, I just didn't understand all of the settings properly. To correct the missing "-" from URLs generated by Ultimate SEO, go into the admin section for SEO URLs, and change the "Remove all non-alphanumeric characters" setting to "false". After that, go to the next setting below and reset theSEO URLs cache to clear out the previously generated URLs. This will cause SEO URLs to generate the way you're looking for ("product-name-etc-etc-p-1" instead of "productnameetcetc-p-1"). Believe it or not, I actually found this information included with the contrib, in the install.html file configuration section. :blush: -Manica, regarding your last post: The code you are showing here is starting from line 25 in my categories.php, in other words, the very next few lines beyond what I posted above. If you're looking for where to paste the SEO URLs code, it should go on the lines just before your line 18. If that doesn't work, write back and post the top part of your categories.php and I'll see if I can help.
  3. Hello :D I think after searching through a bunch of old posts, I have answered my own questions about this mod. It's now working perfectly on my test site, which is slated to go live soon.... But I have one question that is really burning at me here (sorry I know this is somewhat off topic).... I've seen TONS of contriibutions from Chemo (Bobby) on Oscommerce contribs section, and literally thousands of posts from Bobby in supporting his contribs. -In ALL of those, I've not found anything that should have gotten him banned from the forums. -He was such an excellent resource. Ultimate SEO URLs is just one of several great mods chemo created! Does anyone know WHY he was banned from these forums? .....Just curious.... By the way... Manica, regarding your difficulty finding $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : ''); ....It is on line 18 of admin/categories.php in my site, so with this mod installed, the first 23 lines of code on that page look like: <?php /* $Id: categories.php,v 1.146 2003/07/11 14:40:27 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ require('includes/application_top.php'); require(DIR_WS_CLASSES . 'currencies.php'); $currencies = new currencies(); $action = (isset($HTTP_GET_VARS['action']) ? $HTTP_GET_VARS['action'] : ''); // Ultimate SEO URLs v2.1 // If the action will affect the cache entries if ( eregi("(insert|update|setflag)", $action) ) include_once('includes/reset_seo_cache.php'); Hope that helps!
  4. Yes this is a very nice contribution.... I can't wait 'till I get all these little "bugs" worked out on my test site so I can move this to the live one! -I'm still digging through and hacking things up though, so its no wonder I'm finding problems.... I'm glad to see others are successful with this mod and not having the probs I'm running into... Obviously I broke something somewhere. That's okay though, because I'm learning a ton about how ccgv works in the process of tearing through this. :D Also, per your previous question Aaron, I'm testing mostly on Firefox, but I do check things out in IE before going live, etc.... -MJ
  5. Jono / Aaron, I'm pretty sure this has nothing to do with anything commented out in what I posted earlier.... however, that doesn't mean it isnt something else I messed up somewhere along the way.... Here's a little more detail about the problem I've run across: 1) If check/money order or paypal is selected as the payment method (not using any gift cert, etc), and I click "redeem" with nothing entered into the input box... Then I am redirected straight on to the confirmation page, af if I had simply clicked "continue". 2) If credit card is selected as method of payment (with no valid cc info entered), and I click "redeem" (again with nothing entered into the coupon code box), then I am brought back to the checkout payment page with an error at the top complaining that I haven't got the right expiration date entered into the credit card space.... No javascrit warning preceded this to tell me to input payment info into the credit card info entry space... 3) Entry of an invalid redeem code results in proper operation (I get redirected back to checkout payment page with an error stating invalid redeem code) 4) Entry of a valid redeem code also results in proper operation.
  6. If you download the contribution, there is a picture included that provides an example for you of what it looks like. However, I'll PM you with a link to my test site where you can add a product to your cart and take a look at it. (You'll have to create an account, etc)... I'm currently making some modifications, though... Specifically, I'm testing a few changes to switch the "check box" to a "radio button" instead, which looks a bit more natural to me... -MJ
  7. Jono, Yep I've run into the same issue. The problem actully comes from the includes/classes/order_total.php file... The function use_credit_amount() ends up getting called twice. First it is called by the newly-added sub_credit_selection, then it is called again by the original credit_selection() function again later on... I'm still digging through this, trying to make it work a little better, but to fix your immediate issue with duplicate check-boxes, try using the following code in the includes/classes/order_total.php file: function credit_selection() { $selection_string = ''; $close_string = ''; $credit_class_string = ''; if (MODULE_ORDER_TOTAL_INSTALLED) { $header_string = '<tr>' . "\n"; $header_string .= ' <td> <table border="0" width="100%" cellspacing="0" cellpadding="2">' . "\n"; $header_string .= ' <tr>' . "\n"; $header_string .= ' <td class="main"><b>' . TABLE_HEADING_CREDIT . '</b></td>' . "\n"; $header_string .= ' </tr>' . "\n"; $header_string .= ' </table></td>' . "\n"; $header_string .= ' </tr>' . "\n"; $header_string .= '<tr>' . "\n"; $header_string .= ' <td><table border="1" width="100%" cellspacing="1" cellpadding="2" class="infoBox">' . "\n"; $header_string .= ' <tr class="infoBoxContents"><td><table border="0" width="100%" cellspacing="0" cellpadding="2">' ."\n"; $header_string .= ' <tr><td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') .'</td>' . "\n"; $header_string .= ' <td colspan="2"><table border="0" width="100%" cellspacing="0" cellpadding="2">' . "\n"; $close_string = ' </table></td>'; $close_string .= '<td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') . '</td>'; $close_string .= '</tr></table></td></tr></table></td>'; $close_string .= '<tr><td width="100%">' . tep_draw_separator('pixel_trans.gif', '100%', '10') . '</td></tr>'; reset($this->modules); $output_string = ''; while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); if ($GLOBALS[$class]->enabled && $GLOBALS[$class]->credit_class) { // $use_credit_string = $GLOBALS[$class]->use_credit_amount(); //MRJ commented this line out because already used in sub_credit_selection function called from below and used in checkout_payment.php 11/18/05 if ($selection_string =='') $selection_string = $GLOBALS[$class]->credit_selection(); //MRJ note: here is where $selection_string calls out the credit_selection class from the module ot_gv. 11/18/05 // if ( ($use_credit_string !='' ) || ($selection_string != '') ) { //MRJ commented out this line to rewrite and remove $use_credit_string qualifier, not needed in this function anymore since moved into sub_credit_selection() below 11/18/05 if ( $selection_string != '') { $output_string .= '<tr colspan="4"><td colspan="4" width="100%">' . tep_draw_separator('pixel_trans.gif', '100%', '10') . '</td></tr>'; $output_string = ' <tr class="moduleRow" onmouseover="rowOverEffect(this)" onmouseout="rowOutEffect(this)" >' . "\n" . ' <td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') .'</td>' . // ' <td class="main"><b>' . $GLOBALS[$class]->header . '</b></td>' . $use_credit_string; //MRJ commented out this line and replaced with below line because removing $use_credit_string 11/18/05 ' <td class="main"><b>' . $GLOBALS[$class]->header . '</b></td>'; $output_string .= '<td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') . '</td>'; $output_string .= ' </tr>' . "\n"; $output_string .= $selection_string; } } } if ($output_string != '') { $output_string = $header_string . $output_string; $output_string .= $close_string; } } return $output_string; } // #################### Begin Added CGV JONYO ###################### function sub_credit_selection() { // $selection_string = ''; //MRJ commented out, since selection_string is not necessary here 11/18/05 $close_string = ''; $credit_class_string = ''; if (MODULE_ORDER_TOTAL_INSTALLED) { reset($this->modules); $output_string = ''; while (list(, $value) = each($this->modules)) { $class = substr($value, 0, strrpos($value, '.')); if ($GLOBALS[$class]->enabled && $GLOBALS[$class]->credit_class) { $use_credit_string = $GLOBALS[$class]->use_credit_amount(); // if ($selection_string =='') $selection_string = $GLOBALS[$class]->credit_selection(); //MRJ commented this out, is unnecessary 11/08/05 // if ( ($use_credit_string !='' ) || ($selection_string != '') ) { //MRJ removed old code to get rid of $selection_string statement 11/18/05 if ($use_credit_string !='') { $output_string = $use_credit_string; $output_string .= '<td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') . '</td>'; $output_string .= ' </tr></table></td><td width="10">' . tep_draw_separator('pixel_trans.gif', '10', '1') .'</td></tr>' . "\n"; // $output_string.=$GLOBALS[$class]->use_credit_amount(); // $output_string .= $selection_string; } } } } return $output_string; } // #################### End Added CGV JONYO ###################### It's still a bit rough, but it'll do the trick. Unfortunately, I'm still trying to figure out why hitting "redeem" for the coupon entry brings me to the confirmation screen without any payment info present! ...Still working on that one, maybe just an error on my part... HTH -MJ
  8. Aaron, Holy crap!! I just figured it out... It's my fault here, sorry! I took a closer look at my order_total file, and found this: // #################### Begin Added CGV JONYO ###################### global $payment, $order, $credit_covers, $customer_id; // #################### End Added CGV JONYO ###################### if (MODULE_ORDER_TOTAL_INSTALLED) { $total_deductions = 0; Basically, the entire "if (MODULE_ORDER_TOTAL_INSTALLED) { " bit is hidden behind the "end added cgv jonyo" comment! ...When I went back to debug, I didn't catch it since it was commented out, but the end effect was to cause the problems I was having with functions being truncated out of the file... So I "fixed" it by removing the "extra" bracket.... OOPS! my bad :blush: DOH! Thanks for your help!! -MJ
  9. Hey no problem. Looks like I actually posted the wrong info above too!! I put the mod_process function in the right place in my ot_gv.php file, but the post I placed earlier was incorrect... Good thing you re-posted the right stuff :) Thanks! -MJ
  10. Jono, I'm having similar problems after this install.... I searched the support thread for Jonyo's original stuff, and there is a function called mod_process that Jonyo added to catalog/includes/modules/order_total/ot_gv.php. The function, which was modified a few times, is as follows: //------------------------------------------------------------- function mod_process() { global $currencies; $my_order_total = $this->get_order_total(); $my_od_amount = $this->calculate_credit($my_order_total); if ($this->calculate_tax != "None") { $tod_amount = $this->calculate_tax_deduction($my_order_total, $my_od_amount, $this->calculate_tax); $my_od_amount = $this->calculate_credit($my_order_total); } $this->deduction = $my_od_amount; //$order->info['total'] = $order->info['total'] - $my_od_amount; if ($my_od_amount > 0) { $this->my_output[] = array('title' => $this->title . ':', 'text' => '<b>' . $currencies->format($my_od_amount) . '</b>', 'value' => $my_od_amount); } } //---------------------------------------------------------------------- This function needs to be added into catalog/includes/modules/order_total/ot_gv.php as indicated below: $output_string .= '<b>' . $this->checkbox . '</b>' . '</td>' . "\n"; } return $output_string; } //------------------------------------------------------------- function mod_process() { global $currencies; $my_order_total = $this->get_order_total(); $my_od_amount = $this->calculate_credit($my_order_total); if ($this->calculate_tax != "None") { $tod_amount = $this->calculate_tax_deduction($my_order_total, $my_od_amount, $this->calculate_tax); $my_od_amount = $this->calculate_credit($my_order_total); } $this->deduction = $my_od_amount; //$order->info['total'] = $order->info['total'] - $my_od_amount; if ($my_od_amount > 0) { $this->my_output[] = array('title' => $this->title . ':', 'text' => '<b>' . $currencies->format($my_od_amount) . '</b>', 'value' => $my_od_amount); } } //---------------------------------------------------------------------- // #################### End Added CGV JONYO ###################### function update_credit_account($i) { global $order, $customer_id, $insert_id, $REMOTE_ADDR; if (ereg('^GIFT', addslashes($order->products[$i]['model']))) { That fixes one problem.... Prior to finding that problem, I noticed one other bug in the install instructions.... In the following code, there is an extra closing bracket present that causes the order_total class to ignore the bottom half of the code present in the file after you install this "easier to understand" mod: In Step #5 - In /catalog/includes/classes/order_total.php... if(tep_session_is_registered('credit_covers')) tep_session_unregister('credit_covers'); } // #################### End Added CGV JONYO ###################### } //--Note the extra bracket below------------------------------ } //--(end) Note the extra bracket ------------------------------ // this function is called in checkout process. it tests whether a decision was made at checkout payment to use The bracket identified above needs to be removed. The real closing bracket is at the end of the file, just before the ?> at the bottom. These changes have at least gotten my test site back up and running on the checkout page... but I have noticed a couple of other issues I'm still grappling with.... More to follow on those... Hope that helps! -MJ (supra661)
×