Jump to content

amigaman

Members
  • Content count

    122
  • Joined

  • Last visited

  1. I have a problem with some 301 rewrites. I have three different products and I want to 301 rewrite two of them to redirect to the third. I am using code that looks a little like this in .htaccess Rewrite 301 /product-name-blah-p-78.html http://www.mysite.com/product-name-blah-p-31.html Whilst the URL appears to be different after implementing this the user if not actually redirected. So clicking on the link to product 40 produces product 40's page and the url: http://www.mysite.com/product-name-blah-p-31.html?products_id=78 I assume it is possible to use a redirect 301 like this when using this mod so can someone tell me the correct syntax to use?
  2. Is it possible to replace the text that reads 'Click here to enlarge' with the name of the product? A case of replacing the aforementioned text with the $product_name tag?
  3. For people continuing to experience the following error message in their admin: Cannot redeclare class ot_discount_coupon in .../includes/modules/order_total/ot_discount_coupon.php The problem in my case came from the automatic installation of the SQL tables failing because they had already been created. I edited out the code under the install function and the installation worked with no errors.
  4. amigaman

    Batch Order Center Update 1.1

    Even if I just select the order number it produces the same result. Obviously some problem connecting to the database. Any idea from anyone or is this contribution dead?
  5. amigaman

    Batch Order Center Update 1.1

    I'm still getting problems with the contribution finding any orders to export within the date ranges I provide. I have altered the batch_print file as instructed in previous posts to no avail. I am running SQL 5.0.27. I would be grateful if anyone could suggest a solution to this problem. Thanks EDIT: It's also occurred to me that I am using the English version of the date format and not the US version. For example my dates are structured as 11/11/2007 and not 2007/11/11. Will this produce this problem?
  6. I have a decent knowledge of STS. However I don't really see STS as a luxury but an essential part of making a OsComerce site your own. Thanks though.
  7. To clarify , I am using STS 4.x and I want to image to appear wher the $imagelarge usually does.
  8. Great contribution. However I was wondering whether it is possible to have the additional images replace the main image in the main product window rather than popping up in a separate window? Is it? Thanks
  9. I have fixed it by disabling the minus sign from the the sub-total. This is done the Discount Coupon admin under the Modules/Order Total tab. Anyone know of a fix that will still allow the minus to be displayed?
  10. amigaman

    GOOGLE CHECKOUT IPN

    I have fixed it by disabling the minus sign from the the sub-total. This is done the Discount Coupon admin under the Modules/Order Total tab. Anyone knwo of a fix that will still allow the minus to be displayed?
  11. amigaman

    GOOGLE CHECKOUT IPN

    Can anyone help me out with getting this module working with the Discount Coupon module. When attempting to apply a coupon I receive the following... It looks like a simple syntax problem producing the price as --17.99 instead of 17.99. Can somebody suggest a fix? I have also posted this here.
  12. Here is the rror message I am getting when applying this 'fix' for Google Checkout: Error: Error parsing XML; message from parser is: Invalid value for body of unit-price in checkout-shopping-cart/shopping-cart/items/item: This is not a number Warnings: XML failed to validate against the schema at line: 15, column: 15, with error: cvc-datatype-valid.1.2.1: '--17.99' is not a valid value for 'decimal'. XML failed to validate against the schema at line: 15, column: 15, with error: cvc-complex-type.2.2: Element 'unit-price' must have no element [children], and the value must be valid. And here is the part of the 'XML received' by Google that appears to contain the problem: <item> <item-name>Discount Coupon 3FOR2 applied</item-name> <item-description>Discount Coupon 3FOR2 applied</item-description> <unit-price currency="GBP">--17.99</unit-price> <quantity>1</quantity> </item>
  13. I've managed to install the SQL manual by changing the second table to this: CREATE TABLE IF NOT EXISTS discount_coupons_to_orders ( id INT(11) NOT NULL AUTO_INCREMENT, coupons_id VARCHAR(32) NOT NULL DEFAULT '', orders_id INT(11) NOT NULL DEFAULT '0', PRIMARY KEY (id) ); But I have another problem. When I try and create a code in the admin I get the following error: 1136 - Column count doesn't match value count at row 1 insert into discount_coupons values ( 'GJHVWQ', '3 For 2 Offer', '17', 'fixed', null, null, 10, 34.99, 'price', 10) This problem has been addressed by crash3903 on the 28th of June but there solution amends a admin/coupons.php file that looks nothing like the one with the current download. As I am manual altering the db I don't think the solution is relevant anyway. Any one have any ideas on who to solve this?
×