Jump to content

mickeymouse

Members
  • Content count

    99
  • Joined

  • Last visited

Everything posted by mickeymouse

  1. mickeymouse

    Seperate Pricing Per Customer v3.5

    Yes...I did see that..believe it or not..I actually waded through the 40+ pages of this forum since the intro of 4.1. (What a chore.....LMAO!!) Correct me if I'm wrong please..but doesn't that base the discounts on the TOTAL cart quantity..i.e. Product A + Product B etc..?? What I'm searching for is: Product A: Attribute A + Product A: Attribute B = Quantity discount for Product A. I guess simplified....Quantity discounts based on mixed attributes, not mixed products. Many thanks!!
  2. mickeymouse

    Seperate Pricing Per Customer v3.5

    I need a little help from the great guru's of this fabulouse contribution....I've got SPPC 4.1.1 installed and working fine. I've also got the Price Break mod installed and it works also...however it's not quite what I want. I need the QPB to be independent of attributes. I have a small but blooming custom candle business. And I want to offer my customers quantity discounts but want them to be fragrant independent. For example: Product A = $6.00 for 1, $5.00 for 2 or more. Fragrances are in a drop down attribute box. So if a customer orders 1 of Product A, Fragrance A...and 1 of Product A, Fragrance B they would get the price break. Currently if they order the above they would still get charged $6.00 each. The price break mod works fine if they order quantity of the same product and fragrance. I know the solution lies in the shopping cart class but I just can't seem to get it to work correctly. Any ideas or help???? Many thanks, Greg
  3. mickeymouse

    Seperate Pricing Per Customer v3.5

    Has anybody successfully integrated this w/ Linda McGrath's Shoppe Enhancement Controller....?? This contrib is exactly what I need and Jan has done a fantastic job w/ it...but I'm only having a few difficulties, and I've been beating my head on this for quite a while now. I've got it mostly installed, the problems I'm having is that the shopping cart is not showing the correct price on a product level, and the database is not being updated corretly w/ the group price. If anyone could provide any insight what so ever, it would be greatly appreciated. Many thanks, Greg
  4. mickeymouse

    OSC Active Desktop

    I just installed a fresh copy of a stock ms2 installation. works just fine. Alright peeps....now I'm really stumped!! Try changing this: $tax_query = tep_db_query("select products_id, p.products_tax_class_id from " . TABLE_PRODUCTS." p where p.products_id = " . $command['orders_products_id'] . "; "); To This: $tax_query = tep_db_query("select p.products_id, p.products_tax_class_id from " . TABLE_PRODUCTS." p where p.products_id = " . $command['orders_products_id'] . " ;"); It's really wierd that the both of you are getting the same error on the same product id number...that's what really confuses the hell out of me!! Let me know if that little change helps at all. Both sets of code work fine for me Thanks, Greg :o
  5. mickeymouse

    OSC Active Desktop

    OK...I'll look into it right now. Thanks
  6. mickeymouse

    OSC Active Desktop

    There is no need to alter any table structures. No additional installation instructions other than just copying the files into their respective directories. Mike...shoot me off a copy of your products table structure...maybe I can locate the problem for you. Has anybody else had any problems w/ this latest update, as I mentioned, it's working fine for me on 3 different stores. Greg
  7. mickeymouse

    OSC Active Desktop

    Have you altered your products table structure at all? I have this running on 3 different shops with no problems. Greg
  8. mickeymouse

    OSC Active Desktop

    Hey all, I just updated this package with a few goodies: Changes: - Products now display currency symbols - Currency decimals automatically set at your OSC defaults - Product prices now include tax - Broke out orders into 2 categories, "Pending" and "In Process" to give you a better handle on what all you have in the works - Added some nice graphics to make it visually more appealing - Screenshot enclosed Haven't been able to develop a work-around for those w/ the admin access level contribution installed though. Hope ya like it. You can download it here: http://www.oscommerce.com/community/contributions,1925
  9. mickeymouse

    [contribution] Simple Template System (sts)

    Read the FAQ!!!! http://diamondsea.com/sts/sts_faq.html
  10. mickeymouse

    [contribution] Simple Template System (sts)

    The file should be named sts_product_info.php.....chances are that the proper information wasn't copied into the configure.php file. 9 times out of 10 when that error appears it's because a filename is not defined properly in OSC. Follow the instructions as Brian has written them and there shouldn't be any problems. Make sure you edit the configure.php file off your server because it contains all of your database information. If you edit that file off a stock OSC install, you'll break the database connection for your storefront and it won't work anymore!
  11. mickeymouse

    [contribution] Simple Template System (sts)

    from the faq on Brians Website http://diamondsea.com/sts/sts_faq.html: 3) At the bottom of each page, I see the characters "</". Answer: You need to upgrade your server's version of PHP. This was a subtle bug in older versions. Updating your PHP will fix it. You should upgrade it anyway, since if you are running a version with this problem, there are also security fixes that have been added to later versions of PHP that you need to secure your system.
  12. mickeymouse

    [contribution] Simple Template System (sts)

    Could you post your code around that particular line so we can take a look at it?? That will give us a little help
  13. mickeymouse

    [contribution] Simple Template System (sts)

    The header tag contrib will take care of that for you!! Greg
  14. mickeymouse

    [contribution] Simple Template System (sts)

    Carline, Upgrade to the 2.01 version as this was a bug in 2.00. Also, your template version of product_info should be named product_info.php.html in your templates directory hth, Greg
  15. mickeymouse

    [contribution] Simple Template System (sts)

    Iggy....No, you're not reading anything incorrectly. All the product info pages are the same, however, if you look back to page 121, 122 around in there, there are a couple of solutions to this that may work. Greg
  16. mickeymouse

    [contribution] Simple Template System (sts)

    Joey, Check your configure.php file..looks like you didn't follow the install instructions and put the appropriate define statements in.
  17. mickeymouse

    [contribution] Simple Template System (sts)

    Damn..I wish you could edit posts here. I meant rename to product_info.php.html sorry.
  18. mickeymouse

    [contribution] Simple Template System (sts)

    Iggy, Rename the product_info.php.html-SAMPLE file to product_info.php and copy it to your includes/sts_templates directory and it should work Greg
  19. mickeymouse

    [contribution] Simple Template System (sts)

    Shoppe Enhancement Controller This is a complete install it includes OSC MS2.2
  20. mickeymouse

    [contribution] Simple Template System (sts)

    pj, The $headcontent tag is commented out on the sample sts_template.html file. You'll have to uncomment it, although the easiest thing is just to design your own header in your html file and use the rest of the tags to do the dirty work! Greg
  21. mickeymouse

    [contribution] Simple Template System (sts)

    Rick, Only thing I can suggest is to double check your installation. Many of the problems that people post here w/ installation issues is because they didn't follow all the steps. Brian's install instructions are really good and if followed 100% should give you a running shop w/ sts. Mine worked on the first try through and I'm running OSC MS 2.2 w/ Linda's Shoppe Enhancement Controller (which btw is incredible and will give a complete running detailed shop w/ STS added, including full attribute capability, not only drop down menu's but radio buttons, check boxes and text attributes, quantity discount pricing, and the rest of the whole deal) hth a little Greg
  22. mickeymouse

    [contribution] Simple Template System (sts)

    Did you copy the appropriate define statements into your configure.php file????
  23. mickeymouse

    [contribution] Simple Template System (sts)

    Dan, I suggest installing the Header Tag Controller contrib. http://www.oscommerce.com/community/contri...ons,207/page,15 hth, Greg
  24. mickeymouse

    [contribution] Simple Template System (sts)

    Sorry I'm talking about the graphics. What says $cataloglogo=oscommerce.gif for example. Thanks I think the file your looking for is /includes/sts_display_output.php..you can then also define your own tags in /includes/sts_user_code.php Greg
  25. mickeymouse

    [contribution] Simple Template System (sts)

    Sean, Look in your languages/english.php file. This should be what your looking for
×