Jump to content
Latest News: (loading..)

Viper0409

Members
  • Content count

    49
  • Joined

  • Last visited

  1. Viper0409

    Who's Online Enhancement 1.4

    I copied this code below from the install(or Update).txt file. and pasted into phpmyadmin query box and hit go. ALTER TABLE `whos_online` ADD `country_code` VARCHAR( 2 ) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL AFTER `ip_address` , ADD `country_name` VARCHAR( 64 ) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL AFTER `country_code` , ADD `region_name` VARCHAR( 64 ) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL AFTER `country_name` , ADD `city` VARCHAR( 64 ) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL AFTER `region_name` , ADD `latitude` FLOAT NOT NULL AFTER `city` , ADD `longitude` FLOAT NOT NULL AFTER `latitude`; ALTER TABLE `whos_online` ADD INDEX `ip_address` ( `ip_address` ); ALTER TABLE `whos_online` ADD INDEX `country_code` ( `country_code` ); ALTER TABLE whos_online ADD http_referer VARCHAR(255) NOT NULL; ALTER TABLE whos_online ADD user_agent VARCHAR(255) NOT NULL; ALTER TABLE `whos_online` ADD `hostname` VARCHAR( 255 ) NOT NULL AFTER `ip_address` ; REPAIR TABLE `whos_online`; INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('77', 'Google Maps Key', 'GOOGLE_MAPS_KEY', 'YOURKEY', 'Put your Google Maps API Key here.<br><br>You can get one at http://code.google.com/apis/maps/signup.html', '1', '25', NULL, '2009-08-22 12:18:00', NULL, 'tep_cfg_textarea(');
  2. Viper0409

    Who's Online Enhancement 1.4

    OK, I tried to run the query in phpmyadmin but I get the above error. Does anyone have a solution for this ?
  3. Viper0409

    Who's Online Enhancement 1.4

    Thanks for re-uploading this. I successfully extracted it and will install shortly.
  4. Viper0409

    Who's Online Enhancement 1.4

    Hi I just downloaded version 3.6.6 and couldn't extract it. I have repeated this 3 times with the same result. I did read back through this thread and noticed that someone had asked for version 3.6.6 to be re-uploaded but did not see a response to that post. Has anyone else had this experience ?
  5. Thanks Jan Yes, after doing a file comparison I saw the problem and swapped out the mistake. Thanks for taking the time to look at this. :)
  6. Ok I went ahead and made the above change to the compatibility.php file and it has cleared the problem. It remains to be seen if something else is broken, but I will keep my fingers crossed. BTW, thanks for this awesome contribution. It makes life so much easier to be able to follow step by step each step of the upgrade.
  7. ok I just compared the two files, one from the package and my local file, and this is the only difference. and The first quote is the package file and the second is my file. Should I make it same as the package file or would there be a reason for the difference? Thanks
  8. Hi Jan Wow, thanks for the lightning fast reply. The only thing that is on line 179 in compatibility.php is " ?> ", which is right isn't it? :huh:
  9. Hi I am in the process of updating my osCommerce 2.2 MS2 to rc2a and I am manually editing each file because I have quite a few contributions in my store. I have run into a problem as shown below. Can anyone offer any advice on how to overcome this. Thanks in advance
  10. Viper0409

    Links Manager II

    For the benefit of anyone else who may come across this error/warning at some stage. I finally found the cause of the error/warning in the above posts. The lines 132 to 139 were contained in the Blacklisted words function in catalog/links_submit.php file shown below. This was the error/warning: This is the function: I had list of words that I had inserted into my blacklisted words in admin/links and decided to remove a phrase but had left a comma at the end of the last word. This was the empty delimiter that was referred to in the error/warning. eg. bad word a, bad word b, bad word c, <--- notice the comma at the end of the line. After I removed the comma, it worked perfectly and the warning disappeared.
  11. Viper0409

    Links Manager II

    Thanks for your reply Jack I do have the latest version of this contribution V1.22, but I pasted the wrong lines into my post above, from another file, apologies for the incorrect information. the correct lines in catalog/links_submit.php are: The warning error is still on lines 132 through to 139. Thanks for any help you can provide Jack.
  12. Viper0409

    Links Manager II

    Hi Jack I am back again. I was just testing adding a link from the store front and ran into this error after filling in all the details and submitting the test link. In fact the same error occurs for line 132 through to line 139. i.e. The error repeats for line 133, 134, etc. Here are the lines 132 to 139 in my catalog/links_submit.php file. Would you have an idea about what is causing this warning/ error? Thanks Viper
  13. Viper0409

    Links Manager II

    Hi Jack and thanks for your reply, apologies for getting back to you so late, I had a few things to take care of. The above code mod has resolved the problem with the non-populated categories not displaying. All 6 categories are now displayed. Thanks once again for your help and for all the work you do in this and other forums. Viper
  14. Viper0409

    Links Manager II

    Ok, I am back again. According to my site, when the categories are not populated, the categories are hidden. As soon as I populated a non-displayed category, the category appeared. Just letting you know how it is working on my site. Let me know if this is not the correct functionality.
  15. Viper0409

    Links Manager II

    hmmmm, ok, thanks Jack, I will try populating one of the undisplayed categories with a test link and see if it works.
×