Jump to content

knipper

Members
  • Content count

    130
  • Joined

  • Last visited

Everything posted by knipper

  1. knipper

    QBI Quickbooks Import

    Hi Adam and others... I was previously following the other thread, and am glad to see this contibution released. However I have a couple questions. If this is not a good place to post this, feel free to IM or e-mail me through the forum to keep the thread on track. However some answers may help me as well as others looking at this as well. Let me start by saying I am NOT YET a quickbooks user. I am opening a new store (have been doing ecommerce since '96) and am configuring a new osCommerce store, but am going to be required by some of my vendors to have an actual storefront... which will be a whole new animal. (I have been working in a retail for 12+ years) I found the original quickbooks contrib as I was researching different financial software, seeing what will work with osCommerce. Since Quickbooks is affordable, and also seems to work with osCommerce thanks to contibutions like this, I am going to go that route. However.... I will also be using some quickbooks add-ons like POS. Hence, my questions are more quickbooks related than contibution related. So.... If I create my inventory within osC, and get the ecommerce part running, THEN install quickbooks, will the inventory get imported correctly into quickbooks? OR... vice/versa. Can I create the inventory in quickbooks, then be able to upload inventory status to osC. ?(possibly using a different contibution) Since I will also be running a storefront, and inventory will be taken from the same place, I'll need to make sure the the store AND osC inventories are in sync a few times a day, which is my biggest concern. If anyone has input or suggestions about quickbooks and/or their POS add-on, or ANY helpful quickbooks tips I'll be glad to hear any input. Thanks in advance. Again if this is not the appropriate place to post... Adam please request that Mods move it accordingly. Thanks again.
  2. knipper

    YASU

    OK... New Question. This mod is working great. But I'd like to tray and take it one step farther. One thing I noticed is when using the Dropdown boxes is that the path goes back to the osC original URL like... http://www.mydomain/catalog/index.php?cPath=10 I'd like the dropdowns to work like the other links, giving a friendly URL like... http://www.mydomain/catalog/DVD_Movies/Action One odd thing I noticed is from the "Item Page" is the Manufacturers info box on the right, which has more info about the vendor and/or a link to their home page. The odd part is if you click the link from there, you DO get the Friendly URL. But using the dropdown for the same manufacturer you get the standard dynamic url like shown above. Anyone know what would need to be modified to make the dropdowns work like the rest of the links when using this mod? Thanks in advance!
  3. knipper

    YASU

    HHHmmmm... I do have osC in a directory other than root. But took a look at my .htaccess files. My .htaccess for the catalog directory has the admin commented out, as I was having trouble getting in. I don't remember if it was the same issue as you, but may want to give that a try. My admin directory .htaccess which looks just like yours, is in the admin directory, not in the root or catalog .htaccess. Just FYI. Hope this helps.
  4. Jack... You're a genius! :lol: I found the line in includes/STS_display_output.php and commented it out... then removed the comment from Application_top.php (making it active)... And it worked! All seems well and good, and no other problems that I can see at this point. Thank you! I do need to figure out what line to comment out to avoid having my e-mail address show in the header though. Had it once before... Need to find it again. :D :D
  5. Hi again Jack.... Actually I have one additional Line commented out as it was causing a problem with "header tags.php" already being loaded. Here's what I have: // BOF: WebMakers.com Added: Header Tags Controller v1.0 //require(DIR_WS_FUNCTIONS . 'header_tags.php'); // Clean out HTML comments from ALT tags etc. ? require(DIR_WS_FUNCTIONS . 'clean_html_comments.php'); // Also used by: WebMakers.com Added: FREE-CALL FOR PRICE // EOF: WebMakers.com Added: Header Tags Controller v1.0 But kep in mind, all other pages except the review page work normally. :o Edit: Just for the heck of it I uncommented the line to see what would happen, I get this: Works OK again when I comment out the line. (except the reviews page)
  6. Hi Jack, Thanks for the help. I replaced both files with original downloaded versions, with NO changes at all. (Just the default as is) And get the same problem. One additional note... I had been reading multiple threads, and realized that I wasn't in the one I thought. One piece of info you didn't know is that I am using STS as well. Not sure if that is what is actually causing the problem, and not this contribution on its own. I wonder if PnwGifts is also using STS? Thanks again, looking forward to your reply.
  7. Hey Jack... Mine is there and in place. Any other suggestions? As mentioned, it appears all other pages work fine, it's only the "product_reviews_info.php" that is throwing the error. As a side note, I did an install on a different domain and get the same error on the same page. Another side note... on original install I had a function error, and had to move WHERE the function was being called (it was too close to the top of the page) I moved it down, and that fixed it. Just FYI.
  8. Hey All... I have this contribution installed and it appears to be working on all pages EXCEPT product_reviews_info.php where I get the following: Fatal error: Call to undefined function: tep_get_header_tag_products_desc() in /home/xxxxxx/public_html/my_catalog/includes/header_tags.php on line 168 I cruised the previous posts and did not see anything when this occurs on only one page. Did I miss something? I did check product_reviews_info.php and it seems the changes were made properly. (It is the same as other files in the header changes) Thanks in advance.
  9. OK folks.... Here are a couple questions on this contribution. First, I had used this contibution about a year and a half ago, when everything was manually done (just before the release of MS2). I see there have been MANY updates since then. I have installed the MS2 on a new site and am ready to get modding it up. Does the auto-install now also add the changes to "Admin by Richard Fielder for Header Tag Controller" or is this still needed to be run seperately? I see there is a sql file "header.sql" for database changes. So I guess I am asking for clarification... If I run the autoinstaller, does it change/add all the needed files for the Header Tags controller, and the admin contribution at once, then all I need to do is upload all the files, and run the "header.sql" file to be all set? Thanks in advance for the info.
  10. knipper

    [contribution] Simple Template System (sts)

    I am also on a brand new clean install, and the only mod is STS v1.5. I also have the double html and header tags. Did I miss a solution? I do need Javascript to work as I use javascript rollovers for navigation so commenting out that portion won't be good for me. Just to be sure I did a second clean install on a different server/domain, and but this time I added WebMakers.com's Header Tag Controller contribution afterwords to see the results... The first HTML/Header tags include the header tag controller contents, The second set are normal HTML/Head/ Etc. but not the content in the meta tags. Granted I have not yet had time to dig through yet.... SO does anyone have a correction? :blink:
  11. Ahhhh... nevermind. After looking cloder at the code, what needed to be done was to change: case 'PRODUCT_LIST_NAME': $lc_align = ' '; to the following case 'PRODUCT_LIST_NAME': $lc_align = 'center';
  12. Hey Lori, I just installed this mod (trouble free) and have the same thing. It appears the cell is centered, but the text is left justified... even though the image and price above and below are centered. Did you overcome this? WHat needs to be edited?
  13. Ahhhh.... I got it working. :lol: I started with an unmodded local test site and worked my way down the instructions. I was able to use the code from Margs' post for the categories_image line. The I did find some of the code for default PHP had to be moved to different locations. I then copied the changes back to my previously modded store, and all was well. Thanks. 8)
  14. Thanks Del... Let me know what you find!
  15. I was able to get the contribution installed and operating with no trouble. Just to let folks know. Unfortunately it won't work for me due to my layout. My categories/subcategories can have the same name (a manufacturer) so I see the same name listed many times, and I don't know which category/sub category it is for :( I'm trying to install the other cat description mod refernced earlier in the thread, but with difficulties. All in all the contibution looks like it will work good for many people, and is not too difficult to install. :)
  16. I went back through the code again in /admin/categories.php and don't see anything out-of-whack. Unless copying the code from the forum post made it not work. The only other contributions I use are Lindas header tag controller, and Richards admin for the tag controller. I did notice some of the lines modified were in the same area as the admin controller, but it didn't look like any changes were made. Anyone point me the right way or have advice?
  17. I have made all the changes as posted in the instructions, including using the text from your file instead of the original. I have now changed the lines you showed for the categories_image area as well. I can go into the admin, but do not get a new page when I try to edit categories. No error messages, just no new page. Also the ability to upload image, etc. is no longer there. I just went back and looked at all the code changes, and everything looks OK. ANy Idea where I could look for a problem? Thanks !
  18. I am stuck! As the original contribution creator mentioned there is a new function. I understand changes or the replacement need to be made to new_category.insert but what needs to get changed in /admin/categories.php now? I have the following code from my 5/3/03 snapshot: if ($categories_image = new upload('categories_image', DIR_FS_CATALOG_IMAGES)) { tep_db_query("update " . TABLE_CATEGORIES . " set categories_image = '" . $categories_image->filename . "' where categories_id = '" . tep_db_input($categories_id) . "'"); } I don't have the same lines as marg showed. Any suggestions? PS MaxiDVD... I think the mod you are refering to is a similar contribution just released. I tried it out but didn't like it. Thanks though! :)
  19. :D I just found this mod and am ready to try it out. Is the code above what I need to change from the original contribution.. or is there more or something else? Let me know if possible, or if anyone has installed it lately. I'm running the 2.2 csv snapshot from 5/3/03 Thanks!
  20. I've searched thru the easypopulate threads, and through the forum so forgive me if this has been asked and answered a bunch! I'm looking for a way to either delete products from the database based on the easypopulate upload, or have it compare the "old" and "new" products to toggle the onhand to 0 for items not in the new upload. I.E. I want items that are not in the upload to be removed from the existing database or at least hidden so the customer can not see them. Anyone? Thanks in advance!
×