Latest News: (loading..)

dimi78

Members
  • Content count

    25
  • Joined

  • Last visited

1 Follower

About dimi78

  • Birthday 01/12/1978

Profile Information

  • Real Name
    Diederik Van Hijfte
  • Gender
    Male
  • Location
    Sint-Niklaas Belgium
  1. I had some troubles as well before, sometimes the flyouts would not work, I switch to the ul_categories_v1 contribution wich is smaller in file size and works well.
  2. The 2 work great together, I used this in the beginning of my project, but later on switch to a ul categories stucture usng another of Nate's contributions. ul_categories_v1 The top menu of this site where made first with this contribution then later with the other.
  3. I tried that, it's possible but I it still didn't look the way I wanted it. Try the UL categories contribution by the same author. This was my result with that contr.
  4. sounds like an issue with the z-index, this propertie controls wich layer is ontop of the orthers. in your tab css file .dynamic-tab-pane-control .tab-row { z-index: 1; Their are more instances of the z-index in the file ;) http://www.w3schools.com/css/pr_pos_z-index.asp
  5. Did you paste the css code into your css file?
  6. Did you do a step by step compare with the install files of dynamenu?
  7. Hey Tracy, could be one of two things: 1) a problem with dynamenu footer echo 2) a problem with cpath Solution could be to swith from dynamenu to ul categories contribution also by the same author. And use a little javascript to get the menu's working in IE. again I'm just guessing, hope it helps you.
  8. Yes you can, but the osc output will still be in tables. So your div's will be filled with tables. You can always change the output but that's a big job, (belief me, I changed a view of the pages)
  9. Fixed it, i guess my query was wrong anyways I used this work around. in the dm_categories.php file find this while ($row = tep_db_fetch_array($result)) { $table[$row['parent_id']][$row['categories_id']] = $row['categories_name']; } and I replaced that with while ($row = tep_db_fetch_array($result)) { if ($row['categories_id'] != 174) { $table[$row['parent_id']][$row['categories_id']] = $row['categories_name']; }} The if statement could be altered to include a list of categorie Id's, in my case I just tell the code not to make a menu for the categorie_id 174.
  10. Yes I know, Bill does a very good job in doing that, but this isn't the problem I am facing. When I leave the query as is (pulling all the top categories from the database) everything works fine. The menu's extend prober like they should. When I changed the query like posted previously, pulling a list of desired main categories and not all, that the menu started to act strangely. The menu won't extend I will see the desired main categories in my menu, but when you hover over them nothing happens. I'm not sure if this problem is related to STS it's just one of the possibilities out there, but it feels like the same problem people where facing when trying to implement sts and this menu. When you don't place that one line of code in your footer then the menu won't extend. But I do have that line! I'm just wondering what that line does and if that could be the reason of this strange behavior now.
  11. I posted this earlier, my best guess is that it doesn't work because of the sts template system, it appears that what I pasted in the footer isn't doing it when I change the query. Still puzzled at this one.
  12. Hi all, I tried searching this pst but there where so many replies that i must have mist it. I'm trying to limit the menu to a set of first level category id's. $result = tep_db_query('select c.categories_id, cd.categories_name, c.parent_id from ' . TABLE_CATEGORIES . ' c, ' . TABLE_CATEGORIES_DESCRIPTION . ' cd where c.categories_id IN (184,185,195) and c.categories_id = cd.categories_id and cd.language_id="' . (int)$languages_id .'" '.$parent_query. 'order by sort_order, cd.categories_name'); When I use this query I get the requested menu items but they won't fold out. (the subcategories don't come up when hovering). Any one with an idea on how I could get this to work fully?
  13. Thx man, you rock! You gave me the right spot to look. First I was puzzled cause I couldn't find that reference in my file, but I searched the forum over there and found this and followed the instructions but added the $languages_id like you suggested. Yes the $langid helped a lot in designing a multi languages site. It was exactly what I needed. thx again.
  14. example but the more_categories contribution is not added on the server yet. It failed on my desktop test server hence the delay :-" . But it shows you that the other images are being changed when you change language. the more categories contribution can be found using this link. This is a screen shot of my local install.
  15. I have been trying to integrate the more categories contribution with the sts template contribution. For most parts this has been successful, but I have one small problem. The site I'm working on has multiple languages, so I was trying to use the box titles of the more categories as a basis for the images. I created the reference to the box require(DIR_WS_BOXES . 'more_categories.php'); $sts->restart_capture ('more', 'box'); I created an infobox_more_categories.php.html file in the template folder. <div> <div style="width:170px; height:59px; "> <img border="0" src="images/box title/$headertext$langid.gif" width="170" height="59"> I also tried categorie$langid.gif </div> <div>$content</div> </div> Now in a perfect world I should get an image with source nameofbox + mylangid (1 for English for example). But when i run this the source of the image file says www.site.com/images/box title/categories$langid.gif The $langid and the $headertext are not working in my custom created boxes. (they do work for all my other boxes that come wit osc) Anyone with an idea or clue to the solution?